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Introduction
LiDAR360 is the flagship LiDAR post-processing software, which provides comprehensive LiDAR data management and analysis functions. It
has over 10 peer-reviewed point cloud processing algorithms which enables it to process more than 300 GB of LiDAR data simultaneously.
The software platform also includes versatile editing tools and automatic strip adjustment for increased workflow productivity in applications of
terrain, forestry and power line surveying(See the LiPowerline software).

The Terrain module is a suite of GIS tools used primarily for the generation of industry-standard topographic products. Our point cloud filtering
algorithm can precisely extract ground points under complex landscapes and therefore improve the terrain surveying accuracy. The module
also generates more advanced topographic products, such as TDOM, through the fusion of LiDAR and photogrammetry.

The Forestry module brings important technological innovations to forest inventory and analysis. It provides a unique toolset for manipulating
point cloud collected from aerial and terrestrial LiDAR scanners. Defining individual tree level parameters, such as tree height, DBH, LAI, and
crown diameter, are made possible through our segmentation algorithms. A range of regression models for predicting forest structures from
LiDAR variables are also provided.

Specifically, LiDAR360 has the following modules:

Strip Alignment: Point clouds from overlapped strips can be automatically aligned based on strict geometric model. The software can
display aligned strips in real-time and generate aligned point clouds with high accuracy. The module also provides a series of tools to
check and analyze data quality.

Data Management: The module provides management tools for point cloud and raster data, which include format conversion, point cloud
de-noising, normalization, raster band calculation and so on.

Statistics: Based on the number, density and elevation of LiDAR points, statistics can be calculated for data quality evaluation.

Classify: The module provides various classification methods for point cloud classification including ground classification, ground key
point classification, interactive classification, machine-learning-based classification (for building, vegetation, and custom classes) etc.

Terrain: The module can generate DEM(Digital Elevation Model), DSM(Digital Surface Model), CHM(Canopy Height Model) for
geospatial applications. Other related topographic products such as Hillshade, Slope, Aspect, Roughness and Contour are also
supported.

Vector Editor: The module provides vectorization functions for DLG (Digital Line Graphics) workflow. The software displays point cloud
as a high-contrast base map, in which contours of objects (e.g., building, vegetation, roads, street lamps, water, bridges) can be clearly
identified and vectorized.

ALS Forest: Based on ALS(Airborne Laser Scanning) data, the module can extract a series of forestry parameters(Elevation Metrics,
Leaf Area Index, Canopy Cover, etc.), segment individual trees and calculate parameters of individual tree(position, height, canopy, etc.).
Moreover, various regression functions are also provided which can be used in combination with field measurement to retrieve forest
parameters that cannot be directly derived from ALS LiDAR data (such as biomass or stem volume).

TLS Forest: Based on TLS(Terrestrial Laser Scanning) data, the module can estimate the number of trees, extract DBH(Diameter at
Breast Height) with batch processing, segment individual tree, and calculate parameters of individual tree(position, height, etc.).

Geology: Extract terrain features, geological structure surface features, etc. based on airborne lidar point cloud data.

Powerline: Obtaining a clearance distance analysis report based on airborne LiDAR point cloud data, including towers positioning, data
classification, and danger point detection.

LiDAR360 Versions

Modules Free Version Full-Featured Version

Data Visualization √ √

Mass Data Support √ √

Data Management 15 Days Trial √

Strip Alignment 15 Days Trial √

Statistics 15 Days Trial √

Classify 15 Days Trial √

Terrain 15 Days Trial √



Vector Editor 15 Days Trial √

ALS Forest 15 Days Trial √

TLS Forest 15 Days Trial √

Geology 15 Days Trial √

Powerline 15 Days Trial √

Get Started
Please refer to Installation and License to install the software. The usage is described in Tutorials.



Installation
Download the latest version of LiDAR360 Suite from the GreenValley International official website before installation.

System Requirements

RAM: at least 8G or more.
CPU: Intel® Core™ i5/i7; Dual-core processor.
Display Adapter: NVIDIA graphics card recommended, video memory no less than 2GB.
Operating Systems: Microsoft Windows 7 (64-bit), Microsoft Windows 8 (64-bit), Microsoft Windows 10(64- bit), Microsoft Windows
Server 2012 and higher.

Note: Please enable high-performance graphics mode for running the software.

Setup

1. Run the LiDAR360 Suite Setup Wizard.
2. Click Next button in the Welcome Interface.
3. Click I Agree button to continue if you accept the License Agreement.
4. Choose the installation path (or use default path), then click Install button.
5. Click Finish button after installation.

License Manager

There are two licensing approaches to activate LiDAR360, by license dongle or license code. For license dongle, users must not format,
delete, or copy the license dongle.

1) License dongle

Properly insert a license dongle to USB port to activate LiDAR360.

2) License code

License code would be generated based on activation information given by LiDAR360 users. After purchasing a license code, please follow
the following steps to activate LiDAR360.

1.Run the software.

2.Click File > Activate License, the License Manager window will pop up.

3.Under General Information tab, fill in your name and company name, select the modules you want to activate, and then click Copy.

4.Email the copied information to info@greenvalleyintl.com.

5.There are two licensing modes: single use licensing and concurrent use licensing. After receiving the activation key, activate or revoke the
license using online or offline mode.

Single Use Licensing

Activation/Update

Online Activation/Update: When connecting to the internet, under the “Single Use Licensing” tab, enter the authorization key, select
“Online”, and click “Activate” to activate or update. Activation information, such as expiration date, will displayed below. Under
“General Information” page, you may also check the expiration date for each individual module. If you need to set up proxy to
connect to the internet, click  to use proxy, and set up the address, port, user name, and password.

https://greenvalleyintl.com/
mailto:info@greenvalleyintl.com


Offline activation: Step 1: Select “Offline” under the “Single Use Licensing” tab; Step 2: Click “Generate Request File” button to
generate the request file (.req); Step 3: Use a computer that can connect to the internet to browse to https://user.bitanswer.cn, enter
the authorization key to log in, click “Update”, upload the request file (.req), and download the generated upgrade file (.upd); Step 4:
go back to the License Manager interface, click “Apply Promote File” and select the downloaded .upd file.

Revoke

To unbind an activation key from a computer, user could revoke the activation key online or offline. After the authorization key is
revoked, it can be reused on the same computer or a different one.

Online Revoke: In “Single Use Licensing” tab, enter the authorization key, select “Online”, and click “Revoke” to revoke the key. If
you need to set up proxy to connect to the internet, click  to use proxy and to set up the address, port, user name, and
password.

https://user.bitanswer.cn


Offline Revoke: Step 1: Select “Offline” under the “Single Use Licensing” tab; Step 2: Click “Generate Revoke File” button to
generate the request file (.req); Step 3: Use a computer that can connect to the internet to browse to https://user.bitanswer.cn, enter
the authorization key to log in, click “Update”, upload the request file (.req), and download the generated upgrade file (.upd); Step 4:
go back to the License Manager interface, click “Apply Promote File” and select the downloaded .upd file.

Delete

To delete authorization information from the computer, right-click on the authorization key and select “Delete Key”. After being
deleted, the same activation key can only be used on the same computer.

https://user.bitanswer.cn


Concurrent Use Licensing

Install enterprise activation tool on the server to activate the key online or offline. Other users can use the activation windows to input the
server's IP address to activate the software. The default port is 8273. Click "Apply".

6.Click the help button  on the License Manager interface to view the license manager user guide.

Note: If any of the software instance (i.e. LiDAR360, LiMapper, LiGeoreference, LiPowerline) is being opened while updating the
license in License Manager, please restart the software to make the license be effective.

Note: If an user would like to move a key from one computer to another, he/she should revoke first, then activate on the other. If the
license code has been deleted, the user should reactivate on the same computer first, then revoke and activate this key on the other
computer.

Note: Please contact info@greenvalleyintl.com for inquiry and purchase.

Languages

Currently, the supported languages are English, Chinese, French, and Japanese. You can switch the menu language in the following way:

1. Click Display Options> System Setting> Language > English/Chinese/French/Japanese in the menu bar.
2. Language change needs a restart to be effective. Click Yes in the pop-up dialog to restart the software immediately, or click Cancel and

restart later.

mailto:info@greenvalleyintl.com


Tool Reference
This chapter describes the usage of menu bar, toolbar, project management windows and toolbox of LiDAR360 in detail.

Start Page

Toolbar

Quick Toolbar

Ribbon Toolbar

Project Manager Window

Ribbon Tab

File

Tools

Preprocessing

Classification

Terrain

ALS Forest

TLS Forest

Power Line

Display

Profile Editor

Profile View

ToolBox

Strip Alignment

Data Management

Statistics

Classify

Terrain

Vector Editor

ALS Forest

TLS Forest

Power Line

Geological Analysis

Mine



Start Page
Start page is shown as figure below:

Start page can be closed by the close button. Also, users can set Start or Close Start page by checking the box in [Display]->[Show/Hide]->
[Start Page].

What's New

What's New shows the new features in the new version.
Start includes:New Project, Open Project, Add Data

Recent Files

Recent files is shown here. Users can left-click and add the file into viewer. If there is no current viewer, a viewer will be created and the data
will be added to it.

Resources

Resources includes：Visit Company Website, Quick Start, Submit An Enhancement, Submit A BUG, Check for Updates, Projection Datum
Grid, About.



Toolbar
This chapter aims to introduce ToolBar of LiDAR360.The toolbar is at left-side by default, including Colorbar, Viewing and Setting.

Colorbar Tools

Viewing Tools

Setting Tools



Color Tools
With tools in this section, LiDAR360 allows you to visualize vast amounts of point cloud or DEM using the best data representations for your
analysis. You can change the coloration of the point cloud displaying by classification( or intensity, GPS time, return of number etc.). You can
also enhance the render effect using visualization tools such as EDL, PCV and Glass which are intuitive and helpful for quality check.

Display by Height

Display by Intensity

Display by Classification

Display by RGB

Display by Return

Display by Time

Display by Tree ID

Display by Edge Flight Line

Display by Number of Returns

Display by Point Source ID

Display by Scan Angle Rank

Display by Scan Direction

Display by User Data

Display by Scanner Channel

Display by Near Infrared

Display by Blend

Display by Mix

Display by File

Display by EDL

Glass



Display by Height

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Elevation", as shown below.

3. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the window will generate the
corresponding color bar according to the elevation range of the point cloud data. At the same time, the data is displayed by elevation in
the scene. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The elevation values of point cloud data are mapped to several uniformly
varying color intervals, so as to display the variation of elevation values more intuitively.



Display by Intensity

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. The color indicator of the window will generate the corresponding gray color bar according to the

intensity range of the point cloud data. At the same time, the data is displayed by intensity in the scene. The visual effects are better with
EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The intensity values of point cloud data are mapped to several uniformly
varying color intervals, so as to display the variation of intensity values more intuitively.



Display by Classification

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Classification", as shown below.

3. Select the appropriate color for each class and click the "OK" button. The color indicator of the window will generate the corresponding
color bar according to the class attribute of the point cloud data. At the same time, the data is displayed by classification in the scene.
The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The classes of point cloud data are mapped to discrete color values, so as
to distinguish different classes of point cloud data more intuitively.



Display by RGB

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. The data is displayed according to its own RGB values in the scene, as shown below.

Note: This tool only works with point cloud data contains RGB attributes.

Brief: This tool is used for displaying point cloud data. The point cloud data is displayed according to its own color value.



Display by Return

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Return", as shown below.

3. Select the appropriate color bar for each return number and click the "OK" button. The color indicator of the window will generate the
corresponding color bar according to the return number attribute of the point cloud data. At the same time, the data is displayed by return
number in the scene. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The return numbers of point cloud data are mapped to discrete color
values, so as to distinguish different return numbers of point cloud data more intuitively.



Display by Time

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Time", as shown below.

3. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the window will generate the
corresponding color bar according to the GPS time range of the point cloud data. At the same time, the data is displayed by time in the
scene. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The GPS time values of point cloud data are mapped to several uniformly
varying color intervals, so as to display the variation of GPS time values more intuitively.



Display by Tree ID

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. If the point cloud data contains tree ID attribute, then the data will be displayed by tree ID in the

scene. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data after individual tree segmentation.

Brief: This tool is used for displaying point cloud data after Point Cloud Segmentation. The tree ID's of point cloud data are
mapped to discrete color values, so as to distinguish different trees of more intuitively.



Display by Edge Flight Line

Steps

1. Click to activate the window with point cloud data that need to be displayed by edge flight line.
2. Click the  button in the toolbar, and the window of "display by edge flight line" will popup. The window is shown as follow. It should be

noted that when the point cloud is displayed by edge flight line, the edge points are marked as 1.

3. Select different colors for different edges of flight lines and click OK. The color indicator in the lower left corner of the window will
automatically map the the point cloud data in different edges of flight lines to the corresponding colors. For a better display effect, please
turn on the EDL effect.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud files. By mapping the point cloud data's attribute of edge flight line to different color
values, intuitively distinguish point cloud data at the edges of different flight line.



Display by Number of Returns

Steps

1. Click to activate the window with point cloud data that need to be displayed by file.
2. Click the  button in the toolbar, and the window of "display by number of returns" will popup. The window is shown as follow.

3. Select different colors for different number of returns and click the OK button. The color indicator in the lower left corner of the window will
automatically map the different number of returns attribute of the point cloud data to the corresponding colors. At the same time, the point
cloud data in the window will be displayed according to the number of returns. EDL display is better, the effect is shown in the figure. For
a better display effect, please turn on the EDL effect. And the effect is shown as follow.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud data. By mapping the number of returns attribute of point cloud data to different color
values, intuitively distinguish point cloud data with different number of returns.



Display by Point Source ID

Step

1. Click to activate the window with point cloud data that need to be displayed by file.
2. Click the  button in the toolbar, and the window of "display by point source ID" will popup. The window is shown as follow.

3. Select the appropriate color bar in the drop-down box and click the OK button. The color indicator in the lower left corner of the window
will automatically map the changes in point source ID values of the point cloud data to the selected color bar. At the same time, the point
cloud data in the window will be displayed in point source ID.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud data. By mapping the point source ID attribute of the point cloud data to several uniformly
changing color intervals, intuitively show the changes of the point source ID of the point cloud data.



Display by Scan Angle Rank

Step

1. Click to activate the window with point cloud data that need to be displayed by file.
2. Click the  button in the toolbar, and the window of "display by scan angle rank" will popup. The window is shown as follow.

3. Select the appropriate color bar in the drop-down box and click the OK button. The color indicator in the lower left corner of the window
will automatically map the changes in scan angle rank values of the point cloud data to the selected color bar. At the same time, the point
cloud data in the window will be displayed in scan angle rank. For a better display effect, please turn on the EDL effect.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud data. By mapping the scan angle rank attribute of the point cloud data to several
uniformly changing color intervals, intuitively show the changes of the scan angle rank of the point cloud data.



Display by Scan Direction

Steps

1. Click to activate the window with point cloud data that need to be displayed by edge flight line.
2. Click the  button in the toolbar, and the window of "display by scan direction" will popup. The window is shown as follow. It should be

noted that when the point cloud is displayed by edge flight line, the positive direction is marked as 1 and the negative scan direction is
marked as 0.

3. Select different colors for different scan directions and click OK. The color indicator in the lower left corner of the window will
automatically map the the point cloud data in different scan directions to the corresponding colors. For a better display effect, please turn
on the EDL effect.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud data. By mapping the scan direction attribute of the point cloud data to different color
values, intuitively distinguish the point cloud data with different scan directions.



Display by User Data

Step

1. Click to activate the window with point cloud data that need to be displayed by file.
2. Click the  button in the toolbar, and the window of "display by user data" will popup.

3. Select the appropriate color bar in the drop-down box and click the OK button. The color indicator in the lower left corner of the window
will automatically map the changes in the user data of the point cloud data to the selected color bar. At the same time, the point cloud
data in the window will be displayed in user data. For a better display effect, please turn on the EDL effect.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud data. By mapping the user data attribute of the point cloud data to several uniformly
changing color intervals, intuitively show the changes of the user data of the point cloud data.



Display by Scanner Channel

Steps

1. Click to activate the window with point cloud data that need to be displayed by edge flight line.
2. Click the  button in the toolbar, and the window of "display by scanner channel" will popup.

3. Select different colors for different scanner channel and click OK. The color indicator in the lower left corner of the window will
automatically map the the point cloud data in different scanner channel to the corresponding colors. For a better display effect, please
turn on the EDL effect.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud data. By mapping the scanner channel attribute of the point cloud data to different color
values, intuitively distinguish the point cloud data with different scanner channel.



Display by Near Infrared

Steps

1. Click to activate the window with point cloud data that need to be displayed by file.
2. Click the  button in the toolbar, and the window of "display by near infrared" will popup.
3. Select the appropriate color bar in the drop-down box and click the OK button. The color indicator in the lower left corner of the window

will automatically map the changes in near-infrared values of the point cloud data to the selected color bar. At the same time, the point
cloud data in the window will be displayed in near-infrared. For a better display effect, please turn on the EDL effect.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud data. By mapping the near-infrared attribute of the point cloud data to several uniformly
changing color intervals, intuitively show the changes of the near infrared values of the point cloud data.



Display by Blend

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. (Optional) Process the point cloud data by PCV.
3. Click the button  on the toolbar to pop up the dialog "Display by Blend", as shown below.

4. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the window will generate the
corresponding color bar according to the elevation range of the point cloud data. At the same time, the data is displayed in the scene
according to the elevation values and intensity values. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data. The visual effects will be better after PCV process for the point cloud data.

Brief: This tool is used for displaying point cloud data. Consider the elevation attribute and intensity attribute, the point cloud data
is mapped to several uniformly varying color intervals, so as to reflect the comprehensive variation of elevation/intensity more
intuitively, and display the feature class and boundary more explicitly.



Display by Mix

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Mix", as shown below.

3. Select the attribute for display.
4. Select the appropriate color bar in the combo box.
5. Check the classes and return numbers for filtering.
6. Click the "OK" button. Then the color indicator of the window will generate the corresponding color bar according to the selected attribute

range the point cloud data. The data will be filtered by the specified attributes first and then be displayed by the specified attributes in the
scene. The visual effects are better with EDL mode, as shown below.

Brief: This tool is used for displaying point cloud data. Different attributes of point cloud data are mapped to several uniformly
varying color intervals, at the same time different ways of attribute filtering are supported, so as to display the variation of a certain
attribute of the filtered point cloud data more intuitively.



Settings

Display By: The selected attribute will be mapped to specified color range.
Height(Default): The elevation attribute of the point cloud data.
Intensity: The intensity attribute of the point cloud data.
Time: The GPS Time attribute of the point cloud data.

ColorBar: The color bar supports several uniformly varying color intervals for color mapping.
Filter by Classification: List all the classes users can choose to filter the point cloud data.
Filter by Return Number: List all the return numbers users can choose to filter the point cloud data.

Note: This tool only works with point cloud data.



Display by File

Steps

1. Click to activate the window with point cloud data that need to be displayed by file.
2. Click the  button in the toolbar, and the window of "display by file" will popup. The window is shown as follow.

3. (Option) Click random color and use refresh button to randomly colorize point cloud from different files.
4. (Option) Click the color bar, select a color bar from the drop-down box, and calculate the corresponding color of each file according to the

selected color bar.
5. (Option) Click the button in the file color column to select a specific color for it.
6. Click the OK button, the point cloud data in the window will be displayed in the selected color of the file. For a better display effect, please

turn on the EDL effect.

Note: This function is only applicable to point cloud data.

Description: Used to display point cloud data. By mapping the point cloud data from different files to different color values,
intuitively distinguish point cloud data which are from different point cloud files.



Display by EDL

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. The visual effects of the point cloud data in the scene will be improved with EDL mode. The following

picture shows the comparison before and after using EDL display mode.

Note: This tool only works with point cloud data.

Brief: This tool is used to display the point cloud data and enhance the visual effects of the contour features using the Eye Dome
Lighting (EDL) mode. EDL is a shading technique that works with other display mode (e.g. display by height, display by intensity)
to improve the depth perception in 3D point cloud visualization.



Glass Shader
Brief: With the glass shader point cloud object appears translucent.

This effect can be enabled/disabled for individual display window. An example is shown as follows.

Note: The Glass Shader is only applicable to point cloud data.



Viewing Tools
Set current active window to some view.

Top View

Bottom View

Left View

Right View

Front View

Back View

Front Isometric View

Back Isometric View

Set View Mode



Top View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you need to reset to the default
view, please click Full Extent.

Brief: Set camera to top view. View data from +z to -z direction. View plane: x-y plane.



Bottom View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you need to reset to the default
view, please click Full Extent.

Brief：Set camera to bottom view. View data from -z to +z direction. View plane: x-y plane.



Left View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you need to reset to the default
view, please click Full Extent.

Brief: Set camera to left view. View data from -x to +x direction. View plane: y-z plane.



Right View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you need to reset to the default
view, please click Full Extent.

Brief: Set camera to right view. View data from +x to -x direction. View plane: y-z plane.



Front View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you need to reset to the default
view, please click Full Extent.

Brief: Set camera to front view. View data from -y to +y direction. View plane: x-z plane.



Back View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you need to reset to the default
view, please click Full Extent.

Brief: Set camera to back view. View data from +y to -y direction. View plane is x-z plane.



Front Isometric View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you need to reset to the default
view, please click Full Extent.

Brief：Set camera position to front 45 degrees of X-Y plane.



Back Isometric View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you need to reset to the default
view, please click Full Extent.

Brief: Set camera position to back 45 degrees of X-Y plane.



Set View Mode

Steps

1. After clicking this button, the option of projection mode is popped up. If Orthogonal Projection is selected, current active window will be
set in orthogonal projection. If Perspective Projection is selected, current active window will be set in perspective projection.

Settings

Shortcut Key：F3

Note: This tool is only for viewer in 3D mode.

Brief: Select projection mode(orthographic/perspective).



Setting Tools
Basic settings for viewers.

Full Extent

Cross Selection

Configure Point Size and Type

Display Options

As 2D

As 3D

New Window

Profile View



Full Extent

Steps

1. Click the window that contains data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. All the data in the active window will be scaled automatically to cover the entire window, as shown

below.

Note: When there are multiple windows, this tool only works on the active window.

Brief: This tool is applicable to all data types supported by LiDAR360. It makes all the data cover the entire window in top view
and provides full view of all the data.



Cross Selection

Steps

1. Click this button to open the dialog shown below:

2. The buttons of translation, rotation, and scale ratio control the translation, rotation, and scale ratio of the ROI.
3. Click button  to stop the editing of the ROI and return to the normal interactive user-interface.
4. Click button  to reset ROI.
5. Click button  to export point cloud inside the ROI to a new LiData File.
6. Click button  to exit cross selection.
7. The whole display effect is shown below. Drag any face of the ROI to translate it. And the dragged face will be highlighted. Drag the red,

green, or blue track circle to rotate the ROI about the X, Y, or Z axis. The dragged track circle will be highlighted. Drag the green square
to rescale the ROI. The dragged square will be highlighted.

Brief: Cross select partial point cloud using ROI. The boundary and the rotation angles of the ROI can be entered in the user-
interface, or interactively changed by using the mouse. This function can be used for flood analysis and other applications.



Settings

Hot Key: Not applicable.
Prerequisite: Current viewer contains point cloud.
Translation: Switch of using mouse to translate the ROI.
Scale: Switch of using mouse to rescale the ROI.
Rotation: Switch of using mouse to rotate the ROI.
Boundary of ROI: Precisely control the max. and min. value in X, Y, and Z direction of the ROI.
Rotation angles of ROI: Control the rotation angles of the ROI in X, Y, and Z axis.

Note: This function is for all point clouds in the current viewer.



Configure Point Size and Type

Steps

1. Click this button to open the dialog shown as below:

2. Configure point size and type.

Settings

Circular Points: Determine point type. If checked, point will be rendered as circle, otherwise, point will be rendered as square.
Fixed Size: If checked, point size would be fixed. User can adjust point size using the slider below (range 0-50 pixels).
Point Autosize: If checked, point size is auto changing based on the depth of the viewer.

Note: This function is global. If user wants to configure a single point cloud, just right-click it, select Configure Point Size and Type from
the context menu.

Brief: Configure point size and type.



As 2D

Steps

1. After clicking this button, current active window will switch to 2D mode, as shown below:

2. When the display mode of the window is switched to 2D, rotation angle setting slider will be displayed in the status bar. Drag the slider to
change the rotation angle of that window. The range of the rotation angle is [0°, 360°). Clockwise rotation angle is positive. See details
below:

Note: If current active window contains raster data, it can only be set to 2D mode. After removing raster data, it can be set to 3D mode.

Brief: Switch current active window to 2D mode.



As 3D

Steps

1. After clicking this button, current active window will switch to 3D mode, as shown below：

Note: If current active window contains raster data, it can only be set to 2D mode. After removing raster data, it can be set to 3D mode.

Brief：Switch current active window to 3D mode



New Window
Brief：Create new window in the current project.

Steps

1. Click the menu Viewers > Add Window. The result is as follows.

Shortcut Key：Ctrl+F3



Profile View

The use of LiDAR data to produce high-precision terrain products requires manual inspection of the results of automatic classification. In this
case, profile viewing tools are required. LiDAR360 provides profile view function starting from V5.0 version, which can complete classification
inspection more efficiently.

Draw Profile

Profile Viewer Tool

Profile and Measurement Tools

When the profile is turned on, the point cloud window does not support the measurement function. The profile window supports single-point
selection, multi-point selection, length measurement, angle measurement, slope measurement, and height measurement.

Section Window and Strip Alignment

In the track stitching function, we need to view the data position difference between different flight belts caused by the set-up angle error in
the profile window.

The above picture can clearly see the relative position of the point cloud before splicing.

During the splicing process, you can view the splicing effect of different parameters in real time through the section window:

Description: The section editing function allows the user to display the point cloud data of any rectangular area in the main
window in the section window, which is convenient for the user to view, measure, and modify the class.



After ensuring that it is correct, the point cloud can be transformed according to the current parameters and written directly to the disk.

Profile View and Strip Alignment

The measurement tools of the profile window can also assist in the error estimation of the pitch, roll and heading angles in Strip Alignment
function. Please refer to Strip Alignment for more details.

Profile View and ALS Editor

When the ALS Editor toolbar is opened, the host window will be set to 2D view. The Profile tool can help to check whether the seed points
positions are accurate in 3D. Please refer to ALS Editor for more details.

Note： ALS Editor has its own profile tools.

Profile View and TLS Editor

When the TLS Editor toolbar is opened, the host window will be set to 2D view. The Profile tool can help to check whether the seed points
positions are accurate in 3D. Please refer to TLS Editor for more details.

Note： TLS Editor has its own profile tools.



Quick ToolBar
Quick Toolbar is at the upper-left corner of interface, includes: Add and Merge Point Cloud Data

Add Data, Delete Data, Export Data, Open Project, New Project, Save Project, Save As。



Add Data

Import LAS/LAZ File

The LAS file is intended to contain LiDAR point data records. The data will generally be put into this format from software (e.g. provided by
LiDAR hardware vendors) which combines GPS, IMU, and laser pulse range data to produce X, Y, and Z point data. The intention of the data
format is to provide an open format that allows different LiDAR hardware and software tools to output data in a common format.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the LAS file you want to import and click Open for the Open LAS File window where you can do some initial settings as shown in
the figures below:

3. Click tab Header to check general LAS file header information such as Version, Source ID, System ID, Generating Software, File
Creation Day/Year, Header Byte Size, Data Offset, Number of Point Records etc.

4. Click tab Attribute Option to set Crop Option and decide which point attributes you want to import for each point record. LiDAR360
imports all the point attributes by default.

Brief: One of the most useful features of LiDAR360 is its ability to interface with data in many file formats. You can import point
clouds (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV, E57, etc.), tables, images (JPG, TIF), models (OSG, LiModel, LiTin) or
vectors into LiDAR360. It allows you to visualize, animate and edit your point cloud as well. Point cloud data will be converted into
LiData file at the first time being added. LiData file is the LiDAR360 native file format for point cloud and optimized for viewing.



5. Click tab Coordinate Option to set the coordinate system for your point records.

You can search the coordinate system much more quickly by using regular expressions. For example, the WGS 84 coordinate system
will be displayed instantly when you input EPSG code of WGS 84 system as shown in the figure below:



You can also import coordinate system form WKT or PRJ by clicking drop-down menu Add Coordinate System. Recently used coordinate
reference systems holds a history list.

6. Click Apply or Apply All when you finish your configuration. Apply implies that you want this configuration for current point cloud data
only. Apply All means all the point cloud data share the same configuration during the LiDAR360's running and it won't show this
configuration window again even you add new data.

Import TXT File

A point cloud is a set of vertices in a three-dimensional coordinate system usually defined by X, Y, and Z coordinates and other attributes
such as color and normal. These attributes can be simply arranged in one line for each point record and one single TXT file for one-point set.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the TXT file you want to import and click Open for the Open Ascii File window where you can do some initial settings as shown in
the figures below:



3. LiDAR360 can automatically detect the delimiters but you can also specify delimiter manually.

4. There are indeed cells that are colored red in the import window if TXT file has a header. Just skip them by setting Skip line value to 1.

5. Use the drop-downs to give the proper form of your point records.

Import CSV File

The so-called CSV (Comma Separated Values) format is the most common import and export format for spreadsheets and databases. CSV
format was used for many years prior to attempts to describe the format in a standardized way in RFC 4180. The lack of a well-defined
standard means that subtle differences often exist in the data produced and consumed by different applications. These differences can make
it troublesome to process CSV files from multiple sources. Still, while the delimiters and quoting characters vary, the overall format is similar
enough that it is possible to write a single module which can efficiently manipulate such data.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the CSV file you want to import and click Open for the Open ASCII File window where you can do some initial settings as shown
in the figures below:



CSV file can be opened as table or point cloud.

3. Open as Table is recommended if the CSV file is the resultant product of the Segmentation function. The CSV table contains the ID of
each tree, the x, y coordinate locations, the tree height, the crown diameter, and the crown area properties. The data type could be Point
or Circle. If Point type was selected, you should specify the X,Y,Z columns additionally.

If Circle type was selected, you should specify the center and radius.

Click Show Label radio button to show/hide label for each point or circle.

4. The Import TXT File section has more detailed descriptions if you Open as Point Cloud.

Import PLY File

The polygon (PLY) file format, also known as the Stanford triangle format stores three-dimensional data from 3-D scanners. It is a format for
storing graphical objects that are described as a collection of polygons. A PLY file consists of a header, followed by a list of vertices and then,
a list of polygons. The header specifies how many vertices and polygons are in the file. It also states what properties are associated with each
vertex, such as (x, y, z) coordinates, normals, and color. The file format has two sub-formats: an ASCII representation and a binary version for
compact storage and for rapid saving and loading. The header of both ASCII and binary files is ASCII text.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the PLY file you want to import and click Open for the Open PLY File window where you can do some initial settings as shown in
the figure below:



3. Specify properties that associated with each vertex's coordinates(x,y,z).

4. Specify properties that associated with each vertex's color (r,g,b) if they have any. Otherwise, simply choose None.

5. Click Apply when you complete your configuration.

Import E57 File

1. Select the e57 file need to load. For the file which is loaded first time, the following window will popup when being loaded. At the top of
this window, the following information is displayed: the path of the file, the information in the head of the file. And the head contains the
node name, version number, XYZ scaling factor, offset, and bounding box information of the E57 data.

2. In the Attribute Option tab page, users can choose to resample the point cloud when opening it. By default, all points are loaded. Users
can also select the attributes of E57 data and additional attributes to be loaded. By default, all attribute information of E57 data is
imported.



For example: Enter the EPSG code of WGS84 coordinate: 4326, users can quickly find the WGS84 coordinate system:

The records of recently used systems will be displayed in Recently used coordinate reference systems.

Click Apply to import the currently selected E57 data into the software with the current settings and start loading the point cloud. If users
select Apply All, the data opened this time will adopt the same settings. The dialog box for opening E57 data will not pop up until opening an
E57 data again.

1. In the Coordinate Option tab page, users can set the coordinate system of the point cloud data. Enter the keywords of the coordinate
system to quickly find the corresponding coordinate system. You can also click the drop-down menu of the Add Coordinate System
button and choose to import the coordinate system from WKT or PRJ.



Import Raster File

A raster data structure is based on a (usually rectangular, square-based) tessellation of the 2D plane into cells. In its simplest form, a raster
consists of a matrix of cells (pixels) organized into rows and columns (grid) where each cell contains a value representing information. The
geographic location of each cell is implied by its position in the cell matrix. Accordingly, other than an origin point, e.g. bottom left corner, no
geographic coordinates are stored. Due to the nature of the data storage technique data analysis is usually easy to program and quick to
perform.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Raster file and click Open.

Import Vector File

Vector data can be represented at its original resolution and form without generalization. Graphic output is usually more aesthetically pleasing
(traditional cartographic representation). Since most data is in vector form and no data conversion is required. Accurate geographic location of
data is maintained.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Vector file and click Open.

Import Model File

LiModel file is the native file format where LiDAR360 stores triangulated regular network models generated by DEM or DSM. LiTin file is
generated by the irregular 2.5D triangulation model based on the point cloud.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Model file and click Open.

Note: You can drag file(s) into LiDAR360 directly. If you can't, click here for more help.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Add and Merge Point Cloud Data

Steps

1. Click tool botton  to open the Add and Merge Data window.

Bounding boxes of point clouds are displayed in the left area. Bounding box of the selected point cloud is highlighted in red.

2. Select LAS or LiData as your data type.

3. Click  to add LAS/LiData file(s).

4. Click  to remove LAS/LiData file(s).

5. Click  to remove all file(s).

Brief: Merge two or more point clouds in LAS/LAZ or LiData format to one single point cloud in LiData format.



Delete Data

Steps

1. Select the data item you want to remove in the tree widget to active the Remove button .

2. Click  .

Note: In some cases, it is not allowed to remove data from LiDAR360 when it is busy running some critical functions.

Brief: Remove data.



Export Data

Steps

1. Select the point cloud data you want to export in the tree widget on the left.

2. Move the mouse to that item and right click.

3. Click Export to show the Export Point Cloud window.

4. Input file path and name:

5. Set file type:

6. Click Save .

Brief: As described in Import section, you can easily move data into and out of LiDAR360. You can currently export point clouds
from LiData to many other formats (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV etc.).



New Project

Steps

1. Click File > New Project.

That gives you a blank project to work on.

Brief: Create a new LiDAR360 project.



Open Project

Steps

1. Click File > Open Project to show Open Project window:

2. Select a LiDAR360 project file and click Open.

Brief: Open a LiDAR360 project file(*.LiProj).



Save Project

Steps

1. Click the Save Project button  on the tool bar,and then click Save.

2. If this is the first time that you are saving the project, type a name for it in the file name box, and then click Save.

3. You can save a project in the following file format: *.LiPrj.

Brief: Save project.



Save As

Steps

1. Click File > Save As.

2. Type a new name for it in the file name box, and then click Save.

Brief: Save your project file to another path.



Close Project
Brief: Close project.

Steps

1. Click File > Close Project.

2. If you want to save the project as well, type a name for it in the file name box, and then click Save.



Ribbon Toolbar
Ribbon Toolbar is at the upper-right corner of interface, includes:Batch Processing, Help documents, Advanced mode, Basic mode, Display
Optionand Options. Options includes Theme, Title Group Visible,Help, Quick Start, FAQ, Visit Company Website, Submit A BUG, Submit An
Enhancement, and Check for Updates.

Advanced and Basic modes are available for Terrain, ALS and TLS modules. Advanced mode provides all related tools regarding to each
application. Users can decide which tool to use on their demands, based on different datasets. While Basic mode provides a fast way of
analyzing. After setting all parameters and click "Run", data can be batch processed and saved to specified output path.



Batch Processing

Summary

LiDAR360 users can run multi-threaded batch processing routines for multiple functions on one or more .las or .LiData point cloud datasets.
Structured Tool and Command Line function calling modes are supported by the Batch Processing Toolset. The Structured Tool approach
allows the user to save a workflow’s order of operations and parameter settings for future use.

Structured Tool

1. Click the Batch Processing button to display the interface below. Point cloud datasets waiting in the processing queue will be shown in
the list on the top. Supported Batch Processing functions are shown on the bottom left. A sequence of functions to be executed will be
shown on the bottom right after editing.

2. Edit point cloud files using the buttons on the right side of the file list: Click the  button to add point clouds; Click the  button to clear
the file list; Click the  button to remove selected point clouds (.las or .LiData type). Users can select an individual point cloud file by
left clicking (hold Ctrl to select multiple files).

3. Double click a function in the left list (or select this function and click the  button) to add it into the execution sequence. Users must
ensure that all necessary parameters are set in the pop-up window if this function is not parameter-free.



4. (Optional) Double click a function in the execution sequence (or select this function and click the  button) to modify the parameters, if
any parameter needs to be set.

5. (Optional) Select a function in the execution sequence, then click the  or  button to adjust the order of execution.

6. (Optional) Click the  button to clear the execution sequence.

7. (Optional) Click the  button to save the execution sequence and corresponding parameters to file(*.LiProcessList).

8. (Optional) Click the  button to load execution sequence and corresponding parameters from file(*.LiProcessList).

9. Set the number of threads for multi-thread batch processing in the thread number box (scale 1-32, default 4). If the number of threads is
set to 1, a single thread processing will be performed.

10. Click the Execute button after setting the output path. The functions in the sequence will be executed for all point clouds in the file list.
Intermediate and final results are saved under the specified path.

11. Type the tool name in the searching bar to search for the tool. Please note the current language version of the software.

Note: This tool is only applicable to point cloud data (.las or .LiData type).

Some functions without parameters(e.g., PCV, Normalization by Ground Class) can be added directly and freely.

Some functions need extra data as input. For example, the Normalization function is based on DEM. Users should either specify an
existing DEM file as input, or check the option "Use Created File", which suggests that a DEM function must be executed prior to
Normalization. An improper sequence leads to failure in executing these types of functions.

Command Line

1. Open cmd.exe the command line window. Then drag LiBatch.exe from the LiDAR360 installation directory directly into the command line
window or input the correct path to LiBatch.exe. Then press "Enter". Software information, common command line commands and a list
of command-line callable batch functions (in English and Chinese) will appear.



2. The command line allows calling from json files. The data and functions recorded in a json file can be executed in order by inputting -
jsonFile plus the file name of json. The result will be saved to the output path. Json files can be generated using the interface batch
processing or modified manually. Users must keep in strict accordance with the format of relevant parameters to avoid any parsing
errors. For the list of Plugin ID and Action ID used to perform specific functions in the json file, refer to the appendix ID List of Json
Callable Functions for Batch Processing.

-jsonFile BatchProcessList.LiProcessList



3. According to the information prompt, users can enter -i plus the specific data file (full path) as input data. When inputting multiple files,
users can enter -i plus multiple files separated by spaces, or -ifolder plus data type for filtering (.las or .LiData, default: .LiData). Users
must ensure there is no space in the input file path, otherwise a parsing error will be raised. All parameter commands and specific
parameters must be separated by spaces.

Outlier_Rmovel -ifolder ..\data\ las

4. Users can use -o command to set a folder path, instead of a specific file path. If users do not set this parameter, the output file will be
saved in the same directory as the input file by default. Users can use -threadNum command to set the number of threads. Before calling
a function, users can enter -h, -H, -help or -? before the function name to check the arguments of the function. Command format:
command name(case sensitive)-----parameter introduction. To run a function without setting any parameters, users can use the
command -default/-DEFAULT, or leave it blank.

Outlier_Rmovel -h

5. Only one function can be called at each time. Taking outlier removal as an example, the valid input will be Outlier_Removal. The exact
function name must appear in the parameter list. Input -i plus file name and hit "enter" button to run outlier removal to the input file, using
default parameters, and save the output in the same folder as the input.

Outlier_Rmovel -i ..\data*.LiData

6. Taking classifying ground points as an example for the Classification module, users type in the command for classifying ground points -h,
then relevant command line help will appear in the window. For classification, the command -fc stands for the class origin, followed by
corresponding class number(s) according to the class list (default: all classes). The command -tc indicates the aimed class, followed by a
class number as well.

Classify Ground Points -h



7. For instance, the command below means: Run the function to classify ground points, in 8 threads, input file path D:\15.LiData, output file
folder D:\data4test\ (for classification there will not be an output file generated, however, the input point cloud data will be classified),
class origins 1 (unclassified), 2 (ground point), 3 (low vegetation), aimed class ground points, iteration angle 25 degrees, iteration
distance 1.2 meters, other unspecified parameters as default.

Classify Ground Points -threadNum 8 -i ..\input*.LiData -o ..\output\ -fc 1,2,3 -tc 2 -ia 25 -id 1.2



Display Options

Steps

1. Click this button to open the interface shown below. System setting includes UI style setting and language setting. The available styles
include scenic, blue, white, and dark gray. Languages include English, Chinese, French, etc.

2. Click "Viewer Setting" to switch to the interface shown below. The viewer setting includes model display light setting, viewer display, point
display setting, and label marker setting. The model display light setting can only be applied to the model files (such as LiModel, LiTin,
OSGB, etc.), and the position of the light source can be changed.

3. Click "Display Mode Setting" to switch to the interface shown below. The display mode setting is to display the checked display mode to

Brief: Display options include system setting, viewer setting, display mode setting, class settings, and shortcut info. Class priority
list under the class settings sets the priority of the classes in the profile, and will be displayed in order on the classification
interface and the profile view. Shortcut info includes shortcut keys for the commonly used functions of the system.



the ToolBar, and the unchecked display mode to the other display menu:

4. Click "Class Settings" to switch to the interface shown below.

5. Click "Shortcut Info" to switch to the interface shown below.



6. Click "Default All" to restore all settings to default values.

Settings

Hot Keys: Press P on keyboard to change the light source position.



Theme
LiDAR360 provides three GUI themes: Scenic Theme, Blue Theme, White Theme and Dark Gray Theme.

Scenic

Blue

White

Dark Gray



Theme Scenic
Brief：The system interface will be displayed in a scenic theme.

Steps

1. Click on the upper right corner of the software Options > Style > Scenic, the software will be displayed in a scenic theme:



Theme Blue
Brief：The system interface will be displayed in a blue theme.

Steps

1. Click on the upper right corner of the software Options > Style > Blue, the software will display in the blue theme:



Theme White
Brief：The system interface will be displayed in a white theme.

Steps

1. Click on the upper right corner of the software Options > Style > White, the software will be displayed in a white theme:



Theme Dark Gray
Brief：The system interface will be displayed in a dark gray theme.

Steps

1. Click on the upper right corner of the software Options > Style > Dark Gray, the software will be displayed in a dark gray theme:



Project Management Window
The data list in the project is managed by layers and windows separately.

Layer Management

Point Cloud

Raster

Vector

Table

Model

Window Management

Note: The data loaded into the project can be displayed in single/multiple window(s), or not displayed at all. Please drag data to a
certain window for display.



Layer Management

Summary

The project layers manage the data in the software by group, whose types include Point Cloud, Raster, Vector, Table, and Model.

Point Cloud: Proprietary LiData File(*.LiData), LAS File (*.las,*.laz), ASCII File (*.txt,*.asc,*.neu,*.xyz,*.pts,*.csv), E57 file (*.e57);
Raster: Image File(*.tif,*.jpg);
Vector: Vector File(*.shp);
Table: Table File(*.csv);
Model: Proprietary Model File(*.LiModel), Proprietary TIN File(*.LiTin), OSG Model File（*.osgb,*.ive,*.desc,*.obj);

In the project layers the user can remove data from the software, show/hide data in all windows by checking/unchecking the box before data
node (or data type node). The data can be dragged from data node to different windows for display. The context menu (i.e. right-click menu)
of data node, which differs depending on data types, is mainly used for data query, display, statistics, export, and removal, etc.

Click the  button to show the project layers as follows:

Context Menu

Open the context menu by right clicking data type or data.

Context menu of point cloud
Context menu of raster
Context menu of vector
Context menu of table



Context menu of model

Note: The context menu of layer management is effective on all windows, while the context menu of window management is only
effective on specified window.



Point Cloud Context Menu

Summary

The context menus are used to for data import, removal, query, display, statistics, export, etc.

Data Type Context Menu

The user can open this menu by right clicking the point cloud data type.

Import Data: The point cloud data formats supported by LiDAR360 include LiData (*.LiData), LAS (*.las, *.laz), ASCII (*.txt, *.asc, *.neu,
*.xyz , *.pts, *.csv), PLY (*. ply), and E57 (*.e57). The LiData is the proprietary point cloud data format, on which the point cloud
processing are based. Other imported formats of LAS, ASCII and PLY will be converted to LiData for subsequent processing. This
function is the same as the tool  Add Data.
Remove All: Remove all the point cloud data from the project.

Data Context Menu

The user can open this menu by right clicking a point cloud data object.

Info: View the basic information of the point cloud, including the path of the data, the coordinate information, the minimum and maximum
values of X, Y, and Z coordinates, the average and standard deviation of Z, the minimum and maximum GPS time, the minimum,
maximum, and average intensity Value and standard deviation, point cloud bounding box, total points, point cloud category statistics and
echo frequency statistics. If additional attribute information is included, the maximum, minimum and type of each additional attribute will
be displayed. as the picture shows. Click the "Export" button to export the basic point cloud information as a txt file.

Open Containing Folder: Open the folder.

Rename: Rename the file.

View Mode: Select the display mode of point cloud data between the following types.

Display by Height: The interface is shown as follows. The value range of display can be stretched by minimum/maximum or
standard deviation in order to improve the visual effects.



"Recalculate the histogram" is used to count and generate a histogram of all the points' elevation. When opening this function, the
histogram of sampled points' elevation is displayed by default, and the histogram may be inaccurate. The recalculate the histogram
function can take all the points' elevation into account, and generate an accurate histogram.

The curve can be saved in pdf files. Click the button "Save Curve" to pop up the following interface. Set the width, height,
resolution, output path of the curve and click "OK" button to save the curve to local disk.

The visual effects are consistent with the tool  Display by Height.

Display by Intensity: The interface is shown as follows. The value range of display can be stretched by minimum/maximum or
standard deviation in order to improve the visual effects.



"Recalculate the histogram" is used to count and generate a histogram of all the points' intensity. When opening this function, the
histogram of sampled points' intensity is displayed by default, and the histogram may be inaccurate. The recalculate the histogram
function can take all the points' intensity into account, and generate an accurate histogram.

The curve can be saved in pdf files. Click the button "Save Curve" to pop up the following interface. Set the width, height,
resolution, output path of the curve and click "OK" button to save the curve to local disk.

The visual effects are consistent with the tool  Display by Intensity.

Display by Class: Please refer to Display by Class for details.

Display by RGB: Please refer to Display by RGB for details.
Display by Return Number: Please refer to Display by Return for details.
Display by GPS Time: Please refer to Display by Time for details.
Display by Tree ID: Please refer to Display by TreeID for details.
Display by Edge Flight Line: Please refer to Display by Edge Flight Line for details.
Display by Number of Return: Please refer to Display by Number of Return for details.
Display by Point Source ID: Please refer to Display by Point Source ID for details.
Display by Scan Angle Rank: Please refer to Display by Scan Angle Rank for details.
Display by Scan Direction: Please refer to Display by Scan Direction for details.
Display by User Data: Please refer to Display by User Data for details.
Display by Scanner Channel: Please refer to Display by Scanner Channel for details.
Display by Near Infrared: Please refer to Display by Near Infrared for details.
Display by Selected: Select user-defined color to display the point cloud data. The interface and the visual effects are shown below.



Display by Blend: Please refer to Display by Blend for details.

Display by Mix: Please refer to Display by Mix for details.
Display by Additional Attributes: The following window will popup.

1. (Option) Select the attribute needs to set the color from the attribute drop-down list. 2. (Option) Select the index of the attribute
needs to modify from the scalar index drop-down list box. 3. (Option)Select a random color and set the number of colors to be
configured in the Number of Colors box. 4. (Option) Select a color bar from the color bar drop-down list. 5. Set the display range of
the additional attribute through the minimum and maximum values (click Default to restore the maximum and minimum values
calculated by the corresponding index of the attribute), click the Apply button, and the final display effect is shown in the following
figure.

Zoom to Layer: Calculate the bounding box of the current point cloud data. All the windows, in which the data object is loaded, will show
full extent of the bounding box.

Restatistics: Recalculate the Mean Z, Std Z, Mean Intensity and Std Intensity of point cloud data. This function is used to repair older
versions of LiData which may contain incomplete information.

Export: Export the point cloud data to LAS (*.las, *.laz), ASCII (*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv), PLY (*.ply), and E57 (*.e57) format.
The supported LAS version for export are 1.2,1.3,1.4, and the default version is 1.4. This function is the same as the tool  Export.
PCV: Process the point cloud data with PCV to improve the visual effects.
Point Size: The point size of each point cloud data object can be set separately or set uniformly according to the global settings. The
shape of points can be set to circle or square. The interface is shown as follows.



For global point size settings, see the usage of the tool  Configure Point Size.
Point Brightness: Set the brightness of a single point cloud data or all the point cloud data, as shown below:

To set the brightness of all point cloud data, users can click the  icon in the settings tool bar. For more details, please refer to Display
Options.

Remove: Remove the selected point cloud data from the current project. This function is the same as the tool  Remove.

Settings

Display by Height:
Color Bar: The colorbar supports several uniformly varying color intervals for color mapping.
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum pixel values, with the minimum
and maximum pixel values as the endpoints for the histogram. For example, the minimum and maximum pixel values of the
image could be 2488 and 2656 respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values
over the entire histogram range, the brightness and contrast of the image are increased and features in the image are easier to
distinguish.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n) value. For example, the minimum
and maximum pixel values of the image could be 2488 and 2656 respectively. If the value of standard deviation (n) is defined as
2, then the values beyond 2 standard deviation become 0 or 255, the remaining values stretch between 0 and 255.

Display by Intensity:
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum pixel values, with the minimum
and maximum pixel values as the endpoints for the histogram. For example, the minimum and maximum pixel values of the
image could be 2488 and 2656 respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values
over the entire histogram range, the brightness and contrast of the image are increased and features in the image are easier to
distinguish.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n) value. For example, the minimum
and maximum pixel values of the image could be 2488 and 2656 respectively. If the value of standard deviation (n) is defined as
2, then the values beyond 2 standard deviation become 0 or 255, the remaining values stretch between 0 and 255.

Save Curve:
Width: The width of the saved curve.
Height: The height of the saved curve.
Resolution: The resolution of the saved curve.
Output path: The output path of the saved curve.

Point Size:
Circular Points (Optional): Set the shape of the point to circle or square.
Specified set (Optional): Set the point size of the specified point cloud data separately.
Use global set (Optional): Set the point size of the specified point cloud data with global settings.

Note：Except the import data function, other right-click menu functions work on all viewers loaded with the point cloud.



Raster Context Menu

Summary

The context menus are used to for data import, removal, query, display, etc.

Data Type Context Menu

The user can open this menu by right clicking the raster data type.

Import Data: The raster data formats supported by LiDAR360 include TIF and JPG. The function is the same as the tool  Add Data.
Remove All: Remove all the raster data from the project.

Data Context Menu

The user can open this menu by right clicking a raster data object.

Info: View the basic information of raster data, including file path, description, X size, Y size, bands count, pixel size, invalid value of
each band, projection, etc. The interface is shown below.

Open Containing Folder: Open the folder.

Histogram: View the histogram of the raster data, where the values of each band can be stretched separately. The raster data is
displayed in gray color bar by default. Select an appropriate color bar in the combo box. Click the button "Apply", the raster data in the
scene will be rendered according to the above settings, as shown below.

Select the stretch method and generate the corresponding histogram, as shown below.



The button "Default" is used to restore the default settings. The button "Recompute Histogram" is used to calculate all the pixel values of
the raster data again. The sampling points are 250000 by default. When the pixel size of the raster data exceeds the value, the statistical
results may be inaccurate, then this button is needed. The histogram can be saved in *.pdf format. Click the button "Save Histogram" to
pop up the following interface. Set the width, height, resolution, output path of the histogram and click "OK" button to save the result to
local disk.

Zoom to Layer: Calculate the bounding box of the current raster data. All the windows, in which the data object is loaded, will show full
extent of the bounding box.

Zoom to Native Resolution (100%): Display the raster data in 1:1 ratio according to the resolution of the raster data.
Remove: Remove the selected raster data from the current project. This function is the same as the tool  Remove.

Settings

Histogram:
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum pixel values, with the minimum
and maximum pixel values as the endpoints for the histogram. For example, the minimum and maximum pixel values of the
image could be 2488 and 2656 respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values
over the entire histogram range, the brightness and contrast of the image are increased and features in the image are easier to
distinguish.
Percent Clip: Apply a linear stretch between the pixel values defined by percent clip minimum and percent clip maximum. For
example, the minimum and maximum pixel values of the image could be 2488 and 2656 respectively. Percent clip minimum and
percent clip maximum values are 0.02 and 0.98, values less than 0.02 mean the values between 2488 and 2492, values more
than 0.98 mean the values between 2652 and 2656, values between 2488 and 2492 become 0, values between 2652 and 2656
become 255, the remaining values are between 0 and 255.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n) value. For example, the minimum
and maximum pixel values of the image could be 2488 and 2656 respectively. If the value of standard deviation (n) is defined as
2, then the values beyond 2 standard deviation become 0 or 255, the remaining values stretch between 0 and 255.
Histogram Equalization: Apply a non-linear stretch between the pixel values, redistribute the pixel values so that the pixel
values in a certain range is approximately equal. This method works well when there are a lot of pixel values that are closely



grouped together.
Color Bar: The colorbar supports several uniformly varying color intervals for color mapping.
BandList: Select a band from the band list to draw the histogram.
Show all bands (Optional): Whether to show all bands.

Save Curve:
Width: The width of the saved curve.
Height: The height of the saved curve.
Resolution: The resolution of the saved curve.
Output path: The output path of the saved curve.



Vector Context Menu

Summary

The right button menu of vector data in the layer management tree mainly includes import and export vector data, it also contains display
information, display attribute table, zoom to layer, display by elevation, and display by selected color, display by height, and remove
opreations for single vector data.

Data Type Context Menu

Import Data: The import data format is SHP (* .shp), the same with the function , see Add Data. Import vector data generate by Point
Cloud to Contour) , as shown below:

Remove All: Remove all vector data from LiDAR360.

Data Context Menu

Info: View the basic information of vector file, including file path, elements count and bounding box.

Open Containing Folder: Open the folder.
Rename: Rename the file.
Attribute Table: Displays the property sheet information of the vector data. The result is shown in the figure:



Single-click the row or the cell in the attribute table, the corresponding data will be highlighted as shown in the following picture:

Double-click the button in front of the row in the attribute table, it will zoom to the corresponding data, as shown in the following
picture:



Zoom to Layer: Calculates the bounding box of the current vector data, and all windows that contains this file will display globally in this
bounding box range.

Display by Height: Display the vector data by z value based on selected color bar.
Display by Selected: Display the vector data in fixed color, as shown in the following figure:



Remove: Remove vector file from LiDAR360.
Save: Save vector file from LiDAR360.

Note: Except "Import Data", the other function in context menu work on all windows that contains this vector file.



Tables Context Menu

Summary

The right button menu of table data in the layer management tree mainly includes import and export table data, it also contains display
information, display settings, zoom to layer, display by selected color, display by height, recalculate the statistics, export, and other operations
for single model data.

Data Type Context Menu

Import Data: The import data format is CSV（* .csv）. If click this function, pop-up the dialog, select data type as "Point" or "Circle", and
set the specified field X, Y, Z, Diameter (if the data type is circle), and check whether to show labels.

Select data type as "Point", the table file displayed as below:



Select data type as "Circle", the table file displayed as below:

Remove All: Remove all table files from LiDAR360.

Data Context Menu

Info: View the table's basic information, including path, the number of elements, the minimum and the maximum of X, Y, Z values.



Open Containing Folder: Open the folder.

Rename: Rename the file.

Attribute Table: Display the contents of the table. As shown in the following figure, double click specific row, the window will go to the
position.

Single-click the row or the cell in the attribute table, the corresponding data will be highlighted as shown in the following picture:



Double-click the button in front of the row in the attribute table, it will zoom to the corresponding data, as shown in the following
picture:

Zoom to Layer: Calculates the bounding box of the current table data, and all windows that contains this file will display globally in this
bounding box range.

Display by Selected: Display the table data by selected color, as shown in the following picture:



Display by Height: Correspond the elevation information of the table data to a uniformly changing color band. And display the table data
on the screen as shown below:

Remove: Remove the selected file from LiDAR360.

Note: Except "Import Data", the other function in context menu work on all windows that contains this table file.



Model Context Menu

Summary

The right button menu of model data in the layer management tree mainly includes import and export table data, it also contains information,
display setting, zoom to layer, restatistics, export for single model data.

Data Type Context Menu

Import Data: The model formats that LiDAR360 supported includes: Model (.LiTin), LiModel (.LiModel)、OSG data (.osgb, .ive, .desc,
.obj). Among them, the LiTIN format and LiModel format are LiDAR360 defined model format. This function is the same with the function 

 , see Add Data.
Remove All: Remove all model files from LiDAR360.

Data Context Menu

Info: View the basic information of model file, including the path, resolution, the minimum and maximum of X, Y, Z. This function just for
LiTin and LiModel file.

Open Containing Folder: Open the folder.
Rename: Rename the file.
View Mode: Set the model file's display mode, including display by elevation, display by texture, display by light. If the "Display by
Elevation" is selected, the color bar selection dialog will be popped up, the display effect as below:



The user can Convert to Texture LiModel. An example of "Display by Texture" is shown below:

If the "Display by Lighting" is selected, the color bar selection dialog will be popped up, the display effect as below:



Zoom to Layer: Calculates the bounding box of the current model data, and all windows that contains this file will display globally in this
bounding box range.
ReStatistics: Recalculate basic information such as Min X Y Z and Max X Y Z. In general, if you edit the LiModel data, such as smooth
height or repair height, you can use the Restatistics function.
Export: This function is only for LiTin and LiModel file, and the export format is TIF. In General, after 3D visualization editing of LiModel
and LiTIN which generated by DEM, it is necessary to convert the editing files to TIF format file.
Remove: Remove the selected model data from viewer window or project.

Note: Except "Import Data", the other function in context menu work on all windows that contains this model file.



Window Management

Summary

The project windows manage all windows(i.e. viewers) and data in windows. The user can remove data from window, edit display order by
dragging data node, show/hide data in specified window by checking/unchecking the box before window/data node. The context menu(i.e.
right-click menu) of data node, which differs depending on data types, is mainly used for data query, display, statistics, export, and removal,
etc. These functions are effective on specified window.

Click the  button to show the project windows as follows:

Context Menu

Open the context menu by right clicking window or data.

Window Context Menu

Remove All: Remove all data from the selected window.

Data Context Menu

Point Cloud Data Context Menu: Same as the context menu of point cloud data in layer tree.
Raster Data Context Menu: Same as the context menu of raster data in layer tree.
Vector Data Context Menu: Same as the context menu of vector data in layer tree.
Table Data Context Menu: Same as the context menu of table data in layer tree.
Model Data Context Menu: Same as the context menu of model data in layer tree.



Note: The context menu of window management is only effective on specified window, while the context menu of layer management is
effective on all windows.



File
File page includes： Add Data, Project( New Project, Open Project, Save Project, Project Save as, Close),

Batch Processing, Display Option, Activate License, About and Exit。



Tools
This module includes Measurement,Clipping and Data Management.

Measurement

Clipping

DataManagement



Measure Tools
The measure tools are used to measure geometric information about the data.

Pick Point

Multi Pick Point

Density Measurement

Length Measurement

Area Measurement

Angle Measurement

Height Measurement

Gradient Measurement

Volume Measurement

Profile View



Pick Point

Steps

1. Click a valid point in the scene and a label that displays the point attributes will pop up. If the point belongs to point cloud data, then the
label will show the position, intensity, return number, classification and GPS time, as is shown below. If the point belongs to raster data,
then the label will show the position, stretched RGB value and pixel value.

Click the right mouse button, two context menus will pop up. The menu "Clear Measure" is used to clear the selection result. The menu
"Quit Measure" is used to exit the pick point function.

Note: This tool only works with point cloud data, raster data and model data. It's available in the profile window too. Only if it is specified
to do so, will the additional attributes be displayed.

Brief: This tool is applicable to point cloud data, raster data and model data. For point cloud data, the attributes that can be
queried contain position, intensity, return number, classification and GPS time. For raster data, the attributes that can be queried
contain position, stretched RGB value and pixel value.



Multi Pick Point

Steps

1. Left-click the points in the scene and the selection results are marked by labels. At the same time, a table that contains the attributes of
the selection points will pop up, shown as follows. The attributes of point cloud data shown in the table contain index, position (XYZ),
classification, return number, GPS time and intensity. The attributes of raster data shown in the table contain index, position (XY) and
band value. The total number of the points is updated real-time above the table.

2. The "marker size" is used to set the point size of the marker in the scene. The "start index" is used to set the start index of the selected
points.

3. Select a row of the table by left-clicking and click the button  to delete the point.
4. After clicking the "Start Editing" button, the attribute values can be changed by double-clicking the cells in the added attribute columns,

and typing in the new values.

5. After clicking the "Add Attribute" button, the following dialog will pop-up. Currently, it is supported for the following types of custom
attributes: integer, float, text, date, and enum. After click "ok" button, the added field will be displayed in the attributes table.

6. The "Remove Attribute" button is not available when there is no custom attributes added. After adding custom attributes, the custom
attributes can be removed by clicking "Remove Attribute" button (only the custom attributes can be removed).

7. The selection set can be exported as txt, asc, neu, xyz, pts, or csv file. Click the drop-down menu  to pop up "Select Format" dialog,
as shown below. If the selected points belong to raster data, then the menu "Save 2D points" is available. If the selected points belong to
3D data, then the menu "Save 3D points" is available. If the selected points contain 2D data and 3D data, then the menu "Save all points"
is available.

8. Click  to pop up the export dialog. Input the output path, and check the attributes that need to be exported. Click "OK" to

complete the export. Click "Cancel" to cancel the export.
9. If the selected points have not been saved before quiting this tool, a message box will pop up as follows. Click "Save" to save the points.

Click "Discard" to cancel the selections.

Brief: This tool is applicable to point cloud data, raster data and model data. For point cloud data, the attributes that can be
queried contain position, intensity, return number, classification and GPS time. For raster data, the attributes that can be queried
contain position, stretched RGB value and pixel value. Different from the pick point tool, this tool allows querying multiple points at
the same time, and the selection set can be exported in txt, asc, neu, xyz, pts, or csv file.



Settings

X: X component of the coordinate.
Y: Y component of the coordinate.
Z: Z component of the coordinate.
Classification: The class attribute of point cloud data.
Return: The return number attribute of point cloud data.
Time: The GPS time attribute of point cloud data.
Intensity: The intensity attribute of point cloud data.
Index: The index of select point.
BandValue: The band value of raster data.
Output Path: The path of the output file.

Note: This tool only works with point cloud data, raster data and model data. If the center of rotation needs to be changed, hold down
the the Ctrl key and select the center of rotation with the left mouse button. This tool is available in the profile window too.



Length Measurement

Steps

1. Left-click at least two points in the scene and the corresponding polyline will be rendered real-time. The measurement result is displayed
in a label as follows. Double-clicking the last point will stop the measurement process, and the distance value will continue to be
displayed in the label.

Note: This tool only works with point cloud data, raster data and model data. The "Back One Point" is only available before the
measurement is stopped. This tool is available in the profile window, too.

Brief: This tool is applicable to point cloud data, raster data and model data, which calculates the distance between two
consecutive points.



Area Measurement

Steps

1. Left-click at least three points in the scene and the corresponding polygon area will be rendered real-time. The measurement result is
displayed in a label as follows. Double-clicking the last point will stop the measurement process, and the measurement result will
continue to be displayed in the label.

Right-click to go back to the previous point during the measurement.

Note: This tool only works under orthogonal projection. The "Back One Point" is only available before the measurement is stopped.

Brief: This tool is applicable to all data types supported by LiDAR360, which calculates the projected area within the polygon
region. Current window will switch to Orthogonal Projection automatically for 3D data.



Angle Measurement

Steps

1. Select the first point of angle measurement by left-clicking. 2. Select the second point of angle measurement by left-clicking. 3. Select the
third point of angle measurement by double-clicking. The projection angle of the three points on the horizontal plane will be rendered in the
scene and the measurement result is displayed in a label as follows.

Note: This tool only works with point cloud data, raster data and model data. The "Back One Point" is only available before the
measurement is stopped. The tool is available in the profile window too.

Brief: This tool is applicable to point cloud data, raster data and model data, which calculates the angle created by the three
picked points in 3D view and calculates the projection angle of three points on the horizontal plane in 2D view.



Height Measurement

Steps

1. Select the reference point of height measurement by left-clicking.
2. Select the measurement point by double-clicking. The relative height difference between the reference point and the measurement point

will be rendered in the scene and the measurement result is displayed in a label as follows.

Right-click to go back to the previous point during the measurement.

Note: This tool only works with point cloud data and model data. The "Back One Point" is only available before the measurement is
stopped. The tool is available in the profile window too.

Brief: This tool is applicable to point cloud data and model data, which calculates the relative height difference between two
points.



Gradient Measurement

Steps

1. Click the single point of the data with the left mouse button and select the reference point for angle measurement. 2. Double-click the left
mouse button to determine the measurement point, and the measurement ends. The measurement angle is drawn in real time in the scene,
and the measurement result is displayed in the form of a label in real time (as shown).

Note: This function is only for the angle measurement of point cloud data, raster data, and model data. This function can also be used
in the profile window. The undo function can only be used before double-clicking the mouse.

Description: Gradient measurement can be used to measure the gradient on point cloud, raster, or model data. Users can click
the mouse to pick the measurement points interactively to measure the vertical angle of the line formed by the selected two points,
or the angle between the line formed by the selected two points and the horizon plane.



Volume Measurement

Steps

1. After open this tool, the options of volume measurement methods will pop up. If volume measurement is selected, users need to select
the measurement area by clicking mouse; if measurement area is defined by file, users can load the file with measurement area
information to measure the volume of the target object. It is suggested to adjust the window to top view before the tool is used.

2. (Optional) Select at least three points to generate the reference plane for volume calculation by left-clicking. Select the last point by
double-clicking. The border of the selected region will be rendered in red and the dialog "Volume Measure" will pop up.

3. (Opetional) Select the SHP file which defines the boundary of the measurement area (supporting defining the measurement area with
polygon or closed polyline)

4. Set the cell size.
5. Set the reference plane of volume measurement. The options include minimum value, fit plane, and customizing.
6. Set the data source for volume measurement. The data source type includes the loaded point and all points.
7. Click the "Compute" button to generate the measurement result, including Projected area, surface area, cut volume, and fill volume. The

corresponding volume will be rendered in the scene, as shown below.

8. Click the "Export" button to export the result in *.pdf format.

Settings

Brief: This tool is applicable to point cloud data and model data, which calculates filling, cutting and total amount relative to a
reference height. The measurement area can be selected either by interactively selecting polygon vertices or by inputting the
vector file of the polyons. It's commonly used in volume measurement of coal pile and hull.



Cell Size: It defines the smallest unit size for calculation. The smaller the value is, the more accurate the calculation is.
Basic Height: It defines the reference plane to calculate filling and cutting.

Minimum (Default): Use the minimum height of the selected points as the height of the reference plane.
Fitted Plane: Fit the best plane according to the selected points.
Customize: This value is specified by the user.

Data Source: specify the points used to calculate the volume.
Loaded Points: Use the points only in the loaded point cloud files in the specified area. The efficiency is high while the accuracy is
low.
All Points: Use the points in all the point cloud files in the specified area. The efficiency is low while the accuracy is high.

Note: This tool only works with point cloud data and model data in 3D view.



Density Measurement

Steps

1. Active window is adjusted to orthogonal projection automatically when this tool is started. Then the dialog "Density" pops up.
2. If the option "Width" is checked, the width value can be manually input, and the height value will be set to the same as the width value,

then the area value will be decided by "Width" and "Height". The measurement region can be selected by left-clicking.
3. If the option "Width" is unchecked, the width value and the height value will be decided by the size of the rectangle that is drawn

interactively by left-clicking the upper left corner and the lower right corner. The area value will be decided by "Width" and "Height". The
rectangle will be rendered in the scene and the measurement result (number of total points and point density) is displayed in a label as
follows.

Settings

Width: It defines the width of the reference rectangle.
Height: It defines the height of the reference rectangle.
Area: It defines the area of the reference rectangle.

Note: This tool only works with point cloud data and model data under orthogonal projection.

Brief: Point density is an important metric to measure the quality of point cloud data. The average number of points per square
meter can be counted with this tool.



Clipping
Select and save point clouds in interest area.

Polygon Selection

Rectangle Selection

Sphere Selection

Circle Selection

Lasso Selection

Subtract Selection

In Cut

Out Cut

Save Cut Result

Cancel Selection

Cross Selection

Clip



Polygon Selection

Steps

1. Click the Polygon Selection button to activate this function (Click again if you want to deactivate it).

2. Add polygonal vertices by left click. At least 3 vertices are needed to form a closed loop.

3. (Optional) Delete added vertices in reverse order by right click, if some of them are unwanted.

4. Left double click to add the last vertex. The selected points in the polygon area are highlighted.

5. (Optional) Combine multiple selections.

Brief: Select point cloud data in polygon area.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Rectangle Selection

Steps

1. Click the Rectangle Selection button to activate this function (Click again if you want to deactivate it).

2. Add the first vertex by left click. Then move cursor to adjust rectangle size.

3. (Optional) Delete the first vertex by right click, if it's unwanted.

4. Left double click to add the second diagonal vertex. The selected points in the rectangle area are highlighted.

5. (Optional) Combine multiple selections.

Brief: Select point cloud data in rectangle area.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Sphere Selection

Steps

1. Click the Sphere Selection button to activate this function (Click again if you want to deactivate it).

2. Add the center point of sphere by left click. Then move cursor to adjust radius.

3. (Optional) Delete the center point by right click, if it's unwanted.

4. Left double click to confirm the radius. The selected points in the sphere are highlighted.

5. (Optional) Combine multiple selections.

Brief: Select point cloud data in sphere.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Circle Selection

Steps

1. Click the Circle Selection button to activate this function (Click again if you want to deactivate it).

2. Click to select the center of the circle. Move the mouse, and the position of mouse will be recognized as the boundary of the circle. And
the circle will be preview in the window.

3. Right-click to cancel the circle center selection. Go back to the second step and choose the circle center again.

4. Double-click to define the boundary of the circle. The selected points in the circle area are highlighted.

5. (Optional) Combine multiple selections.

Brief: Select point cloud data in circle area.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Lasso Selection

Steps

1. Click the Lasso Selection button to activate this function (Click again if you want to deactivate it).

2. Click to select the starting point of the ROI. Move the mouse, and the mouse position will be used as a lasso boundary to form a closed
area. And the area will be preview in the window.

3. Right-click to cancel the selection. Go back to the second step and choose the starting point of ROI again.

4. Double-click to end the boundary selection. The selected points in that area are highlighted.

5. (Optional) Combine multiple selections.

Brief: Select point cloud data with a Lasso tool.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Subtract Selection

Steps

1. Activate one of the geometric selection tools (Polygon Selection, Rectangle Selection or Sphere Selection) before using Subtract
Selection. Then please activate/deactivate Subtract Selection by left click.

2. (Optional) If Subtract Selection is inactive, multiple selections can be combined.

Brief: This function is effective on one of the geometric selection tools (Polygon Selection, Rectangle Selection or Sphere
Selection). If Subtract Selection is inactive, more points can be added to the currently selected. If active, unwanted points can be
removed from the currently selected.





3. (Optional) If Subtract Selection is active, unwanted points can be removed from the currently selected.



Shortcut Key: Press Ctrl + Z to undo the last operation.

Note: This function is only applicable to point cloud data.



Cancel Selection

Steps

1. Click this button after selections(Polygon Selection, Rectangle Selection, Sphere Selection) or cut operations(In Cut, Out Cut). All the
selections and cut operations will be cancelled.

Note: This function is only applicable to point cloud data.

Brief: Cancel all the selections and cut operations.



In Cut

Steps

1. Select points using Polygon Selection, Rectangle Selection or Sphere Selection. The selected points are highlighted.

2. Click the In Cut Button. The result is shown in the following figure.

3. (Optional) You can repeat this function several times to get the result you need.

Shortcut Key: Press Ctrl + Z to undo the cut operation. The corresponding selection is also cancelled.

Note: This function is only applicable to point cloud data.

Brief: Cut point clouds after selection. The selected points are kept while the unselected are hidden.



Out Cut

Steps

1. Select points using Polygon Selection, Rectangle Selection or Sphere Selection. The selected points are highlighted.

2. Click the Out Cut Button. The result is shown in the following figure.

3. (Optional) You can repeat this function several times to get the result you need.

Shortcut Key: Press Ctrl + Z to undo the cut operation. The corresponding selection is also cancelled.

Note: This function is only applicable to point cloud data.

Brief: Cut point clouds after selection. The selected points are hidden while the unselected are kept.



Save Cut Results

Steps

1. Click this button after successful cut operations(In Cut, Out Cut). An interface is shown as follows.

2. Select source point cloud files, from which new files are generated.

3. (Optional) Check/Uncheck the option "Merge files into one" according to demand.

4. Specify the output path. New file names are created based on the source file names and system time. An example of new file name is
"SourceFileName_CutResult_SystemTime.LiData".

5. After data saving, a dialog will ask if you want to add the new files to current project.

6. Click Yes or No according to demand.

Brief: Save results after cut operation as new point cloud files.



Clip by Circle

Summary

Clip by circle tool extracts the point cloud data within user-defined circle(s), and the extracted points can be saved in one or multiple files.

Usage

Click Data Management > Clip > Clip by Circle

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
X Coordinate (m): Enter the X coordinate of the circle center.
Y Coordinate (m): Enter the Y coordinate of the circle center.
Radius (m): Enter the radius of the circle.
Ignore Different Additional Attributes: When inputs are several point cloud files, and this option is checked, only the same additional
attributes of the point cloud files will be merged. If this option is unchecked, and there are some different attributes in the additional
attribute tables, the mergence of different point cloud files cannot be done.
Generate a File: Extract all the point cloud data within 2D circle(s) to one file.
Generate Multiple Files: Extract the point cloud data within each circle and save them to one individual file. The file is named by its
center and radius by default.

：After clicking this button, users will be able to draw circle in the current window. Single-click to choose the center of the circle, and
drag the mouse to change the size of the circle. Double-click to end the selection. The coordiantes of the center of circle and the radius of
the circle will be displayed in the window.

: Click this button to add the coordinates and radius of a circle to the processing list. Perform the same operation to add multiple
clipping circles.

: Click this button to load external data files. The file format refers to the Clip Range File Format in the appendix.
: Click this button to remove the selected row(s) in the processing list.

Output path: The generated file will be saved in this output path.



Clip by Rectangle

Summary

Clip by rectangle tool extracts the point cloud data within user-defined rectangular(s), and the extracted points can be saved in one or multiple
files.

Usage

Click Data Management > Clip > Clip by Rectangle

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Y Maximum (m): Enter the maximum Y coordinate of the rectangle.
Y Minimum (m): Enter the minimum Y coordinate of the rectangle.
X Minimum (m): Enter the minimum X coordinate of the rectangle.
X Maximum (m): Enter the maximum X coordinate of the rectangle.
Ignore Different Additional Attributes: When inputs are several point cloud files, and this option is checked, only the same additional
attributes of the point cloud files will be merged. If this option is unchecked, and there are some different attributes in the additional
attribute tables, the mergence of different point cloud files cannot be done.
Generate a File: Extract all the point cloud data within the rectangle to a file.
Generate Multiple Files: Extract the point cloud data within each rectangle and save them to one file. The file is named by the
rectangle's lower left corner coordinate and the rectangle's width and height by default.

：After clicking this button, users will be able to draw rectangle in the current window. Single-click to choose the first vertex of the
rectangle, and drag the mouse to change the size of the rectangle. Double-click to end the selection. The the location information of the
rectangle will be displayed in the window.

: Click this button to add the entered rectangle range to the processing list. Perform the same operation to add multiple clipping
regions.

: Click this button to load external data files. The file format refers to the Clip Range File Format in the appendix.
: Click this button to remove the selected row(s) in the processing list.

Output Path: The generated file will be saved in this output path.



Data Management
Data management includes Point Cloud Conversion, Raster Conversion, Model Conversion, Vector Conversion and Other Point Cloud Tools:

Extract

Extract includes: Extract by Class, Extract by Elevation, Extract by Intensity, Extract by Return, Extract by Time.

Point Cloud Conversion

Point Cloud Conversion includes: Convert to ASCII, Convert to TIFF, Convert to Shape,

Convert to DXF, Convert to Las, Convert to E57, Conversion LiData to LiData, Convert to LiData.

Raster Conversion

Raster Conversion includes: Convert TIFF to ddLiModel, Convert to Texture LiModel, Convert TIFF to LiData, Convert TIFF to ASCII.

Model Conversion

Model Conversion includes:Convert LiModel to TIFF, Convert LiTIN to DXF.

Vector Conversion

Vector Conversion includes: Convert Shape to KML, Convert KML to Shape.

Other Point Cloud Tools

Other Point Cloud Tools includes: Remove Outliers, Subsampling, Tile by Range, Tile by Point Number, Merge, Extract Point Cloud
Boundary, Extract Color from Image, Noise Filter, Denormalization, PCV, Subdivision, Transform GPS Time, Define Projection, Reproject,
Smooth Points.



Preprocessing
Preprocessing page includes： Calibration, Adjustment, Classify Groud Points, Control Point Report,Quality Inspection,Projections and
Transformations.

Quality Inspection

Quality Inspection includes： Trajectory Quality Analysis, Elevation Difference Inspection, Strip Overlap Analysis, Density Quality Analysis.

Projections

Projections includes： Define Projection, Reprojection, Transformation, Elevation Adjustment,

Four-Parameters Solution, Seven-Parameters Solution, Convert ASCII to BLH.

Transformation

Transformation includes: ICP Regression, Manual Registration, Manual Rotation and Translation.



Classification
Classification module is shown as figure below:

Classificaiton Tools includes： Classify by Attribute, Classify Ground Points, Extract Median Ground Points, Classify Air Points, Classify by
Height Above Ground, Classify Model Key Points.

Other Classify includes： Classify Low Points, Classify Below Surface Points, Classify Isolated Points,

Classify Noise Points, Classify by Min Elevation Difference, Classify Closeby Points,

Classify Buildings, Classify by Trained ML Model；

Classification Editor includes:Classify Ground by Selected, Classify by Interactive Editing。



Terrain
Terrain module has two modes: Basic and Advanced. Click the button at upper-right corner to select mode.Basic mode provides one-click
processing for terrain products generation.

Advanced

Tools of Advanced mode is shown as figure below:

Preprocessing includes： Subsampling, Remove Outliers, Classify Groud Points, Smooth Points

Based on Point Cloud includes： DEM, DSM, Point Cloud to Contour, Generate TIN.

Based on Raster includes： Hillshade, Slope, Roughness, Aspect.

Based on TIN includes： TIN to Contour, TIN to DEM.

Terrain Conversion includes： Convert TIFF to LiModel, Convert to Texture LiModel, Convert LiModel to TIFF

Analysis Tools includes: Deviation Analysis, Change Detection

Model Editor includes： LiModel Editor, LiTin Editor.

Other tools include: Section Analysis, Vector Editor, Query Dip and Strike, Profile Editor.

Basic

Tools of Basic mode is shown as figure below:

Click "Run" and a dialog will pop up. Click "File Selected" and select the point cloud file to be processed. Then, go to Parameter tab and set
parameters for functions. After that, click "OK" and batch process the data, results will be saved to the specified Output Path.

Other tools include: Section Analysis, Vector Editor, Query Dip and Strike, Profile Editor.



ALSForest
ALS Forest module provides two modes:Basic and Advanced.

Advanced

Advanced mode is showed as figure below:

ALS Preprocessing includes：Subsampling, Remove Outliers, Classify Ground Points, DEM, DSM, CHM, Normalize( Normalize by DEM,
Normalize by Ground Points).

ALS Tools includes: Calculate Forest Metrics by Grid,

Regression Analysis:Linear Regression, Support Vector Machine, Fast Artificial Neural Network,

Random Forest Regression, Run Existing Regression Model.

Segmentation:Point Cloud Segmentation, Generate Seeds by Layer Stacking, Generate Seeds by CHM,

Point Cloud Segmentation from Seed Points, CHM Segmentation.

ALS Tools: Clear Tree ID, Extract by Tree ID, Statistic Individual Tree Attributes Denormalization.

ALS Forest Editor includes:ALS Seed Point Editor, Profile Editor.

Basic

Basic mode is showed as figure below:

Click"Run", and a window pop up as figure below. Click "File selected" tab and select the point cloud file.Then, click "Parameter" tab and set
parameters for each function. Click "OK" and the functions will batch process. Result data will be saved under "Output Path".

ALS Tools includes:Clear Tree ID, Extract by TreeID, Statistic Individual Tree Attributes), Denormalization.

ALS Forest Editor includes:ALS Seed Point Editor, Profile Editor.



TLSForest
TLS Forest module has two modes: Basic and Advanced. Click the button at upper-right corner to select mode.Basic mode provides one-click
processing for TLS analysis.

Advanced

Tools of Advanced mode is shown as figure below:

Preprocessing includes： Subsampling, Removal Outliers, Classify Ground Points, Normalization( Normalization, Normalization by
GroundClass).

TLS Tools include: Leaf Area Index,

Segmentation: Point Cloud Segmentation, Point Cloud Segmentation from Seed Points.

Tree Attribute: Statistic Individual Tree Attributes, Increase Individual Tree Attributes.

Other ALS Tools: Clear Tree ID, Extract by Tree ID, Denormalization.

TLS Forest Editor includes： DBH Measure, TLS Seed Point Editor, Individual Tree Editor, Profile Editor.

Basic

Tools of Basic mode is shown as figure below:

Click "Run" and a dialog will pop up. Click "File Selected" and select the point cloud file to be processed. Then, go to Parameter tab and set
parameters for functions. After that, click "OK" and batch process the data, results will be saved to the specified Output Path.

TLS Tools include: Clear Tree ID, Extract by TreeID.

TLS Forest Editor includes: DBH Measure, TLS Seed Point Editor, Individual Tree Editor, Profile Editor.



Power Line
Powerline page is shown as figure below:

Tools include: Setting, Mark Tower, Classify, Danger Points, Clear User Data, Profile Editor.



Display
This chapter explains usages of different modules and functions on Display page, includes Display and Record, Viewers and Operations.

Display and Record

Viewers

Operations



Display and Record
Display menu of the software.

Render to Image

Capture Image

Camera Roam

Save to Video

Background Grid

Camera Setting

Display Solid Model

Display Wireframe

Display Vertices



Render to File
Brief: This tool can render the current 3D view as an image file (*.bmp format is supported). The user can also change the zoom factor, which
affects the final image size.

Steps

1. Adjust the 3D view to get the scene you want to render.
2. Click Display > Render to File and you will get a dialog shown as follows.

3. (Optional) Set the zoom factor.
4. (Optional) Check or uncheck the "Don't scale features (points size)" according to demand.
5. (Optional) Set the Output path.
6. Click "OK" to get the rendered image.

Settings

Input: Current active window.
Zoom: Default value is 1 (original image size). You can increase the rendered image size by setting larger zoom factor (the resulting size
is displayed on the right).
Don't scale features (points size): By default unchecked. If it is checked, the rendered point size won't be increased, even if the zoom
factor is greater than 1.
Output path: The file path to which the image will be saved.

Note: When EDL is on, Render to File tool supports adding the EDL effects to the results.



Capture Image

Steps

1. Click this button, open save file dialog, default file name is window name, click "OK" to save file.

Brief: Save the view in current window as a JPG file.



Camera Roam
Brief: This function can control the scene camera to navigate through a roam path. Two types of roam path are supported including roam
path based on viewport and roam path based on POS file. This function can also generate immersive video if cooperated with Save to Video
function.

Steps

1. Click Display > Camera Roam to open Camera Roam Set dialog as bellow.

2. Choose mode as desired(Select "Roam by Viewports" or "Roam by Pos Path").

2.1 Roam by Viewports
Speed: Set the speed of Roam by Viewports.

Add Key Frame：Click this button to add current viewport as a key frame.
Delete Key Frame: Click this button to delete a key frame.
Load Key Frames from File: Click this button to import a key frame file.
Save Key Frames to File: Click this button to export all key frames to file.
Delete All Key Frames: Click this button to delete all key frames.

Select a key frame in the list: Scene camera will be adjusted to this key frame.
2.2 Roam by POS File

Check or uncheck "Show Path" as desired.
Set the Path Width, which will be activated when "Show Path" is checked.
Click Settings to open the following dialog.

Select a POS File: txt format only, each line of the file represents a key frame. The first three columns are assumed to be XYZ.
Column delimiters include comma, semicolon and space.
Set parameters: Including offset, time step, yaw, pitch, roll.



Click "Ok" to end the roam path setting.
3. Click "Start Roam" to begin roam through current path. After finished, the following dialog will show.

4. Click "Ok" to end the camera roam.
5. Click "Cancel" to exit this function.

Settings

Input: Viewport of current window or POS file.
Settings of Roam by POS file：

Path Width: Non negative integer only, defines the line width of POS trajectory in the viewer.
X/Y/Z Offset：The default value will be the offset of scene coordinate to the world coordinate system, as POS data is in the world
coordinate system.
Time Step: real number larger than 0.01 only, defines the time interval between key frames. The smaller this value is, the slower the
roaming speed is.
Yaw/Pitch/Roll：Local roam coordinate is defined that the orign is key frame center, the Y axis points to the motion direction, the X
axis is defined based on Y axis and world coordinate Z axis using right-hand coordinate system principle, the Z axis is defined based
on X axis and Y axis using right-hand coordinate system principle. By default, the roam camera is towards -Z, the right of camera is
+X, the upper of camera is +Y. Yaw means spinning around +Z. Pitch means spinning around +X. Roll means spinning around +Y.



Save To Video
Brief: Record the current window screen and save as video (mp4 and avi formats are supported).

Steps

1. Click Display > Save To Video, an interface will show as follows.

2. Set the frame rate(default is 25 frame per second).
3. Set the bit rate.
4. Set the output path of video.
5. Click "OK". The following interface is shown on the left-top corner of the current window.

6. Change the camera to get the scene which you want to record.
7. Click "Stop" or "Start"

Stop：Pause the current record.
Start：Recover the record.

8. Click "End" to finish recording. The video will be saved.

Settings

Input: the scene of the window for record.
Frame Rate: The frequency (rate) at which consecutive images called frames appear on a display.
Bit Rate: Refers to the number of bits used per unit of playback time to represent the video. Lower bit rate may result in lower resolution
of the picture and has mosaics on the picture, and however the higher bit rate may lead a larger video file.
Output path: The file path to which the video will be saved.

Note: When EDL is on, Save to Video tool supports adding the EDL effects to the results.



Background Grid
Summary：This tool can be used to display the 3D grid in the viewer window. When there are multiple point clouds in the window and the
distance between the point clouds is short, the grid range of all point clouds is calculated and displayed. When there are multiple grids in the
window and the point cloud is far away, the grid range of the point cloud within the display range of the current window is calculated and
displayed.

Steps

1. Click Display > Background Grid to use this function.

Settings

Function Summary：Set the display or hide of grid plane (XY plane, XZ plane, YZ plane), display or hide of grid label, grid line style, line
color, and font color.

Grid Plane (XY Plane, XZ Plane, YZ Plane) Display or Hide (Default is Display All): Check or uncheck the checkboxes in front of the
three planes to change the display status of the corresponding planes.
Grid Label Display or Hide (Default is Display): Check or uncheck the checkbox before the text to change the display status of the
label.
Line Style (Default is Solid Line): Click , select the grid line style (solid or dot).
Line Color (Default is White): Click , a color selection interface will pop up, and one of these colors can be
selected as the color of the line.
Font Color (Default is Red): Click , a color selection interface will pop up, and one of these colors can be
selected as the color of the font.
Axis Setting (X-Axis, Y-Axis, Z-Axis) Cell Size (Default is "50"): Click , the value will increase or decrease in steps of 10.
User can also directly enter a specific value. The cell size of the Y-axis and Z-axis can be set to be the same as the X-axis, so that there
is no need to set the cell size of the Y-axis and Z-axis separately.



Camera Setting

Steps

1. After clicking this button, the dialog shown below would pop up:

2. Adjust camera rotation using sliders.

Settings

Prerequisite: Current active window must be in 3D mode.
Current mode: Show projection type of current active window, including perspective projection and orthogonal projection.
X: Camera rotation around X axis.
Y: Camera rotation around Y axis.
Z: Camera rotation around Z axis.
Camera/Eye Center: Non-editable, computed using rotation.
Field of view: Field of view, default 30 degree.
Distance: Distance to viewpoint. Non-editable.

Brief:Camera settings for current active 3D window.



Display Solid Model

Steps

1. Click this function, the models in the current active window will display in model, as shown in the figure below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief：Set model files in the current window to display in model type.



Display Wireframe

Steps

1. Click this button, the models in current active window will display as triangle mesh, as shown in the figure below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Switch display mode of models in current window to triangle mesh mode.



Display Vertices

Steps

1. Click this button, the models in current active window will display as points, as shown in the figure below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Switch display mode of models in current window to point mode.



Viewers
This menu provides operations to create, close and arrange windows.

New Viewer

Close Active Viewer

Close All Viewers

Viewers Layout

Tile Viewers

Tab Viewers



Close Active Viewer
Brief: Close the active window in the current project.

Steps

1. Click the menu Viewers > Close. The active window will be closed.

Shortcut Key：Ctrl+F4



Close All
Brief: Close all windows in the current project.

Steps

1. Click the menu Viewers > Close All. All windows are closed.



Viewer Layout
Tile Windows

Tab Viewers



Tile Windows
Brief: Rearrange all the viewers in tiled fashion.

Steps

1. Click the menu Viewers > Viewers Layout> Tile Windows. The result is as follows.

Note: This function needs at least one window in the current project.



Tab Viewers
Brief: Rearrange all the viewers in tab fashion.

Steps

1. Click the menu Viewers > Viewers Layout> Tab Viewers. The result is as follows.

Note: This function needs at least one window in the current project.



Operations
Window Linkage

Rolling Screen

Go To



Window Linkage

Steps

1. Click this button to open the dialog shown below:

2. The windows list contains all windows in LiDAR360, double-click a window that needed to linkage, or select the window then click button 
 to add the window. Also, user can click button  to add all windows to linkage windows list. The linkage windows

list all windows under linkage, double-click a window to remove, or select the windows and then click button  to remove.
Also, user can click button  to remove all linkage windows.

3. If "Cross Line" is checked, cross line will be displayed in the linkage windows. The following figure shows if the cross line is checked:

Note: If the current window contains raster data, it will be displayed in 2D. If the linkage windows contain 3D window and 2D window,
the windows will be displayed in 2D mode.

Brief: Enable windows linkage of multiple viewers.



Rolling Screen

Steps

1. Click this button to open the dialog shown below:

2. Current files list contains files in current viewer. Double-click a file that needs to be added to rolling screen, or select files and then click 
, or click button  to add all files to rolling screen files. The rolling screen files list contains files in rolling screen,

double-click a file to remove, or select files and then click button  to remove, or click button  to remove all files.

3. Click "OK". In the viewer, press the "Shift" button on the keyboard then drag. The window is shown below:

Settings

Prerequisite: An active viewer.

Note: This function cannot be apply to the profile window. Click this button again to exit.

Brief: Enable rolling screen for current viewer.



Go To

Steps

1. Click the window that contains data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar and the mouse pointer turns to . Select a particular point in the scene. The attributes of this point

will be shown in a label. At the same time, the "Go To" dialog pops up, as shown below.

3. If "Pick Point" is checked, the focus point is selected by mouse click. Otherwise, the coordinates of the focus point are selected by
manual input.

4. Set the time to go to the selected point.
5. Click the "OK" button. The label will disappear, and a red dot will start to flash.
6. When it is focused to the selected point, the red dot disappear, as shown below.

Settings

X: X component of the coordinate.
Y: Y component of the coordinate.
Z: Z component of the coordinate.
Time: Time to go to the selected point.
Pick Point (Optional): If "Pick Point" is checked, the focus point is selected by mouse clicking.

Note: When there are multiple windows, this tool only works on the active window.

Brief: This tool is applicable to point cloud data, raster data and model data. It's used to focus to the selected point.



Profile Editing

The use of LiDAR data to produce high-precision terrain products requires manual inspection and correction of the results of automatic
classification. In this case, it is necessary to use the profile editing and classification tools. LiDAR360 has provided memory editing and
external memory editing starting from V3.1, and multiple viewers can select the classification mode at the same time. The profile editing tool
of LiDAR360 provides a series of editing tools, and supports shortcut key operations. With shortcut keys and mouse operations, users can not
only switch between different tools for classification operations more conveniently, but also perform classification inspections and corrections
more efficiently.

Block Editing Tool

Draw Profile

Profile Vector Tools

TIN Tools

Select Toos

Classify Panel

Profile Viewer Tool

Breakline Tool

Profile and TIN Tools

TIN tool is to build triangular model in real time, you can use check editing effects.

Note: You can use shortcut P on keyboard to adjust light, which can improve the display effect.

Please refer to TIN Tools for detailed information.

Profile and Measurement Tools

When the profile is turned on, the point cloud viewer and TIN viewer do not support measurement functions. The profile viewer supports
single-point selection, multi-point selection, length measurement, angle measurement, slope measurement, and height measurement.

Profile and Boresight Correction

When using boresight correctio, we need to check mismatch issue between trajectory segments in profile viewer.

Description：Users can draw a buffer on point cloud in 3D viewer and check correspongding profile in profile viewer. It can help
with data check, measurement and classification.



The above figure is the relative position before boresight correction.

During the correction, you can check real-time correction performance in profile viewer:

You can confirm and apply the correction parameters to the point cloud. It can be directly overwrite the previous point cloud data.

Besides, the measurement tools in profile viewer can help to evaluate Pith, Roll and Heading. Please refer to Strip Alignment for detailed
information.

Profile and ALS Editor

When activate the ALS Editor, the main viewer will switch to 2D viewer. You can use profile viewer to check if seed points are correct in 3D
view. Click Profile Tool to open profile viewer. Select a polygon area in point cloud viewer, and corresponding point cloud will appear in the
profile viewer. Then, you can zoom or rotate in profile viewer to check seed points.

Note：Profile in ALS Editor doesn't have the same profile tool bar as general profile tool.

Profile and TLS Editor

When activate the TLS Editor, the main viewer will switch to 2D viewer. You can use profile viewer to check if seed points are correct in 3D
view. Click Profile Tool to open profile viewer. Select a polygon area in point cloud viewer, and corresponding point cloud will appear in the
profile viewer. Then, you can zoom or rotate in profile viewer to check seed points.

Note：Profile in TLS Editor doesn't have the same profile tool bar as general profile tool.



Block Editing Tool
Block editing tool allows users to split the LiData into several tiles, and inspect and edit each block separately. After starting editing, software
will load all the points in the current block for inspection and editing according to the block size. At this time, users can choose to create TIN to
view the quality of data classification. And reclassify those areas which are mis-classified.

Icon Dicription Hot Key

Start block editing, split the data into tiles. Inspect and edit them separately

Undo Ctrl+Z

Redo Ctrl+Y

Save Ctrl+Shift+S

Settings

Hot Key Settings

Block Move to the Left Alt+←

Block Move to the Right Alt+→|

Block Move Up Alt+↑

Block Move Down Alt+↓

Choose the Block

Display/Hide the Text

Edit Toolbar

Start Editing

Note: It is recoomended that approximate 500k points are in each block in average when choosing the width of each block.

Description: Clicking on the start editing button, the window of "block setting" will pop-up. Set the width and the buffer size of the
blocks in the "split by width" option. After setting the parameters and clicking ok, the all the points in the chosen block will be
displayed in the window.



Undo

Note: In each profile editing, the undo and redo functions can only return results within 20 steps before the current result.

Redo

Note: In each profile editing, the undo and redo functions can only return results within 20 steps before the current result.

Save

Settings

Save when changing the block: If this option is checked, the software will automatically save the edit when users change the editing
block to another one.

Hot Key Settings
After clicking this function, users can set the hot keys for part of the functions in profile editing. After clicking this function, the popup window is
shown as follows:

Description: This function allows users to undo the previous steps. This function will be disabled after saving the data. This
function is available when the data is either split into tiles or not.

Description: This function allows users to redo the undone steps. This function will be disabled after saving the data. This function
is not available if the data are not split into tiles.

Description: Save the changed data to the corresponding LiData.

Description: Block editing tool allows user to set whether to save the editing for current block when changing the block to be
edited.



The hot keys occupied by the framework of LiDAR360 cannot be used here. All the editable operations for the profile are listed in the profile
window. Click the hot key column, and press the key on the keyboard, and then click OK to finish the setting.

Block Change Toolbar
Block Change Toolbar is actived only when the data is split into tiles.

Move to the Left

Move to the Right

Move Up

Move Down

Select the Block

Description: Change the editing block to the one left to the current editing block. And display it in the main window.

Description: Change the editing block to the one right to the current editing block. And display it in the main window.

Description: Change the editing block to the one above the current editing block. And display it in the main window.

Description: Change the editing block to the one below the current editing block. And display it in the main window.

Description: This function is only available when the data are split into tiles. Click this button, and users can select the block to be
edited in the main window.



Display/Hide Blocks
Description: This function is only available when the data are split into tiles. Cilick this button and the numbers of the blocks will
be displayed/hidden.



Draw Profile

Icon Description Hot Key

Start Profile Editing Tool Alt+S

Move Profile

Rotate Profile Area X or ← →

Expant Profile Area

Move up Profile ↑

Move down Profile ↓

Profile Tool

Buffer

Description: Click the triangle icon right to the profile icon, and then click the buffer settings button, the buffer settings window will popup.
This function can help users to fix the size of the buffer area.

Move Profile

Rotate

Description: Used to create a profile view of a certain area when select an area in the main window or TIN window.

Description: When the move profile tool is activated, move the mouse to the profile area and drag it. The profile area can be
moved with the mouse. If the mouse drag outside the profile area, it will not be moved with the mouse.

Description: Support to rotate the profile area based on the angle that users enter in the rotate settings window. Click the triangle
next to the icon and click the rotate settings button, the rotate settings window will popup.



Expand

Move Up the Profile

Move Down the Profile

Description: Used to expand the width of profile area by the entered number. If the entered number is negative, the profile area
will be reduced.

Description: Used to move up the current profile to create a new profile with the same size and right above the current profile.

Description: Used to move down the current profile to create a new profile with the same size and right below the current profile.
Click the triangle next to the icon and click the step length settings button, the step length settings window will popup. If the
checkbox in front of the step length tag is checked, the step length will be fixed as 1.5 times step length and cannot be changed. If
the checkbox is unchecked, users can change the step length based on their needs.



Classify Panel
Classify panel consists of four ground points filters and three class to class classification methods. Four ground points filters, including TIN
filter,conicoid filter,slope filter,and extract median ground points, are only available when the point cloud data are split into blocks. And three
class to class classifications allow users to set the original class and target class, and then choose the area need to be classified. The points
in the chosen area of the original class will be classified as target class points.

Description Hot Key

Switch Class Modification Method Shift+E

Classify the chosen points as new class. Choose the target class by number key. 0-9



Profile Viewer Tool
By default, profile view shows the front view of selected rectangle area. Users can change the view mode in the drop-down menu .

Icon Description Hot Key

Front View

Rear View

Left View

Right View

Rotate Scene R

Measuring Tools

Grid



Strip Alignment
Airborne LiDAR measurement system is influenced by various error sources, of which the systematic errors (the largest error source) cause
the systematic deviation of laser footprint coordinates. Mounting of LiDAR measurement system requires the axis of the scanning reference
coordinate system and inertial platform reference coordinate system to be parallel. However, while mounting of system, it is not guaranteed
that they are parallel, resulting in the so-called systematic boresight error. In the Strip Alignment module, airborne LiDAR point clouds of
overlapping strips can be aligned through boresight calibration.

Boresight

Boresight Error Calculation

Trajectory Adjustment

Control Point Report

Trajectory Quality Analysis

Elevation Difference Inspection

Strip Overlap Analysis

Density Quality Analysis



Boresight
Brief: In the Boresight module, airborne LiDAR point clouds of overlapping strips can be aligned through boresight calibration. This module
includes the following functions: loading/deleting/splitting trajectories, cutting point cloud according to trajectories, matching trajectory and
point cloud, transforming point cloud based on boresight calibration parameters, eliminating point cloud redundancy (cut overlap), etc.

Usage

1. Open boresight module. Click ToolBox > Strip Alignment > Boresight or Preprocessing > Boresight, and the corresponding toolbox and
Trajectories List Widget is shown as follows.

2.  Open Trajectory Files: After clicking this button, an interface pops up to ask you to set the workspace.

Set the workspace and a dialog for adding trajectories will be shown as follows.

LiDAR360 supports two formats of trajectory files: POS(*.pos) (text format file) and SBET(*.out)] (binary format file).



○ POS File Example 1: If the POS file does not contain GridX and GridY information, the user has to specify following headers (GPS
time, longitude, latitude, height, roll angle, pitch angle and yaw angle) for data columns. An example is shown as follows.

It is required to select the correct projection coordinate system as the following picture.

○ POS File Example 2: If the POS file contains GridX and GridY information, the user has to specify following headers (GPS time,
longitude, latitude, height, roll angle, pitch angle, yaw angle, GridX and GridY) for data columns. An example is shown as follows.



If the information of GridX or GridY is not correct, the POS File Example 1 can be used.
For both of the two examples, click "Apply" to make the current settings apply on current trajectory file, and all the trajectory files will be
affected by the current settings if you click "Apply all".

The information of added trajectories will be shown in Trajectories List Widget. (Optional) Click to set the workspace.
3.  Pick Point: Left click a certain point in the trajectory and the information of this point will be displayed.

4. Segment Select

4.1 Select by Polygon

Click  Draw Polygon button.
Left click to make an user-defined polygon in the view.
Click Select by Polygon button, to select segment in the area of user-defined polygon.

4.2 Select by Bursh

Click  Select on Trajectory button.
Left click to select the starting point in the trajectory.
Along the trajectory, select the ending point, the trajectory between the starting point and the ending point will be selected.

4.3 Select by Trajectory Graph

Click  Select on Graph button, the trajectory graph will pop up.



(Optional) Select an trajectory in trajectory combox, the selcted segment of the trajectory and the trajectory will be shown in the
graph.
(Optional) Select an attribute. Users can select different display mode, including display by height, display by quality factory, display
by roll, display by pitch, display by heading and display by velocity.
Select both Start Time and End Time via scrollbars.
Click to add a new segment.
(Optional) Change display range. All the trajectory information at any time will be displayed in trajectory graph as a default. Scroll up
and down of mouse wheel to zoom in and out the graph, click to restore the default display.

All the selected segment will be shown in Trajectories List Widget.

5.  Split Trajectories: Click this button to split the source trajectories by selected segments. New generated trajectories will be stored as
POS file format in the workspace and named by the GPS starting and ending times of the trajectory. An example of new file name is
"GPSStartTime_GPSEndTime.POS". The effect of cutting is shown as follows.

6.  Cut Point Cloud Based on Trajectories.
6.1 Click the button to pop up a dialog.

Select the point cloud data files to be cut. Check the “Cut by Trajectories' Buffer”and set the Buffer parameter as desired.
6.2 Click "OK". LiDAR360 will cut the point cloud by the trajectories and show the process speed accordingly. The cutting results will
be saved and the name of the point cloud is identical to the corresponding POS file. A dialog pops up to ask the user whether to load
the results or not.

7.  Match Point Cloud and Trajectory: Click this button, the point cloud data and the corresponding trajectory will be displayed in the
same color.



8.  Calibration: Click this button to pop up a dalog.

8.1 This function is applied to correct the Boresight Error, which can be calculated automatically (Automatic Alignment) or input
manually (Manual Alignment).

Automatic Alignment:
Select the boresight error you want to correct, and set the Translation TOL and Rotation TOL. Click "Calculate" to generate the
boresight error automatically and the result will be shown in the "Boresight Correction" part of the interface. Click "Clear Matching" to
delete the matching information. After modifying relevant parameters, users can calculate the alignment parameters again. After the
calculation of automatic alignment, LiDAR360 will figure out the Alignment Quality. The Alignment Quality will be shown in the
"Alignment Quality" tab page. Click "Export" button to save the alignment quality information, and Click "Generate Report" button to
generate the automatic alignment quality report. (Theory of correction based on automatic adjustment.)



Manual Alignment:
Adjust the boresight error manually. (Theory of correction based on manual measurement.)

Click "Apply" and the transformation of error correction will be applied on the selected Transform Type.

8.2 For both automatic and manual method, correction result can be checked in the profile window.

Before transformation



After transformation
8.3 Buttons on the right of the "Boresight correction" provide the following operations: "loading from file", "saving to a file" and
"cleaning".

8.4 If the alignment effect is satisfied, you can switch Transform Type from the "Loaded Point Cloud" to "Selected Point Cloud Files".
Click "Apply" to finish the transformation.

9.  Cut Overlap: Click this button to set the Cut Overlap Parameters. Click "OK" button, then the redundant points between the
overlapped trajectories will be classified or deleted.



10. Show Single Trajectory

Select a trajectory in the Trajectories List Widget, right click to pop up the Context Menu.
Click the Show Single Trajectory button, the color of the selected trajectory will be changed gradually, and then the trajecotry will
twinkle several times.

11. Delete Trajectories or Segments.

Select the trajectories or segments in the Trajectories List Widget, right click to pop up the Context Menu.
Click the Delete button and the selected trajectories and segments will be removed.

12. Show/Hide Trajectory or Segment Check/Uncheck the checkbox of the trajectory or segment in the Trajectories List Widget will
Show/Hide the trajctory or segment.

13. Trajectory Display the software supports muti-display modes: 13.1 Display by Time(Default)

Click button, the trajectory will be displayed in different color according to acquisition time, users can select the color bar in a pop-
up window.

13.2 Display by Height

Click button, the trajectory will be displayed in different color according to height information, users can select the color bar in a
pop-up window.

13.3 Display by Quality

Click button, the trajectory will be displayed in different color according to quality information, users can select the color bar in a
pop-up window.

13.4 Display by Specific Color

Click button, the trajectory will be displayed in specific color according to user-defined color, users can select the color in a pop-
up window.

13.5 Show selected segments

Check button, the unsegmented area will be hide, and only selected segment part will display.

Settings

Parameters of Cutting point cloud based on Trajectories
Buffer: The remaining distance in both sides of trajectory while cutting.

Parameters of Transform
Boresight Error



ΔX/ΔY/ΔZ: Correction parameters of boresight offset error.
ΔRoll/ΔPitch/ΔHeading: Correction parameters of boresight pose error.

Automatic Alignment: It matches corresponding points between strips automatically and calculates optimal correction value of
boresight error via adjustment.

Translation TOL: The maximum translation tolerance of ΔX, ΔY, ΔZ. The default value is 0.05 m.
Rotation TOL: The maximum rotation tolerance of ΔRoll, ΔPitch, ΔHeading. The default value is 5°.
Options: Users can decide whether the 3 translations and 3 rotations are involved in adjustment to calculate correction values.
For most aerial data, it is not recommended to correct ΔZ. In default state, all the rotations are selected while all the translations
are unselected.

Alignment Quality: After automatic alignment calculation, LiDAR360 will figure out the alignment quality and show the result in the
alignment quality result tab.

Min Error: Minimum error of matched corresponding points.
Max Error: Maximum error of matched corresponding points.
RMSE: RSE error of matched corresponding points.

Transform Type:
Loaded Point Cloud: The loaded point cloud which is matched with trajectory in LiDAR360. When the transformation is applied,
the corresponding point cloud is modified and the transformation effect can be shown in real-time. When boresight module exits,
relevant transformation is eliminated without saving.
Selected Point Cloud Files: In this type, the file list area on the interface will be activated, users can choose which point cloud
file(s) will participate in the transformation. Then the results will be saved to the file. It doesn't loss the information even though
the boresight module exits.

Parameters of Cut Overlap:
Type:

Classify: Classify points into target category and save the result in the original point cloud file.
Delete: Classify points into target category and then delete them from initial point cloud data (Note: If the input point cloud
contains points of target category, they will also be removed).

From Class: Point cloud target category.
Edge: Grid unit size (length) of overlapping area. This parameter is used to rasterize the point cloud data of the overlapped area.
Density: Smallest point density of grid unit. If the point density is smaller than the defined threshold, these points will not be
classified to redundant points.
By Angle with Trajectory: Angle between point cloud and trajectory. If this angle is larger than the threshold, the point cloud will be
classified to redundant points.
By Scan Angle: If scanning angle is larger than the threshold, point cloud will be classified to redundant points. (Note: this function
can only be used when scanning angle is recorded by point cloud.)

Note:
1. The matching principle of a point cloud file and a trajectory is that: Each GPS time of all the points in the point cloud is inside the
trajectory's GPS time span.
2. In most cases, the effect from X,Y or Z is tiny, while the ground control points are needed for higher precision of Z value. Therefore,
only Roll, Pitch and Heading are selected to take apart in the adjusting by default.
3. The result may not satisfy if accuracy of the POS data file is not enough, and users can make an manual alignment based on the
result.
4. For Overlapped function, at least two pairs of matched point cloud and trajectories are needed.



Boresight Error Calculation
The boresight error between laser scanner coordinate system and GNSS/INS coordinate system is the largest systematic error source of
airborne LiDAR. The laser footprint error caused by the boresight error also depends on flight height and scanning angle.

LiDAR360 provides two approaches to eliminate the boresight error:

1. Correction based on manual measurement
2. Correction based on automatic adjustment

The principles of them are described as follows.

Manual Correction

Firstly, datasets for calibration need to be acquired during perpendicular and round flights (e.g., 4 flights: from east to west, from west to east,
from north to south, from south to north). After data acquisition the boresight angle errors can be retrieved using the Stepwise Geometric
Method(Zhang et al., 2010), which is based on measurements of overlapping laser footprints of regular objects (e.g., playground, building).
Compared to angle errors, the translation errors are of less importance and hence omitted in the manual correction.

ΔRoll

Error of Roll angle leads to an oblique result of horizontal ground, which is shown in the following figure. The planar position of scanned object
is shifted along scanline (perpendicular to flight direction).

Please measure the following parameters in the data acquired during round flights of same height.

Start a Profile Window perpendicular to the flight direction. Then measure the height difference ∆ℎ of quasi-homologous objects in two
strips.
Measure the horizontal distance r between the object and centerline of two strips in 2D-View Window.

The formula to calculate the Roll angle error is as follows:

ΔPitch

The position of scanned object is shifted along scanline due to Pitch angle error. The following figure shows the affected laser footprints.



Please measure the following parameters in the data acquired during round flights.

Start a Profile Window along the flight direction. Then measure the distance D between centers of homologous objects along the flight
direction.
Estimate the average flight height H based on trajectory and object heights. The heights of round flights should be roughly equal.

The formula to calculate the Pitch angle error is as follows:

ΔHeading

Error of Heading angle leads to object shifting and distortion. The following figure shows the erroneous result.

Please display data acquired during round flights in 2D-View Window.

Measure the average distance S between centers of homologous objects in two strips.
Measure the distance D between two strips.

The formula to calculate the Heading angle error is as follows:

Automatic Correction

While the manual correction relies on well-trained operators, the automatic correction can reduce manual work significantly. Based on
datasets with regular objects, the automatic process can replace manual correction and achieve equivalent or even better accuracy.



The algorithm is capable of correcting not only the angle errors, but also the translation errors. Users have the flexibility to check/uncheck
every correction parameter. By default, the software only calculates the angle errors, because they have the largest weights. The principle of
the algorithm is as follows:

1. Extract feature points and their normals in overlapping strips. Please refer to (Glira et al., 2015).
2. Match the feature points to get corresponding pairs.
3. Construct the correction model and calculate the distances of paired points along their normal.
4. Minimize the corresponding distances using least-square method, and get the correction parameters.

    @inproceedings{
        author={Zhang Xiaohong, Forsberg Rene},
        title={Retrieval of Airborne Lidar Misalignments Based on the Stepwise Geometric Method},
        booktitle={Survey Review 42(316):176-192 April 2010},
        year={2010},
    }

    @inproceedings{
        author={Philipp Glira, Norbert Pfeifer, Christan Briese and Camillo Ressl},
        title={A Correspondence Framework for ALS Strip Adjustments based on Variants of the ICP Algorithm},
        booktitle={PFG Photogrammetrie, Fernerkundung, Geoinformation Jahrgang 2015 Heft 4},
        year={2015},
    }



Trajectory Adjustment
If point clouds discrepancies are still obvious after Boresight, the misalignment may be caused by trajectory errors. With this tool, trajectories
and related point clouds can be post-processed and refined.

Click the button Strip Alignment>Trajectory Adjustment, the interface will pop up. This function estimates fluctuating errors of trajectory, then
updates point clouds based on correction values.

Check trajectory correction components on the interface, set spline node interval for trajectory fluctuation, click OK button, then the software
runs automatically. Point cloud data will be corrected accordingly.

A quality report in HTML format will be generated after correction.

You can use profile tool to view the correction results, as shown below.

Before correction



After correction

Parameter settings

Adjust
ΔX/ΔY/ΔZ: position components of trajectory correction.
ΔRoll/ΔPitch/ΔHeading: angular components of trajectory correction.

Spline Node Interval (Sec): Fluctuating corrections for trajectory are calculated based on spline nodes. The smaller the interval, the
higher the fluctuation's frequency. A smaller interval is preferred if trajectory errors vary a lot in local region. Default value is valid for most
data.
Input POS: Input the corresponding POS file of the point cloud.
Output:Select the output path for adjusted result data, including point cloud, trajectory and HTML quality report.



Control Point Report

Summary

Control point report tool will create a report about elevation difference of laser point clouds and ground control points, which can be used to
check the elevation accuracy of laser point clouds and improve the height accuracy of laser point clouds using calculated adjusted values.

Control point file is the text file separated by comma. Every row is composed by 3 columns which are X, Y and Z. The first row is the header,
and please refer to Control Point File Format for specified format. At least 3 control points are requested to successfully create the control
point report.

The output report displays information of elevation difference between used laser point clouds and control points of elevation, statistic
information of height difference like average magnitude, standard deviation, root mean square, average of elevation difference as well as
maximum and minimum height difference.

Usage

Click Strip Alignment > Control Point Report.

After computation, the position of every control point can be checked by left double click at any position on the control point row in order to
jump to the location of control point. Using Profile tool can help to check the relative position between control points and point cloud more
intuitively.



After the calculation, users can choose the control points, or change the maximum slope and maximum triangle edge length, and then click
"Calculate" to re-calculate.

Settings

Input Data: Input file can be single point cloud data file or point cloud data set.
From Class (default value is "all class"): User needs to select the point cloud class which is used to check control point elevation
accuracy, and normally point cloud of hard surface such as ground point, construction point, etc. are chosen.
Z tolerance (default value is "0.15"): The accuracy of the point cloud in the Z-axis direction. To avoid the distance between the points is
too small leads to the excessive slope.
Max Slope (°, default value is "45"): Maximum terrestrial gradient tolerance. If gradient is larger than this value, elevation difference will
not be computed. Normally control points are chosen at the flat terrain, therefore if gradient is too steep, the result will be easily affected
by wrong information.
Max Triangle (m，default value is "20"): The longest side length of triangle is used to avoiding the large deviation caused by elevation
interpolation. If the side length of triangle is too long, it is indicated that points of initial category in point cloud area where control points
are located are less and calculated error of elevation difference is large.
Known Points: Input control point file.
Point Size (default value is "0.10"): The location of control points can be displayed in the window by double clicking the corresponding
data in the list of control point report. The size of point controls the size of control points shown in the window.
Dz limit (default value is "3"): Set the tolerance of Dz. If Dz is not within the tolerance, show red in order to inspect elevation difference
with large error between point cloud and control points. Maximum tolerance = Average Dz + Dz × Std Deviation. Minimum tolerance =
Average Dz - Dz × Std Deviation.
Calculate: After setting parameters, click this button to calculate elevation difference.
Export: Export control point report file of TXT format. The file contains elevation error information of point cloud data and statistical
information of Dz.



Trajectory Quality Analysis

Summary

Trajectory Quality Analysis tool checks trajectory quality from the height analysis, speed analysis and flight attitude analysis.

Usage

Click Strip Alignment > Trajectory Quality Analysis.

Load trajectory file(s) and set the parameters of height analysis, speed analysis and fight attitude analysis. This tool supports generating
reports for each analysis. Click Export to save the quality report in html format.

Click  to load data. The supported formats of POS files contain *.OUT and *.pos. Click  to clear loaded data.

Settings

Height Analysis: Height analysis report contains strip name, max height, min height, height difference, height variance, mean height and
qualified flag of each strip. The Yes is qualified, and No is unqualified. The mean height of qualified strip is displayed as green, or as red.
Click Export button to save the result in html format.
Design Height (m, default value is "0"): Designed height value.
Height Tolerance (%, default value is "0"): The floating ratio of designed height. For example, 5% denotes that the qualified height
range is between (1- 5%) × designed height and (1 + 5%) × designed height.
Generate Report: Click Generate Report button to save height analysis quality report.

Speed Analysis: The speed analysis report contains strip name, max speed, min speed, speed difference, speed variance, mean speed



and qualified flag of each strip. The mean speed of qualified strip is displayed as green, or as red. Click Export button to save the result in
HTML format.
Design Speed (m/s, default value is "0"): Designed speed value.
Speed Consistency (%, default value is "0"): The floating ratio of designed speed. For example, 5% denotes that the qualified speed
range is between (1- 5%) × designed speed and (1 + 5%) × designed speed.
Generate Report: Click Generate Report button to save speed analysis quality report.

Flight Attitude Analysis: Flight attitude analysis report contains strip name, max roll, mean roll, max pitch, mean pitch, strip deformation
(%) and qualified flag of each strip. The Yes is qualified, and No is unqualified. The strip deformation of qualified strip is displayed as
green, or as red. Click Export button to save the result in html format.
Strip Deformation (%, default value is "3"): According to the related data standard, the qualified threshold of strip deformation is
generally set to 3%.
Generate Report: Click Generate Report button to save flight attitude analysis quality report.

Integral Report: Click Full Report button to save the integral report.



Elevation Difference Inspection

Summary

Elevation Difference Inspection tool analyzes the elevation difference between point clouds.

Usage

Click Strip Alignment > Elevation Difference Inspection

Settings

Input Data: Input files can be single point cloud file or point cloud dataset. The data to be processed must be opened in the LiDAR360.
From Class: The point cloud classes used in the elevation difference quality inspection.
Grid Size (m, default value is "2"): The grid size in the point cloud gridding.
Cut off Value (m, default value is "0.5"): The data will be ignored if the height difference is greater than this threshold. Considering the
moving vehicles in the scanning area which can be scanned at different time, it is necessary to set the cut off value for height difference.
Output Path: The results of elevation difference quality inspection will be exported to the selected folder, which contains the result of
each strip density quality inspection and integral report in HTML format.



Strip Overlap Analysis

Summary

Strip Overlap Analysis tool analyzes the overlap between point clouds.

Usage

Click Strip Alignment > Strip Overlap Analysis

Settings

Input Data: The input files should be 2 or more point cloud files. The data to be processed must be pre-opened in LiDAR360.
Input POS File: Click  to load the data. The supported formats of POS files include *.OUT and *.pos. Click  to clear the loaded
data. Click  to clear the loaded POS file(s).
Overlap Threshold (%, default value is "25"): Set the threshold to define the overlap region between two adjacent strips.
Output Path: The results of overlap quality inspection will be exported to the selected folder, which contains the results of each strip
overlap quality inspection in SHP format and a comprehensive report in html format.



Density Quality Analysis

Summary

Density Quality Analysis tool analyzes the density of point cloud.

Usage

Click Strip Alignment > Density Quality Analysis

Settings

Input Data: Input file can be single point cloud file or point cloud dataset. The data to be processed must be opened in the LiDAR360.
Density Threshold: The point density between the adjacent thresholds is shown in the corresponding color.
Grid Size (m, default value is "1"): The grid size in the point cloud gridding.
Output path: Select the output path of density inspection quality report. The folder contains the results of each strip density quality
inspection and integral report in html format.



Data Management
This chapter introduces the basic tools commonly used for point cloud and raster data processing. Contents include: point cloud tools, raster
tools, clip tools, format conversion and data extraction.

Point Cloud Tools

Remove Outliers

Noise Filter

Normalize by DEM

Normalize by Ground Points

Demormalization

Merge

Extract Point Cloud Boundary

Subsampling

PCV

Extract Color from Image

Subdivision

Transform GPS Time

Smooth Points

Raster Tools

Raster Mosaic

Raster Subdivision

Raster Calculator

Tile

Tile by Range

Tile by Point Number

Tile by PDrawLine

Tile by Polygon

Projections and Transformations

Define Projection

Reproject

Transformation

Elevation Adjustment

Transformations Calculation

ICP Registration

Convert ASCII to BLH

Manual Registration

Manual Rotation and Transformation

The Geoid Model

Create Transformations

Clip



Clip by Circle

Clip by Rectangle

Clip by Polygon

Conversion

Convert to ASCII

Convert to TIFF

Convert to Shape

Convert to DXF

Convert to LAS

Convert to E57

Convert LiData to LiData

Convert LAS to LiData

Raster Conversion

Convert TIFF to LiModel

Convert to Texture LiModel

Convert TIFF to LiData

Convert TIFF to ASCII

Model Conversion

Convert LiModel to TIFF

Convert LiTin to DXF

Vector Conversion

Convert Shape to KML

Convert KML to Shape

Extract

Extract by Class

Extract by Elevation

Extract by Intensity

Extract by Return

Extract by GPS Time



Point Cloud Tools
The point cloud tools include the following point cloud processing functions:

Remove Outliers

Noise Filter

Normalize by DEM

Normalize by Ground Points

Denormalize

Merge

Extract Point Cloud Boundary

Subsampling

PCV

Extract Color from Image

Subdivision

Transform GPS Time

Smooth Points



Remove Outliers

Summary

Common noises include high level gross errors and low level gross errors. As shown below, high level gross error is usually caused by the
returns of high-flying objects (such as birds or aircraft) during the process of data collection; low-level gross error are returns with extremely
low attitudes caused by the multipath effect of a laser pulse. The Outlier Removal tool aims to remove these errors as much as possible and
therefore improve the data quality.

The algorithm will first search for each point's neighboring points within a user-defined area and calculate the average distance from the point
to its neighboring points. Then, the mean and standard deviation of these average distances for all points are calculated. If the average
distance of a point to its neighbors is larger than maximum distance (maximum distance = mean + n * standard deviation, where n is a user-
defined multiple number), it will be considered as an outlier and be removed from the original point cloud.

Effect picture:

Usage

Click Data Management > Point Cloud Tools > Remove Outliers

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Neighbor Points (default value is "10"): The number of points required in the neighborhood to calculate the average distance of each
point. If there are not enough points found, the algorithm will not be executed.
Multiples of std deviation (default value is "5"): The factor multiplied by the standard deviation to calculate the maximum distance.
Output path: Path of the output file. After the function being executed, a new file will be generated. When more than one files are
entered, the path needs to be set to a folder.



Note: The algorithm of this function can be performed repeatedly to improve the denoising results. The outlier removal results is limited
if the noises are to dense.



Noise Filter

Summary

Remove the outliers from the point cloud data. Different from the remove outliers function, this function has a better processing performance
(filters more outliers) on objects with a flat surface (such as walls, interior tunnel walls, and the ground).

Usage

Click Data Management > Point Cloud Tools > Noise Filter.

Settings

Input Data: The input data can be a single point cloud file, or can be a point cloud data collection; these data to be processed must be
pre-opened in LiDAR360 software.
Radius(Default value is “0.5m”): Set the radius of the fitting plane. This function can be used when users know the approximate density
of the point cloud data.
Recommended Radius: Automatically calculate the appropriate searching radius according to the input point cloud data.
Multiples of std deviation(Default value is “1.0”): Using the relative error (sigma) as a parameter for outliers removal. The algorithm
will automatically calculate the standard deviation (stddev) of a point P's surrounding fitting plane. If the distance, d, from this point to that
plane is less than sigma * stddev, this point, P, will be kept. The reduction of this relative error results in removing more points.
Conversely, more points will be retained. The change of this parameter will not ifnluence the efficiency.
Remove Isolated Points: The point will be treated as an isolated point when there is less than 4 points within the distance of the
searching radius (cannot create a fitting plane with less than 4 points).
Output Path: The point cloud data will be save at this path after the outliers are removed.



Normalize by DEM

Summary

The normalization tool can remove the influence of terrain relief on the elevation value of the point cloud data. This function requires that the
extent of the DEM overlaps with the extent of the point cloud data. The normalization process is performed by subtracting the corresponding
terrain elevation of the DEM from each point's Z value. The output of this function is similar to Normalize by Ground Class.

Usage

Click Data Management > Point Cloud Tools > Normalize by DEM

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Input DEM File: Users can select single or multiple single-band TIFF image files from the drop-down list. File format: *.tif.

: Users can add external DEM file data.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all the data in the list.

Add Z Value to Additional Attributes: Add the Z value of the current point cloud to the additional attribute table. If this option is not
checked, then the normalized point cloud cannot be denormalized.



Output Path: Path of the output file. After the algorithm being executed, the new normalized file will be generated. When entering more
than one file, the path will need to be set as a folder.



Normalize by Ground Points

Summary

The normalization tool can remove the effects of topographic relief on the elevation value of point cloud data. This function requires that the
input data has already been classified into ground points and non-ground points. The normalization process is performed by subtracting the
terrain elevation (represented by the elevation of the closet ground point to each point) from each point's Z value. The output of this function is
similar to Normalize by DEM.

Usage

Click Data Management > Point Cloud Tools > Normalize by Ground Points

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Add Z Value to Additional Attributes: Add the Z value of the current point cloud to the additional attribute table. If this option is not
checked, then the normalized point cloud cannot be denormalized.
Output path: Path of the output file. After the function being executed, the normalized new file will be generated. When entering more
than one file, the path needs to be set as a folder.



Denormalize

Summary

Denormalization tool can reset the Z value of the normalized data. Users need to check the option "Add Original Z Value to Additional
Attributes" when performing Normalize by Ground Points or Normalize by DEM. After denormalization, the Z value will be reset as the original
Z value stored in the additional attributes.

Usage

Click Data Management > Point Cloud Tools > Denormalize

Settings

Input Data: The input data could be one or more point cloud files. The input data should be in *.LiData format.
Output Path: The path of the output data after denormalization. When number of input data sets is more than one, the output path
should be a folder.



Merge

Summary

Merge multiple point cloud files into a single point cloud file. This function is the reverse operation of Tile by Range and Tile by Point Number.

Usage

Click Data Management > Point Cloud Tools > Merge

Settings

Ignore Different Additional Attributes: When the input data sets are more than one, if this option is checked, then only the same
additional attributes will be merged. If there are any different additional attributes and this option is unchecked, the mergence cannot be
done.
Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Output path: Path of the output folder. After the algorithm being executed, a new file will be generated.



Extract Point Cloud Boundary

Summary

Use a regular hexagon to extract the boundary of a point cloud data. According to the Extraction Hexagon Height, determine the height of
each regular hexagon, and draw each hexagon based on the bounding box of the point cloud data. If the number of points within a hexagon is
greater than or equal to the user-defined Minimum Number of Points value, this hexagon will be kept and merged with its connected
hexagons. The ultimate output file is the final border vector file.

Usage

Click Data Management > Point Cloud Tools > Extract Point Cloud Boundary

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.

Extraction Methods: Choose the method to extract the boundary. Currently supports three methods, hexagon, convex hull, and concave
hull.

Hexagon (Default): Use hexagon to extract the boundary of the the data. Set the Hexagon Height to determine the size of the
hexagon. And draw every hexagon according to the minimum bounding box of the data. If the points inside the hexagon is more than
Minimum Number of Points, then draw the hexagon. Merge the adjacent hexagons to generate the shapefile of the boundary.

Hexagon Height (m)(default value is "10"): The height of the hexagon, which is used to set the size of drowning a hexagon.
Minimum Number of Points (default value is "1"): The thresholding number of points in a hexagon, below which no hexagon
will be drawn.

Convex Hull: Extract the 2.5-demantional convex hull of the point cloud in the XY plane (ignore the Z value). The output file is the
vector file (polygon) of the convex hull of the original point cloud. Each node of the polygon is extracted from the points in the point
cloud (with Z value).
Concave Hull: Extract the 2.5-demantional concave hull of the point cloud in the XY plane (ignore the Z value). The output file is the
vector file (polygon) of the concave hull of the original point cloud. Each node of the polygon is extracted from the points in the point
cloud (with Z value).



Maximum Side Length (m)(default value is "2"): The max. side length of all the sides of the output concave hull. The software
first detects the convex hull of the point cloud, then loops inward to capture the concave hull, and ensures that the maximum
side length is not greater than this value. When the value is too large, the calculation efficiency is improved, but the result will
not show the boundary details of the point cloud well; if the value is too small, the boundary will be clearly show the details, but
the calculation efficiency will be reduced. Therefore, in order to obtain the best extraction results, it is recommended that users
set this value to be more than 2 times the average distance of the point cloud. The users can also set this value to zero. At this
time, the program will automatically estimate the average distance between all the points, and set the parameter as twice of the
average distance.

Output path: Path of the output file. A new boundary vector file will be generated after the algorithm is executed. File format: *.shp.



Subsampling

Summary

Subsampling point clouds, namely, reducing the number of point clouds, LiDAR360 offers three methods for resampling: minimum point
spacing, sampling rate, and octree.

Usage

Click Data Management > Point Cloud Tools > Subsampling

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Sampling Type: This parameter defines the resampling method.

Minimum Points Spacing (default, default value is "0.0000"): Users need to set a minimum point spacing between two points so
that the minimum three-dimensional distance between any two points in the sampled point cloud will not be less than this value. The
larger the value is set, the fewer points will be kept.
Sampling Rate (default value is "99.99%"): Users need to set the percentage of reserved points. In this mode, LiDAR360 will
randomly retain the specified number of points. Reserved Points = Total Number of Points * Sample Rate. The value of this
parameter ranges from 0 to 100%. The smaller the value is set, the fewer points will be kept.
Octree (default value is "21"): This method allows users to select an "octree" subdivision level and build 3D voxels for the input
point cloud. Only the point closest to each voxel center will be retained. The "octree" subdivision level ranges from 1 to 21. The
smaller the value is set, the fewer points will be kept.

Output path: Path of the output file. New file will be generated after the function being executed.



PCV

Summary

PCV tool can be used to improve visualization effect of a point cloud. The principle of the PCV (Portion of Visible Sky) algorithm is to evenly
distribute multiple light sources at the top of the hemisphere or sphere calculate, and then calculate the cumulative number of times when the
light can be irradiated by illuminating each point in a point cloud. The last statistical result will be used as the intensity of the point cloud. The
rendering effect of the point cloud intensity after PCV calculation is shown in the figure below.

Usage

Click Data Management > Point Cloud Tools > PCV

Select the point cloud data that needs to be processed by PCV.

After the PCV process, the intensity range of a point cloud will be 0-255. By clicking on display by intensity or clicking display by the
mixed mode, users can see the boundary between different land covers more clearly in the point cloud after PCV process. The figure
below shows an example of intensity and height blend displaying effect after PCV calculation.





Extract Color from Image

Summary

Extract Color from Image tool can extract RGB information from multi-band imagery and assigned them to each point in a point cloud. The
user is required to enter one or more multi-band images that overlapping with the extend of the point cloud data.

After the process is completed, the display mode of the point cloud data will automatically change to RGB display (you can also click  on
the toolbar button, to display the point cloud in RGB).

Usage

Click Data Management > Point Cloud Tools > Extract Color from Image

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Input File: The user needs to enter one or more multi-band images that are geographically overlapping with the point cloud data. If the
image data has already been opened in the software, click the drop-down button to select the data, or you can click  to open the
external image data. Click  to remove selected images from the list and click  to clear the image data list. File format: *.tif.



Subdivision

Summary

Subdivision tool can divide a point cloud to a series of frames based on the user defined scales. Currently, for rectangle-division, LiDAR360
supports four subdivision scales: a scale of 1:5000 (taken to 1 km), 1:2000 (taken to 0.1 km), 1:1000 (taken to 0.1 km), and 1:500 (taken to
0.01km). The frame ID will be named by the coordinate number, which is composed of the southwest corner of the frame (Y coordinate + X
coordinate). After the operation is completed, one or multiple LiData file will be generated. A vector file in shp format will also be generated
recording each subdivided frame.

Usage

Click Data Management > Point Cloud Tools > Subdivision

Settings

Input LiData File: Input the point cloud data to be subdivided. If the point cloud data is already open in the software, click the drop-down
button to select the data; or you can click  to open external point cloud data. Click  to remove the selected data. Click  to clear
the data list. File format: *.LiData.
Subdivision by Rectangle: Use "Subdivision by Rectangle". Scale is 1:500 by default.
Subdivision by Latitude and Longitude: Use "Subdivisions of Graticules". Scale is 1:500 by default.
Scale: Users can choose the scale of the division. For rectangle-division, LiDAR provides four scales, including 1:500, 1:1000, 1:2000,
1:5000. For subdivisions of graticules, LiDAR provides eleven scales, including 1:500, 1:1000, 1:2000, 1:5000, 1:10000, 1:25000, 1：
50000, 1:100000, 1:250000, 1:500000, 1:1000000.
Buffer (default is "0"): The size of buffer around each data.
Ignore Different Additional Attribute: In the case of processing multiple input point clouds, if this option is checked, only the same
additional attributes will be merged. Otherwise, as long as there are different additional attributes, the merge cannot be performed.
Output Path: The path for the output folder. After running this function, the new divisions will be generated.



Transform GPS Time

Function Description

This function converts the GPS time information in LiData from GPS coordinate time to GPS week second, or from GPS week second to GPS
coordinate time. There are two ways to record the GPS time information, GPS week second and GPS coordinate time (GPS standard time
minus 10^9).

Usage

Click Data Management > Point Cloud Tools > Transform GPS Time.

If the GPS time of the selected data is GPS weeks and seconds, the pop-up interface is as shown in the figure below：

If the GPS time of the selected data is GPS coordinated, the pop-up interface is as shown in the figure below：

Lidar360 TransformGPSTime

Settings

Input Data：Enter a LiData point cloud data file.

If the GPS time of the input point cloud data is GPS weeks and seconds, it needs to be converted to GPS coordination time.

Collection Date：If the GPS time information of the input point cloud is in GPS week second and to be transformed into GPS coordinate
time, the week number is necessary. And the week number must be greater than 1654. Otherwise, when being subtracted by 10^9, the
GPS time will be negative. If the GPS time information of the input point cloud is in GPS coordinate time and to be transformed into GPS
week second, the week number is unnecessary.



Smooth Points

Summary

Smooth the laser point cloud based on the neighbouring points, making the point cloud look more consistent.

Usage

Click Data Management > Point Cloud Tools > Smooth Points.

Settings

Input Point Cloud Data：Input the LiData point cloud data to be smoothed.

Smoothing Type：

XYZ（Default） ：In the 3D smoothing process, the points on the vertical plane are smoothed in the XY direction, and the points on the
horizontal plane are smoothed in the Z direction.

Elevation ：Fit the best fitting plane equation according to the neighboring points, and adjust the elevation of the center point to
better fit the plane equation. If the adjustment distance exceeds the repair threshold, no adjustment will be made.

Search Radius (m) (Default Value is “0.2”)：Search radius of neighboring points.

Max Fix Distance (m) (Default Value is “0.1”)：The maximum single-point adjustment distance threshold, beyond which it will not be
adjusted.

Output Path：Set the output path for smooth point cloud files generated by the smoothing process.

Default：Restore the setting parameters to the default values.



Raster Tools
Raster tools include Band Calculation, Raster Mosaic, and Raster Subdivision.

Raster Mosaic

Raster Subdivision

Raster Calculator



Raster Mosaic

Summary

Raster Mosaic refers to the technical process of merging two or more images to one image. LiDAR360 provides seven sampling methods:
Nearest Neighbour, Bilinear, Cubic, CubicSpline, Lanczos, Average, and Mode. It is the reverse operation of Raster Subdivision.

Usage

Click Data Management > Raster Tools > Raster Mosaic

Settings

Input Tiff File: Users can select multiple files (>1) to be processed from the drop-down list.
: Users can add multiple external images for image mosaic.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all images in the list.

Sample Type: Users need to select the sampling type from the drop-down list.
NearestNeighbour (default): Nearest neighbor, sampled from the nearest neighbor.
Bilinear: Bilinear sampling (2 x 2 cores).
Cubic: Cubic convolution approximation (4 x 4 kernels).
CubicSpline: Cubic B-spline approximation (4×4 kernel).
Lanczos: Lanczos Window Sine Interpolation (6×6 Cores). Lanczos can be used as a low pass filter or to smoothly interpolate the
value of a digital signal between its samples.
Average: Calculate the average of all non-value pixels.
Mode: Select the most frequently occurring value for all sampling points.

Output path: Path of the output folder. After the function is executed, a new file will be generated.

https://en.wikipedia.org/wiki/Lanczos_resampling


Raster Subdivision

Summary

The raster subdivision tool is the inverse operation of Raster Mosaic. The frame number adapts the coordinate number and consists of the
southwest corner of the frame (Y coordinate + X coordinate). A scale of 1:5000 is taken into 1 km, 1:2000 and 1:1000 to 0.1 km, and 1:500 to
0.01 km.

Usage

Click Data Management > Raster Tools > Raster Subdivision

Settings

Input File: Users can select the file to be processed from the drop-down list.
: Users can add external files that need to be processed.

Scale (default "1:500"): Users can select a targeted scale. LiDAR360 has four scale options: 1:500, 1:1000, 1:2000, and 1:5000.
Output path: Path of the output folder. After the function is executed, new subdivided files will be generated.



Raster Calculator
This tool is a spatial analysis tool. User can input raster data algebraic expressions, use operators and functions to do mathematical
calculations, in order to establish selection queries, or enter raster data algebraic syntax.

Advantages of the raster calculator tool:

1. Supports the use of variables in raster data.
2. The ability to apply operators to three or more inputs of an expression.
3. The raster calculator is used to execute single-line algebraic expressions through a simple, calculator-like tool interface, using a variety of

tools and operators. When multiple tools or operators are used in an expression, the speed of execution is generally faster than
executing each operator or tool separately.

Principle Description

Use the calculator buttons to enter values in expressions. Use the operator buttons to enter mathematical operators (addition, division, etc.)
and logical operators (greater than, equal to, etc.) into expressions. By clicking these buttons, user can enter a number or operator into the
current position of the pointer in the expression. The following are some examples of expressions that can be executed in the raster calculator
tool. In these expressions, the raster layer name is enclosed in quotation marks, such as "dist".

("pop" > 150) & ("dist" > 10)
(("reclass_rd_dist" * 3) + ("reclass_landuse" * 2) + "reclass_elev") /6.0
("Band4" - "Band3") / Float("Band4" + "Band3")
Con("elev" <= 3000, 1, 0)
Con(IsNull("elev"),0, "elev")
Con(("landuse1" == 1) & ("landuse2" == 5), "landuse1" + "landuse2", 99)
Con(Raster('elev') != 0,'elev')
(Con('elev', 'elev', "", "elev_feet <> 0")) + Raster("tree_height")
Con("inRas" < 45,1, Con(("inRas" >= 45) & ("inRas" < 47),2, Con(("inRas" >= 47)&("inRas" < 49),3, Con("inRas" >= 49,4))))

Usage

Click Data Management > Raster Tools > Raster Calculator.

Settings

Raster Data：Display the raster data path (.tif) contained in the main interface, user can import the local raster data, perform expression
calculations, and remove or clear the imported data.

Calculator Buttons：Contains number buttions 1, 2, 9, 0, etc. Algebraic operator buttions +, -, *, /, etc. Logical operators >, <, ==, etc.
The major operation and logical buttons are as follows:

/ Divided by != Not equal to == Equal to & AND

X Multiplied by < Less than <= less="" than="" or="" equal<="" td=""> | OR

- Minus > Greater than >= Greater than or equal ^ Exclusive OR



+ Plus ~ NOT C Clear expression

Function：Lists the functions of abs, tan, cos, log, etc.

Function Description

abs Absolute value function

acos Arc-cosine function

acosh Hyperbolic arc-cosine fuction

cosh Hyperbolic cosine function

asin Arc-sine function

asinh Hyperbolic arc-sine function

sin Sine function

tan Tangent function

atanh Hyperbolic arc-tangent function

atan Arc-tangent function

cot Cotangent function

pow Exponent power function

log Logarithm function

sqrt Square root function

sinc Sinc function

Calculator Expression：Use the calculator button to enter values in the expression, or use operators, functions, etc. to form a raster
calculation expression with raster data, and display it in this panel.

Output Path：Select the output directory or .tif file path. This output raster represents the result value of the calculation expression.



Tile
The Tile Tool Includes Tile by Range, Tile by Point Number, Tile by Draw Line, and Tile by Polygon.

Tile by Range

Tile by Point Number

Tile by Draw Line

Tile by Polygon



Tile by Range

Brief

Tile by Range divides the point cloud into a series of small data files based on the user-defined width ,length and buffer size of the small data
file. This process begins from the lower-left corner of the input file's bounding box,the result includes the point cloud blocks data(including
buffer) and the blocks boundary stored in the shp file(not including buffer). The output of this function is similar to Tile by Point Number.

Brief

Click Data Management > Point Cloud Tools > Tile by Range

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Width (m)(default value is "500"): The width of the data block size, which is the length in the X-axis direction.
Height (m)(default value is "500"): The length of the data block size, which is the length in the Y-axis direction.
Buffer (m)(default value is "0"): The extend size of every block in all directions.
Output path: Path of the output folder. After the function being executed, new files will be generated which include the point cloud blocks
data(including buffer) and the blocks boundary stored in the shp file(not including buffer).



Tile by Point Number

Summary

Tile by Point Number divides the point cloud into a series of small data files with a total of user-defined number of points. This process
begins from the lower-left corner of the input file's bounding box. The output of this function is similar to Tile by Range.

Principle

The Point Number entered by the user will be recalculated according to the actual number of blocks in the actual chunking process. The
formula is as follows:

Among them,  is the number of tiles,  is the actual point number of a tile,  is the total number of points in the

original file, and is the user-defined point number.

Effect picture of tile:



Original point cloud data and point cloud data after chunking by point (different yellow bounding boxes represent different point cloud data).

Usage

Click Data Management > Point Cloud Tools > Tile by Point Number

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Point Number (default value is "50000"): Set the number of points in each tile. Note that the actual number of points in a tile may be
slightly different from the user-defined number.
Output path: Path of the output folder. After the function being executed, new files will be generated.



Tile by Draw Line

Summary

Draw a straight line on the Viewer and divide the point cloud data into two pieces by using this line as the boundary.

Usage

ClickData Management > Point Cloud Tools > Tile by Line

Enter the coordinates for the start and end points, or update the start and end points by drawing a line on the Viewer after clicking the buttons
on the right side of the dialog box.

Settings

Input Data：The input file should be a single point cloud data file. File Format: *.LiData.
Initial Point（X,Y）：The XY of initial point.
Termination Point（X,Y）：The XY of termination point.
Out Path：Path of the output folder，After the function is executed, the divided point cloud file and the shp file of the block boundary are
generated. The block boundary stored in the shp file does not include the size of the buffer.



Tile by Polygon

Summary

Read the Polygon information in the SHP file with the vector data type of Polygon or MultiPolygon, and extract the points inside the Polygon,
outside the Polygon or between the polygons to generate a new point cloud file.

If the data format of shp is Polygon, a new file will be generated for the points in each polygon, and a point cloud file will be generated for
points that are not in any polygon.

If the data format of shp is MultiPolygon, it will generate point cloud data from the point cloud file of the inner polygon, generate point cloud
data from the point set between the inner polygon and the outer polygon, and generate point cloud files from all points other than Polygon.

Usage

ClickData Management > Point Cloud Tools > Tile by Polygon

Settings

Input Point Cloud Data：The input file can be a single point cloud data file or multiple data files. File Format:*.LiData.
Shp File：Include polygon information.
Named With The Attribute Name of The shp File：Select the attribute field of Polygon and name the newly generated block data.
Calculate the Polygon Topological Relationships：When the polygon type of the shp file is polygon, calculate the topological
relationship between the polygons. If checked, the topological relationship between polygons will be calculated. If it is not checked, all
points in the Polygon will be generated into a new file.
Output Path：Path of the output folder, the point cloud file after the function is executed will be output under this file path.



Projections and Transformations
Different kinds of transforms for point clouds, e.g. reprojection, elevation adjustment, are provided. The calculation of parameters necessary
for transforms, e.g. seven-parameter solution, four-parameter solution, are provided as well.

Define Projection

Reproject

Transformation

Elevation Adjustment

Transformations Calculation

ICP Registration

Convert ASCII to BLH

Manual Registration

Manual Rotation and Translation

The Geoid Model

Create Transformations



Define Projection

Summary

Define projection information for point cloud data, including geographic coordinates (usually latitude and longitude coordinates) and projection
coordinates (plane coordinates calculated from projection). Note that when use this tool to define the projection information for point cloud
data, they should not have projection information previously.

Usage

Click Data Management > Projections and Transformations > Define Projection

Settings

Select Input file: The input file can be a single point cloud data file or multiple point cloud data files. File format: *.LiData.

Current File's Coordinate Name：Display the current coordinate name.

Filter: Users need to enter a customized coordinate system. By entering the coordinate system keywords, the corresponding coordinate
system can be filtered from the Coordinate reference systems of the world table (for example: to set the point cloud coordinate system
to WGS 84 / UTM Zone 49N, users can enter UTM 49N in the filter for fast screening, or enter its EPSG number 32649 for quick search.)
Users can also import external coordinate system by clicking the Add Coordinate System button.



Add Coordinate System: Users can add external coordinate system settings or customize coordinate system settings. LiDAR360
software provides four ways to add external coordinate system:

Add Geographic Coordinate System
Add Projected Coordinate System

Add Geographic Coordinate System

Name: Users can customize the name of a geographic coordinate system .
Datum:

Name: Users can customize a datum name or select a known datum from the drop-down list.
Spheroid: If a user selects the datum from the drop-down list, the ellipsoid parameter does not require to be entered.

Name: The name of the spheroid.
Semimajor Axis: Spheroid's major semiaxes.
Inverse Flattening: Inverse flattening of the spheroid.

Angular Unit:
Name: Users can customize the angle unit name, or select the angle unit name from the drop-down list.
Radians Per Unit: Define the unit of arc in the geographic coordinate system.

Prime Meridian:
Name: Users can customize the name of the central meridian, or select the name of the central meridian from the drop-down list.
Longitude: Input the central meridian longitude.

Add Projected Coordinate System



Name: Users can customize the name of a projection coordinate system.
Projection:

Name: Users can customize a projection name or select a known projection from the drop-down list. It should be noted that user-
defined projections can be modified from a projection template selected from the drop-down list.

Linear Unit:
Name: Users can customize the linear unit name or select the linear unit name from the drop-down list.
Meters per Unit: Input meters per unit.
Geographic Coordinate System: Users can paste the geographic coordinate system parameters into the text box, or click to
change.

Change

When the user clicks on the Modify button, the following dialog box will pop up for modifying the geographic coordinate system.

The user can filter out the needed coordinate system through the filter operation, or can also add the geographic coordinate system through
the New Geographic Coordinate System. Setting method is the same as Add Geographic Coordinate System.



Reproject

Function Description

The point cloud can be reprojected among geographic coordinate systems and projected coordinate systems. When different geographic
coordinate systems are converted to each other, LiDAR360 provides the seven parameter transformation model to adjust the differences
between ellipsoids and reference planes. To achieve this, users can select the "using the seven-parameters" option, click the "Seven
Parameters Setting" button, and then enter the values for X-translation, Y-translation, Z-translation, X-axis rotation, Y-axis rotation, Z-axis
rotation, and scale factor for the seven-parameter transformation.

Usage

Click Data Management > Projections and Transformations > Reproject

Settings

Select Input File： The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Current File's Coordinate Name：Display the coordinate system name of the current point cloud.
Use Seven Parameters： Users can choose whether to use seven parameters for re-projection. If checked, seven parameters will be
used; vice versa.
Seven Parameters Setting：Select the Use Seven Parameters option and click the Create button to create a seven-parameter
conversion relationship. Please refer to Create Transformations。
Filtering： Users need to enter a customized coordinate system. By entering the coordinate system keywords, the corresponding
coordinate system can be filtered from the Coordinate reference systems of the world table (for example: to set the point cloud
coordinate system to WGS 84 / UTM Zone 49N, users can enter UTM 49N in the filter for fast screening, or enter its EPSG number
32649 for quick search.) Users can also import external coordinate system by clicking the Add Coordinate System button.
Add coordinate systems：For details, refer to Define Projection parameter settings.
Output path： Path of the output file. New files will be generated after the function being executed.

Note: The reprojected point cloud must already have projection information. To check whether the current point cloud has projection
information, users can select the data in the data list and its projection information will be displayed in the current file coordinate system



Transformation

Function Description

LiDAR360 software supports multiple coordinate transformation methods. Users can select a transformation method to perform coordinate
conversion according to their needs.

Usage

Click Data Management> Projection and Coordinate Conversion> Coordinate Conversion

Usage

1. Input Data： The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.

2. Select or customize transformation method: available for reference, Create Transformtions.

3. Output Path：Path of the output folder. After the algorithm being executed, new files after coordinate conversion will be generated.



Elevation Adjustment

Summary

The elevation of raw laser data is normally represented by ellipsoidal height. Normally these values need to be transformed to values in
regional height system or local height system. For large area, the adjustment of elevation can not be defined as a mathematical formula.
Hence, the model of elevation adjustment is required to be defined. The algorithm is to build triangular network model using known control
point data as well as to interpolate and correct local points using height anomaly between different height systems. Adjusted elevation result
can be checked according to the Control Point Report.

It is recommended to use control point data containing entire project region to adjust model in order to provide more accurate elevation
information to the project border.

Usage

Click Data Management > Projections and Transformations > Elevation Adjustment

Setting

Input Data: Input files can be single point cloud file or point cloud data set.
Input File: Users need to input adjustment model file of control points. This file data can be generated by tool of Control Point Report.
Output path: Output adjusted point cloud data.



Conversion relationship calculation

Function Description

This function calculates the required conversion relationship based on the control point pair, and can save the calculated conversion
relationship to the history file for reuse. Currently supports four-parameter and seven-parameter solutions.

Usage

Click Data Management> Projection and Coordinate Conversion> Conversion Relationship Calculation

Lidar360 Transform

Parameter Settings

Parameter Solution：The method of parameter calculation supports four parameters and seven parameters.
Source/target coordinate file：Input the control point source coordinate file, the format can be referred to Seven Parameter format.
Source/target coordinate system：When the coordinate form is x y h / BLH, the coordinate system can be selected, please refer to
Define Projection.
Source/target coordinate form：

X Y Z (Earth-centered coordinate system): Select this item when the input data is in the projected coordinate system. At this time,
the "source/target coordinate system" cannot be selected. Directly calculate the seven-parameter transformation between the source
coordinate and the target coordinate. If the user selects four parameters, it will be forced to switch to X Y Z
X Y H / BLH: Select this item when the input data is in the projection/geographical coordinate system. At this time, you need to
select the "source/target coordinate system". After the selection is completed, it will automatically switch once according to the
selected coordinate system. When selecting BLH, you can select degrees or degrees: minutes: seconds.
Report：Calculate the conversion relationship and generate a report, which contains the calculated conversion relationship
parameters and the back-projection report of various control points. The report can be saved as HTML and ASCII format.
Define conversion relationship：Please refer to Create Transformation.

Seven-Parameter Solution
Using Bursa model to calculate the seven parameters for the transformation among different coordinate systems according to three or more
pairs of tie-points. The parameters include three translation parameters, dx, dy, dz, three rotation parameters, rx, ry, rz, and a scaling factor,
m. The calculation formula is shown below. Bursa seven parameters formula can be written as follow:



Lidar360 Transform

Convert the above formula to a equation set, which is：

Lidar360 Transform

In the equation set, there are seven unknown parameters. If there are three or more than pairs of tie-points, these seven parameters can be
solved through the above equation set using the least square method.

Four-Parameter Solution
According to two or more control points, users can calculate the four parameters that used to perform coordinate system transformation. The
four parameters include two translation parameters, dx and dy, a rotation parameter, T, and a scaling factor, K.



Convert ASCII to BLH

Summary

Transform the X, Y, Z information stored in the ASCII data to B (latitude), L (longitude), and H (ellipsoid height) in Geographic Coordinate
System. All the other attributes in ASCII file will be kept.

Usage

Click Data Management > Projections and Transformations > Convert ASCII to BLH.

Settings

Input ASCII Data: Input an ASCII file. The supported formats include .txt and .CSV.
Coordinate System of Current Data: Select the coordinate system of current point cloud file
Skip Lines: The number of lines that need to be skipped for the currently selected ASCII data (usually description information or column
headers).
Separator: The separator of each component of the selected ASCII data.
Source Projection: Projection information of the selected ASCII data.
Output Path: Output the converted file to the specified path.



Manual Registration
This tool is used for coordinate rectification of to-be-aligned data with respect to reference data. The two datasets can be "point cloud and
point cloud", "point cloud and image", or "image and image". At least 3 pairs of homologous points(or fitted spheres in point cloud) should be
added in the datasets, which are displayed in separate windows, before the calculation of transformation parameters. You can evaluate the
accuracy using the residuals of homologous points listed in the table window.

Note: You have to create at least two display windows (except the profile window) before using this tool.

Steps

1. Create two display windows and load the reference data and the to-be-aligned data into separate windows. Click the Manual
Registration tool to open the following dialog.

2. Select Reference window for the reference data and Alignment window for the to-be-aligned data. Then click the OK button. The
following table window with a series of tools pops up.

3. (Optional) Click the Load Data button to load homologous points from existing file. Then you can skip the manual measurement (steps 5,
6, 7).

4. Click Pick Point or Pick Registration Sphere to measure a pair of homologous points (or fit a pair of spheres) in reference window and
alignment window. If spheres are fitted, their centers are used as homologous points.

5. Click the button Add Point to add blank row for a new pair of homologous points.

6. Repeat steps 5 and 6 to pick at least three pairs of homologous points (or spheres).

7. (Optional) If the option Predict is checked and there exist at least 3 pairs of homologous points, the corresponding position in the
reference window will be predicted after picking a point in the alignment window.

8. (Optional) The user can exclude a pair of homologous points in the calculation of transformation parameters: (1) Uncheck the row of the
homologous points in the table; (2) Or click the Delete Point button after selecting the corresponding row.

9. (Optional) The user can modify the coordinates of added homologous points: (1) Pick point again in the alignment window and reference
window after selecting a row of homologous points; (2) Or double click the coordinates in a row, then input new values directly.



10. (Optional) The user can view each homologous point quickly for quality check: Double click a row in the table to jump to the
corresponding positions in the display windows.

11. (Optional) Click the Save Data button to save the homologous points to file.

12. Click the button Transform to calculate transformation parameters and generate aligned data.

Toolbar

Following functions are integrated in the toolbar.

 Save Data: Save homologous points to file.
 Load Data: Load homologous points from file (Please refer to File Format of Homologous Points).
 Add Point: Add blank row for a new pair of homologous points in the table.
 Delete Point: Delete selected row in the table.

Point Size (Default: "20"): Point size of homologous points in display windows.

Predict (Default: Unchecked): If this option is checked and there exist at least 3 pairs of homologous points, the corresponding position in
the reference window will be predicted after picking a point in the alignment window.

 Pick Point: Pick homologous points in reference window and alignment window.
 Pick Registration Sphere: If target ball is used for point cloud registration, this function can fit sphere automatically after clicking the

target ball in point cloud. The sphere center is used as homologous point.
R: Radius for sphere fitting. Please input the actual radius of target ball.

RMS: The threshold of root mean square error for sphere fitting. Please set larger value for point cloud of low quality in case of fitting failure.

Adjust Scale (Default "unchecked"): If the scale between data is different, this option needed to be checked in order to generate a scaling
factor. If it is not checked, the point cloud is considered to be a rigid transformation, and the calculated rotation matrix does not contain a
scaling factor.

Transform: The coordinates are rectified based on homologous points. While processing image data, the user can specify different
methods, which include polygonal correction and polynomial correction. The polynomial correction varies depending on N pairs of
homologous points. |Polynomial Correction|Condition| |:-:|:-:| |Primary Polynomial |3 <= n="" <="" 6|="" |quadratic="" polynomial="" |6="" 10|=""
|cubic="" |10="" Preview: If this option is checked, a new window for preview will be created. The reference point cloud and the point
cloud with the current transformation matrix applied will be displayed in this window. If users want to see the transform in preview, they can
use this function. Currently, the preview only supports adding point cloud data. The picture below shows the effect of preview function.

Export Transform Matrix: When the point pairs picked in two windows are more than 3 pairs, software will generate the transform matrix
shown in the matrix information table. Click this button to save the current transform matrix.

Input Transform Matrix: Input a txt format transform matrix. The matrix should be 4 by 4. Click "apply" to show the matrix in the matrix



information table.



Manual Rotation and Translation
Manual Rotation and Translation can be used on point cloud. It wil generate corresponding transformation matrix. Then you apply the matrix
to the point cloud data.

Note: This tool can only be activated when there's point cloud data in the view.

Steps

1. Create a new viewer, drag point cloud into the viewer. Click Manual Rotation and Translation tool.

2. In the popup window, select point cloud to align and reference data. Then, the table window will pop up. See tools information below.

Tools

In the table window, the buttons from left to right are: open matrix, save matrix, match data center, pause rotation and translation
transformation, restore to initial state, and data transformation.

The matrices saved and opened by this tool are all matrices in the world coordinate system and will be displayed in the current matrix table on
the right.

The translation and rotation angle information displayed on the left is calculated based on the rotation center, where the rotation center is the
world coordinate corresponding to the geometric center point of the bounding box of the file data to be registered.

 open matrix：Import existing matrix files. See appendix for detailed information.
 save matrix：save matrix in txt file.
 match data center：When you have a reference point cloud, you can use this tool to match the center point of two point cloud, and move

the point cloud to align based on the center calculation.
 pause：Pause operation. You can check the difference between point cloud to align and reference point cloud when pausing.
 restore：Restore the data to the initial state, and modify the rotation transformation matrix into a unit matrix.
 apply matrix：After applying the transformation matrix, you can save the result of the point cloud transformation to the original file or

generate a new file. Transformation formula: A known point P0(X0,Y0,Z0)。 Below is transformation matrix M： a00 a01 a02 a03 a10 a11 a12
a13 a20 a21 a22 a23 a30 a31 a32 a33 The formula is [X1 Y1 Z1 1] = [X0 Y0 Z0 1]\*M /(a03\*X0 + a13\*Y0 +a23\*Z0); P0 after
transformation: P1(X1,Y1,Z1).
TX：After checking this option, you can perform translation operations on the X axis. The amount of translation in the X direction will be
displayed on delt X.
TY：After checking this option, you can perform translation operations on the Y axis. The amount of translation in the Y direction will be
displayed on delt Y.
TZ：After checking this option, you can perform translation operations on the Z axis. The amount of translation in the Z direction will be
displayed on delt Z.
Rotate：There are four options of X, Y, Z, XYZ. If you select one, you can only perform rotation operations on that axis.



The geoid model
When coordinate transformation is carried out in the projection library, vertical coordinate system transformation needs to provide vertical
reference grid data to carry out effective transformation. EGM2008 geoid model elevation conversion is provided by default in the software. If
you need to support other regional geoid models, you need to download the corresponding grid data files. Grid documents are provided by
the official PROJ library, provided here proj-data-1.2 to download, if you need to download the latest full version data. Visit website
https://proj.org/download.html to download the latest version. After downloading and extracting, copy all Files in the folder to the Geoid folder
under the software installation directory. Default is in C:\Program Files\GreenValley Suite\LiDAR360\5.0.0.0\geoid, "5.0.0.0" is the version
number, may be different in every versions.

https://download.osgeo.org/proj/proj-data-1.2.tar.gz
https://proj.org/download.html


Create Transformation

Function Description

This function can define and edit a variety of conversion relations, these conversion relations can be saved in the history file for users to use
again.

Supported conversion relationship:

Four parameters：Including two translation parameters Dx, Dy, a rotation parameter Theta (seconds), and a zoom ratio t（ppm).

Lidar360 Transformation_linear

Seven parameters：The seven parameters in the Bursa model are three translation parameters Dx (meters), Dy (meters), Dz (meters),
three rotation parameters Rx (seconds), Ry (seconds), Rz (seconds) and a zoom The ratio m (ppm).

Lidar360 Transformation_linear

The formula of Bursa's seven parameters can be written as follows：



Lidar360 Transform

The seven-parameter model can be converted into 3D affine transformation parameters, and the conversion relationship is：

Dx = Dx;
Dy = Dy;
Dz = Dz;
Rx(″) = Rx(″);
Rx(″) = Rx(″);
Rx(″) = Rx(″);
Mx(ppm) = m(ppm);
My(ppm) = m(ppm);
Mz(ppm) = m(ppm);

3D affine transformation：

Lidar360 Transformation_linear

Dx, Dy, Dz (default value is "0") : Panning values added to X, Y, Z.
Mx, My, Mz (default value is "0") : Scale factor applied to X, Y, and Z.
Rx, Ry, Rz (default value is "0") : The angle of rotation about the X, Y, and Z axes in degrees.

Four parameters (displayed as two-dimensional transformation parameters) : Two-dimensional transformation parameters,
also known as XYMultiply.



Lidar360 Transformation_linear

The targeted coordinates are calculated using the following formula:

Among them, Px, Py, Pz, a, b, c, d, e are the transformation parameters, Sx, Sy, Sz are the original coordinates, and X, Y, Z are the
transformed coordinates. This is often used as a 2D Helmert transformation.

Px = Dx;
Px = Dy;
Pz = 0.0;
Define k = t / 1000000 + 1.0;
Define tRad = theta / 3600.0 / 180 * PI;
Then：
 a = k * cos(tRad);
 b = -k * sin(tRad);
 c = k * sin(tRad);
 d = k * cos(tRad);
 e = 1.0;

Linear transformation：The linear transformation is used to pan and zoom a point cloud. A panning parameter and a scaling parameter
need to be set to the X, Y, Z coordinates, respectively.

Lidar360 Transformation_linear

The targeted coordinates are calculated using the following formula:



Among them: Sx, Sy, Sz are the scaling factors for the x, y, and z coordinates. Px, Py, and Pz are the panning parameters for the x, y, and z
coordinates. x, y, and z are the original coordinates, and X, Y, and Z are coordinates obtained after the linear transformation.



Clip
The clipping tools include Clip by Circle, Clip by Rectangle and Clip by Polygon.

Clip by Circle

Clip by Rectangle

Clip by Polygon



Clip by Polygon

Summary

Clip by polygon tool extracts the point cloud data within a user-defined polygon vector file, and the extracted points will be saved in one or
several files.

Usage

Click Data Management > Clip > Clip by Polygon

Settings

Input Data: Select one or more point cloud data files. File Format: *.LiData.

Interactive Polygon: Click  to start to create the polygon. Click in the viewer to select the nodes and double-click to end selecting.

After this, the polygon will be added to the polygon list. Click  to delete the polygon in the list.

Shape File: Select the vector file pre-loaded in LiDAR360 from the drop-down menu, or click the button  to load an

external vector data file.
Ignore Different Additional Attributes: When inputs are several point cloud files, and this option is checked, only the same additional
attributes of the point cloud files will be merged. If this option is unchecked, and there are some different attributes in the additional
attribute tables, the mergence of different point cloud files cannot be done.
Generate Single File: When users choose to export a single file, the point cloud will be clipped by all polygons in the vector data. All
results will be saved in one file.
Generate Multiple Files: When users choose to export single file, the point cloud will be clipped by all polygons in the vector data. The
point cloud in each polygon unit will be saved as one file.
Use Attributes Names: When users select to Generate Multiple Files, this function can be used. Users can name the files by selected
attributes. When attributes are not available, the files will automatically be named as its idenfication number.
Output Path: The generated files will be saved in this output path.

Note: The vector data file used to clip the point cloud data must be a existing polygon file.



Point Cloud Conversion
Point Cloud Format Conversion Tool Provides Conversion Between Point Cloud and Other File Formats.

Convert to ASCII

Convert to TIFF

Convert to Shape

Convert to DXF

Convert to Las

Convert to E57

Convert LiData to LiData

Convert Las to LiData



Convert to ASCII

Summary

The Convert to ASCII tool can convert the LiData point cloud to ASCII format, a text format that can be easily viewed in a text editor.

Usage

Click Data Management > Conversion > Convert to ASCII

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are supported.
Export Format: LiDAR360 supports two suffix formats: txt and csv, and support separators are: commas, spaces and TAB.
Output path: Path of the output folder. After the conversion is executed, the converted new file(s) will be generated.



Convert to TIFF

Summary

The Convert to TIFF tool can convert LiData point cloud data to raster images according to the Attribute of the points in Cell Value method.

Usage

Click Data Management > Conversion > Convert to TIFF

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
XSize (m, default value is "2"): The X pixel resolution of the output raster.
YSize (m, default value is "2"): The Y pixel resolution of the output raster.
Attribute (default is "Z"): Select the point attribute used to calculate the raster cell value.

Z (default): Generate the raster data using the Z value of the point cloud data.
Intensity: Generate raster data using the intensity values of the point cloud data.
Scan angle: Generate raster data using the scan angle of point cloud data.
Return number: Generate raster data using the return number of the point cloud data.
Number of returns of given pulse: Raster data is generated using the number of returns of given pulse of the point cloud data.

Cell value: Choose how to fill raster pixel values.
Minimum (default): Use the smallest attribute value as the value of a raster cell.
Average: Use the average of attribute values of all points within a raster cell as its value.
Maximum: Use the largest attribute value as the value of a raster cell.

Merge files into one: Users can set merging all raster into one data file. If not checked, each point cloud data will be generated into a
separate raster file.
Output path: Path of output folder. After the function is executed, the converted new file is generated.



Convert to Shape

Summary

The Convert to Shape tool can convert point cloud files in LiData format to point files in vector format.

Usage

Click Data Management > Conversion > Convert to Shape

Settings

Input data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported, and all Las attributes are supported. The selected
attributes will be written in the attributes of the shape file data.
Output path: Path of the output folder. After the conversion being executed, the converted new file will be generated.



Convert to DXF

Summary

The Convert to DXF tool can convert LiData format point cloud files to point vector data in DXF format. LiDAR360 software exports DXF files
in ASCII format.

Usage

Click Data Management > Conversion > Convert to DXF

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
From Class: Source class (es), supports up to 256 different classes.
Tile: Since the amount of point cloud data is often large, the software provides an optional tile mode that can split the input data file to a
number of tiles.

No Tile: Export a single DXF file.
Tile by Rows and Columns: According to the boundary of the point cloud data, the point cloud will be split into a total number of
rows * columns data blocks evenly, and a single DXF file will be generated.

Rows (default value is "3"): User-defined number of rows that the point cloud want to be split into.
Columns (default value is "3"): User-defined number of columns that the point cloud want to be split into.

Tile by Width and Height: The point cloud will be split into a number of tiles from the lower left corner by the specified width and
height, one DXF file per block.

Width (m, default value is "100"): User-defined block width.
Height (m, default value is "100"): User-defined block height.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s) will be generated.



Convert to Las

Summary

Convert to Las can convert point clouds in LiData format to LAS format, namely the standard Lidar point cloud data format.

Usage

Click Data Management > Conversion > Convert to Las

Settings

Select Input File: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are supported.
RGB Range: There are three options for the RGB range.

none：Output according to the original RGB range of the selected file.
0~255 (8 bits): Output with the RGB mapped to 0~255. If the color range of the file selected is 0~1 or 0~65535, it can be mapped to
0~255 for output.
0~65535 (16 bits)：Output with the RGB mapped to 0~65535. If the color range of the file selected is 0~1 or 0~255, it can be
mapped to 0~65535 for output.

Source Unit: The unit of the LiData to be exported as LAS file. As the only supported unit in LiDAR360 is meters currently, this option is
fixed as "meter".
Target Unit: The unit of the exporting LAS file. Choose from meters, decimeters, centimeters, millimeters, feet, and inches.
LAS Version (Default value is 1.4): The version of the exporting LAS file. Choose from 1.2 to 1.4. Please refer to LiData Format for
details. When exporting from a higher version to a lower version, the exceeded field range limitation will be set as 0.
Output Path: Path of the output folder. After the conversion being executed, the converted new file(s) will be generated.



Convert to E57

Summary

Convert to E57 can convert point clouds in LiData format to E57 format.

Usage

Click Data Management > Conversion > Convert to E57

Settings

Select Input File: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported. The basic and additional attributes are supported.
Output Path: Path of the output folder. After the conversion being executed, the converted new file(s) will be generated.



Convert LiData to LiData

Summary

Convert the version of LiData file. Currently, the tool supports the conversion between LiData 1.9 and LiData 2.0. LiData 2.0 supports the
additional attributes and expands the scope of some attribute fields (i.e., the number of classes has been expanded from 32 to 256). It is
required to use LiData 2.0 file to run some of the functions, i.e., change detection, deviation analysis.

Usage

Click Data Management > Conversion > Convert LiData to LiData

Settings

Input Data: Input data could be one or more point cloud files. File format: *.LiData.
LiData Version (2.0 by default): The version of output LiData file. It is supported to export LiData in the version of 1.9 or 2.0.



Convert Las to LiData

Summary

Convert to LiData can convert point cloud data in LAS or LAZ formats to LiDAR360 customized point cloud format (LiData format).

Usage

Click Data Management > Conversion > Convert Las to LiData

Settings

File List: Import the file that needs to be converted. The file formats currently supported are : .las, .laz. Users need to click  to select
the point cloud data; users can select one or more file(s) in the existing list and click  to delete them from the list; users can click 
to remove all files in the list.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are supported.
Source Unit: The unit of the importing point cloud file. Choose from meter, decimeters, centimeters, millimeters, feet, and inches.
Target Unit: The unit of the exporting LiData. As the only unit supported in LiDAR360 is meter, this option is fixed as "meter".
LiDAR Version (The most updated version of LiData by default): The version of the exporting LiData. Choose from 1.9 and 2.0

Note: LiData 2.0 supports all the features of LAS 1.4. LiData 1.9 is mainly used to support LAS 1.0 to LAS 1.3. Please refer to LiData
Format for details. When exporting from a higher version to a lower version, the exceeded field range limitation will be set as 0.

In Geographic Coordinate System (Unchecked by Default): If the input LAS point cloud is in Geographic Coordinate System , please
check this option. And the data will be projected to the projected coordinate system to be displayed normally in LiDAR360.It should be
notice that the format of the input point cloud must be: longitude,latitude,altitude.
Output Path: Path of the output folder. After the conversion is executed, the converted new file(s) will be generated.



Raster Conversion
Raster format conversion tool provides conversion between raster data and other file formats.

Convert TIFF to LiModel

Convert to Texture LiModel

Convert TIFF to LiData

Convert TIFF to ASCII



Convert TIFF to LiModel

Summary

Convert TIFF to LiModel tool can convert single-band raster data (DEM, DSM, CHM, etc.) to LiModel format. The LiModel format is a
LiDAR360 software customized format that allows the converted single-band raster data to be displayed and edited in a 3D window.

Usage

Click Data Management > Conversion > Convert TIFF to LiMode

Settings

Input Tiff File: Users can select the file to be processed from the drop-down list.
: Users can add files to be converted that have not been opened.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all files in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s) will be generated.



Convert to Texture LiModel

Summary

Convert to Textured LiModel tool is based on the Convert Image to LiModel tool, which maps color values of a DOM data to the LiModel
model for display. This function only supports single file data conversion.

Usage

Click Data Management > Conversion > Convert to Texture LiModel

Settings

Input DEM: Users can select a file to be converted from the drop-down list or use the button  to load an external data file.

Single-band raster data is required.

Input DOM: Users can select a desired file from the drop-down list or use the button  to load an external data file. The

selected color image needs to have at least three bands.
Output LiModel: Path of the output file. After the conversion being executed, the converted new file will be generated.



Convert TIFF to LiData

Summary

Convert TIFF to LiData tool can convert single-band raster data (DEM, DSM, CHM, etc.) to LiData. This tool is particular useful when the
users can harldy acuquire point clouds in a certain area but have accurate raster products.Tthis function can help to simulate the point cloud
data in that region missing LiDAR points.

Usage

Click Data Management > Conversion > Convert TIFF to LiData.

Settings

Input TIFF File: Users can select the files need to be processed from the drop-down list. The files will be added to the list of files to be
processed.

: Users can insert external files to be processed.
: Users can select one file in the list of files to be processed, and click this button to remove this file from that list.
: Click this button to clear the list of files to be processed.

Select Sampling Center: Users can choose either the corner (default) or the center points of the pixels as the sampling center.
Output Path: Path of output folder. After the function is executed, the converted new file is generated.



Convert TIFF to ASCII

Summary

Convert TIFF to ASCII tool can be used to convert TIFF format raster images to files in ASCII format.

Usage

Click Data Management > Conversion > Convert TIFF to ASCII

Settings

Input Tiff File: Users can select the file to be processed from the drop-down list.
: Users can add external file(s) to be converted.
: Users can select one or files in the list and click this button to remove them from the list.
: Click this button to clear all files in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s) will be generated.



Model Conversion
Model conversion tool provides conversion between model files and other file formats.

Convert LiModel to TIFF

Convert LiTin to DXF



Convert LiModel to TIFF

Summary

Convert LiModel to TIFF tool converts LiModel format files to raster images in TIFF format. After editing LiModel data, users can use this
function to convert the data to TIFF format.

Usage

Click Data Management > Conversion > Convert LiModel to TIFF

Settings

Input LiModel File: User can select a file to be processed from the drop-down list.
: Users can add external data files to be converted.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all the data in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file will be generated.



Convert LiTin to DXF
Convert the TIN in LiTin format to Drawing Exchange Format, or DXF format.

Usage

Click Data Management > Conversion > LiTin to DXF.

Settings

File List: Input the TIN files to be converted. The supported format is LiTin. Users can click  to add external data, or users can select
the file in the file list and click  button to remove the file from the list. Click  button to clear all the files from the file list.
Output Path: select the output path to store the newly generated DXF file.



Vector Conversion
Vector Conversion Tool Provides Mutual Conversion of Vector Format Files.

Convert Shape to KML

Convert KML to Shape



Convert Shape to KML
The data in shape format will be converted to KML format. KML format reference：https://wiki.openstreetmap.org/wiki/KML

Usage

Click Data Management > Conversion > Convert Shape to KML.

Settings

Input Shape File： Users can select the files need to be processed from the drop-down list. The files will be added to the list of files to be
processed.

：Users can insert external files to be processed.
：Users can select one file in the list of files to be processed, and click this button to remove this file from that list.
：Click this button to clear the list of files to be processed.

Output Path：Path of output folder. After the function is executed, the converted KML file is generated.

https://wiki.openstreetmap.org/wiki/KML


Convert KML to Shape
The data in KML format will be converted to shape format. KML format reference：https://wiki.openstreetmap.org/wiki/KML

Usage

Click Data Management > Conversion > Convert KML to Shape.

Settings

Input KML File： Users can select the files need to be processed from the drop-down list. The files will be added to the list of files to be
processed.

：Users can insert external files to be processed.
：Users can select one file in the list of files to be processed, and click this button to remove this file from that list.
：Click this button to clear the list of files to be processed.

Output Path：Path of output folder. After the function is executed, the converted Shape file is generated.

https://wiki.openstreetmap.org/wiki/KML


Extract
Extraction tools include Extract by Class, Extract by Elevation, Extract by Intensity, Extract by Return, and Extract by Time.

Extract by Class

Extract by Elevation

Extract by Intensity

Extract by Return

Extract by Time



Extract by Class

Summary

Extract by class tool can extract all the point cloud data of the user-selected class, and save the data in one file. This function supports
multiple file operations.

Usage

Click Data Management > Extract > Extract by Class

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
From Class: Users need to select the class to be extracted from the drop-down list. The unavailable status in the drop-down list
represent the corresponding category that does not exist in the file.
Output path: Path of the output folder. After the function being executed, the extracted new file(s) will be generated.



Extract by Elevation

Summary

Extract by Elevation tool can extract the point cloud data in the user-defined elevation range to a file. This function supports multiple file
operations.

Usage

Click Data Management > Extract > Extract by Elevation S

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Min (m, default value is "100"): Users need to enter the minimum elevation value of the point cloud data to be extracted.
Max (m, default value is "200"): Users need to enter the maximum elevation value of the point cloud data to be extracted.
Output path: Path of the output folder. After the function being executed, the extracted new file(s) will be generated.



Extract by Intensity

Summary

Extract by Intensity tool can extract all the point cloud data within the user-defined intensity range. This function supports multiple file
operations.

Usage

Click Data Management > Extract > Extract by Intensity

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Min (default value is "100"): Users need to enter the minimum intensity value of the point cloud data to be extracted.
Max (default value is "200"): Users need to enter the maximum intensity value of the point cloud data to be extracted.
Output path: Path of the output folder. After the function being executed, the extracted new file(s) will be generated.



Extract by Return

Summary

Extract by Return tool can extract all the point cloud data of the user-defined return number, and saved the data in a file. This function
supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Return

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Return number: Users need to select the return number of the point cloud data to be extracted. Click on the drop-down menu to select
the return number, including: first return, last return, 2nd return, 3rd return, 4th return, and returns after 4th.
Output path: Path of the output folder. After the function being executed, the extracted new file(s) will be generated.

Note: If the data does not have the return number selected by the user, the extraction will not be executed.



Extract by Time

Summary

Extract by GPS time tool can extract all the point cloud data within the user-defined GPS time range, and save them in a file.

Usage

Click Data Management > Extract > Extract by Time

Settings

File List: Select the file to be processed from the drop-down list.
Min Time: Displays the minimum GPS time value in the point cloud file selected by the user. This value does not require user settings.
Max Time: Displays the maximum GPS time value in the point cloud file selected by the user. This value does not require user settings.
Start Time (default value is "min Time"): Input the minimum GPS time value of the point cloud data to be extracted.
End Time (default value is "max Time"): Input the maximum GPS time value of the point cloud data to be extracted. This value must
be larger than the start time.

: If you want to extract the point cloud at a specified interval, enter the interval value in the text box, and then click this button, the
values of the start time and end time will increase at the set interval.

: Add the input time range to the range list. All point cloud data in the time range will be extracted into one file.
: Users can click this button to load external GPS range file. The time range in the file needs to be between the min Time and the

max Time. The file format can be referred to the appendix for information in the GPS time extract file format.
: Users select a row in the time range list and click this button to remove the row from the list.

Output Path: Path of the output folder. After the function being executed, the extracted new file will be generated.



Statistics
LiDAR360 can be used for statistical analysis of point cloud data and raster data.

Grid Statistics

Volume Statistics

Raster Statistics



Grid Statistics

Summary

LiDAR360 supports fast grid statistics analysis on point cloud data. The tool supports meshing of point cloud data to count the number of
points, density, and Z attributes in the grid. It can be used to view the point cloud data flight and processing quality, as well as analyze the
geographical features of the flight area. If only one type of data in point cloud data is counted, the Extract tool can be used to extract point
clouds and perform statistics.

Steps

1. Select the point cloud data file to analyze from the Data List drop-down box.
2. Select Variable to be analyzed. Users can select the variables to be analyzed from the drop-down box.
3. Set Spacing size.
4. Click the Calculate button.
5. (Optional) Click Draw Histogram to view the histogram of the grid statistics. You can also use Stretch method to stretch the histogram.
6. (Optional) Users can click Save Histogram to save the displayed histogram as a PDF file.
7. (Optional) Users can click Save Grid to save the statistics grid as a single-band grayscale image, or select Color Bar and click Save

GeoTiff to map single-band grayscale images to multiband color images. It should be noted that if the user selects Stretch action, the
single-band image will be mapped after stretching.

Usage

Click Statistics > Grid Statistics

Settings

Data List: Users need to select point cloud data to be counted from the drop-down list.

Variable: Users need to select the variable to be analyzed from the drop-down list. Fill the statistic value of the variable in the grid.



Number of Points (default): Count the number of points in the grid.

Density: Calculate the density of the point cloud within the grid, which is obtained by dividing the number of points by the grid area.

Z: To calculate the user-defined Z-value of the point cloud in the grid.

Statistics: If you select the Z variable in the Variable list, users need to select the statistical method for the Z variable.

Minimum (default): The minimum value of Z variable in the statistics grid.

Maximum: The maximum value of Z variable in the statistics grid.

Mean: The average value of Z variable in the statistics grid.

Range: The range of Z variable in the statistics grid (range = maximum - minimum).

Deviation: The standard deviation of Z variable in the statistics grid.

Spacing (m, default value is "1"): The size of the statistics grid.

Calculate: After setting the parameters, click this button to calculate.

Save Grid: Save the statistics grid as a single-band grayscale image in the format of .tif or .csv.

Stretch: Users can choose whether to stretch Draw Histogram or Save GeoTiff.

None (default): Do not perform any stretching operation.

Minimum and Maximum: Use the maximum and minimum values of the statistical grid data for stretching. Linear stretch is applied
based on the minimum and maximum pixel values, which will be regarded as the endpoints of the histogram. For example, the
minimum and maximum values of a image are 2488 and 2656, linear stretch will rearrange the values based on a linear equation
calculated from the maximum and minimum values to re-distribute pixel values from 0 to 255. By distributing the pixel values over
the entire histogram, the image brightness and contrast can be improved, making the elements in the image more distinguishable.

Minimum (default value is the minimum of the grids): The minimum value of the stretch.

Maximum (default value is the maximum of the grids): The maximum value of the stretch.

Std Deviation: The stretching operation is performed using the standard deviation of the statistical grid data. The quasi-difference
stretch type applies the linear stretching to the maximum value (maximum = mean + n standard deviation) and minimum value
(minimum = mean - n standard deviation).

n: The multiple of the standard deviation.
Percent Clip: Percent stretch uses statistical grid data. Percent Stretch applies a linear stretch between the pixel values of the
minimum and maximum cropping percentages. For example, the minimum and maximum values of a image are 2488 and 2656
respectively, and the user-defined minimum and maximum values of clipping percentage are 0.02 and 0.98 respectively. Values
less than 0.02 stand for values between 2488 and 2492, and values above 0.98 stand for values between 2652 and 2656. The
value between 2488-2492 will become 0, while the value between 2652-2656 will become 255. Other values will be distributed
between 0-255.

Minimum (default value is "0.02"): The minimum stretch percentage, range 0~1.0.

Maximum (default value is "0.98"): The maximum stretch percentage, range 0~1.0.

Draw Histogram: Draw a histogram of grid statistics in the canvas.

Save Histogram: Save the drawn histogram in the PDF format.

Color Bar: LiDAR360 provides 11 color bar options for users to choose.

Save GeoTiff: Save statistical grid data as a multi-band color image based on the user-selected Color Bar.

Close: Close the tool.

Note: The Save Grid function saves the original statistical result as a single-band TIFF file. Save GeoTiff function saves the result after
histogram stretch and performs RGB three-channel mapping according to the selected color bar.



Volume Statistics

Summary

LiDAR360 supports the use of surface model data (single-band tif data) with spatial overlaps to calculate volume statistics. By subtracting the
lower surface from the upper surface, the statistical filling amount (Fill), excavation amount (Cut ) and total fill volume (Total) (calculated by
subtracting fill volume from volume of excavation) can be obtained.

Usage

Click Statistics > Volume Statistics

Settings

Upper Surface: Users can select the *.tif format file from the drop-down list, or click  to select external file.

Lower Surface: Users can select the *.tif fornat file from the drop-down list or click  to select external file.

Output Statistics: Specify the path to output the statistical result as a *.txt format file. The file contains the path of the upper and lower
surface files, spatial resolution, XSize, YSize, and the amount of the filler.

Note: The upper and lower surface files are single-band data, they must have the same spatial resolution and the spatial ranges have
intersections. The unit of the point cloud data processed by LiDAR360 is meter, and the calculated fill volume, excavation volume, and
total amount are in cubic meter.



Raster Statistics

Summary

This function can perform neighborhood calcuation for each cell in a tif format raseter data. The output can be different kinds of statistics of
the neighborhood. The statistics include mean, maximum, minimum, range, standard deviation, and sum.

Usage

Click Statistics > Raster Statistics

Settings

Statistics Type ("Mean" by default): Users can choose any type of statistics in the drop-down menu. The statistics include mean,
maximum, minimum, range, standard deviation, and sum.

Mean: Calculate the mean value for the neighborhood of each cell to be as the value of the cell at the same location as the orignal
cell.

Maximum: Calculate the maximum value for the neighborhood of each cell to be as the value of the cell at the same location as
the orignal cell.
Minimum: Calculate the minimum value for the neighborhood of each cell to be as the value of the cell at the same location as
the orignal cell.
Range: Calculate the range for the neighborhood of each cell to be as the value of the cell at the same location as the orignal
cell.
STD: Calculate the standard deviation for the neighborhood of each cell to be as the value of the cell at the same location as the
orignal cell.
Sum: Calculate the sum for the neighborhood of each cell to be as the value of the cell at the same location as the orignal cell.

Neighborhood Settings: Settings of the neighborhood size.
Height: Height of the neighborhood.
Width: Width of the neighborhood.

Ignore NoData in Calculation (Checked by default): If this option is checked, the software will will ignore the NoData cells in the
neighborhoods during the calcuation. If this option is not checked, software will define the cell with NoData in its neighborhood as
NoData. If this option is checked, for those NoData cells, the software will calcuate the statistics with the values from their
neighborhoods. If the all the cells in the neighborhood of a cell are NoData, whether or not this option is checked, this cell will be defined
as NoData during the calculation.
Output Result: The path for the result of raster statistics.



Classify
LiDAR360 can be used to classify unclassified point cloud, or to reclassify points that have already been classified.

Conicoid Filter

Slope Filter

Classify Ground Points

Extract Median Ground Points

Classify by Attribute

Classify Low Points

Classify Below Surface Points

Classify Isolated Points

Classify Noise Points

Classify Air Points

Classify by Height Above Ground

Classify by Min Elevation Difference

Classify close by Points

Classify by Range

Classify Buildings

Classify Model Key Points

Classify by Machine Learning

Classify by Trained ML Model

Classify Ground by Selected

Classify by Interactive Editing



Slope Filter

Summary

As the name implies, this filtering method extracts terrain based on changes in point cloud slope. Therefore, its drawbacks are as follows:
sensitive to slope change, not reliable in steep areas, and easy to flatten the convex parts on the terrain. This method is more suitable for
areas with smooth terrain changes, in that case, the filtering efficiency is high. Click this button, and the dialog as shown below pops up.

Settings

From Class: Source class (es).
To Class: Target class.
Slope Threshold (°, default value is"30"): The maximum slope threshold of the slope between grid point and its 8 neighborhood grids.
If it is larger than the threshold, it is classified into non-ground points, and vice versa.
Grid Size (m, default value is"1"): The side length of the grid. In addition, a 3 * 3 grid composes a filter window.



Conicoid Filter

Summary

Ground points are classified by fitting quadric surfaces. The specific idea is: first, mesh the point cloud, select the lowest point of the grid
within a certain size window to construct the quadric surface, and compare the distance between the point cloud and the fitting surface in the
calculation window and the set distance threshold, which is less than this Thresholds are classified as ground points; otherwise, they are
classified as non-ground points. This method is suitable for undulating terrain, but not very steep areas. Click this button, and the dialog as
shown below pops up.

Settings

From Class: Source class (es).
To Class: Target class.
dz Tolerance (m, default value is"0.3"): After fitting the surface using the grid low point, calculate the height difference between each
unclassified point and the surface. If the height difference is greater than the threshold, the unclassified point is classified as non-ground
point. Otherwise, it’s classified as ground point.
Grid Size (m, default value is"1"): The size of the grid that meshes the point cloud. The smaller the grid size, the finer the ground will
be fitted, which keeps more details, but the filter efficiency will be a bit affected.
Window Size (default value is"3"): This function uses a moving window to fit the surface, so the window size directly affects the final
filtering result. The larger the window, the larger the area where surface is fitted each time. The grid size and window size need to
complement each other for best results.



Classify Ground Points

Summary

Ground points classification is an important operation of point cloud preprocessing, which can be implemented in LiDAR360 with an improved
progressive TIN densification filtering algorithm (Zhao et al.,2016).

The algorithm first generates a sparse triangulated irregular network(TIN) through seed points, and then iteratively processes layer-by-layer
densification until all ground points have been classified. The specific steps of the algorithm are described as follows:

1. The initial seed point selection. If the point cloud contains buildings, the maximum building size is taken as the grid size to grid the point
cloud, and for the point cloud without the building, the default value is used as the grid size. Take the lowest point in the grid as the
starting seed point.

2. Build a TIN. The initial TIN was constructed using the initial seed point.
3. Iterative densification process. Traverse all the unclassified points, query the triangles that each point belongs to in the horizontal

projection plane; Calculate the distance(d) from the point to the triangle and the max angle between the point and three vertices with the
triangles plane. As shown in the figure below, the distance and max angle are compared with the Iteration distance and Iteration angle,
separately. If it is less than the corresponding threshold, then the point is classified as a ground point and added to the triangulation.
Repeat this process until all ground points have been classified.

The flow of algorithm is shown in the figure.

Usage



Click Classify > Classify Ground Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Max Building Size (m, default value is "20"): The maximum length of the building edge that exists in the point cloud scan. If this
parameter is set too small, the flat roof of the building may be mistaken for the terrain. When there is a building in the point cloud data,
the maximum building size can be measured by using the Length Measurement in the menu bar. The value of this parameter should be
greater than the measured value. For point cloud data without buildings, this parameter can use the default value of 20m.
Max Terrain Angle (°, default value is "88"): The maximum slope of the terrain shown in the point cloud. This parameter can determine
whether the points nearby the ground points belong to the ground or not. Usually, the parameter can be set as default.
Iteration Angle (°, default value is "8"): The allowable range of angles between unclassified points and ground points. For areas with
large topography and undulations, it can be bigger.Generally, it is set between 10 to 30 degrees. In addition, the iteration angle should
adjust with the iteration distance.
Iteration Distance (m, default value is "1.4"): Distance threshold between the unclassified points and the triangle in the triangle mesh.
When the topography is highly undulating, it should be set to a larger value. The general setting is 1~2 meters.In addition, the iteration
distance should adjust with the iteration angle.
Reduce Iteration Angle When Edge Length < (m, default value is "5", Optional): When the triangle length of the points to be
classified is smaller than the threshold, the iteration angle should be decreased. Use the parameter to indicate that when the point to be
classified corresponds to the length of the triangle in the triangulation network is less than the threshold, the iteration angle is reduced
accordingly. When a sparse ground point needs to be obtained, the threshold may be increased accordingly.
Stop Triangulation When Edge Length < (m, default value is "2", Optional): When the triangle length of the point to be classified
corresponds to the length of the triangle is less than the threshold, the densification of triangulation network is stopped. This value can
prevent the locally generated ground point from being too dense. When this value increase, the ground points will be sparse, and vice
versa.
Only Key Points (Optional): Extract key points of terrain model on the basis of ground point filtering. This function can preserve the key
points on the terrain and sparse the points on the flat area. For the specific usage, please see Classify Model Key Points.

Note: Because the actual terrain is complex and changeable, when using this function to perform ground point classification, different
parameters needs to be adjusted in order to achieve relatively ideal results. In addition, the classification result in local area can be
reclassified by Classify Ground by Selected and the Classify by Interactive Editing tool.

    @inproceedings{
        author={Zhao X Q, Guo Q H, Su Y J and Xue B L},
        title={Improved progressive TIN densification filtering algorithm for airborne LiDAR data in forested areas},
        booktitle={ISPRS Journal of Photogrammetry and Remote Sensing,117:79-91},
        year={2016}
    }



Extract Median Ground Points

Summary

Point clouds generated from data collected by small aircrafts and unmanned aerial vehicles (UAVs) typically have many ground points and
individual point densities in these regions can be very high. Traditional point cloud filtering methods used to thin these high density regions
often produce ground point subsets with vertical thicknesses that can be measured in centimeters. When these filtered point clouds are used
to create 3D mesh objects (e.g. TINs), the results tend to be poor as the 3D modeled surfaces have an uneven appearance.

The Extract Median Ground Points tool can be used to obtain a ground point cloud that is thinner and smoother than those produced using
traditional point cloud filtering methods. Generating this type of ground point cloud allows for consideration of the points found in a denser and
thicker ground point cloud. This method belongs to the optimization step after the initial ground point has been extracted. Therefore,
the point cloud data must first be classified using ground point classification method. The comparison results before and after using
the median ground point classification method are as follows:

Usage

Navigate to and click on Classify > Extract Median Ground Points

Settings

Input Data: Single or multiple point cloud data files can be input into the tool. Each point cloud must contain points classified as ground
points and have been loaded in the LiDAR360 software.
From Class: Source class(es) that represent ground points or other points are included in the median ground points finding operation.
From Ground Class to: Classify target ground points that do not meet the median rule to this class.
Min Height (meters, default value is "0.02"): The minimum height above the lowest ground point elevation found in the input file(s)from
which ground points will be taken and used to find the median ground point elevation. Ground points falling below the Min Height will not
be used to find the median ground point elevation value. The default value is set to 0.02 meters.
Max Height (meters, default value is "0.3"): The maximum height above the lowest ground point elevation found in the input file(s)from
which ground points will be taken and used to find the median ground point elevation. Ground points falling above the Max Height will not



be used to find the median ground point elevation value. The default Max Height value is set to 0.3 meters.
Grid Size (meters, default value is "0.5"): The grid size defines the horizontal extents of the square area from which ground points will
be extracted from the input file(s)and then used to find a median ground point elevation value for each grid cell. When the number of
points in a grid cell falls below a user-defined threshold, the median ground point elevation for that grid cell will not be included in the
output dataset. The default Grid Size is 0.5 meters.
Multiples of Std Deviation (default value is"0.3"): The number and thickness of the extracted point cloud ground points are controlled
by the user-defined Multiples of Std Deviation parameter. The default value is 0.3, which means that 22% of ground points are extracted
as ground points. Moreover, a value of 0.5 Multiples of Std Deviation corresponds to 40% of all points classified as ground points being
extracted. 0, 7 corresponds to 50%, 0.9 corresponds to 62%, and 1.5 corresponds to 86%.
DefaultValue: Click to set all Extract Median Ground Points tool parameters to their default values.

Note: This classification algorithm is only applicable to thicker ground point data scanned by small aircrafts and unmanned aerial
vehicles (UAVs). This data must be classified by ground points first, as an optimization step.



Classify by Attribute

Summary

This function classifies the point cloud into another class according to their attributes. Currently available classification attributes include
Absolute Elevation, Intensity, GPS Time, Scan Angle, and Return Number. In addition, the function can restore all classes and/or reclassify
the point cloud for undesirable classification results.

Usage

Click Classify > Classify by Attribute

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Choose Attribute: The selected attribute will be used to classify the point cloud.

None (default): The default setting will change all points in the From Class option to To Class.
Absolute Elevation: Classified by elevation range. If the elevation value of a point is between the specified range, it will be assigned
to the To Class.
Intensity: Classified by intensity range. If the intensity value of a point is between the specified range, it will be assigned to the To
Class.
Time: Classified by GPS time. If the GPS time value of a point is between the specified range, it will be assigned to the To Class.
Angle: Classified by scan angle. If the scan angle value of a point is between the specified range, it will be divided into the To Class.
Return: Classified by the return number. If the return number at a point is between the specified range, it will be assigned to the To
Class.



Classify Low Points

Summary

The low point refers to the noise point that is lower than the actual terrain. The existence of the low point will affect the extraction of the
ground point, because the progressive triangulation filtering algorithm is based on the seed points represented by the lowest point of the
gridded point cloud. Therefore, filtering out the low point is a preprocessing operation, which directly affects the filtering effects, the
establishment of a digital model, and the generation quality of contour lines. The triangulated terrain model created by the ground points with
low points is shown below.

The distribution of low points is divided into individual points or clusters. The algorithmic flow of this function is:

1. Traverse the point cloud and search for points to be classified within a certain range of radius of the current single point or point cluster.
2. Calculate the maximum height difference between the current point and the neighboring point, which is compared with the threshold.
3. If the value is greater than the threshold, the current point is considered to be a low point, otherwise, it is not classified as a low point.

Usage

Click Classify > Classify Low Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Points Number (default value is“1”): When the number of points is set to 1, the single low point is classified. If it is greater than 1,
cluster low points are classified.
Radius (m, default value is"5"): The radius threshold between the unclassified point and the neighboring point.
Height (m, default value is"0.5"): The height difference threshold between the unclassified point and the neighboring point.
DefaultValue: Click this button to set all parameters as default.



Classify Below Surface Points

Summary

This function classifies points in the initial category that are below the elevation of the surrounding neighborhood. For example, when the
starting category is ground, this method can be used to classify points lower than the surface elevation to be the lower-than-the-surface point.
The main algorithm idea of this function is:

1. Search for a certain number of nearest points for the current point in initial class.
2. Fit the plane with the nearest point.
3. Calculate the absolute value of the height difference between the current point and the plane. If the value is less than the set Z

tolerance, it is not categorized. If it is greater than the tolerance, go to the next step.
4. Calculate whether the difference between the current point elevation and the average value of the neighboring points is greater than the

Limit of the standard deviation. If it is greater than, then it is classified as the target category; otherwise, it is not classified.

Usage

Click Classify > Classify Below Surface Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Limit (default value is"3"): The multiple of the mean squared error of the neighboring point fitting plane of the unclassified points. The
larger the value, the less points will be classified into the target class.
Z tolerance (m, default value is"3"): The threshold of height difference. The point to fit plane distance less than this value is not
classified. The larger the value, the less points will be classified into target class.
DefaultValue: Click this button to set all parameters as default.



Classify Isolated Points

Summary

This function classifies points in a certain area of point cloud, which is generally used to find outliers in the air or below the ground.

Usage

Click Classify > Classify Isolated Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Points Number (default value is"3"): If the number of points in the neighboring radius are less than or equal to the value, the point is
considered as an isolated point.
Radius (m, default value is"5"): Neighboring search radius.
DefaultValue: Click this button to set all parameters as default.



Classify Air Points

Summary

This function classifies points that are significantly higher than the surrounding points into airborne noise points. The idea of the algorithm is
the same as the principle of Outlier Removal in the data management module.

Usage

Click Classify > Classify Air Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Neighbor Points (default value is"10"): The number of neighbors that will be used to determine whether a point is a noise in the sky.
Calculate the distance between each point to the nearest point and calculate the standard deviation of the nearest distances.
Multiples of std deviation (default value is"5"): If the deviation of points beyond the minimum allowable threshold, they are considered
as noise in the sky. The larger the threshold, the less the noise will be divided into.
DefaultValue: Click this button to set all parameters as default.



Classify Noise Points

Summary

Classify the outliers in the point cloud data as a certain class in the format of *.LiData.

Usage

Click Classify > Classify Noise Points.

Settings

Input Data: The input data can be a single point cloud file, or can be a point cloud data collection; the data to be processed must be pre-
opened in LiDAR360 software.
Radius(Default value is “0.5m”): Set the radius of the fitting plane. This function can be used when users know the approximate density
of the point cloud data.
Recommended Radius: Automatically calculate the appropriate searching radius according to the input point cloud data.
Multiples of std deviation(Default value is “1.0”): Using the relative error (sigma) as a parameter for outliers removal. The algorithm
will automatically calculate the standard deviation (stddev) of a point P's surrounding fitting plane. If the distance, d, from this point to that
plane is less than sigma * stddev, this point, P, will be kept. The reduction of this relative error results in removing more points.
Conversely, more points will be retained. The change of this parameter will not ifnluence the efficiency.
Remove Isolated Points: A point will be treated as an isolated point when there is less than 4 points within a distance of the searching
radius (cannot create a fitting plane with less than 4 points).



Classify by Height Above Ground

Summary

This function classifies the points on the surface of the terrain with a certain height, which can quickly classify vegetation at different heights.
For example, this classification can be performed three times to separate low vegetation (0-1m), medium vegetation (1-10m), and high
vegetation (10-100m), see the figure below.

Usage

Click Classify > Classify by Height Above Ground

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be opened in the LiDAR360 software.
From Class: Source class(es).
Ground Class: The default ground point is 2-class.
To Class: Target class.
Min Height (m, default value is "0"): The minimum height difference of the area to be classified above the ground points.
Max Height (m, default value is "1"): The maximum height difference of the area to be classified above the ground points.
DefaultValue: Click this button to set all parameters as default.

Note: This function need to contain the ground point in the cloud.



Classify by Min Elevation Difference

Summary

For each point in the data, this function calculates the elevation difference between the lowest point within a specified radius around it and
itself. If the elevation difference is between Min Elevation Difference and Max Elevation Difference, that point will be marked as Target
Class.

Usage

Click Classify > Classify by Min Elevation Difference

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Min Elevation Difference (m, default value is"0"): Threshold for the minimum elevation difference.
Max Elevation Difference (m, default value is"1"): Threshold for the maximum elevation difference.
Radius (m, default value is"5"): The radius of the area needs to be classified at the current point, which needs to be classified.
DefaultValue: Click this button to set all parameters as default.



Classify Close by Points

Summary

This function is used to classify those points close to the certain class(es) of points. For each points in the source class, find the points in its
specified 2D or 3D neighborhood area, and determine whether these points meet certain conditions (i.e., belong to a specified class). Those
points meet the requirement will be classified as the target class.

Usage

Click Classify > Classify Closeby Points.

Settings

Input Data: The input data could be one point cloud file or a set of point cloud files. The data to be processed must be opened in
LiDAR360 software.
Neighbor Class: The points of this class which is close to the source points will be classified.
Source Class: The points close to this class will be classified.
Target Class: Target class of the classification.
Search Method: The method for searching in the neighborhood. Support 2D or 3D neighborhood.

Radius: Neighborhood search radius.



Classify by Range

Summary

Initial points within the polygon are classified into target categories.

If the input shp is of Polygon type and the Calculate Polygon Topological is not checked, all initial points in the polygon will be classified into
target categories. If the Calculate Polygon Topological is checked, then only the initial points within the inner polygon and the outer cross-
deformation interval will be classified, and the points in the inner polygon remain unchange.

If the input shp is of MultiPolygon type, the points of the initial category in the inner polygon and the outer multi-deformation interval will be
classified into target categories, and the points in the inner polygon will remain unchanged.

Usage

Click Classify > Classify by Range.

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Categories to be classified.
To Class: Classification target category.
Shape File: Select shp of Polygon type.
Calculate Polygon Topological: The maximum height difference of the area to be classified above the ground point.

Note: This function requires that the point cloud contains the ground point category.



Classify Buildings

Summary

This function classifies buildings in point cloud data.

Usage

Click Classify > Classify Buildings

Settings

Input Data: The input file can be a single point cloud data file or a point cloud dataset, which must be opened in the LiDAR360 software
and has already been classified by ground points.
From Class: Source class(es).
Ground Class: The default ground point is 2-class.
To Class: Target class.
Normal Radius (m, default value is "3"): The radius of the neighborhood when calculating the normal vector of each point in the point
cloud. Usually set to 4-6 times the distance between points.
Angle Threshold (°, default value is "10"): The angle threshold between two points in plane clustering. When the actual angle of two
points is less than the threshold, the two points will be clustered into the same group.
Elevation Tolerance (m, default value is "0.6"): The distance threshold from point to plane in plane clustering, which is expected to be
slightly larger than the average point distance. When the actual distance is less than the threshold, the point and plane will be clustered
into the same group.
Minimum Points Number (default value is "100"): The minimum points number of building patches.
Max Slope (°, default value is "60"): The angle between the plane and the vertical direction. Greater than this value is not considered
as the top of the building but the wall or other classes.
Max Building Size (m, default value is "60"): The maximum length of buildings, which was used for the detection of building patches
between blocks.
DefaultValue: Click this button to set all parameters as default.

Note: Using this function requires that the point cloud has been classified by ground points.



Classify Model Key Points

Summary

This function can thin a certain level of the classified points. It is generally used to generate a sparse point set that retains the key points in
the complex terrain area and thin the points in the flat area from the extracted dense ground points.

The idea of the algorithm is: first, meshing of point cloud data, and then use the seed points in the grid to establish the initial triangulation
network. According to the upper and lower boundary thresholds, the points that meet the conditions are added to the triangulation network.
The process is iterated until all of the key points of terrain model are classified. In the following figure, the yellow point is the ground point and
the purple point is the key point of terrain model.

Usage

Click Classify > Classify Model Key Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Tolerance Above (m, default value is"0.15"): The maximum allowable elevation tolerance value over the triangulation model
composed by the original points. The larger the value, the more sparse the key points will be extracted, and vice versa.
Tolerance Below (m, default value is"0.15"): The maximum allowable elevation tolerance value under the triangulation model
composed by the original points. The larger the value, the more sparse the key points will be extracted, and vice versa.
Grid Size (m, default value is"20"): The value is used to ensure the density of key points extracted from the model. For example, if you
want to ensure that there is at least one point in the grid every 20 meters, this value is set to 20.
DefaultValue: Click this button to set all parameters as default.



Classify by Machine Learning

Summary

This feature uses random forests (machine learning) method to classify point cloud data. In the same batch of data, it is necessary to
manually edit the categories of a small amount of data. After the model is trained, a large amount of data is processed in batches, and it is
used to reduce the amount of labor. This feature supports two kinds of processes, one is through selecting training samples, generating
training models, and classifying the data, the other is classifying the data directly using the existing models.

Usage

Click Classify > Classify by Machine Learning

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
From Class: Source class(es).
Training Class: The classes that are of interest to the user are trained, which will also be included in the classification results. At least
two types of training categories should be selected, of which one must be unclassified
Training Files: Click  to load training data. Click  to remove the selected data. You can train multiple files. The categories in the
training data are edited manually.
Building Parameters: The parameters are set only when buildings are included in the training class, which were used to set the
maximum building size and minimum building height, respectively.

Max Building Size (m, default value is"60"): The largest building size in the data to be processed.
Min Building Height (m, default value is"3"): The smallest building size in the data to be processed.

Save Model: After training, save the model in the file path with the custom .vcm file format . This model file can be used as input data for
Run Machine Learning Classification Model.
DefaultValue: Click this button to set all parameter as default.

Training a small amount of manually edited data, including unclassified, vegetation, building, and all involved in training, as shown below:



Handle a large number of data results, including unclassified, vegetation, building, as shown below:



Classify by Trained ML Model

Summary

By directly importing the machine learning model with the suffix vcm for classification to classify the point cloud. It should be noted that the
source cloud data trained for the imported machine learning model should contain relevant geometric features of the unclassified data.

Usage

Click Classify > Classify by Trained ML Model

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be opened in the LiDAR360 software.
From Class: Source class(es).
Import Model File: Import the trained model file, whose suffix is vcm. This file is generated by Classify by Machine Learning.



Classify Ground by Selected

Summary

Due to the complex and varied terrain of point cloud data, it is often difficult to achieve good classification results using a set of parameters
when using Classify Ground Points, especially for the mixed areas (mountains, plains, etc.). This function can reclassify the ground points in
the unsatisfactory area.

Usage

First load the data in the window. Click Classify > Classify Ground by Selected, the classification toolbar appears at the top of the data
window, as shown below.

From left to right: polygon selection, rectangle selection, sphere selection, subtract selection, clear selection, classify by attribute, conicoid
Filte, slope filter, TIN filtering, extract median ground points, recover selection, and exit.

Polygon Selection

Rectangle Selection

Shpere Selection

Subtract Selection

Clear Selection

Classify by Attribute

Conicoid Filter

Slope Filter

Brief: Using method see point cloud selection tool Polygon Selection.

Brief: Using method see point cloud selection tool Rectangle Selection.

Brief: Using method see point cloud selection tool Sphere Selection.

Brief: Using method see point cloud selection tool Subtract Selection.

Brief: Clear selected point cloud area.

Brief: Using method see classification tool Classify by Attribute.

Brief: Using method see classification tool Conicoid Filter.

Brief: Using method see classification tool Slope Filter.



TIN Filter

Extract Median Ground Points

Recover Selection

Exit

Note: The ground point classification algorithms provided by the selected area point classification include: Conicoid Filter, Slope Filter,
and TIN Filter. Different methods should be chosen according to the terrain. Generally, the effect of TIN filter is the most stable and
therefore we recommend this first. In addition, it would be better to handle each file seperately.

Brief: Using method see classification tool Slope Filter.

Brief: Using method see classification tool Classify Ground Points.

Brief: Using method see classification tool Extract Median Ground Points.

Brief: Restore last selected point cloud area.

Brief: Exit this tool bar.



Classify by Interactive Editing

Summary

Because it is difficult to attain 100% accuracy with the automatic classification algorithm, human-computer interaction classification is usually
required to meet product requirements. Manual inspections and reclassifications are performed in the profile window. The profile tool is used
to examine the classification results and modify them. For the accuracy improvement of the classification, real-time changing TINs can be
generated to assist the classification.

Steps

1. When performing interactive editing and classification of point cloud, it is better to ensure that the point cloud is displayed in the class
display mode.Click on the color bar toolbar  to display by class.

2. Click , open the profile window to start checking the classification results. In the main window of profile mode, point cloud can only be
displayed in 2D mode.

3. Select the point cloud in the main window and select the corresponding point cloud in the profile window. At the same time, the selected
area can Up Move by clicking  or Down Move by clicking  and Rotate by clicking .

4. For points with inaccurate classification, you can use the Polyline Above Selection  and Polyline Below Selection  or selection
tools (  Polygon selection,  rectangle selection, and  circle selection,  lasso selection,  detect plane, and  circular
brush selection are provided) for reclassification. First click , set the class, then click on the above tools to classify points to specified
classs.

5.In general, to visualize point cloud classes more intuitively, you need to generate a TIN. Click the TIN button  generate a TIN and
intuitively perform interactive classification via the top left and right views of the TIN. You can also use the TIN Left, TIN Right, TIN Up, TIN
Down, and Pick Tile functions in the drop-down menu of the TIN to perform interactive classification by block.



6.If the manual classification error needs to be modified, you can undo the previous operations with the shortcut Ctrl + Z, or clear all
temporary operations by clicking .

7.After confirming the classification results, you should click  to finish save.

Note: After classifying by editing, you need to click the Save button to save it in the file.



Terrain
The Terrain module contains a range of products required for terrain production, of which the DEM (Digital Elevation Mode) indicates that the
bare earth surface (vegetation and other objects are removed), the DSM (Digital Surface Model) represents the surface characteristics of
terrain and other objects (e.g. tree canopy), and CHM (Canopy Height Model) indicates the normalized height of vegetation and ground
objects. Hillshade maps can be created by any digital model for visualization.

Grid Parameters

DEM

DSM

CHM

Hillshade

Slope

Roughness

Aspect

Raster to Contour

Generate Elevation Annotation

Point Cloud to Contour

Generate TIN

TIN to Contour

TIN to DEM

Deviation Analysis

Change Detection

Section Analysis

LiModel Editor

LiTIN Editor



Grid Parameters
When generating terrain products, it is necessary to set up some grid cell size parameters and determine the interpolation method for grid unit
calculation.

XSize and YSize

Through XSize and YSize, users can set the size of sampling interval (resolution) in meters. For instance, if XSize and YSize values are set to
2, respectively, the grid unit size is 2 meters by 2 meters.

Buffer size

Buffer Size (cell) (default is "5"): The size of each block of raster data extending around, in unit of cell.

Interpolation Methods

LiDAR360 provides three kinds of raster cell interpolation methods: IDW (Inverse Distance Weight) interpolation, kriging interpolation, and TIN
(Triangulated Irregular Network) interpolation.

IDW

In the inverse distance weighting interpolation method, the value of a grid element is computed using its nearby points, and the weighted
average value is judged by the distance of the center point of the grid unit. Users need to set the weight value.

The search radius can be used to define the input points of each raster image meta value interpolation, which consists of variable radius and
fixed radius.

Power(default value is "2")：The power of the sampling point to the center distance of the pixel to control the degree of the influence of
the sampling point elevation on the pixel center.

Radius Variable: Use a “Variable” to find a specified number of sampling points for interpolation.

Distance(Pix)(default value is "5"): Restricts the distance to search for adjacent points, by default 5 pixels.
Number of Points(default value is "12"): The number of nearest neighboring points used for interpolating, which is set 12 as
default.

Radius Fixed：Interpolation using all points in a fixed radius range.
Distance(Pix)(default value is "5"): The point within the range of the radius is used for interpolation, by default 5 pixels.
Number of Points(default value is "12"): The smallest number of points used for interpolation, which is set 12 by default. If
required points were not found within the specified radius, it will increase the search radius until find the minimum number of points.



Kriging

The Kriging interpolation method computes the optimized covariance and uses the Gaussian process interpolation grid value. The RADIUS
search can be used to define the input points of each raster image meta value interpolation, which is divided into variable radius and fixed
radius.

Radius Variable: Use a “Variable” to find a specified number of sampling points for interpolation.
Distance(Pix)(default value is "5"): Restricts the distance to search for adjacent points, by default 5 pixels.
Number of Points(default value is "12"): The nearest neighbor point to use when interpolating, and by default is 12.

Radius Fixed: Interpolation using all points in a fixed radius range.
Distance(Pix)(default value is "5"): The point within the range of the radius is used for interpolation, by default 5 pixels.
Number of Points(default value is "12"): The smallest number of points used for interpolation, by default 12. If required points not
found within the specified radius, increase the search distance until find the minimum number of points.



TIN

Extracts a grid cell value from a surface formed by a plurality of triangles consisting of the nearest adjacent point. This tool offers two options
of interpolation.

Delaunay: Create the Delaunay triangulated network by traditional point-by-point insertion. All the points will be involved.

Spike Free TIN: Remove all the points with abnormal altitude. It can lead to generating triangulated network without obvious spikes.

Freeze Distance (default value is "1.0 meter"): The shortest distance in xy plane of each side of triangle in the triangulated
network. When inserting a new point and its Z value lower Insertion Buffer, freeze all the triangles whose three sides are all less
than Freeze Distance. The frozen triangles will no longer change. The larger this value is, the fewer points will be involved in
creating the network, the more smooth the network will be and the less details will be included. Conversely, more points will be
involved in creating the network, the more details will be included and the more possible spikes will appear in the network.
Insertion Buffer (default value is "0.5 meter"): When trying to freeze a new triangle right after freezing another one, the difference
in altitude value should be lager than this threshold. Decreasing this value will result in more triangles will be frozen too early, new
point cannot be inserted, less spikes will appear, processing will be faster, and more details will be lost. Conversely, more details will
be included, and more spikes will be included in the network.

@inproceedings{
    author={ Khosravipour A, Skidmore A K, Isenburg M},
    title={Khosravipour A, Skidmore A K, Isenburg M. Generating spike-free digital surface models using LiDAR raw point clouds: A new approach for 
forestry applications},
booktitle={ International journal of applied earth observation and geoinformation, 52: 104-114},
    year={2016}
}

Merge files into one



If this option is not checked, each point cloud data will be processed separately, resulting in more than one grid file. Check this option to
merge all generated raster files into one file.

Fill in holes

If there are no points near the grid unit, the grid cells may not have data values. When this option is checked, data values can be computed
by analyzing adjacent grid units and using the selected interpolation method to fill in an area with no values.

Note: The "Fill in holes" function is only for closed holes.



DEM

Summary

Digital Elevation Model (DEM), is the digitized simulation of terrain through limited topographic elevation data (i.e. the digitized representation
of terrain surface). It represents the ground elevation with a set of ordered numerical array. It is a branch of the digital terrain model, which
can be used to generate all other terrain feature values.

Usage

Before you can generate a digital elevation model, first Classify Ground Points. Click on the Terrain > DEM.

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must have classified ground points and opened
in LiDAR360 software.
Parameter Settings: See Grid Parameters Settings.
Output Path: Save DEM file to a path.
Default Value: Click this button to restore all parameter defaults.

The original point cloud (left below) and the DEM (right below).

Based on DEM, a myriad of products including Slope, Aspect, Roughness and Contour can be generated.

Note: Point clouds that are used to generate DEM need contain ground points.



DSM

Summary

Digital Surface Model (DSM) refers to the digital representation of height of the surface including the buildings, bridges, trees etc. Compared
to a DEM, a DSM contains more elevation information for buildings, bridges, forests and other surface object that don’t exist in the DEM. DSM
is based on DEM and further covers the elevation of surface information other than the ground.

Usage

Click on the Terrain > DSM.

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be already opened in LiDAR360 software.
Include Class: Classifications of point cloud for DSM generation.
Parameter Settings: See Interpolation Parameters Settings.
Output Path: Save DSM file to a path.
Default Value: Click this button to restore all parameter defaults.

The DSM generated from the point cloud whose initial category is ground and unclassified. Point cloud data is shown on the left, DSM is
shown on the right.



CHM

Summary

The Canopy Height Model (CHM) can be obtained by subtracting DEM from DSM, and the following figure shows the the relationship of the
DSM (Digital Surface Model), DEM (Digital Elevation Model) and the CHM(Canopy Height Model).

Usage

Using this function requires a DEM and a DSM. Click on the Terrain > CHM.

Settings

Input DSM: Input a DSM file, the generation method can be seen in DSM.
Input DEM: Input a DEM file, the generation method can be seen in DEM.
Output CHM: The path of CHM file to save.

The original point cloud (seen left below) and the generated CHM(see figure right below).





Hillshade

Summary

The Hillshade tool obtains the assumed illumination of the surface by determining the illumination for each image element in the grid. The
assumed illumination can be obtained by setting the position of the light source and calculating the illumination value of each image element
related to the adjacent pixels. In the analysis or graphic display, the Hillshade tool can greatly enhance the surface visualization especially
when using transparency.

Usage

Click on the Terrain > Hillshade.

Settings

Input Tiff File: Input DEM file format in Tiff. The drop-down box allows to select the Tiff data that has already been opened in the
LiDAR360 software. Users can also import Tiff data by clicking .OR delete imported Tiff data by clicking .Or clear all the imported
data by clicking .
Azimuth (°)(default value is "315"): Using North as the benchmark, the degree range is 0~360 clockwise and the default is set to 315
degree(NW).
Altitude(°)(default value is "45"): The angle between the incident direction of the light source and the ground plane, which ranges from
0 to 90 degrees and uses 45 degree as default.
ZScale(default value is "1"): The stretch scale of the Z value.
Color Relief: Color rendering of hillshade.

Yes: There are 11 types of optional color bar.
No(default): Black and white color bar.

Output path: The path where the generated hillshade map file will be saved.
Default Value: Click this button to restore all default parameters.

DEM (left below) and Hillshade map (right below).





Slope

Summary

Slope shows how deep is the terrain surface. This function analyzes terrain slope based on DEM and generates slope images.

Usage

Click on the Terrain> Slope.

Settings

Input Tiff File: Input DEM file format in Tiff. The drop-down box allows to select the Tiff data that has already been opened in the
LiDAR360 software. User can also import Tiff data by clicking .OR delete imported Tiff data by clicking .Or clear all the imported
data by clicking .
ZScale(default value is "1"): The stretch scale of the Z value.
Output path: The path where the generated slope map file to be saved.
Default Value: Click this button to restore all default parameters.

DEM (left below) and slope map (right below).



Roughness

Summary

Indicators that reflect changes in surface fluctuations and degree of erosion. It is generally defined as the ratio of surface area to the projected
area on the horizontal plane.

Usage

Click on Terrain > Roughness.

Settings

Input Tiff File: Input DEM file format in Tiff. The drop-down box allows to select the Tiff data that has already been opened in the
LiDAR360 software. Users can also import Tiff data by clicking . Or delete imported Tiff data by clicking . Or clear all the imported
data by clicking .
Output path: The path where the generated roughness map file to be saved.

DEM (left below) and roughness map (right below).



Aspect

Summary

Aspect refers to the orientation of the terrain slope, defined as the direction of the projection of the slope normal on the horizontal plane.
Slope direction is of great importance for mountain ecology. The slope is an angle, which is measured clockwise with a range between 0
(north) and 360 (north as well). This function can analyze terrain aspect based on DEM and generates aspect map.

Usage

Click on Terrain > Aspect.

Settings

Input Tiff File: Input DEM file in Tiff format. The Drop-down box allows to select the Tiff data that has already been opened in the
LiDAR360 software. User can also import Tiff data by clicking . Or delete the imported Tiff data by clicking . Or clear all the
imported data by clicking .
ZScale(default value is "1"): The stretch scale of the Z value.
Output path: The path where the generated aspect file to be saved.
Default Value: Click this button to restore all default parameters.

The DEM (left below) and the aspect map (right below).



Raster to Contour

Summary

The contour refers to the closed curve of the adjacent points with equal elevation on the topographic map. Raster to Contour is to connect the
grid points that have the same elevation value, which can build the contour.

Usage

Click the Terrain > Raster to Contour.

Settings

Input Tiff File: Input DEM file format in Tiff. The drop-down box allows to select the Tiff data that has already been opened in the
LiDAR360 software. Users can also import Tiff data by clicking .OR delete imported Tiff data by clicking .Or clear all the imported
data by clicking .
Contour Interval(m)(default value is "10"): The elevation difference of the adjacent contour lines.
Contour Base(default value is "0"): The elevation of the generated contour is calculated from the base elevation. The difference
between elevation of the contour and base elevation is the integral multiples of the contour interval. For example, the contour base is 0
and the contour interval is 10m, thus the distribution of contour is :0, -10, -20, -30, …,10, 20, 30,...
Output path: The path where the generated contour file to be saved.
Default Value: Click this button to restore all default parameters.

DEM (left below) and contour map (right below).

Note: Use the Elevation Smoothing Tool of LiModel Editor to smooth the contour.



Generating elevation annotations

Summary

Using point cloud and contour lines to generate elevation points for topographic mapping.Notes Elevation Points File.

Usage

Click Terrain > Generating elevation annotation.

Settings

Input Tiff File: Input DEM file format in LiData.
Input Contour File (.shp): Input Contour file format in shp，The file needs to contain one or more contours.
Radius (m)(default value is "15"): A Note Elevation Point is generated within a region with a defined radius.
Output path: The path of the generated contour lines file(s) to save.



Point Cloud to Contour

Summary

The Point Cloud to Contour tool extracts elevation contours from input point cloud data by developing a triangular irregular network (TIN) from
ground class points. This is then used to construct lines of equal elevation that are output as a polyline through TIN to Contour.

Usage

Navigate to and click on Terrain > Point Cloud to Contour.

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset which must have classified ground points and have
been loaded in LiDAR360 software.
Scale: There are 11 scales for generating the point cloud, which correspond to different height intervals. For instance,

1:500: 1:500 scale.
1:1000: 1:1000 scale.
1:2000: 1:2000 scale.
1:5000: 1:5000 scale.
1:10000(default): 1:10000 scale.
... ...

From Class: Point cloud classes that participates in the construction of contour lines.
Contour Base (m)(default value is "0"): The elevation value of each contour line is relative to a user-defined Contour Base elevation.
Contours falling at lower elevations relative to the Contour Base elevation will take on negative values and contours falling at higher
elevations relative to the Contour Base elevation have positive values. The default Contour Base elevation value is zero (0) meters.
Generated lines of equal elevation are evenly spaced and the distance separating any two contour lines will be held constant.
Triangle’s Maximum Length (m)(default value is "30"): This parameter allows users to set a maximum edge length value, in meters
(m), of arcs found in the triangulation network, constructed from elevation attributed ground points, that is used to generate contours. If
the length of a triangle side, or arc, in the network is greater than the defined threshold, that edge will be excluded from the construction
of elevation contours.
Minor Contour (default state is checked): The Minor Contour option allows users to define what is also referred to as the 'half-distance
contour'. When the major contour interval, which is defined by the Scale, does not adequately show the topographic detail of an area
(such as when little local relief is present, i.e., flat areas), the contour lines are drawn at the Minor Contour Interval. The Minor Contour
Interval option is turned ON by default.

Spacing (m)(default value is "2.5"): Height interval, the absolute value of height difference between two adjacent minor contour



lines.
Color (default value is "yellow"): The color of Minor Contours.
Line Weight (default value is "1"): The weight of Minor Contours.

Basic Contour (default state is checked): The Basic Contour option allows users to include lines of equal elevation that represent the
landscape. The Basic Contour option is turned ON by default.

Spacing (m)(default value is "5"): Height interval (in meters), the absolute value of height difference between two adjacent basic
contour lines.
Color (default value is "Blue"): The color of Basic Contours.
Line Weight (default value is "2"): The weight of Basic Contours.

Major Contour (default state is checked): The Major Contour option allows users to include bold contour lines that facilitate easy
interpretation of terrain and topography. Major Contours are drawn at the Base Contour and at every 4th interval above and below the
Base Contour. For example, if the Base Contour elevation is 0 meters, the Basic Contour Spacing is 100 meters (m) and the maximum
ground point elevation found in the input file(s) is 1000 meters, then Major Contours would appear at 0 meters, 400 meters and 800
meters.

Spacing (m)(default value is "25"): Height interval (in meters), the absolute value of height difference between two adjacent major
contour lines.
Color (default value is "Red"): The color of Major Contours.
Line Weight (default value is "3"): The weight of Major Contours.

Generate Notes Elevation Points (default state is checked): Generate notes elevation points in outputs.
Radius (m)(default value is "15"): A Note Elevation Point is generated within a region with a defined radius.

Optimization: Optimized settings for smoothing the generated contours.
Mean Smooth (default state is checked): The Mean Smoothing contour optimization method replaces the measured or estimated
(interpolated) ground elevation points along a contour line (otherwise known as contour points) with mean contour points that
represent weighted average X and Y coordinates of adjacent contour points found on a given line of equal elevation. This operation
will reduce the number of contour points used to construct the contour line and will smooth the outputs of the Point Cloud to Contour
tool. Users can choose to include 3, 5 or 7 neighboring contour points in the calculation of the weighted average X, Y coordinate
locations of mean contour points. By default, the Mean Smoothing Contour Operation Setting is turned ON and 5 neighboring
contour points are used to find the weighted average contour point location.

3:The number of neighboring contour points participating in smoothing at the current point is 3.
5 (default):The number of neighboring contour points participating in smoothing at the current point is 5.
7:The number of neighboring contour points participating in smoothing at the current point is 7.

Bezier Smooth (default value is "155"): The Bezier Smoothing contour optimization method replaces the measured or estimated
(interpolated) ground elevation points along a contour line (otherwise known as contour points), with contour points that fall within an
angle threshold range from 0 to 180 degrees. The larger the threshold setting, the smoother the contour lines.
Delete the contour when its area <(m²)(default value is "10"): When the area of the closed contour is less than this threshold, it
will be deleted.
Delete the contour when its length (m)(default value is "5"): Non-closed contours are deleted if their length is less than this
threshold.

Generate Shp (default):Save Point Cloud to Contour tool outputs to a shapefile (.shp) format with the following feature attributes:
contour line type, contour line width, contour line color, and contour line elevation. Users can choose to output the generated Contour
features as a 2-D or 2.5-D polylines. Point Cloud to Contour tool outputs will be generated as 2-D shapefiles by default.
Generate DXF: Save Point Cloud to Contour tool outputs to a Drawing Exchange Formatted (.dxf) file. NOTE: LiDAR360 supports the
generation of DXF format contour files, however, the software does not currently support the reading and visualization of DXF formatted
Contour lines files.
Output path: The path of the generated contour lines file(s) to save.
Default Value: Click this tool option to restore all default parameters.

Point cloud data (left below) and contour map (right below).



Note: Before using this tool, ground points should be generated in advance.



Generate TIN

Summary

Generate irregular triangulation model based on point cloud, LiDAR360 adopts custom triangulation model file format*.LiTin。

Usage

ClickTerrain > Generate TIN。

Parameters Setting

Input data：The file can be a single point cloud data file or a point cloud data set; the data to be processed must be opened in the
LiDAR360 software.
From Classes：Source class(es).
Method：Methods to generate TIN. Now there are two methods, Delaunay and Spike Free TIN.

Delaunay：Use point-by-point insertion to generate Delaunay TIN.
Maximum Triangle Side Length(default value is "30 meter"): Delete any triangle whose longest size is longer than this value.
Spike Free TIN：Remove the points with abnormal elevation, in order to generate TIN without obvious spikes.

Freeze Distance (default value is "1.0 meter") :The shortest distance in xy plane of each side of triangle in the triangulated
network. When inserting a new point and its Z value lower Insertion Buffer, freeze all the triangles whose three sides are all less
than Freeze Distance. The frozen triangles will no longer change. The larger this value is, the fewer points will be involved in
creating the network, the more smooth the network will be and the less details will be included. Conversely, more points will be
involved in creating the network, the more details will be included and the more possible spikes will appear in the network.
Insertion Buffer (default value is "0.5 meter") :When trying to freeze a new triangle right after freezing another one, the
difference in altitude value should be larger than this threshold. Decreasing this value will result in more triangles will be frozen
too early, new point cannot be inserted, less spikes will appear, processing will be faster, and more details will be lost.
Conversely, more details will be included, abd more spikes will be included in the network.

Tile：The results consist of three types of tiles: "Tile by Scale","Tile by Width and Height" and "No Tile".
Tile by Scale(default)：Generate TIN by a certain scale.

Scale：Point cloud tile scale.
1：500(default)：1：500 scale.
1：1000：1：1000 scale.
1：2000：1：2000 scale.
1：5000：1：5000 scale.

Buffer(m))(default value is "10"):The buffer size of the overlap between two adjacent point cloud tiles.
Tile by Width and Height:Tile by a certain width and height.

Width(m)(default value is "100"):Width of point cloud tile.
Height(m)(default value is "100"):Height of point cloud tile.
Buffer(m)(default value is "10"):The buffer size of the overlap between two adjacent point cloud tiles.

No Tile：The point cloud generates a TIN as a whole and no tile.
Flatten(optional)：The flatten tool is used to flatten the specified range based on user input files.
Input File: The input file is the polygon-type shapefile. The irregular triangulation will be flattened based on the file range and the Z
attribute.



Z Attribute:The Z attribute of flattening.
Input Breakline(option):Import the breaking line file and add the multi-segment lines in the file as soft breaking lines to TIN.
Output path:The path where the generated TIN file to be saved.

Point cloud data (left below) and TIN (right below).

    @inproceedings{
        author={ Khosravipour A, Skidmore A K, Isenburg M},
        title={Khosravipour A, Skidmore A K, Isenburg M. Generating spike-free digital surface models using LiDAR raw point clouds: A new approach 
for forestry applications},
        booktitle={ International journal of applied earth observation and geoinformation, 52: 104-114},
        year={2016}
    }



TIN to Contour

Summary

This function directly connects contour point positions of the same elevation on the TIN stored in the LiTin file to generate contour lines.

Usage

Click on the Terrain > TIN to Contour.

Settings

Input TIN File：Input LiTin file(s). The drop-down box allows to select the LiTin data that has already been opened in the LiDAR360
software. User can also import LiTin data by clicking . Or delete imported LiTin data by clicking . Or clear all the imported data by
clicking .
Default Value: Click this button to restore all default parameters.

The other parameters settings of the interface are the same as Point Cloud to Contour.



TIN to DEM

Summary

This function can generate DEM with the LiTin file.

Usage

Click Terrain > TIN to DEM。

Settings

Input TIN File:Input LiTin file(s). The drop-down box allows to select the LiTin data that has already been opened in the LiDAR360
software. User can also import LiTin data by clicking . Or delete imported LiTin data by clicking . Or clear all the imported data by
clicking .
XSize(m)(default value is "2.0"):The XSize of the grid to generate the DEM.
YSize(m)(default value is "2.0"):The YSize of the grid to generate the DEM.
Import Breakline(optional):Import the breakline file and add the multi-segment lines in the file as soft breakline to TIN.
Output path:The path where the generated DEM file to be saved.
Default Value: Click this button to restore all default parameters.



Deviation Analysis

Description

To calculate the distance between two point cloud and add the result into additional attribute. This function can calculate the distance
between any two point in 3D space, which can be used for deviation analysis.

Usage

Click Terrain > Deviation Analysis.

Settings

Reference Cloud: Selected reference LiDAR data.
Compared Cloud: Selected LiDAR data to be compared.
From Class: Select point class involved in Deviation Analysis.
Voxel Size: The smaller the voxel size, the more precise the deviation analysis.
By Default: Click this button to restore default settings.



Change Detection

Description

To calculate the relative height change of the two periods of point cloud, and output it as a tiff format image and html report. In the image, red
represents increase, green represents decrease, and other parts are displayed in grayscale on elevation values. The relative change of the
two period of the point cloud will be added to the corresponding LiData file as an additional attribute (for example, the elevation change of the
point cloud to be compared relative to the reference point cloud will be written out as an additional attribute to the point cloud to be compared
LiData). This function can be used for disaster analysis, illegal building comparison, earthwork change analysis, vegetation growth change
analysis, etc.

Usage

Clic Terrain > Change Detection.

Parameters

Reference Cloud：Select the reference point cloud. The reference point cloud is the benchmark of the point cloud to be compared, and
its change relative to the point cloud to be compared (currently the Z value) will be written into the reference point cloud as an additional
attribute "DistanceReference", which will be displayed in green in the image.
Compared Cloud：Select the point cloud to be compared.Its change relative to the reference point cloud (currently the Z value) will be
written into the reference point cloud as an additional attribute "DistanceReference", which will be displayed in red in the image.
From Class：The point cloud class involved in change detection. Each class in the two point clouds will be compared separately.
Cell Size：The side length of the grid that grids the point cloud. The smaller the value is set, the more detailed the change detection
between the point clouds, and vice versa, the rougher.
Dz Tolerance：The point cloud is assigned the corresponding distance value only when the elevation value change is greater than this
threshold value, and the point cloud is considered as no change if it is less than this threshold value, and the change distance is 0.

Default：Restore default settings.

Output Path：Output path for result data.

Note: Both point cloud verison should be lidata2.0. You can convert lidata to higher version. Convert LiData为LiData Note: You can
right click the file name to show attribute table.



Section Analysis

Summary

The Section analysis module is aimed at road cross-sections and tunnel cross-sections, and mainly solves problems such as the design of
reference cross-section lines based on point cloud and model data, the extraction of real cross-sections, the analysis of over-excavation and
under-excavation of cross-sections, and the generation of reports. This function is based on the actual measurement data to obtain the
measurement section of each location or the real topographic undulation; it can edit and manage the measurement section; finally output the
information of each section and generate the over-under-excavation report.

Usage

Import the point cloud data into the currently active window, click Terrain > Section Analysis, a section analysis toolbar will appear at the top
of the data display window.

Section Analysis Toolbar functions include (from left to right): Section Analysis Editor, Create Section Polyline, Import Section Polyline,
Extract Points Along Section Line, Save Section Polyline, Generate Orthogonal Reference Lines, Save Reference Section Lines, Import
Designed Cross Sections, Generate Road Cross Section Diagrams, Generate Tunnel Cross Section Diagrams, Show/Hide Vector Tools,
Clear Tools, and Exit.

Navigate to and Click on Editor > Start Edit.

Select the point cloud or model data loaded in the window to start section analysis. Users need to select measured data and design data. The
measured data is used to generate the real cross section (the default is red), and the design data is used to generate the design cross
section. The measured data is a required option, and the design data is optional. Only when the design data is selected can the over-under-
excavation analysis be performed after the real cross-section is generated.

Generate Reference Section Line

Import Section Polylin

Function Description：Create a reference section line by drawing a series of points with the mouse. This tool supports drawing
multiple reference section lines.

Function Description：Click this button to open the import reference line interface, which supports text files (*.txt), graphics files
(*.dxf), and vector files (*.shp).



LiDAR360 Terrain

Extract Points Along Section Line

Parameter Settings

Section：Select the section line from which the point cloud needs to be extracted.

Buffer size (meters) (default is "1.00")：The buffer distance perpendicular to the reference section line. If set to 100 meters, the two
ends on the left and right of the section line will be buffered by 50 meters.

Save Section Polyline

Function Description：Click this button to extract the point cloud data file around the reference section line. If a model file is
loaded, all the vertices of the triangulation network within the model range will be extracted.

Function Description：Save the created Section Polylines to a .txt or .shp formatted file. The format of the saved section polyline
file should be consistent with the format of the section line imported from an external source.



Auto-Generate Cross-Section Polyline

Paramneter Settings

Left width (m) (default is "5"): Set the length of the left end of the generated reference cross section along the line.
Right width (m) (default is "5"): Set the length of the right end of the generated reference cross section along the line.
Step length (m) (default is "100"): The step length for generating the reference cross section.
Start mileage (kilometers) (default is "0"): Generate the starting mileage of the reference cross section, and the mileage of the cross
section will be accumulated on this basis.
By step size: Generate a reference cross section according to a specific step size.
By node: Only generate reference cross-sections at nodes.
By step and node: Generate a reference cross section at a specific step, and process nodes at the same time.
Export Sections: Save the currently generated orthogonal section lines, which can be saved in ASCII file (.txt) and vector file (.shp)
formats.

Function Description：Generate Cross-Section Polyline



Manually add cross-section polyline

LiDAR360 Terrain

Parameter Settings

Add only on a certain centerline: Only add on a specific centerline, and it is invalid when snapping to other centerlines.
Left width (m) (default is "5"): Set the length of the left end of the generated reference cross section along the line.
Right width (m) (default is "5"): Set the length of the right end of the generated reference cross section along the line.
Start Capture: Start to add a cross section, move the mouse to any center line, and click the left mouse button when the center line is
highlighted, and the new cross section will be added to the vertical section.

The cross section is shown in the figure.

LiDAR360 Terrain

Import Designed Cross Section

Function Description：Click this button to turn on the function of manually generating reference cross-sections. You can use the
mouse to add cross-sections at any position on the vertical cross-section.

Function Description：Click this button to import the designed section into the software. Support text files (*.txt), the read section



Generate Road Section Chart

Click and hold the left button of the mouse and move on the section chart, users can view the section information at the position of the mouse
in real-time. In the figure below, the position of the red label of the point cloud on the left corresponds to the dark red label in the chart on the
right. When you click the "Calculate" button, a parameter setting dialog box pops up.

LiDAR360 Terrain

Parameter Settings

Section thickness (m) (default is "1"): Use point cloud data to generate a section view along the width of the section line.
Source category: The point cloud category involved in generating the section.

Function Description：Click this button to import the designed section into the software. Support text files (*.txt), the read section
lines will all be displayed as design section lines. For the design section format, please refer to the "Import Reference Section
Line" function.

Function Description：Click this button to generate the section chart of a given road.



Section step(m) (default is "5"): the section will be streamlined in sections according to the set step length according to the distance
threshold, and the section will be linear at integer multiples of the section step length Interpolation method to interpolate points. If the
value is set to 0, the overall section is simplified.
Distance threshold (default is "0.01"): The section will be streamlined according to this parameter using Douglas algorithm. The larger
the value, the fewer and more streamlined points will be retained, otherwise the more points and details will be retained.
Type: Take the section data according to the elevation type to generate a section view.

Bottom (default): Take the lowest point of the section data to generate a section view.
Top: Take the highest point of the section data to generate a section view.

Max Edge Length (m)(default value is "0"): The threshold of the maximum length of the segment lines, which needs to be used in
conjunction with the Split Profile on Longer Edges. If the distance between two points in the section view is larger than the Max Edge
Length, it will be disconnected into two segments. The default value is 0, which means no disconnection.
Split Profile on Longer Edges: Divide the Profile into multiple segments according to the length threshold of segment (Users need to
consider the threshold of the maximum edge length).

Yes: Segment Profile into multiple segments based on the threshold of segment length.
No (default): Do not segment Profile into multiple segments based on the threshold of segment length.

Section Index: Select the profile displayed in the dialog to highlight it in the window.

LiDAR360 Terrain

Export Sections：Export the currently generated cross-section line, which can be saved as one or more files. Supports csv, HDM, HDM
(South), shp and dxf formats in Chinese environment, but does not support hdm format in English environment. Export result format,
please reference Section Product File Format.
Export Picture：Save a screen shot of the current dialog section as a .pdf formatted image file. Users can set the resolution and
dimensions of the exported section view in the export dialog.



Generate Tunnel Section Chart

Click the Calculate button to pop up the parameter setting dialog box. Click OK to generate the tunnel crosssection. Canvas can be panned
and zoomed with the mouse.

Function Description：Click this button to generate a tunnel section chart based on the cross sectional line.



LiDAR360 Terrain

Tunnel cross-section parameters：
Maximum side length (m) (default is "5"): The maximum line segment side length threshold, which needs to be used in conjunction
with the split long side. When the split long side is checked, if between two points in the cross-sectional view If the distance is greater
than this value, it will be broken into two segments. The default value is 0, which means no segmentation.

Section Thickness (m) (default is "0.1"): Use point cloud data to generate the cross-section map along the width of the cross-
section line.

Export Sections: Export the currently generated tunnel section lines, which can be saved as 2D or 3D files. Currently, txt, shp and dxf
formats are supported.
Export Image: Save the cross section of the current dialog box as a picture, and the save format is pdf. The user can set the resolution
and size of the exported cross section in the export interface.
Edit Section Line Nodes: Edit the nodes of the tunnel section line. After editing is turned on, you can drag and drop the nodes. It is used
to edit the wrong or noisy tunnel boundary.
Section ratio: Compare the generated reference section of the tunnel with the design section of the tunnel and calculate the amount of
fill and cut. Fill and excavation are displayed in different colors (colors can be set).
Export Comparison Report: You can export the cross-sectional view and cross-sectional information on the current canvas into a
report, and output it to the specified folder.
Distance measurement: After starting the distance measurement, you can click on the canvas with the left mouse button to pick up the
points to be measured. When picking, you can use the mouse to zoom and pan the canvas at the same time. Double-click the left mouse
button to complete the measurement; click the "distance measurement" button again to end the measurement.
Settings: The setting dialog box pops up. You can set the point cloud color, section node color, fill and cut color, etc.
Show section properties: You can show/hide the current section properties.

The measurement section report is shown in the figure below.



LiDAR360 Terrain

Show or Hide Section Polylines

Clear Section Polylines

Exit

Function Description：Show or hide section polylines as needed, including Draw Line, Orthogonal Line, Section Line and all.

Function Description：Clear all or some of the Section Polylines using this tool. Clearing options include: Clear Line, Clear
Orthogonal Line, Clear Section Line, and Clear All.

Brief: Exit Section Analysis.。



LiModel Editor

Summary

Provides editing operations for LiModel. The user can select area of interest using Polygon Selection, Lasso Selection, Screen Selection, or
Shp Selection, which can be edited by various operations such as Flatten Height, Smooth Height, Repair No Data, Repair Height by Variance,
Repair Height and Delete Height.

Usage

Click Terrain > LiModel Editor. The current activation window will show the LiModel Editor toolbar.

Data Selection

Click Start Edit in the drop-down menu for editing. You can select one or more data which has been opened in LiDAR360 for editing.

Polygonal Selection
Left-click to add the polygon vertex, double-click to finish the selection. Right-click to Back One Point or Clear Selection before
finish. Unlike Screen Selection tool, you cannot select an area that exceeds the data range.



Lasso Selection

Screen Selection

Shp Selection

Flatten Height

Flatten Height (m): Set the elevation value. The default value is the average of the elevation values of the vertices of the selected
region.

The schematic diagram is as follows, the left image is the original data, and the right image is the edited version.

Left-click to start the Lasso Selection, move to add one point, and double-click to finish the selection. Right-click to Back One
Point or Clear Selection before finish. Unlike Screen Selection tool, you cannot select an area that exceeds the data range.

Left-click to add the polygon vertex, double-click to finish the selection. Right-click to Back One Point or Clear Selection before
finish. You can select the area that exceeds the data range.

For a specific range, the existing 2d SHP format vector file can be imported, and the polygon is identified by the software as the editing area.

Click this button, or right-click to select Flatten Height. You can set elevations for selected area range models to specified
elevation values for rivers or waters that have the same altitude.



Smooth Height

Kernel Size (default value is "5"): The size of the mean filter kernel, it can only be odd.

The schematic diagram is shown below. The left figure shows the original data, and the right figure shows the effect after editing.

Repair No Data

The schematic diagram is shown below. The left figure shows the original data, and the right figure shows the effect after editing.

Click this button, or right-click to select Smooth Height, which can smooth the selected area range model. Using image mean
smoothing to process the model in the selected region point by point, it is suitable for smoothing DEM to generate smooth contour
lines.

Click this button, or right-click to select Repair No Data. Use bilinear interpolation to calculate the elevation value of NO Data
values in the area.



Repair Height by Variance

Elevation Variance Threshold: The elevation variance threshold is used to determine whether it is a noise.

The schematic diagram is shown below. The left figure shows the original data, and the right figure shows the effect after editing.

Repair Height

Click this button, or right-click to select Repair Height by Variance. It is used to repair the noise caused by noise, according to the
variance of its elevation value with the neighborhood point to determine whether it is a noise. Bilinear interpolation is used to
calculate the elevation of the noise point.

Click this button, or right-click to select Repair Height. It is used to repair the elevation in the specified range. The bilinear
interpolation method is used to calculate the elevation of the parameter conditions.



Select the Bad Point Value: Select the bad point value to support the following types.
All selected as a region of no data value (default): All selected areas will be repaired.
Elevation Range: Only grids with elevation values within the minimum and maximum values are repaired. The default values for the
maximum and minimum values are the maximum and minimum elevation values for the vertices of the selected area.
Internal No Data Value: Only the non-valued areas are repaired.

The schematic diagram is shown below. The left figure shows the original data, and the right figure shows the effect after editing.

Delete Height

The schematic diagram is as follows, the left image is the original data, and the right image is the edited version.

Save Editing Results

Click this button, or right-click to select Delete Height. Delete the selected point elevation point.

Save the edited result to LiModel file.



Cancel editing

Exit

Cancel editing, discard edit result, reload original file to display.

Exit LiModel Editor. If the editing result is not saved, and click the Exit button or click the Edit button to finish the editing of the
menu, the software will pop up the prompt window as shown below. Click Yes to save the editing result and exit. Click No to exit
without saving the editing result. Click Cancel returns.



LiTIN Editor

Summary

Provides editing operations for LiTin. It can be edited by various operations such as Add Single Point, Delete Single Point, Flatten, Delete
Multiple Points, Add Breakline, Delete Breakline, Select Edge, Select Triangle.

Note: LiTin can be displayed by model, triangle or point (switching shortcut: W). It is recommended to use "triangular" display to see the
editing effect. The model display tool is shown in the following figure.

Usage

Click Terrain > LiTIN Editor. The current activation window will show the LiTIN Editor toolbar.

Data Selection

Click Start Edit in the drop-down menu for editing. You can select one or more data which has/have been pre-opened in LiDAR360 for
editing.

Add Single Point

Height Source: The following four options are provided to define the height source.

Left-click to add a vertex in the triangulation model. Users can select the source of the elevation value. This function is suitable for
local editing.



From Surface (default): The elevation is determined by triangular interpolation.
Max Z From Surface: The maximum elevation of the model.
Min Z From Surface: The minimum elevation of the model.
As Specified: User input a customizded elevation.

Delete Single Point

Delete Multi Points

Add Breakline

Line Type: Select the breakline to support the following types.
Soft Line(default): Soft breakline.
Hard Line : Hard breakline.

Set Elevation: Available under hard breakline, project the breakline point to the same elevation surface, the user can manually
input or activate the selection button to pick up the point in the scene to set the elevation.
Automatic Elevation: Available under hard breakline. The default is the height of the last breakline point.

Add Breakline for Closed Area (Lake)

Use the mouse to interactively draw the closed area, set the parameters, and click the Add button to complete the addition.

Set Elevation: Project the breakline point to the same elevation surface, and the user can manually input or activate the selection button
to pick up the point in the scene to set the elevation.
Minimum Elevation: Project the breakline point to the elevation plane corresponding to the lowest point in the area.

Add River Breakline

Use the mouse to interactively draw two river bank lines (to be drawn along the same direction), set the parameters, and click the Add button
to complete the addition.

Starting Elevation Value: This parameter defines the starting elevation value of the river. The default is the elevation of the starting point
of the first river bank line. The user can manually input or activate the selection button to select a point within the scene to set the
elevation.
End Elevation Value: This parameter defines the end elevation value of the river. The default is the elevation of the end point of the first
river bank line. The user can manually input or activate the selection button to select a point within the scene to set the elevation.

Delete Breakline

Left-click to delete a vertex from the triangulation model, and reconstruct the triangulation with its neighboring points. This function is suitable
for local editing, removing noise points or misclassified points intervening the generated terrain trend.

You can select a triangle area and delete the triangle inside the area. It is suitable for deleting noise points or misclassified points
in a local area.

Add breakline by mouse interaction. You can select the break line type, elevation value, and whether it is closed. This function is applicable to
water bodies, highways and other situations where the terrain changes violently. It is used to distinguish the trend of the terrain around the
fault line.

Delete the selected breakline.



Select Edge

Select Triangle

Save

Cancel

Exit

Delete the selected breakline.

Select the edge of a triangle. The selected edge will be displayed in red.

Select a triangle. The selected triangle will be displayed in red.

Save the editing results to a LiTin file.

Discard the editting results and reload the original file to display.

Exit LiTIN Editor. If the editing result is not saved, the software will pop up the prompt window as shown below. Click Yes to save
the editing result and exit. Click No to exit without saving the editing result. Click Cancel to return.



Vector Editor
Vector Editor can realize the vectorization in the process of drawing digital line. It provides high contrast display effects based on the well
displayed point cloud with image data as the background. Therefore, the function can clearly distinguish houses, vegetation areas, roads,
street lights, water areas, bridges, and other objects. Moreover, it can generate vectorized results in SHP and DXF format, which support
subsequent editing and processing with other third-party software such as ArcGIS and AutoCAD.

Vector Editor provides basic entities (i.e. point, line, polyline, rectangle, polygon, and circular) to complete the mapping of key features of the
scene. The above features are organized by the layer and stored in shp file format.

In addition, Vector Editor provide layer merge function, which can integrate the vectorization result into a DXF file. The result can be export
and further input to other mapping software to be symbolized and trimmed in order to get the standardized surveying and mapping results.

Note: To get clear display effect of the surface object, the point cloud data should be processed by PCV（Portion of Visible Sky） before
vectorization. The following figure shows the point cloud with elevation + EDL mode (left), and the mixed display after PCV processing
(right).

Usage



Click Vector Editor > Vector Editor

Element Extraction

Basic Function

Entity Modify

Layer Management

Profile

Entity Vectorization

Entity Selection

Entity Snapper



Editor

Control the start and end of vector editing, and support to edit one vector object at a time. The vector objects that can be edited include:
select vector files for editing, sketch editing and new file editing.

Select Vector File

Click Editor > Select Vector File, The interface for selecting vector object data pops up. The vector object data that has been loaded into the
editing window will appear in the selection list. Select the data to be edited.

After starting editing, other functions of the vector editing toolbar will be activated.

During the editing process, the edited vector data cannot be removed from the editing window.

New Temporary Scratch Vector

Click Editor > New Temporary Scratch Vector,

A temporary editing panel is constructed in the editing window, vector editing can be carried out, and the edited vector data is loaded into the
directory tree as a temporary object in the window.

After starting editing, other functions of the vector editing toolbar will be activated.

During the editing process, the edited vector data cannot be removed from the editing window.

New Vector File Edit

Click Editor > New Vector File Edit,

The file selection interface pops up, and the corresponding vector data file (supports dxf or shp format) is generated according to the path
selected by the user, and the vector data file is loaded into the editing window to open the editing of the vector data.

After starting editing, other functions of the vector editing toolbar will be activated.

During the editing process, the edited vector data cannot be removed from the editing window.

End Edit

Click Editor > End Edit, After ending editing, a prompt box will pop up to save the editing results. After the user makes a selection as required,
the editing function is exited, and other functions of the toolbar will be grayed out.



Entity Vectorization

This function provides a variety of vectorization operations for different entities (such as point, line, circle, polyline, and polygon entities) as
well as providing specific editing functions for polyline and polygon.

Note: For the point layer, users can only add point entities except the lines, circles, polylines, and polygons. For the line layer, users
cannot add point entities, but can add lines, circles, polylines, and polygons.

Draw Point

1. Left-click the mouse to pick the point position.
2. Repeat step 1 to draw the next point entity.
3. Right-click the mouse to end drawing.

Two Points Line

1. Left-click the mouse to select the starting point of the line segment entity or click the right mouse button to cancel.
2. Left-click the mouse to select the ending point of the line segment or click the right mouse button to back to step 1.
3. Right-click the mouse to end drawing.

Note:
This drawing automatically opens the Reference Plane setting interface.The vector elements drawn in the main window and Linked
Viewer are limited to the reference plane, and the vector elements drawn in the profile window are automatically limited to the center
plane of the profile.

Polyline

1. Left-click the mouse to select a point, or click the right mouse button to cancel.
2. Left-click the mouse to select one more point, or click the right mouse button to step 1.
3. Right-click the mouse to end drawing.

Note:
This drawing automatically opens the Reference Plane setting interface.The vector elements drawn in the main window and Linked
Viewer are limited to the reference plane, and the vector elements drawn in the profile window are automatically limited to the center
plane of the profile.

Rectangle From Three Points

1. Left-click the mouse to select point A, or click the right mouse button to cancel.
2. Left-click the mouse to select point B, or click right mouse button to return to step 1.
3. Left-click the mouse to select point C, continue to draw the next rectangle, or click right button to return to step 2.
4. Right-click the mouse to end drawing.

Note:
This drawing automatically opens the Reference Plane setting interface.The vector elements drawn in the main window and Linked
Viewer are limited to the reference plane, and the vector elements drawn in the profile window are automatically limited to the center
plane of the profile.

Draw the entity point by clicking the left mouse button. The steps are shown as follows.

Draw the line segment entity, click the left mouse button to pick the beginning and ending point of the line segment entity. The
steps are shown below.

Draw polyline through mouse interaction, which provides three types of editing functions(i.e. add node, append node, and deleting
node).

Select three points to draw the rectangle which is not paralleled with the coordinate axis by mouse interaction.



Draw Polygon

1. Left-click the mouse to choose a vertex of polygon, or click the right mouse button to cancel.
2. Left-click the mouse to choose one more point, or click the right mouse button to return back to step 1.
3. Right-click the mouse to end drawing.

Note:
This drawing automatically opens the Reference Plane setting interface.The vector elements drawn in the main window and Linked
Viewer are limited to the reference plane, and the vector elements drawn in the profile window are automatically limited to the center
plane of the profile.

Add Node

1. Left-click the mouse to select the polygon that you want to edit, or click the right mouse button to cancel.
2. Left-click the mouse to chose the location of the polygon entity and add nodes to the position. Users can also click the right mouse button

to return to step 1..
3. Right-click the mouse to end adding.

Append Node

1. Left-click the mouse to select polyline that you want to edit, or click the right mouse button to cancel.
2. Left-click the mouse to select the point, and determine the position of the inserted point according to the distance. If it is closer to the

starting point, the point will be appended before the starting point, otherwise it will be appended after the end point. Users can also click
the right mouse button to cancel the editing of the polyline and return to step 1.

3. Right-click the mouse to end appending.

Delete Node

1. Left-click the mouse to select the polygon that you want to edit, or click the right mouse button to cancel.
2. Left-click the mouse to choose the node of the polygon entity and delete. Users can also click the right mouse button to return to step 1.
3. Right-click the mouse to end deleting.

Reshaping

1. Left click to select the polyline or polygon entity.(Right click to exit editing.)
2. Pick points in the scene.
3. Double click to finish the editing.

Cut Polygons

1. Left click to select the polyline or polygon entity.(Right click to exit editing.)
2. Pick points in the scene.

Drawing polygon by the mouse interaction.

Edit polygon and add node by mouse interaction.

Appending nodes at the start or end of the polyline by the mouse interaction.

Edit polygon and delete node by mouse interaction

Reshape lines or polygons by drawing sketches on selected features. The feature adopts the sketch shape connected from the
first intersection to the last intersection of the sketch and the feature.

Cut polygon by the drawn line.



3. Double click to finish the editing.



Element Extraction

The Element Extraction module is used to extract element in the scene. The module provides intersection drawing line,Semi-automatic
building contour vectorization and road ridge vectorization.

When starting any function of this module, if there is no layer currently, the software will automatically add a layer. The vectorized objects
drawn by any function of this module will be stored on the layer.

Draw by Intersection

Click Draw by Intersection button to activate this function.

1. Click the left mouse button to select two points on one side of the building in turn.
2. Click the left mouse button to select two points on the other side of the building in turn.
3. The two selected edges will automatically extend to meet the intersection point.
4. (Optional) Right-click the mouse to pop up a right-click menu, and select Close Polyline, Back Point, or End Current.
5. (Optional) Click the back button on the toolbar to back the selected vertex.
6. (Optional) Click the tool bar close button to automatically close the current polyline and end the drawing of the current intersection

drawing method.

Extract Building Outline

Click the Extract Building Outline button to start this function, and the parameter configuration interface will pop up.

1. Click the left mouse button to select the area to be extracted.
2. Double-click to end the area selection and automatically extract the outline of the selected area.
3. The outline is vectorized into a polyline and added to the building layer.
4. (Optional) Click the back button on the toolbar to back out the outline extracted last time.
5. (Optional) Click the redo button on the toolbar to re-add the outline of the last rollback.

Parameters:

Dividing Roof Layer(default ON)：Check to extract outline by building roof, uncheck to extract overall boundary.
Min Area(m²)：The minimum area of entity to extract.
Point Spacing(m)：Average distance between points.
Inner(default OFF)：Check to extract inner outline.
Outer(default ON)：Check to extract outer outline.
Regularization(default ON)：Check to regularize the outlines.
Angle Tolerance(°)：Angle tolerance of regularization, range from 15-30 degree. The highter the degree, the less the sharp edges.

Extract Road Ridge

Click the Extract Road Ridge button to activate this function.

1. Move the left button of the mouse, and the scene will recognize whether the mouse position is a plane, an intersection ridge or an
intersection corner in real time.

2. When an intersecting ridge appears, click the mouse to extract the ridge.
3. The ridge line is vectorized into a polyline and added to the road layer.
4. (Optional) Click the back button on the toolbar to back out the last extracted ridge.
5. (Optional) Click the redo button in the toolbar to cancel the retreat of the last ridge extraction.

Parameters:

Length(m)：The length of search box.The larger the value, the faster the search speed, but too large a value will span two sections of
roads that are not connected.
Width(m)：The width of search box.
Height(m) ：The height of search box.
Curve Angle(°) ：The curve angle of road ridge.



Basic Function

Vector Editor provides a variety of basic functions, such as Vertex Editing, Attribute Query, Undo, Redo, Delete entity, Zooming, and Setting.

Undo

Redo

Delete Entity

Attribute Query

Setting

Undo the last edit.

Redo the last edit.

You need to first select the entities which need to be deleted, and then perform the delete operation.

You can query entity geometry attribute. Users can use the left mouse button to select the entity, which make the geometry
attribute of the entity displayed in the pop-up dialog, as shown below.

Configure various parameters for vector measurement.



Show Crossing Line: This parameter defines whether to display the cross wire in the screen center or not.

Yes(default): Show.
No: Hide.

Double Click Mouse's Left Button to Finish Editing：This parameter defines whether the current editing can be ended when double
click the left mouse button.

Yes: Double click Mouse's left button to finish editing.
No(default): Single click Mouse's right button to finish editing.

Show Context Menu: This parameter determines whether to show context menu using right click.

Yes(default): Show.
No: Hide.

Capture Distance (15px): Capture the distance.

Shortcut：Shortcut settings.

Configure various parameters for vector measurement.



Profile Editor

Profile can help with vector editing.

Click

Note:
1.The vector elements by drawing are automatically restricted to the center plane of the section.
2.When modifying vertex or moving vector object in the profile window, only the height value of the vertex or vector object is changed.

Open Profile viewer.Details please refer toProfileTools



Filter by Elevation

Description

After setting the center position and the buffer, the filtered point set is displayed in the scene. The Z value range of the points displayed after
elevation filtering are all within the buffer zone with the position as the value center.

Parameters

Position：Show middle Z value.
Buffer：Buffer size around Z value.
Show Plane：Whether to show the plane or not.
Transparency：Set the transparentcy, range from 0 to 99.
Color：Color settings.

The elevation filter is an auxiliary function of vector editing, it can filter out the interference points.



Linked Viewer

Description

The linked viewer is an auxiliary function of vector editing. It loads other types of data in the same area, such as TIN data, Raster data for
auxiliary editing. Editing such as drawing lines, drawing points, and building boundary extraction can be done in a linked viewer.

Parameters

Linked Viewer：The viewer list contains all the viewers currently opened by the software, select the associated viewer for auxiliary
editing.



Entity Modify

Entity provides many basic functions, such as shift/copy, rotate and scale.

Shift/Copy

Copying entities to one copy or multiple copies, which can create the same entities in different locations. In addition, multiple entities can be
created with the same offset increment by this function. The steps are shown below.

1. Select the entities that you want to copy.
2. Click copy and click the left mouse button to select the base position.
3. Left-click the mouse to select the location where you want to move, the pop-up dialog box will be displayed.

Settings

Delete Original: Remove the original entity and keep the moved entity.
Keep Original: Keep both the original entity and the moved entity.
Multiple Copies: Keep the original entity, copy multiple entities, set the number of copies, and the multiple entities will be shifted with the
same offset increment.

Rotate

Rotate entities to get one copy or multiple copies at different rotation angles. In addition, multiple entities can be created with the same angle
increment. The steps are shown below.

1. Select the entities that you want to rotate.
2. Click rotate and click the left mouse button to select the position of rotation center.
3. Left-click the mouse to determine the final angle position of the rotation, the pop-up dialog box will be displayed.

Settings

Delete Original: Remove the original entity and keep the rotated entity.
Keep Original: Keep both the original entity and the rotated entity.
Multiple Copies: Keep the original entity, copy multiple entities, set the number of copies, and the multiple entities will be rotated with the
same angle increment.
Angle（°）: Set the angle value of rotation.

Scale

Scale entities to get one copy or multiple copies at different scales in different locations. The steps are shown below.

1. Select the entities that you want to scale.
2. Click copy and left-click the mouse to select the zoom center position, the pop-up dialog box will be displayed.



Settings

Delete Original: Remove the original entity and keep the scaled entity.
Keep Original: Keep both the original entity and the scaled entity.
Multiple Copies: Keep the original entity, copy multiple entities, set the number of copies, and the multiple entities will be scaled with the
same scale increment.
Isotropic Scaling: This parameter defines the scaling of the X and Y directions, separately. If checked, the scaling of X，Y and Z
directions are the same.

X: Set the scaling of the X direction.
Y: Set the scaling of the Y direction.
Z: Set the scaling of the Y direction.



Entity Selection

Select

Select All

Deselect All

Select Entity

Select Window

The function provides a variety of operations to select entities, such as Select, Select all, Deselect all, Select entity, Select
Window, Deselect Window, Select intersected entities, Select layer, and Invert selection.

Can select and modify entity. - (Optional) Click to select entity. - (Optional)Draw rectangle to select entity. - (Optional)Modify entity
end point. - (Optional)Modify entity.

Select all entities in the scene.

Deselect all entities which are selected in the scene.

Left-click the mouse to select the entity.

Left-click the mouse to draw rectangle, the entities will be selected within this rect.



Select Intersected Entities

Select Layer

Invert Selection

Left-click the mouse to draw rectangle, the entities will be selected within this rect.

Left-click the mouse to draw straight line, all entities intersected with the line will be selected.

Left-click the mouse to select one entity, and then all entities within its layer will be selected.

All selected entities in the scene will be deselected.



Entity Snap

Vector Editor provides a variety of snapper operations, The function can control the point location clicked by the mouse, which can improve
accuracy of vectorization.

Snap on Endpoint

Snap on Entity

Snap Center

Snap Middle

Snap Intersection

Restrict Orthogonal

Snap Point Cloud

Snap Model

Snap startpoints and endpoints, such as starting point and ending point of one line.

Select the closed point of entity, snapping can move along the entity.

Snap the center of the entity, such as the center of a circle.

Snap middle points of an entity, such as the midpoint of the line segment.

Snap intersecting points of multiple entities, such as the intersection of two lines.

After selecting a current point, the subsequent selected points can only move in the orthogonal direction (vertical or horizontal
direction) of the current point.

Snap points on the point cloud, this snap is suitable for drawing corners of house etc.

Snap the closest point of model.



Layer Management

Brief：Vector editing is managed with layers, which means a file is treated as a layer. Clicking the triangle button of the "File" will show the
drop-down menu, including the "New File", "Open File", "Save File", "Remove File" and "Export File" functions.

Add Layer

Right click Layer>Add layer:

1. Click the dropbox to select layer name, or directly enter a layer name.



2. Select layer type (oint or line). If creating point layer, you need to set color and point size; if creating line layer, you need to set line color,
size and type.

3. Click Color button to set the color.

4. Size setting is between 1-10 pixel.

Save All Layers

Right click Layer>Save All Layers:

Select the Save as and directory, then click OK. > Note: 1. If file is saved as shp, _points.shp or _lines.shp will be created. #### Remove All
Layers #### Right click *Layer>Remove All Layers*:

Click "Yes" to save all layers and remove them all.
Click "No" to remove all layers.



Click "Cancel" to quit removing all layers.

Show

Click Show button to show layer.

Hide

Click Hide button to hide layer.



Reference Plane

Description

The reference plane is a drawing plane set in the main window of the vector editing module. When drawing lines, rectangles, and polygons,
the reference plane setting interface automatically pop up. When drawing vector objects in the main window and the associated window, they
are limited to the reference plane. </p></div>

Parameters

Height Source：The reference plane is a horizontal plane, and the corresponding height can be set of multiple sources:

Customize：Users can customize the height by manually entering.

Min Z：Take minimum Z of point cloud as height.

Middle Z：Take middle Z of point cloud as height.

Max Z：Take maximum Z of point cloud as height.

Elevation Filter：Height refer to the center position value in Elevation Filter.

Plane Height：Show plane height.

Show Reference Plane：Whether to show reference plane or not.
Transparency：Transparency setting of reference plane.
Color：Color setting of reference plane.



ALS Forest
This chapter describes how to deal with aerial (both UAV and airborne) LiDAR data for froestry applications. This chapter include: Statistical
Parameter Extraction, Regression Analysis, Individual Tree Segmentation, Batch Processing, Clear Tree ID, Extract Point Clouds by Tree ID
and ALS Editor.

Theory of Elevation Metrics

Theory of Intensity Metrics

Theory of Canopy Cover

Theory of Leaf Area Index

Theory of Gap Fraction

Forest Metrics

Calculate Forest Metrics by Grid

Calculate Forest Metrics by Polygon

Calculate Forest Metrics by Forest Stands

Regression Analysis

Sample Data and Independent Variables

Linear Regression

Support Vector Machine

Fast Artificial Neural Network

Random Forest Regression

Run Existing Regression Model

Segmentation

CHM Segmentation

View the CHM Segmentation Results

Point Cloud Segmentation

View the Point Cloud Segmentation Results

Generate Seed Points from CHM

Generate Seeds from Layer Stacking

Point Cloud Segmentation from Seed Points

Batch Process

Forest Metrics

Point Cloud Segmentation

Canopy Height Model(CHM) Segmentation

Registration

Auto Registration by Tree Locations
Clear Tree ID

Clear Tree ID by CSV File

Statistic Individual Tree Attributes

Extract by Tree ID

Forest Structure Change Detection

ALS Editor



Theory of Elevation Metrics

Summary

Elevation Metrics are statistical parameters related to point cloud elevation. They are frequently used in regression analysis, especially when
correlating field plot measurements with LiDAR data. In this model, 46 statistical parameters related to elevation and 10 parameters related to
point cloud density can be calculated. The resultant product is a table in CSV format or a set of TIFF files.

Principle

Average Absolute Deviation: Computed using the following equation: , where Z  represents the elevation of i

point within a statistical unit, Z represents the average elevation of all points within a statistical unit, and n is the number of points in a
statistical unit.

Canopy relief ratio: Computed using the following equation: , where mean represents the average elevation of a

statistical unit, min represents the minimum elevation of a statistical unit, and max represent the maximum elevation of a statistical unit.
AIH (15): Within a statistical unit, all normalized lidar point clouds are sorted according to the elevation and the cumulative heights of all
points are calculated. The cumulative height of X% points in each statistical unit is the statistical unit's AIH. In LiDAR360, 15 AIH can be
calculated, including 1%, 5%, 10%, 20%, 25%, 30%, 40%, 50%, 60%, 70%, 75%, 80%, 90%, 95% and 99%.
AIH Interquartile Distance: Computed using the following equation: , where AIH75% represents the 75% AIH
statistical layer, and AIH25% represents the 25% AIH statistical layer.

Coefficient of Variation: Computed using the following equation: , where Z  represents the standard

deviation of elevation within a statistical unit, and Z  represents the average elevation within a statistical unit.
Density Metrics(10): The point cloud data is divided into ten slices with the same height interval from low to high, and the proportion of
returns in each height interval is the corresponding density metrics.
Kurtosis: The kurtosis of the Z value of all points in a statistical unit. The calculation formula is 

, in which Z  is the height value of the i-th point in each statistical unit, Z is the

average height of all points in each statistical unit, n is the point number in each statistical unit, and σ is the standard deviation of point
cloud height distribution within a statistical unit.
MADMedian: The median of median absolute deviation.
Maximum: The maximum value of Z for all points in a statistical unit.
Minimum: The minimum value of Z for all points in a statistical unit.
Mean: The mean value of Z for all points in a statistical unit.
Median: The median of Z for all points in a statistical unit.

Generalized means for the 2nd power: Computed using the following equation: , where Z  is the Z value of the i

point in a statistical unit.

Generalized means for the 3rd power: Computed using the following equation: , where Z  is the Z value of the i

point in a statistical unit.
Elevation Percentile (15): Within a statistical unit, all normalized lidar point clouds are sorted by elevation, and then the elevation at
which X% of points in each statistical unit is located is the elevation percentile of this statistical unit. In LiDAR360, 15 elevation
percentiles are calculated, including 1%, 5%, 10%, 20%, 25%, 30%, 40%, 50%, 60%, 70%, 75%, 80%, 90%, 95% and 99%.
Elevation Percentile Interquartile Distance: Computed using the following equation: , where Ele75%
represents the 75% elevation statistical layer, and Ele25% represents the 25% elevation statistical layer.
Skewness: This value shows the symmetry of Z values of all the points in each statistical unit. The calculation formula is 

, in which Z  is the height value of the i-th point in each statistical unit, Z is the average height of all points in each

statistical unit, n is the point number in each statistical unit, and σ is the standard deviation of point cloud height distribution within a
statistical unit.
Standard Deviation: The standard deviation of Z for all points in a statistical unit.
Variance: The variance of Z for all points in a statistical unit.
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Theory of Intensity Metrics

Summary

The intensity metrics are similar to the elevation metrics with the exception that point intensity is used rather than point elevation. Therefore,
this function can be used only if the point cloud data contains intensity information. Overall, 42 statistical parameters related to intensity can
be calculated, and the resultant product is a table in CSV format or a set of TIFF files.

Principle

Average Absolute Deviation: Computed using the following equation: , where I  represents the intensity of i  point

within a statistical unit, I represents the average intensity of all points within a statistical unit, and n is the number of points in a statistical
unit.
AII (15): Within a statistical unit, all normalized lidar point clouds are sorted according to their intensity values and the cumulative
intensities of all points are calculated. The cumulative intensity of X% points in each statistical unit is the statistical unit's AIH. In
LiDAR360, 15 AIH can be calculated, including 1%, 5%, 10%, 20%, 25%, 30%, 40%, 50%, 60%, 70%, 75%, 80%, 90%, 95% and 99%.

Coefficient of Variation: Computed using the following equation: , where I  represents the standard deviation

of intensity within a statistical unit, and I  represents the average intensity within a statistical unit.
Kurtosis：The kurtosis of the intensity values of all points in a statistical unit. The calculation formula is 

, in which Z  is the intensity value of the i-th point in each statistical unit, Z is the

average intensity of all points in each statistical unit, n is the point number in each statistical unit, and σ is the standard deviation of point
cloud intensity distribution within a statistical unit.
MADMedian：The median of median absolute deviation of the intensity values of all points in a statistical unit.
Maximum：The maximum of the intensity values of all points in a statistical unit.
Minimum：The minimum of the intensity values of all points in a statistical unit.
Mean：The mean of the intensity values of all points in a statistical unit.
Median：The median of the intensity values of all points in a statistical unit.
Skewness: This value shows the symmetry of intensity values of all the points in each statistical unit. The calculation formula is 

, in which Z  is the intensity value of the i-th point in each statistical unit, Z is the average

intensity of all points in each statistical unit, n is the point number in each statistical unit, and σ is the standard deviation of point cloud
intensity distribution within a statistical unit.
Standard Deviation：The standard deviation of the intensity values of all points in a statistical unit.
Variance: The variance of the intensity values of all points in a statistical unit.
Intensity Percentile (15)：Within a statistical unit, all normalized lidar point clouds are sorted by intensity, and then the intensity at which
X% of points in each statistical unit is located is the intensity percentile of this statistical unit. In LiDAR360, 15 intensity percentiles are
calculated, including 1%, 5%, 10%, 20%, 25%, 30%, 40%, 50%, 60%, 70%, 75%, 80%, 90%, 95% and 99%.
Intensity Percentile Interquartile Distance: Computed using the following equation: , where Int75% represents
the 75% intensity statistical layer, and Int25% represents the 25% intensity statistical layer.
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Theory of Canopy Cover

Summary

Canopy cover is the percentage of vertical projection of forest canopy to forest land area (Jennings et al., 1999). It is an important parameter
in forest management, and it is also an essential factor for estimating forest volume.

Principle

LiDAR360 adopts two different algorithms for calculating canopy cover for point cloud with and without return number information
respectively. If the point cloud has return number information, it will be first divided into different grids according to a user-defined xsize and
ysize. In each pixel, canopy cover can be calculated as the ratio of LiDAR first vegetation returns (higher than the user-defined threshold) to
the total number of LiDAR first returns.

where CC is canopy cover, n  is the number of vegetation first returns, and n  is the number of all first returns.

If point cloud does not have return number information, it will also be first divided into different grids according to a user-defined xsize and
ysize. In each pixel, canopy cover can be calculated as the ratio of LiDAR vegetation returns to the total number of LiDAR returns. Similar to
the calculation of gap fraction, any points higher than 2m will be treated as vegetation points in the calculation.

where CC is canopy cover, n  is the number of vegetation return, and n  is the total number of returns.

According to (Ma et al., 2017), the canopy cover generated from these two methods have no significant difference. The resultant product is a
raster file in TIFF format, the value ranges from 0 (no canopy cover/completely open) to 1 (completely covered by canopy).

    @inproceedings{
        author={Jennings S B, Brown N D and Sheil D},
        title={Assessing forest canopies and understorey illumination: canopy closure, canopy cover and other measures},
        booktitle={Forestry,72(1): 59-73},
        year={1999}
    }

vegfirst first

veg total



    @inproceedings{
        author={Ma Q, Su Y J and Guo Q H},
        title={Comparison of Canopy Cover Estimations From Airborne LiDAR, Aerial Imagery, and Satellite Imagery.},
        booktitle={IEEE Journal of Selected Topics in Applied Earth Observations and Remote Sensing,10(9): 4225-4236},
        year={2017}
    }



Theory of Leaf Area Index

Summary

The Leaf Area Index (LAI) is one of the most basic parameters that characterizes the forest canopy structure. It is defined as half of the
surface area of all leaves projected on the surface area of a unit(Chen et al.,1991). LAI can be calculated from the normalized LiDAR
vegetation points.

(a) Direction of light incidence, (b) the zenith angle refers to the angle between the incident ray and the vertical direction, (c) the projection of
the leaf in the vertical direction, (d) describes the extinction coefficient, and (e) describes the aggregation coefficient.

Principle Description

LAI value is calculated using the following equation:

where ang is the average scan angle, GF is the gap fraction，and k is the extinction coefficient, which is closely related to the leaf angle
distribution (Richardson et al.,2009).

The average scan angle is calculated from LiDAR points using the following equation:

where ang is the average scan angle, n is the number of LiDAR points and angle  is the scan angle of the i  LiDAR point.

The Gap Fraction (GF) is calculated using the following equation:

where n  is the number of ground points and n is the total number of LiDAR points.

    @inproceedings{
        author={Chen J M and Black T A},
        title={Measuring leaf area index of plant canopies with branch architecture},
        booktitle={Agricultural and Forest Meteorology,57(1-3): 1-12},
        year={1991}
    }

    @inproceedings{

i
th

ground



        author={Richardson J J},
        title={Modeling approaches to estimate effective leaf area index from aerial discrete-return LiDAR},
        booktitle={Agricultural and Forest Meteorology, 149 (6): 1152-1160},
        year={2009}
    }



Theory of Gap Fraction

Summary

Gap Fraction is a crucial variable that governs interactions between light and vegetation and requires accurate modelling to predict light
climate in the canopy, photosynthetic activity or canopy reflectance.

Principle

The Gap Fraction (GF) is calculated using the following equation:

where n  is the number of ground points and n is the total number of vegetation and ground points. Note that all LiDAR points with a
normalized height lower than the user-defined height break (2m is commonly used) are treated as ground points in gap fraction calculation
(Richardson et al.,2009).

    @inproceedings{
        author={Richardson J J, Moskal L M and Kim S H},
        title={Modeling approaches to estimate effective leaf area index from aerial discrete-return LIDAR},
        booktitle={Agricultural and Forest Meteorology,149: 1152-1160},
        year={2009}
    }

ground



Forest Metrics
The Forest Metrics menu contains Elevation Metrics, Intensity Metrics, Canopy Cover, Leaf Area Index, and Gap Fraction generated from
point cloud data.

Calculate Forest Metrics by Grid

Calculate Forest Metrics by Polygon

Calculate Forest Metrics by Forest Stands



Calculate Forest Metrics by Grid

Summary

Calculate the forest metrics based on the point cloud data in grids. Split the point cloud data with multiple grids, and then calculate the forest
metrics in each grid. The forest metrics include elevation, intensity, canopy cover, LAI, and gap fraction.

First, this function will divide the point cloud into different grids with a certain size in the horizontal direction. And then Calculate the forest
metrics based on users selection, and, for each grid, generate a CSV file or TIFF file to store the result.

Usage

Click AlS Forest > Forest Metrics > Calculate Forest Metrics by Grid to generate the selected forest metrics.

Settings

Input: Make sure that all the input files are normalized. The input file(s) can be a single file or a file set. The file(s) to be processed must
be opened in LiDAR360 before using this function.
XSize (meter) (default value is "15"): The grid size in X direction. This value should be larger than the crown size of the trees. For the
data acquired from most of the forest, this value should be larger than 15.
YSize (meter) (default value is "15"): The grid size in Y direction. This value should be larger than the crown size of the trees. For the
data acquired from most of the forest, this value should be larger than 15.
Height Threshold (meter) (default value is "2"): The threshold to divide the data in vertical direction. The point cloud above this height
will be used to calculate the forest metrics. The default value is 2.
Leaf Angle Distribution (default value is "0.5"): A mathematical expression of leaf probability distribution in three-dimensional space,
which is related to vegetation type, leaf angle, and beam direction. According to the empirical formula, the user can determine the value
of leaf angle distribution according to the actual situation of the forest. Studies have shown that the elliptic distribution of leaf angle, which
has a leaf angle distribution value of 0.5, may be applicable to the actual situation.
Output Path: Path of the output file. A corresponding raster file (tif format) or CSV file will be generated for each input point cloud data,
which can be used in the regression analysis.
DefaultValue: Restore the default parameters.

Note: Only when the point cloud data is loaded in the software can you use the Elevation Metrics function; otherwise, the message
"There is no point cloud data meeting the conditions of calculation!" will pop up. If the maximum Z value of the point cloud is greater
than 200 m or the maximum Z minus the minimum Z is greater than 200 m, the data is not considered to have been normalized, and
the prompt information shown in the figure below will pop up. Click “YES” to keep using this type of data in the operation; otherwise,
click "NO" and reselect the input data file.





Calculate Forest Metrics by Polygon

Summary

Calculate the forest metrics based on the point cloud data in the given polygon file. The forest metrics include elevation, intensity, canopy
cover, LAI, and gap fraction.

Read the position information of the polygon(s) stored in the input SHP file. Calculate the forest metrics and gerenate a result record for each
polygon.

Usage

Click AlS Forest > Forest Metrics > Calculate Forest Metrics by Polygon to generate the selected forest metrics.

Settings

Input: Make sure that all the input files are normalized. The input file(s) can be a single file or a file set. The file(s) to be processed must
be opened in LiDAR360 before using this function.
SHP file: The vector data that contains the polygon(s) in which the users need to generate the forest metrics. The SHP file can be added
into LiDAR360 or manually input by the users.
Height Threshold (meter) (default value is "2"): The threshold to divide the data in vertical direction. The point cloud above this height
will be used to calculate the forest metrics. The default value is 2.
Leaf Angle Distribution (default value is "0.5"): A mathematical expression of leaf probability distribution in three-dimensional space,
which is related to vegetation type, leaf angle, and beam direction. According to the empirical formula, the user can determine the value
of leaf angle distribution according to the actual situation of the forest. Studies have shown that the elliptic distribution of leaf angle, which
has a leaf angle distribution value of 0.5, may be applicable to the actual situation.
Output Path: Path of the output file. A corresponding raster file (tif format) or CSV file will be generated for each input point cloud data,
which can be used in the regression analysis.
DefaultValue: Restore the default parameters.

Note: Only when the point cloud data is loaded in the software can you use the Elevation Metrics function; otherwise, the message
"There is no point cloud data meeting the conditions of calculation!" will pop up. If the maximum Z value of the point cloud is greater
than 200 m or the maximum Z minus the minimum Z is greater than 200 m, the data is not considered to have been normalized, and
the prompt information shown in the figure below will pop up. Click “YES” to keep using this type of data in the operation; otherwise,
click "NO" and reselect the input data file.



Calculate Forest Metrics by Forest Stands

Summary

Calculate forest metrics by forest stands for each point cloud data. The metrics include Elevation Metrics, Intensity Metrics, Canopy Cover,
Leaf Area Index, and Gap Fraction. For each poitn cloud data, a record will be generated and stored in a CSV file.

Usage

Click ALS Forest > Forest Metrics > Calculate Forest Metrics by Forest Stands to generate the selected forest metrics.

Settings

Input: Please ensure that each input point cloud data is normalized data; the input file can be a single point cloud data file or a point
cloud data set; to be The processed data must be opened in the LiDAR360 software. -Height threshold (m) (default is "2"): The
threshold for dividing the point cloud into different layers, and the point whose height exceeds the threshold will participate in the
calculation. The default value is 2 meters. -Leaf inclination angle distribution (default is "0.5"): A mathematical expression of the
probability distribution of leaves in a three-dimensional space, which is related to vegetation type, leaf inclination angle and beam
direction. The user can determine the value of the leaf inclination angle distribution based on the empirical formula combined with the
actual situation of the forest. Studies have shown that the elliptical distribution of leaf inclination angles may be suitable for most forests,
with a value of 0.5. -Output Path: Output path. After running, each input point cloud data file will generate a corresponding CSV file or a
set of TIFF files, which can be used as independent variables in regression analysis. -Default: Restore the height threshold and leaf
inclination angle distribution to the default values.

Note: Only when the point cloud data is loaded in the software, can you use the grid-based calculation of forest parameters function,
otherwise, the software will pop up the prompt message "There is no point cloud data meet the conditions of calculation!". If the
maximum Z value of the point cloud is greater than 200 or the maximum Z minus the minimum Z is greater than 200, the data is
considered to be unnormalized, and the software will pop up the prompt message shown in the figure below, click "YES", this type of
data Still participating in the calculation, click "NO", this type of data will not participate in the calculation, and the user can re-select the
data that meets the conditions.



Sample Data and Independent Variables

Sample Data

All regression methods require sample data derived from field measurements to train the regression model. The sample data can be imported
using the “Import Training Data” dialog of each regression model. The imported file should be in text format (.txt extension) and must contain
a header to label each column. The first two columns should be the X and Y coordinates of each sample, followed by any dependent values.
Note that multiple dependent values can be given, but only one can be used for each regression execution. See Sample Data File in the File
Formats section of the Appendix for information about sample data file.

Settings

Sample Data: Click  next to the sample data input box to select sample data. Imported values can then be viewed in the

Import Training Data section.
Dependent Variable: This parameter defines the dependent variable used in the regression analysis. Only one dependent variable from
the sample data file can be selected each time.
Plot Type: This parameter defines the plot type. It should be selected based on the plot surveying methodology.

Square (default): The plot is square.
Circle: The plot is circle.

Length (meter)：When the plot type is square, set the length of the plot.
Radius (meter)：When the plot type is circle, set the radius of the plot.
Local Error Buffer：When the plot type is circle, set the radius of the plot.
X: X coordinate of the plot center.
Y: Y coordinate of the plot center.

Independent Variables

For the Independent Variables section, users can select the independent variables from Elevation Percentile, Elevation Density, Intensity
Percentile, LAI, Gap Fraction and Canopy Cover. Users can also import data in .csv or .tif format. While importing a .csv table, only one can
be selected at a time, and must contain at least four fields, including X, Y, X size, and Y size (each column would be added to the list as an
independent variable). However, multiple .tif images can be added at once. Every time a .tif image is added successfully, an independent
variable named after the file name of .tif will be added to the list.



Note: The selected sample data should be within the extent of LiDAR point cloud. The XY range and scale of all imported .tif
independent variables must be consistent. While importing a .csv file, X, Y, X size, and Y size will be imported as independent variables
to the list. In this case, it is recommended to remove these 4 variables, or at least remove X size and Y size, depending on the case. It
is also recommended to have more samples than dependent variables, otherwise it could lead to infinite solutions when solving the
matrix.



Linear Regression

Description

This tool use Python scikit-learn and NumPy to build linear regression model.

Usage

Click ALS Forest > Regression > Linear Regression.

Parameters

Sample data：Refer to Sample data and dependent variable.
Dependent variable：Refer to Sample data and dependent variable.
Plot type：Square or circle.
Length：Length or radius of the plot.
Optimize by considering location uncertainty：If check, the value in the location uncertainty represents the accuracy value of the
range query. The model will query all sample points that meet the conditions according to the range (if the number of sample points
exceeds 50, the first 50 points will be selected as samples), and then the model will be selected based on these sample points The best
point is used as analysis data. If uncheck, the model will select the closest point as the analysis data according to the sample point.
Accuracy assessment：Using the K-Fold cross evaluation model. According to the input K-Fold parameters, the samples are divided
into K class, one of them is taken as the test data in turn, the others are used as the training data for model training, the test data is used
for testing, and the smallest error is selected The model of is used as the best model. Note: The K-Fold value must be greater than or
equal to 2.
Save regression Model：If check, the model will be generated in output path.

http://scikit-learn.org/stable/
http://www.numpy.org/


Save regression dataset：If check, the csv will be generated in output path.
Output path：To select output path. The corresponding model report (linear regression.html) file will be generated, which records the
error and related values of the model; the corresponding result file (linear regression.tif) will be generated, which is calculated according
to the model and the imported tif or csv file The value of the independent variable predicts the result of the corresponding dependent
variable; and according to the check situation, choose to generate the regression model and data set.

Note: The imported sample data must be included in the imported independent variable data range. Independent variables can be
added or deleted according to the actual situation. The final result file is generated based on the imported independent variable
information.



Support Vector Machine

Summary

This tool is an implementation of the LIBSVM (Chang et al.,2011) for support vector regression (SVR). LiDAR360 supports forest metrics
estimation using two SVR types (epsilon-SVR and nu-SVR) and four kernel types (linear, polynomial, radial basis function and sigmoidal).

Usage

Navigate to ALS Forest > Regression Analysis > Support Vector Machine.

Settings

Import Training Data: Refer to Sample Data and Independent Variables.
Independent Variables: Refer to Sample Data and Independent Variables.
Kernel Type: Users can select the type of kernel function here including RBF function, Linear, Polynomial, and Sigmoid.

RBF Function (default): , where γ > 0.
Linear: .
Polynomial: , where γ > 0.
Sigmoid: .

SVM Type: Two types of SVM method are provided.
EPSILON_SVR (default): EPSILON SVR(ϵSVR ).
NU_SVR: NU SVR(νSVR).

Degree (default value is "3"): Kernel function parameter.
Gamma (default value is "0.1"): Kernel function parameter.



Accuracy Assessment: Based on the K-Fold cross validation model, a sample would be partitioned into k subsets according to input K-
Fold value (no less than 2). Take one of subsets as a validation dataset and the remaining subsets as training datasets to form a model,
then run this model and test the fitting of validation set to training sets. Repeat this process until every subset is treated as a validation
set at least once and select out the model with the least MSE (mean square error) as the optimal model.
Save Regression Model: Tick the checkbox to save the SVM model (Support Vector Machine.model) under the output path.
Save Regression Dataset: Tick the checkbox to save the training dataset (Support Vector Machine.csv) in .csv format under the output
path.
Output Path: Choose an output directory. A support vector machine regression model report (Support Vector Machine.html), recording
the model's parameters and accuracy (R-square, RMSE), would be generated under this directory. A prediction result file (Support Vector
Machine.tif), based on the support vector machine regression model and input variables from a .tif or .csv file, would also be generated
under this output directory.

Note: The dimension of imported sample/training data must be within the scope of independent variables, which may be adjusted
accordingly. The model/result is based on the passed-in variables.

    @inproceedings{
        author={Chang C C and Lin C J},
        title={LIBSVM: A Library for Support Vector Machines},
        booktitle={ACM,2(3):1-27},
        year={2011}



    }



Fast Artificial Neural Network

Summary

Implementation of FANN (Fast Artificial Neural Network) regression to provide ANN (Artificial Neural Network) regression.

Usage

Navigate to and click on ALS Forest > Regression Analysis > Fast Artificial Neural Network.

Settings

Import Training Data: Refer to Sample Data and Independent Variables.
Independent Variables: Refer to Sample Data and Independent Variables.
Momentum (default value is "0.6"): Set the momentum parameter in ANN regression analysis for selecting the optimized path.
Learning Rate (default value is "0.7"): The global learning rate for training the network.
Accuracy Assessment: Based on the K-Fold cross validation model, a sample would be partitioned into k subsets according to input K-
Fold value (no less than 2). Take one of the subsets as a validation dataset and the remaining subsets as training datasets to form a
model, then run this model and test the fitting of the validation set to training sets. Repeat this process until every subset is treated as a
validation set at least once then select out the model with the least MSE (mean square error) as the optimal model.
Save Regression Model: Tick the checkbox to save the ANN model (Fast Artificial Neural Network.model) under the output path.
Save Regression Dataset: Tick the checkbox to save the ANN training dataset (Fast Artificial Neural Network.csv) in .csv format under
the output path.
Output Path: Choose an output directory. A fast artificial neural network regression model report (Fast Artificial Neural Network.html),
recording the model's parameters and accuracy (R-square, RMSE), would be generated under this directory. A prediction result file (Fast

http://leenissen.dk/


Artificial Neural Network.tif), based on the fast artificial neural network regression model and input variables from a .tif or .csv file, would
also be generated under this output directory.

Note: The dimension of imported sample/training data must be within the scope of independent variables, which may be adjusted
accordingly. The model/result is based on the passed-in variables.



Random Forest Regression

Principle Description

This tool use Python Package scikit-learn and NumPy to build up the Random Forest model.

Usage

Click ALS Forest > Regression Analysis > Random Forest Regression.

Setting

Sample Data: Please refer to Sample Data and Independent Variables。
Independent Variables: Please refer to Sample Data and Independent Variables。
Random Forest: These values define Random Forest's parameters.

Tree Num：Tree number in the Random Forest model.
Max Depth：The maximum depth of Random Forest model.
Min Split：The minimum split of Random Forest model.
Min Leaf：The minimum leaf number in Random Forest model.

Accuracy Assessment：Use K-Fold cross-validation model. According to the inserted K-Fold parameters, divide the sample into K
groups. Each group will be taken as testing data by training the model using other remianing samples. Note that K-Fold value should be
larger than 1 (don't include 1).
Save Regression Model: If the box is checked, a model named (Random Forest.model) will be generated in the output path, after the
program being successfully run.
Save Regression Dataset：If the box is checked, a training data model named (Random Forest.csv) will be generated in the output path,
after the program being successfully run.
Output Path: The path for the output files. The software will generate a model report (Random Forest.html) with the residuals and related
values of the model, a result file (Random Forest.tif), and a regression model file (optional).
Default Value: Restore all the default values for all parameters.

http://scikit-learn.org/stable/
http://www.numpy.org/


Note: The inserted sample data must be included in the range of inserted independent variables. The number of independent variables
can be changed based on the users' situation. The final result is generated according to the inserted independent variables. Max Depth
and Tree Num should be greater than 0.



Run Existing Regression Model

Summary

This tool estimates forest metrics using any available regression models (Linear Regression, Support Vector Machine, Fast Artificial Neural
Network and Random Forest Regression).

Usage

Navigate to ALS Forest > Regression Analysis > Run Existing Regression Model.

Insert Model File

Select a regression model file (*.model) generated by the regression analysis tools, including linear regression, support vector machines, fast
artificial neural network, or random forest, etc.

Insert Independent Variables

Inserted file should be in CSV or TIF format. CSV files must have attributes of X, Y, XSize, and YSize. Each attribute will be added into the list
as a independent variable. Only one CSV file can be added; while several TIF files can be added. Each TIF will be added to the list as a
independent variable with its file name. The number of independent variables must be the same as the number of independent variables in
the model selected. (To learn more about each independent variable, please refer to Elevation Metrics, Intensity Metrics, Canopy Cover, Leaf
Area Index, and Gap Fraction)

Setting

Plot Type: This parameter defines the plot type. Users can choose that according to the survey in the sample data.
Square (default): The plot is in square shape.
Circle: The plot is in circle shape.

Length (meters): When the plot type is square, set the length of the plot.
Radius (meters)：When the plot type is circle, set the radius of the plot.



Output Path: Select the path for the output files. The software will generate two files, "Regression Predict.tif" file and "Regression
Predict.html" report, after succeeding to predict. The TIF file is the result of prediction.

Note: the number of inserted independent variable must be the same as the number of independent variables in the inserted model.
Otherwise, it will lead to failing to predict or large residuals.



Segmentation
Segmentation provides a series of functions for segmenting individual trees and therefore acquire individual tree attributes from ALS data.

CHM Segmentation

View the CHM Segmentation Results

Point Cloud Segmentation

View the Point Cloud Segmentation Results

Generate Seed Points from CHM

Generate Seeds from Layer Stacking

Point Cloud Segmentation from Seed Points



CHM Segmentation

Summary

CHM segmentation utilizes the watershed segmentation (Chen et al., 2006) technique to identify and delineate individual trees, and therefore
obtain individual tree information, such as tree location, tree height, crown diameter, crown area and tree boundaries.

Principle

The basic principle of watershed segmentation algorithm is if placing a water source in each regional lowest point in the CHM and flooding the
entire relief, barriers can be generated when different water sources meet. The resulting set of barriers can build a watershed by flooding,
which is the segmentation result. Note that the CHM segmentation result can be affected by the CHM resolution. It is recommended that the
CHM should have a spatial resolution higher than 1 m to ensure a sufficient segmentation result. Moreover, the CHM segmentation result can
also be largely influenced by tree density and tree species. If the algorithm does not work well in certain study area, users can try to use other
segmentation algorithms to get the best segmentation result.

(a) CHM; (b) Watershed Segmentation Algorithm; (c) CHM Segmentation Result

Usage

Navigate to ALS Forest > Segmentation > CHM Segmentation.

Settings

Input Data: The input file can be a single CHM file or multiple CHM files. The data should be opened in LiDAR360 before being
processed.
Maximum Tree Height (meter)(default value is "80"): The threshold defining the maximum tree height in a study areas. CHM pixels
above this threshold will not be considered in the segmentation.
Minimum Tree Height (meter)(default value is "2"): The threshold defining the minimum tree height in a study areas. CHM pixels
below this threshold will not be considered in the segmentation.
Buffer Size (pix)(default value is "50"): A threshold controls the block size for performing CHM segmentation, which can avoid physical
memory overflow. This value should be larger than the maximum crown area and smaller than 1500. If the CHM is larger than 1500 by
1500 pixels, the CHM will be forced to divided into a number of blocks with a size of 1500 by 1500 pixels.
Crown Base Height Threshold (meter)(default value is "0.8"): The starting height of the crown range. A reasonable base height value
can help to improve the accuracy of the boundary and area of crown. After setting the base height, the pixels higher than this height will
be included to generate the vector boundary of crown, while the pixels lower than this height will be excluded. Users should set this value
according to the species and growing situation of the trees in order to get the best result.



Gaussian Smooth (optional): This parameter is to control whether to perform Gaussian smoothing. In general, it is recommended to
check the Gaussian smoothing option to remove noise effects.
Sigma (default value is "1"): Gaussian smoothing factor. The greater the value is, the smoother the results are. The degree of
smoothness can affect the number of trees being segmented. In the case of under-segmentation, it is recommended to reduce this value
(e.g. 0.5); and in the case of over-segmentation, it is recommended to increase the value (e.g. 1.5).
Radius (pix)(default value is "5"): The window size used by Gaussian smoothing, which should be an odd number. Generally, it can be
set to the average crown diameter.
Output Path: Path of the output file. The resultant product is a comma-separated table in “csv” format and a polygon file in "shp" format.
The CSV table contains the ID, location (x and y coordinates), height, crown diameter, and crown area of each segmented tree. The shp
file contains the boundary of each tree, and its corresponding attribute table contains the ID, location (x and y coordinates), height, crown
diameter, and crown area of each segmented tree. Refer to the CHM Segmentation Results for segmentation result examples.
DefaultValue: Restore the default parameters.

Note: The CHM Segmentation function can only be used when the raster data is loaded in the software. Otherwise, the message
“There is no raster data!” will pop up.

    @inproceedings{
        author={Chen Q, Baldocchi D, Gong P and Kelly M},
        title={ Isolating Individual Trees in a Savanna Woodland Using Small Footprint Lidar Data},
        booktitle={Photogrammetric Engineering and Remote Sensing, 72(8): 923-932},
        year={2006},
    }



View the CHM Segmentation Results
After the CHM segmentation is completed, each input CHM data will generate a corresponding CSV file and SHP file, and the CHM can be
superimposed and displayed with the CSV file and the shp file. Load the CHM, csv and shp files into the software respectively. The following
figure shows the superimposed display effect of CHM and shp data, and the attribute table of csv data.

Open the csv file as a table, as shown below, and select the X, Y, Z corresponding to the TreeLocationX, TreeLocationY and TreeHeight,
respectively. Check the "Show Label" option (if the label has too much text and block other information, one can remove the data and reopen
it without checking the "Show Label" option). Click “Apply” to load the csv file in the software.

On the csv file name, click the mouse right button, select Table Attribute, and the property information will be prompted. Double-click on the
mouse left button anywhere in each line, the viewer will jump to the corresponding individual tree location.



Point Cloud Segmentation

Summary

Point Cloud Segmentation can directly segment LiDAR point cloud, which can reduce the influence of under-canopy information loss in the
CHM segmentation method. Individual tree information, including tree location, tree height, crown diameter, crown area and crown volume
can be obtained from the segmentation results.

Background

The point cloud segmentation algorithm was developed by Li et al.(2012). This method assumes that there are always gaps between trees.
By finding the local maximum as seed points, each individual tree can be segmented based on the geometric correlations between each point
and the seed points. The principle of this method is shown below:

The algorithm starts from the global maximum value, using it as the seed point A of the first segmented tree. Then, another local maximum, B,
which is close to A but with a distance to A d  larger than the user-defined threshold, will be used as the seed point of the second
segmented tree. Every point between A and B will be clustered to one of these two trees following the minimum spacing rule. For example, if
the spacing between point C and the first tree d  is less than that between point C and the second tree d , point C will be clustered to the
first tree correspondingly; if the spacing between point D and the first tree d  is larger than that between point D and the second tree d ,
point D will be clustered to the second tree; if a point (point E) has the same distances to point A and point B, it will be set as the boundary
point of these two trees. The spacing threshold should be close to the radius of the individual tree crown. When the spacing threshold is too
large or too small, under-segmentation or over-segmentation may occur.

Usage

To identify individual trees using point cloud segmentation, navigate to and click on ALS Forest > Segmentation > Point Cloud Segmentation.

AB

AC BC
AD BD



Settings

From Class: Classes which participate in the point cloud segmentation (All classes by default).
Input Data: Ensure that each input point cloud data is Normalize by DEM or Normalize by Ground Points. The input file can be a single
file or multiple data files. Point cloud data should be opened in LiDAR360 before being segmented.
Spacing Threshold (meter)(default value is "2"): The 2D euclidean distance between the top of the tree is very important for tree
segmentation. When setting the distance threshold parameter, the threshold value should be lower than the minimum allowable 2D
Euclidean distance between two adjacent trees.
Height Above Ground (meter)(default value is "2"): Usually it is desirable to ignore points below a certain height to avoid the influence
of low vegetation (e.g., grass and shrubs). Points below this threshold will not be considered in the segmentation. A value of 2 meters is
commonly used.
Optimize color rendering for individual tree segmentation result (checked by default): By reorganizing the tree ID generated after
the individual tree segmentation, it can greatly solve the problem of rendering the same color to the trees next to each other.
Output Path: Path of the output file. The resultant product is a comma-separated table in .csv format which contains the TreeID, location
(x and y coordinates), height, crown diameter, crown area and crown volume of each individual tree. Refer to ALS point cloud
segmentation results for the output example.
DefaultValue: Restore the default parameters.

Note: Only when the point cloud data are loaded in the software, can you use the Point Cloud Segmentation function; otherwise the
message "There is no point cloud data meeting the conditions of calculation!" will pop up. If the maximum Z value of the point cloud is
greater than 200 meters or the maximum Z minus the minimum Z is greater than 200 meters, the data is considered to not have been
normalized, and the prompt information shown in the figure below will pop up. Click “YES” to keep using this type of data in the
operation; otherwise, click "NO" and reselect the input data file.

    @inproceedings{
        author={ Li W K, Guo Q H, Jakubowski M K and Kelly M},
        title={A new method for segmentation individual trees from the LiDAR point cloud},
        booktitle={ Photogrammetric Engineering and Remote Sensing,78(1):75-84},
        year={2012}
    }



View the Point Cloud Segmentation Results
After segmenting the trees, Tree IDs are saved to each point in the point clouds used in the segmentation, the results can be viewed within a
window viewer. Load the point cloud used for the tree segmentation into a 3D viewer. Ensure the viewer is active and press the Display by
Tree ID button in the color tools toolbar. The following is an example of a point cloud colored by individual tree. The ALS Editor tool can be
used to check the single tree segmentation results. At the same time, it can be used for editing operations such as add, delete seed points
etc., and segment the point cloud data based on the edited seed points.

The tree ID attribute of each point can be queried by the Pick Point（ ）tool on the toolbar.

CSV file generated by segmentation can be superimposed with the point cloud, and the CSV file can be opened as a table. Select X, Y and Z
as the TreeLocationX, TreeLocationY and TreeHeight respectively in the CSV file as shown below, and check the Show Label (if the label has
too much text and blocking other data, affect the display effect, you can remove the data and open again, do not check the Show Label), click
“Apply” to load the CSV file in the software.



Click the right mouse button on the CSV file name, select Table Attribute, you can view the property information, double-click the left mouse
button anywhere in each line, you can jump to the corresponding location. The following figure shows the effect of superimposed display of
point cloud data and CSV file. Open the attribute table of the CSV file and double-click to jump to the selected row.



Generate Seed Points from CHM

Summary

This tool aims to generate individual tree seed points from CHM so that they can be used for Point Cloud Segmentation based on Seeds. The
ALS Editor tool can be used to edit the seed points and therefore improve the individual tree segmentation accuracy.

Usage

Navigate to ALS Forest > Segmentation > Generate Seed Points from CHM.

Settings

Input Data: The input file can be a single CHM file or multiple CHM files. The data should be opened in LiDAR360 before being
processed.
Maximum Tree Height (meter)(default value is "80"): The threshold defining the maximum tree height in a study areas. CHM pixels
above this threshold will not be considered in the segmentation.
Minimum Tree Height (meter)(default value is "2"): he threshold defining the minimum tree height in a study areas. CHM pixels below
this threshold will not be considered in the segmentation.
Buffer Size (pix)(default value is "50"): A threshold controls the block size for performing CHM segmentation, which can avoid physical
memory overflow. This value should be larger than the maximum crown area and smaller than 1500. If the CHM is larger than 1500 by
1500 pixels, the CHM will be forced to divided into a number of blocks with a size of 1500 by 1500 pixels.
Gaussian Smooth (optional): This parameter is to control whether to perform Gaussian smoothing. In general, it is recommended to
check the Gaussian smoothing option to remove noise effects.
Sigma (default value is "1"): Gaussian smoothing factor. The greater the value is, the smoother the results are. The degree of
smoothness can affect the number of trees being segmented. In the case of under-segmentation, it is recommended to reduce this value
(e.g. 0.5); and in the case of over-segmentation, it is recommended to increase the value (e.g. 1.5).
Radius (pix)(default value is "5"): The window size used by Gaussian smoothing, which should be an odd number. Generally, it can be
set to the average crown diameter.
Output Path: Path of the output file. The resultant product is a comma-separated table in “csv” format which contains ID and x, y, z
coordinates of each seed points.
DefaultValue: Restore the default parameters.

Note: Generate Seed by CHM Segmentation function can only be used when the raster data is loaded in the software. Otherwise, the
message “There is no raster data!” will pop up. The interface and parameters setting of Generate Seed by CHM are the same as those
of CHM Segmentation. The difference between these two tool is that CHM Segmentation will generate a csv file that includes attributes
such as tree height, crown diameter and crown area, and a shp file for tree boundary, while Generate Seed by CHM will not generate a
shp file. For the seed point file format, refer to Seed Points File.



Generate Seeds from Layer Stacking

Summary

This tool aims to generate individual tree seed points using an layer stacking algorithm so that they can be used for Point Cloud Segmentation
based on Seeds. The ALS Editor tool can be used to edit the seed points and therefore improve the individual tree segmentation accuracy.

Usage

Navigate to ALS Forest > Segmentation > Generate Seeds from Layer Stacking.

Settings

Input Data: Ensure that each input point cloud data is Normalize by DEM or Normalize by Ground Points. The input file can be a single
file or multiple data files. Point cloud data should be opened in LiDAR360 before being processed.
XSize (meter)(default value is "1"): Grid x-axis resolution. It is recommended to set this parameter between 0.3m and 2m.
YSize (meter)(default value is "1"): Grid y-axis resolution, It is recommended to set this parameter between 0.3m and 2m.
Height Above Ground (meter)(default value is "2"): Usually, it is desirable to ignore points below a particular height to avoid influence
low vegetations (e.g., grass and shrub). Points below this threshold will not be considered in the segmentation. A value of 2 m is
commonly used.
Layer Thickness (meter)(default value is "1"): The layer thickness is used to cut the layer for stacking. It is recommended to set this
parameter between 0.5m and 2m.
Minimum Spacing Between Trees (meter)(default value is "1"): This parameter should be set as the minimum spacing of the tree.
This parameter can be adjusted to avoid over- or under-segmentation.
Buffer Size (pix)(default value is "50"): A threshold controls the block size for performing segmentation, which can avoid physical
memory overflow. This value should be larger than the maximum crown area and smaller than 1500. If the image is larger than 1500 by
1500 pixels, it will be forced to divided into a number of blocks with a size of 1500 by 1500 pixels.
Gaussian Smooth (optional): This parameter is to control whether to perform Gaussian smoothing. In general, it is recommended to
check the Gaussian smoothing option to remove noise effects.
Sigma (default value is "1"): Gaussian smoothing factor. The greater the value is, the smoother the results are. The degree of
smoothness can affect the number of trees being segmented. In the case of under-segmentation, it is recommended to reduce this value
(e.g. 0.5); and in the case of over-segmentation, it is recommended to increase the value (e.g. 1.5).
Radius (pix)(default value is "5"): The window size used by Gaussian smoothing, which should be an odd number. Generally, it can be
set to the average crown diameter.
Output Path: Path of the output file. The resultant product is a comma-separated table in “csv” format which contains the ID and x, y, z
coordinates of each seed points.
DefaultValue: Restore the default parameters.

Note: Only when the point cloud data is loaded in the software can you use the Generate Seed by Layer Stacking function; otherwise,
the message "There is no point cloud data meeting the conditions of calculation!" will pop up. If the maximum Z value of the point cloud
is greater than 200 m or the maximum Z minus the minimum Z is greater than 200 m, the data is not considered to have been



normalized, and the prompt information shown in the figure below will pop up. Click “YES” to keep using this type of data in the
operation; otherwise, click "NO" and reselect the input data file. The seed point file obtained by layer stacking is the same as the seed
point file generated by CHM, please refer to Seed Points File.



Point Cloud Segmentation from Seed Points

Summary

This function supports batch processing of multiple files. The input data includes normalized point cloud data and the corresponding seed
points file. For the generation of seed points file please refer to Generate Seed Points from CHM and Generate Seeds from Layer Stacking.

Usage

Navigate to and click on ALS Forest > Segmentation > Point Cloud Segmentation from Seed Points.

Settings

From Class: Classes which participate in the PCS with seeds (all classes by default).
Input Data: Ensure that each input point cloud data is Normalize by DEM or Normalize by Ground Points.
Point Cloud File: Click  to select the point cloud data to be processed.
Seed File: Click  to select the seed file.

: Five datasets can be processed in batch by default. Click to add more files to be processed.
: Delete the selected point cloud and seed points file.
: Clear the file list.

Height Above Ground (meter)(default value is "2"): Point cloud data above this value will be divided into single trees. To split low
trees, set this value to be smaller than the minimum tree height to be divided.
Optimize color rendering for individual tree segmentation result (checked by default): By reorganizing the tree ID generated after
the individual tree segmentation, it can greatly solve the problem of rendering the same color to the trees next to each other. Note: if
choosing to optimize the color rendering, the tree IDs in new csv file for individual tree segmentation are not one-to-one correspond to
those in the input seeds files.
Output Path: Path of the output file. The output product is a comma-separated table in the .csv format which contains the ID of each
tree, the x, y coordinate locations, the tree height, the crown diameter, the crown area and the crown volume. Refer to ALS point cloud
segmentation results.
DefaultValue: Restore the default parameters.

To view the segmentation results, please refer to View the Point Cloud Segmentation Results.



Batch Process
The batch processing menu contains the automated workflows for the extraction of forest metrics, which includes Forest Metrics, Point Cloud
Segmentation, Canopy Height Model(CHM) Segmentation, and all prerequisites for these operations as follows:

1. Remove Outliers
2. Classify Ground Points (Filter)
3. DEM
4. Normalize by DEM
5. Forest Metrics, Point Cloud Segmentation or Canopy Height Model(CHM) Segmentation processing

Forest Metrics

Point Cloud Segmentation

Canopy Height Model(CHM) Segmentation



Forest Metrics

Usage

Navigate to ALS Forest > Batch Process > Forest Metrics. The For Forest Metrics tool can extract all metrics found in the ALS Forest > Forest
Metrics automatically.

The first interface that appears in the dialog box is a series of steps to be followed in the automatic extraction of statistical parameters.

If any process has been completed, it can be ignored in the batch. Clicking “Next” will prompt a dialog shown as follows to ask whether the
uncheck step has been done? If yes, click "OK" to the next step to select the file for batch processing.

All the point cloud data opened in the software is showed in the list of unprocessed file. Users can determine whether the data is involved in
the operation use the check box in front of the file name. By default, each point cloud data will be processed separately. If you check "Merge
files into one", the software will merge the selected point cloud data into one file before subsequent processing.

Click “Next” and set appropriate parameters for all steps involved in the batch processing.

For parameters setting of "Outlier Removal", please refer to Remove Outliers.



For parameters setting of "Classify Ground Points", please refer to Classify Ground Points.

For parameters setting of "DEM", please refer to DEM.

At the step of "Input DEM File", users can choose the DEM generated by the last step or an existing one already loaded into the project (the
speed of batch processing will increase dramatically if an existing DEM is used rather than creating it at every batch).

Click “Next” and choose the "Forest Metrics Type" which need to be extracted. Depending on the choice, a set of parameters will need to be
given, please refer to Forest Metrics.



Click “Finish” to begin the batch process.



Point Cloud Segmentation

Usage

Navigate to ALS Forest > Batch Process > Point Cloud Segmentation. The Point Cloud Segmentation tool is used for automatic segmentation
and processing of airborne LiDAR data.

The steps of this process are similar to the Forest Metrics. For more information about the point cloud segmentation, please refer to the Point
Cloud Segmentation.



Canopy Height Model(CHM) Segmentation

Usage

Navigate to ALS Forest > Batch Process > Canopy Height Model(CHM) Segmentation. The CHM Segmentation tool is used for automatic
segmentation and processing of CHM derived from LiDAR data.

The steps of this process are similar to the Forest Metrics. For more information about the CHM segmentation, please refer to the CHM
Segmentation.



Registration
Registration method for forestry data.

Tree Based Point Cloud Registration



Auto Registration by Tree Locations

Summary

This function register two point cloud data sets based on the location of the trees (Li J , Zhao P , Hu Q , et al., 2020) (Guan H , Su Y , Hu T ,
et al., 2019). The location information of the trees is stored in a CSV file, and the file should at least contain two attributes, the TreeLocationX
and TreeLocationY. Please refer to Individual Tree Segmentation Result File Format for the detailed format information. The data to be
registered must be two flat surface with trees, which means the registration will only translate the data and rotate the data around the Z-axis.
The calculation of the transform matrix consists of two steps, namely the calculation of the horizontal rotation matrix and the calculation of the
vertical translation. For horizontal transform, this function first creates feature descriptors for each individual tree position; then votes based
on the similarity of the feature descriptors. The individual tree position with the higher score will be used as the matching point, and finally
calculate the two-dimensional rotation matrix according to the matching points. For registration in the vertical direction, this function first
obtains the point cloud in the neighborhood of each individual tree, and then uses the maximum or minimum value in the point cloud for
registration in the Z direction. This process uses the 3σ principle to make the confidence level of the difference in Z direction highest. The
success rate of registration depends on the matching degree between the point cloud to be registered and the corresponding position of the
registration point cloud. The higher the matching degree, the higher the algorithm success rate. The matching degree of individual tree
depends on the degree of data overlap. the accuracy of position, and so on.

Usage

Click ALS Forest > Registration > Auto Registration by Tree Locations

Settings

Reference Point Cloud: The reference point cloud data. After the registration, the point cloud to be registered will be transform to the
coordiante system of the reference point cloud.
Point Cloud to be Registered: The point cloud data to be registered. After the registration, the transform matrix will be applied to this
point cloud data and generate a new file.
Number of Neighborhood Points (default value is 8): The size of the neighborhood used to generate the feature descriptors. The
increase of the size of the neighborhood will increase the time complexity of the algorithm, while it will increase the robustness of the
feature descriptors at the same time. The decrease of this value will improve the algorithm efficiency, while it will increase the number so
that the matching point outliers as well. This value should be set to 8 ~ 12.
Minimum Votes (default value is 6): The individual tree positions below this number of votes will be considered as outliers and will not
participate in the match. The smaller this value, the more matching points will be obtained, but the error of matching point pairs will also
be greater. The larger this value is, the fewer matching points are obtained. If the value is too large, there will not be enough matching
points for transform matrix calculation. When the number of neighborhood points increases, this value can be increased accordingly. This
value should be set to 6 ~ 9.
Homography Matrix Backprojection Error (default value is 3.0): Backprojection error of homography matrix. Candidate points



selection is performed by using homography matrix combined with Ransac algorithm. The smaller the backprojection error, the fewer the
matching points of the selected single wood and the higher the matching degree. The larger this value is, the looser the filter conditions
for matching points are, and the greater the error of matching point pairs. While this value is too small, it may lead to not enough
matching points participating in the calculation. This value should be set to 2~4 most suitable.
Searching Radius （meter) (default value is 2.0): When performing Z-direction registration, the search radius used for neighborhood
search. When registering in the Z direction, users need to find the real point cloud of each individual tree in a certain neighborhood on the
XY plane, and then use the coordinates of the real point cloud for registration. If the value is too large or too small, the point cloud will not
be able to describe the real terrain relief. This value should be set to 1.0~3.0, if it is too large, it will reduce the efficiency of the algorithm.
Z Translation ("Minimum" by default): There are two registration methods in the Z direction, namely "maximum value" and "minimum
value". This value describes that after performing a radius search on the position of the individual tree, the "maximum/smallest value" of
the point cloud in the neighborhood is taken as the true matching point, which is used to calculate the final translation in the Z direction.
When using the "maximum value", it is necessary to ensure that there is no missing or distorted treetop point cloud near the individual
tree, otherwise it will be impossible to extract accurate matching points from the point cloud. When using the "minimum value", it is
necessary to ensure that there are enough ground points near the individual wood, otherwise the Z direction matching will fail.

    @inproceedings{
        author={Li J , Zhao P , Hu Q , et al.},
        title={ Robust point cloud registration based on topological graph and Cauchy weighted lq-norm},
        booktitle={Isprs Journal of Photogrammetry & Remote Sensing, 160:244-259},
        year={2020},
    }

    @inproceedings{
        author={Guan H , Su Y , Hu T , et al.},
        title={ A Novel Framework to Automatically Fuse Multiplatform LiDAR Data in Forest Environments Based on Tree Locations},
        booktitle={IEEE Transactions on Geoence and Remote Sensing},
        year={2019},
    }



Clear Tree ID

Summary

After the point cloud being segmented, the tree ID information is stored in the LiData file. If the segmented point cloud data needs to be
segmented again, users need to clear the tree ID first.

Usage

Navigate to ALS Forest > Clear Tree ID.

Select the point cloud data to be processed, click "OK".



Clear Tree ID by CSV File

Summary

After the point cloud is segmented, there may be a wrongly segmented tree. The ID corresponding to the wrongly segmented tree can be
recorded in a CSV file, and then the CSV file can be used to clear the wrongly segmented tree in the point cloud.

Usage

Click ALS Forest> Clear Tree ID by CSV File.

Select the point cloud data to be processed and click OK.



Statistic Individual Tree Attributes

Summary

This function is used to correct the tree heigh, crown area, and other individual tree information after the individual tree editing.

Usage

Click ALS Forest > Statistic Individual Tree Attributes.

Settings

Input Data: The input data should be the point cloud after individual tree segmentation.
Height Above Ground (meter) (default value is "0.3"): The point above this height will be used in the segmentation. This parameter
can help uses to weaken the influence from the ground or grasses on the statistics calculation. If this value is too large, it will impact on
the detection of tree structure.
Minimum Tree Height (meter) (default value is "2"): This parameter can be set according to the growth situation of trees in the
measuring area. It can be used to filter the small trees.
Output Path: The output path of the statistics result. The file contains the Tree ID, XY location of each tree, tree height, crown diameter,
crown area, and crown volume.
Default: Reset all the parameters as their default values.



Extract by Tree ID

Summary

This function is used to extract part or all point clouds from the segmented point cloud based on Tree ID. When exporting the data into one
file, the optional formats include LiData, CSV, and LAS. When exporting the data into multiple data, the optional format will be CSV file only.

Usage

Navigate to ALS Forest > Extract Point Cloud by Tree ID.

Settings

Select File: Select the point cloud data with segmented tree ID information from the drop-down list. Only one file can be selected at a
time, and it has to be opened in LiDAR360 already.
Min (default value is "0"): The minimum value of tree ID to be extracted. The default value is zero.
Max: The maximum value of tree ID to be extracted. The default value is the number of trees in the point cloud. If the point cloud has not
been segmented, the minimum and maximum values of the tree ID are both zero.
Extract to A File (default): The point cloud in the selected range is extracted into a CSV, LiData, or LAS file that contains the X, Y, Z
coordinates and tree ID information.
Extract to Multiple Files Based on Tree ID: Extract the point cloud data based on tree ID and save them as different CSV files for each
tree. The stored information are X, Y, Z coordinates and tree ID information for each tree.
Output Path: Output path for the results.



Forest Structure Change Detection

Summary

The LiDAR PAC (profile area change) metric, as a simple and integrated method, demonstrated promising potential in characterizing fine-
grained changes in forest structure. The method can be beneficial for forest managers in evaluating fire-induced environmental and economic
losses, and provide useful information for forest restoration design.

Principle Description

First, this function divides the data into different grids according to the XSize and YSize set by the users. For each grid, normalize the height
value of all the points to the range of 0 to 1. And then, sort the points by height and calculate its cumulative height percentile. Calculate the
height value for each integer cumulative percentile from 0 to 99% (100 values in total). Then fit the 100 cumulative height percentiles to the
profile curve, and calculate the profile area (PA) delineated by the percentile profile curve and the X axis. After calculating the PA value of the
curve area before and after the change, use the PA after the change minus the PA value before the change to get the PAC value.

Usage

Click ALS Forest > Forest Structure Change Detection

Settings

Input: Make sure that all the input files are normalized. The input file(s) can be a single file or a file set. The file(s) to be processed must
be opened in LiDAR360 before using this function.
XSize (meter) (default value is "30"): The grid size in X direction. This value should be larger than the crown size of the trees. For the
data acquired from most of the forest, this value should be larger than 15.
YSize (meter) (default value is "30"): The grid size in Y direction. This value should be larger than the crown size of the trees. For the
data acquired from most of the forest, this value should be larger than 15.
Height Threshold (meter) (default value is "2"): The threshold to divide the data in vertical direction. The point cloud above this height
will be used to calculate the forest metrics. The default value is 2.
Output Path: Path of the output file. Two PA images (before and after the change), a PAC image, and a report will be generated.
DefaultValue: Restore the default parameters.

Note: The selected point cloud data must be normalized ALS data.

    @inproceedings{
        author={Tianyu Hu,Qin Ma,Yanjun Su,John J.Battles,Brandon M.Collins,Scott L.Stephens,Maggi Kelly,Qinghua Guo},
        title={A simple and integrated approach for fire severity assessment using bitemporal airborne LiDAR data},
        booktitle={Int J Appl Earth Obs Geoinformation,78(2019): 25-38},
        year={2019}
    }



ALS Editor

Summary

The ALS editor tools are used for checking the ALS individual tree segmentation results, editing (i.e., adding and deleting) seed points, and
segmenting point cloud data based on the edited seed points.

Usage

In an active window, load the ALS point cloud data to be edited.

Navigate to and click on ALS Forest > ALS Editor.

The ALS Editor toolbar options, from left to right, are: Start/End Edit, Open Seed Point File, Save Seed Point File, Add Seed Points, Select
Seed Points, Deselect Seed Points, Cancel Selection, Delete Selected Seed Points, Clear All Seed Points, Profile, Filter Trees, Point Cloud
Segmentation Based on Seed, Clear TreeID, Seed Setting, and Exit.

Start/End Edit

Click Editor > Start Edit.

Select the data to be edited (this should be a normalized point cloud and only one dataset can be edited at a time). Click “OK”, and then other
functions on the ALS Editor toolbar will be available.

During the editing process the selected data cannot be removed from the window. When editing is completed, click “End Edit”. Other toolbar
functions will be unavailable at this point.



Open Seed Points File

Save Seed Points File

Add Seed Points

Select Seed Points

Brief: Select a seed point file (please refer to Seed Points File in the appendix for the correct format) and the window below will
pop up. Please note that there is a header line in the seed point file, therefore the first line should be ignored when the file is
opened.

Brief:When the editing is completed, the seed points can be saved as a new CSV file without overwriting the original file.

Brief: Add seed points manually in under-segmented areas. Users may be prompted to select the peak - or the point close to the
peak - of a tree as the seed point.

Brief: Select seed points for editing.



Deselect Seed Points

Cancel Selection

Delete Selected Seed Points

Clear All Seed Points

Profile

Filter Trees

After filtering the point clouds by tree height (from 2.71 meters to 10 meters), the filtered results will be highlighted (as shown below).

Brief: This tool can be used to deselect incorrect seed points which may have been selected in error.

Brief: Cancel the selection of seed points.

Brief: For areas that are over-segmented, incorrect seed points can be selected and deleted by using the Select tool.

Brief: Remove all seed points in the window.

Brief: When the ALS Editor toolbar is opened, the point cloud window will change to 2D display mode. The profile tool can show if
the seed points are accurate in 3D. Click the Profile Tool button and a new window will be created. Click the mouse left button to
select a polygon and all points within the polygon will be displayed in the new window in 3D.

Brief: After point cloud segmentation, properties like tree height and crown area can be obtained. Filter Trees can be used to view
(highlighted), hide, delete, or export individual trees based on individual tree properties, such as TreeID, tree height and crown
area. For example, users can view the trees with height in a certain range. Or users can select the trees with extremely small or
large crow area, which may be over-segmented or under-segmented. When using this function, users must add the segmented
point cloud and the segmentation result to the software.



Point Cloud Segmentation Based on Seed

Clear Tree ID

Seed Setting

Color (default color is "Red"): Click , and then the dialog for selecting colors will pop up as shown below. Any color may be
selected as the seed point color from this window.

Alpha (default value is "0.5"): Transparency of the seed point, ranging from 0 to 1, with 0 being completely transparent and 1 being
opaque. The default value is 0.5. Click  and the value will be incremented or decremented by 0.1, or the user can
directly enter a specific value.

Show Seed ID (optional): Use the check box to determine if the seed point ID is displayed in the window.

Brief: Segment the point cloud data based on the edited seed points. Refer to PCS with Seeds.

Brief: If the point cloud data has been previously segmented, the Tree ID should be removed prior to performing individual tree
segmentation again. Refer to Clear Tree ID.

Brief: Users can set the color, alpha and size of the seed points, and may choose to show the seed point ID and its label size.



Seed Size (default value is "0.5"): The seed size, ranging from [0,100). Click  and the value will be incremented or
decremented by 1, or the user can directly enter a specific value.
Label Size (default value is "1"): The label size, ranging from [0, 100). Click  and the value will be incremented or
decremented by 1, or the user can directly enter a specific value.

Exit

Note: If the point cloud has been segmented, you need to Clear Tree ID prior to segmenting it again. If segmentation has not been
performed, the message "All files have been segmented, please clear tree ID first!" will be displayed.

Brief: To exit ALS Editor, click the exit button and a prompt window below will pop up. Click “Yes” to close the ALS Editor toolbar
or click “No” to return to the editor window.



TLS Forest
The TLS Forest modules are specifically for terrestrial LiDAR scans, including methods for ground point classification, segmenting individual
trees from a LiDAR scan by identifying tree trunks, editing individual tree properties, editing individual tree, etc.

Leaf Area Index

Filter Ground Points

Point Cloud Segmentation

View the Point Cloud Segmentation Results

Point Cloud Segmentation from Seed Points

Clear Tree ID

Extract by Tree ID

Statistic Individual Tree Attributes

Increase Individual Tree Attribute

TLS Stem Extraction

TLS Editor

Individual Tree Editor

DBH Measure



Leaf Area Index

Summary

Leaf Area Index (LAI) is defined as half of the surface area of all leaves projected on the surface area of a unit.

Principle Description

The algorithm was developed according to Li et al. (Li et al.,2016).For each statistical unit, a three-dimensional network is first constructed
with a cell size of 1.5 times the average distance between each two points. Then, for the constructed three-dimensional network, count the
total number of three-dimensional cells in each layer and the number of cells containing laser points in that layer. Based on that result,
calculate the frequency of laser points in each layer.

Where </img> is the point frequency of the s-th layer,  is the number of cells which contains the laser points in the s-th layer; 
 is the total number of three-dimensional cells in the s-th layer. And then calculate the LAI in the s-th layer:

Where  is the leaf inclination correction factor. Usually, it is set as 1.1. Finally, accumulate the LAI of each layer to calculate the LAI for
the entire statistical unit.

Usage

Click TLS Forestry > Leaf Area Index, to generate TLS leaf area index.

Settings

Input Data: Ensure that each input point cloud data is Normalize by DEM or Normalize by Ground Points. The input file can be a single
file or multiple data files. Point cloud data should be opened in LiDAR360 before being processed.
XSize (meter)(default value is "15"): The length of a grid size should be greater than an individual tree crown width. For most forest
types, the grid size should be greater than 15 meters.
YSize (meter)(default value is "15"): The width of a grid size should be greater than an individual tree crown width. For most forest
types, the grid size should be greater than 15 meters.
Volex Size Setting：

Volex Size (meter) (default value is "0"): The size of the cell which is used to divide the statistical unit.
Coefficient (default value is "1.5"): The coefficient used to calculate the size of the three-dimensional cell. The cell size is the
product of this coefficient and the average distance between each two points in the point cloud.



Output Path: Path of the output file. A corresponding raster file (.tif format) will be generated for each input point cloud data. The .tif files
can be used as an independent variable of the regression analysis.

Note: Only when the point cloud data is loaded in the software can you use the TLS Leaf Area Index function; otherwise, the message
"There is no point cloud data meeting the conditions of calculation!" will pop up. If the maximum Z value of the point cloud is greater
than 200 m or the maximum Z minus the minimum Z is greater than 200 m, the data is not considered to have been normalized, and
the prompt information shown in the figure below will pop up. Click “YES” to keep using this type of data in the operation; otherwise,
click "NO" and reselect the input data file.

@inproceedings{ author={ Li Y , Guo Q , Tao S , et al.}, title={Derivation, Validation, and Sensitivity Analysis of Terrestrial Laser Scanning-
Based Leaf Area Index}, booktitle={ Canadian Journal of Remote Sensing, 2016, 42(6):719-729.}, year={2016} }



Filter Ground Points

Summary

Extract ground points from TLS point cloud data.

Usage

Navigate to TLS Forest > Filter Ground Points.

Settings

Input Data: The input data can be a single point cloud data file or multiple data files. Point cloud data should be opened in LiDAR360
before being filtered.
From Class: The list of point cloud classes that can be used for ground point filtering. If a certain class is existed in the point cloud and
its check box is checked, it will be involved in the filtering operation.
To Class: Targeted class.
Grid Size (meter)(default value is "0.5"): Resolution of the grid.
Ground Thickness (meter)(default value is "0.3"): Point cloud data from the lowest point of the grid to the points with the user-defined
thickness will all be classified as ground points.
Window Smooth (optional): Use neighborhood grid data to conduct ground point consistency filtering.
Window Size (default value is "3"): Size of the neighborhood window. 3 indicates a window size of 3*3.
DefaultValue: Restore the default parameters.



Point Cloud Segmentation

Summary

The TLS point cloud segmentation method (originally developed by Tao et al.,2015) utilizes a bottom-up approach to identifying individual
trees. This is because TLS data is typically acquired beneath the canopy where tree stems can be readily observed and used to inform the
segmentation algorithms that delimit the spatial extents of individual trees within a forest or stand. Individual Tree attributes, including Tree
Height and Diameter at Breast Height (DBH), can be then determined for each tree segmented out of the input TLS dataset.

Usage

Navigate to and click on TLS Forest > Point Cloud Segmentation.

Settings

Input Data: Ensure that each input point cloud data is Normalize by DEM or Normalize by Ground Points.
From Class: Classes which participate in the point cloud segmentation (all classes by default).
Cluster Tolerance (meter)(default value is "0.2"): Users can control the accuracy and efficiency of the individual tree segmentation
process by changing this value. Increase of this threshold will result in higher efficiency of the individual tree segmentation process. But if
this threshold is too large, it will lower accuracy.
Minimum Cluster Size：This parameter will influence the growing of point cloud of individual tree's crown. Fewer points will lead to higher
accuracy and lower efficiency. Vice versa.
Maximum DBH (meter)(default value is "1.4"): Upper DBH threshold for fitting DBH.
Minimum DBH (default value is "1.2"): Lower DBH threshold for fitting DBH.
Height Above Ground (meter)(default value is "0.3"): Only the points above this height will be involved in individual tree segmentation.
This parameter is used to decrease the influence of ground points and weeds to the segmentation. It will influence the accuracy of the
detection of trunk, if this value is too large.
Minimum Tree Height (meter)(default value is "2"): Lower threshold of an object which could be recognized as a tree. This is used for
filtering out small trees based on the growth rate of the region.
Trunk Height (meter)(default value is "1.6"): the algorithm will extract the points in the range between Height Above Ground and
Trunk Height, and detect the trunk used as the starting point of growing of point could. It is suggested that this value should be less than
the height of the lowest branch.
Optimize color rendering for individual tree segmentation result (checked by default): By reorganizing the tree ID generated after
the individual tree segmentation, it can greatly solve the problem of rendering the same color to the trees next to each other.
Output Path: Path of the output file, which is a comma-separated database table in the .csv format containing the ID of each individual
tree identified during the segmentation process, the x, y coordinate of each individual tree, individual tree heights, DBHs, crown
diameters, crown areas, and crown volumes. Please refer to Individual Tree Segmentation Result File Format in the appendix.Please
refer to View the Point Cloud Segmentation Results for the steps to view the results.
DefaultValue: Reset each parameter to the default value.

    @inproceedings{
        author={Tao S L, Wu F F, Guo Q H, Wang Y C, Li W K, Xue B L, Hu X Y, Li P, Tian D, Li C,Yao H, Li Y M, Xu G C and Fang J Y},
        title={Segmentation tree crowns from terrestrial and mobile LiDAR data by exploring ecological theories},
        booktitle={ISPRS Journal of Photogrammetry and Remote Sensing,110:66-76},



        year={2015}
    }



View the Point Cloud Segmentation Results
After segmenting the trees, Tree IDs are saved as an attribute to each point in the point cloud data. The results can be viewed within a
window viewer. Load the point cloud used for the tree segmentation into a 3D viewer. Ensure the viewer is active and press the Display by
Tree ID button in the toolbar. The following is an example of a point cloud colored by individual tree. TLS Editor tools are used for checking
the TLS individual tree segmentation results. Moreover, it can be used to edit operations such as add, delete seed points, and segment the
point cloud data based on the edited seed points.

The tree ID attribute of each point can be queried by the Pick Point（ ）tool on the toolbar.

CSV file generated by segmentation can be overlaid with the point cloud, and the CSV file can be opened as a table. Select X, Y and Z as the
TreeLocationX, TreeLocationY and TreeHeight respectively in the CSV file as shown below, and check the Show Label (if the label has too
much text and blocking other data, one can remove the data and reopen it without checking the Show Label). Click “Apply” to load the CSV
file in the software.

To view the DBH, CSV can also be selected to be displayed by circle and select DBH as the diameter.

Click the mouse right button on the CSV file and select Table Attribute. The property information will be displayed. Double-click the mouse left
button anywhere in each line, and it will jump to the corresponding location. The following figure shows the effect of superimposed display of
point cloud data and CSV file.





Point Cloud Segmentation from Seed Points

Summary

The TLS PCS with Seeds function supports batch processing for multiple files. The input data includes normalized point cloud data and the
corresponding seed point file. For TLS point cloud normalization, please refer to the Normalize by DEM or Normalize by Ground Points tool
section of the LiDAR360 User Manual. For more information on the generation of seed point files, please refer to Batch Extraction DBH tool
section of the LiDAR360 User Manual.

Note: Different from Point Cloud Segmentation from Seed Points in ALS Forest tool set, the DBH values are used in Point Cloud
Segmentation from Seed Points in TLS Forest tool set. According to the 3D coordinates of the seed points, the algorithm will search for the
points within the range of the radius of DBH or the closest point as the original seed points cluster for the following segmentation. If the DBH
values are not available here, please set them to 0. For the format information, please refer to Seed Points File.

Usage

Navigate to and click on TLS Forest > Point Cloud Segmentation from Seed Points.

Settings

From Class: Classes which participate in the PCS with seeds (all classes by default).
Point Cloud File: Click  to select the point cloud data to be processed.
Seed File: Click  to select the seed file.

: Five datasets can be batch processed per tool run. Click  to add files to be processed.
: Delete the selected point cloud and seed points file.
: Clear the file list.

Cluster Tolerance (meter)(default value is "0.2"): Users can control the accuracy and efficiency of the individual tree segmentation
process by changing this value. Increase of this threshold will result in higher efficiency of the individual tree segmentation process. But if
this threshold is too large, it will lower accuracy.
Minimum Cluster Size：This parameter will influence the growing of point cloud of individual tree's crown. Fewer points will lead to higher
accuracy and lower efficiency. Vice versa.
Maximum DBH (meter)(default value is "1.4"): Upper DBH threshold for fitting DBH.
Minimum DBH (default value is "1.2"): Lower DBH threshold for fitting DBH.
Height Above Ground (meter)(default value is "0.3"): Only the points above this hight will be involved in individual tree segmentation.
This parameter is used to decrease the influence of ground points and weeds to the segmentation. It will influence the accuracy of the
detection of trunk, if this value is too large.
Optimize color rendering for individual tree segmentation result (checked by default): By reorganizing the tree ID generated after
the individual tree segmentation, it can greatly solve the problem of rendering the same color to the trees next to each other. Note: if



choosing to optimize the color rendering, the tree IDs in new csv file for individual tree segmentation are not one-to-one correspond to
those in the input seeds files.
Minimum Tree Height (meter)(default value is "2"): Lower threshold of an object which could be recognized as a tree. This is used for
filtering out small trees based on the growth rate of the region.
Output Path: Path of the output file, which is a comma-separated database table in the .csv format containing the ID of each individual
tree identified during the segmentation process, the x, y coordinate of each individual tree, individual tree heights, DBHs, crown
diameters, crown areas, and crown volumes. Please refer to Individual Tree Segmentation Result File Format in the appendix.Please
refer to

View the Point Cloud Segmentation Results for the steps to view the results.

DefaultValue: Reset each parameter to the default value.



Clear Tree ID

Summary

After the point cloud has been segmented, the tree ID information is stored in a LiData file. If the segmented point cloud data needs to be
segmented again, users need to clear the tree ID first.

Usage

Navigate to TLS Forest > Clear Tree ID.

Select the point cloud data to be processed, and then click "OK".



Extract by Tree ID

Summary

This function is used to extract part or all point clouds from the segmented point cloud based on Tree ID.

Usage

Navigate to TLS Forest > Extract by Tree ID.

Settings

Select File: Select the point cloud data with segmented tree ID information from the drop-down list. Only one file can be selected at a
time, and it has to be opened in LiDAR360 already.
Min (default value is "0"): The minimum value of tree ID to be extracted. The default value is zero.
Max: The maximum value of tree ID to be extracted. The default value is the number of trees in the point cloud. If the point cloud has not
been segmented, the minimum and maximum values of the tree ID are both zero.
Extract to A File (default): The point cloud in the selected range is extracted into a CSV file that contains the X, Y, Z coordinates and
tree ID information.
Extract to Multiple Files Based on Tree ID: Extract the point cloud data based on tree ID and save them as different CSV files for each
tree. The stored information are X, Y, Z coordinates and tree ID information for each tree.
Output Path: Output path for the results.



Statistic Individual Tree Attributes

Summary

This function is used to correct the tree heigh, crown area, and other individual tree information after the individual tree editing.

Usage

Click TLS Forest > Statistic Individual Tree Attributes.

Settings

Input Data: The input data should be the point cloud after individual tree segmentation.
Maximum DBH (meter)(default value is "1.4"): Upper DBH threshold for fitting DBH.
Minimum DBH (default value is "1.2"): Lower DBH threshold for fitting DBH.
Height Above Ground (meter) (default value is "0.3"): The point above this height will be used in the segmentation. This parameter
can help uses to weaken the influence from the ground or grasses on the statistics calculation. If this value is too large, it will impact on
the detection of tree structure.
Minimum Tree Height (meter) (default value is "2"): This parameter can be set according to the growth situation of trees in the
measuring area. It can be used to filter the small trees.
Update File (Unchecked by default): If this option is checked and the input file contains the valid DBH values, the DBH values will not
be recalculated. Only other attributes will be updated. If this option is unchecked, or the DBH values in the input file is invalid, all the
attributes will be recalculated.
Output Path: The output path of the statistics result. The file contains the Tree ID, XY location of each tree, tree height, crown diameter,
crown area, and crown volume.
Default: Reset all the parameters as their default values.



Increase Individual Tree Attributes

Summary

This function is mainly used to expand the attribute field of individual tree attribute file.

Usage

Click TLS Forest > Increase Individual Tree Attributes.

Settings

Individual Tree Attributes File: The input data is a individual tree attribute file, which is a comma-separated CSV table, and must
contain at least two fields: TreeLocationX, TreeLocationY, the detailed file format can refer to Individual Tree Segmentation Result File
Format。
Reference File: The reference point file is a comma-separated text file with two lines and three fields: X, Y, and Radius; X and Y are
reference point positions, and Radius is radius. If the reference point file is input, the azimuth and distance of the trees within a certain
radius with the reference point as the center are calculated, and then added to the individual tree property file as extended attributes.
Slope File：The slope file is in TIFF format. If the slope file is imported, the slope of the tree position is obtained and added to the single
tree attribute file as an extended attribute.
DEM File：The DEM file is in TIFF format. If the DEM file is imported, the slope of the tree position is obtained and added to the single
tree attribute file as an extended attribute.

The following is an example of reference point files:

X,Y,Radius
322716.24,4102494.69,15.0

The following is an example of individual tree property file:

TreeID, TreeLocationX, TreeLocationY
1, 322716.24, 4102494.69
2, 322751.21, 4102499.9
3, 322519.35, 4102499.3

The following is an example of the extended individual tree property file:

TreeID, TreeLocationX, TreeLocationY, Azimuth, Distance
1, 322716.24, 4102494.69, 36.165, 8.982
2, 322751.21, 4102499.9, 41.282, 4.491
3, 322519.35, 4102499.3, 32.008, 4.708



Stem Extraction

Summary

This function will identify tree stem from TLS forestry point cloud data and divide them into target categories.

Usage

Click on TLS Forest> Stem Extraction.

Settings

-Input: The input file can be a single point cloud data file or a point cloud data set; the data to be processed must be opened in the LiDAR360
software. -Compute Unit: You can choose GPU or CPU. -Classification Target Class: The user must select at least one function in
classification and segmentation. After checking the classification and running, the stem will be classified into the target class. -Segmentation
Source Class: When the user selects segmentation, the source class trees will be segmented into individual trees. When the classification is
checked, the target class of the classification will be set as the source class of the segmentation. Otherwise, the user needs to specify the
segmentation source class.



TLS Editor

Summary

The TLS Editor toolbar contains functions for checking the results of individual tree segmentation routines run on Terrestrial Laser Scan (TLS)
input data. The TLS Editor is also used to extract Diameter at Breast Height (DBH) for individual trees, to add or delete seed points, to
execute point cloud segmentation operations that include seed points, and to measure physical attributes of individual trees found in the
source dataset.

Usage

Load the point could data to be edited into the viewer and activate the view window.

Navigate to and click on TLS Forest > TLS Editor to load the TLS Editor toolbar in the active view window.

TLS Editor toolbar functions (from left to right): Start/End Editing/Open Seed Point File/Save Seed Point File, Fit DBH, Batch DBH Extraction,
Methods of Fitting DBH (including Fit Circle, Fit Column and Fit Ellipse), Select, Subtract, Cancel Selection, Select Point Cloud, Select Seed
Points, Add Seed Points, Delete Seed Points, Clear All Seed Points, Profile, Measure Individual Tree Attributes, Filter Trees, Point Cloud
Segmentation Based on Seed, Clear Tree ID, Setting and Exit.

TLS Editor Tool Description

Start/End Edit

To begin editing session navigate to and click on Editor > Start Edit.

Select the data to be edited (this should be already be normalized, and only one dataset can be edited at a time). Click “OK”, then a setting
window will pop up to set the color and size of the seed point, whether to display the ID, and the height of point cloud for display. The default
point cloud height for display is 1.2 - 1.4 meters.



In the process of editing, the selected data cannot be removed from the window. Click “End Edit” to complete the editing, and other functions
in the toolbar will then be unavailable.

Open Seed Points File
Brief: Select a seed point file (please refer to Seed Points File in the appendix) for the format of seed point file, and the window
below will pop up. Please note that there is a header line in the seed point file, therefore, the first line should be ignored when the
file is opened.



Save Seed Points File

Fit DBH

The picture below (left) is the result of selecting the point cloud data of an individual tree. The picture below (right) is the result of DBH fitting:
1 indicates ID number, 0.5889 is the fitted DBH value in meters.

Batch Extraction DBH

Min Points Number (default value is "10"): Minimum threshold for the number of trees of each category. If the number is less than this
value, then no DBH fitting will be conducted.

Brief:When editing is completed, the seed points can be saved as a new .csv file without overwriting the original file.

Brief: Select the desired individual tree for DBH fitting.

Brief: Select the point cloud data of multiple trees and then perform batch fitting of tree DBH (the parameter settings are shown as
below). By default, the function uses the entire point cloud in the window for batch DBH fitting. Users can also select out a part of
point cloud for fitting.



The picture below (left) is the result of selecting the point cloud data of multiple trees. The picture below (right) is the result of DBH fitting:
1,2,3 and 4 indicate ID number, 0.5359, 0.5130, 0.6078 and 0.4756 are the fitted DBH value in meters.

Methods of Fitting DBH

Brief: Users can flexibly select the point cloud in a 2D window by setting a height or using the profile window for DBH fitting. Methods of fitting
DBH include Fitting by Circle, Fitting by Column and Fitting by Ellipse. By default, the method of Fitting by Circle is adopted. If the tree is
slanting, the Fitting by Cylinder method can be used.

Fit Circle (optional): Use the least squares method to the fit a circle from the x-y coordinates of input points.
Fit Column: Use the least squares method to fit a three-dimensional cylinder from input points where the diameter is the DBH of the tree.
Fit Ellipse: Use the least squares method to fit an ellipse from the x-y coordinates of input points, and the DBH will be calculated as 2
sqrt（major axis minor axis). This method is for trees with an oval-shaped trunk.

Select

Subtract

Cancel Selection

Select Point Cloud

Select Seed Points

Add Seed Points

Brief: Select traget by using polygon, rectangle, or circle frame. Select point cloud or seed point to fit the DBH. For over-
segmentation, users can select these wrong seed points and delete them.

Brief: If there are point clouds or seed points selected by mistake, this tool can be used to delete the wrong ones from the
selected range.

Brief：Deselect point clouds or seed points.

Brief: Select point cloud to fit DBH.

Brief: Select seed points for editing.

Brief: Add seed points manually in under-segmented places. Users are normally prompted to select the peak or the point close to
the peak of a tree as the seed point.



Delete Seed Points

Clear All Seed Points

Profile

Pan Profile

Measure Individual Tree Attributes

Brief: For places that are over-segmented, wrong seed points can be selected and deleted by using the Select tool.

Brief: Remove all seed points in the window.

Brief: When the TLS Editor toolbar is opened, the point cloud window will change to 2D display mode. The profile tool can show if
the seed points are accurate in 3D. Click the Profile Tool button and a new window will appear. Click the mouse left button to
select a polygon, and all points within the polygon will be displayed in the new window in 3D.

Brief: After drawing the profile area in the main window, users can translate the profiled area by clicking this tool, and see the
profile data in real-time.

Brief: Click this button to open a profile window to measure the attributes of individual trees, including tree height, CBH,
straightness etc., and save the attribute information into a file. If the Editor of Tree Attributes is activated, change of seed points
will not update the attribute table of tree information. If users need to see the updates, re-open the editor window.

: Click this button to save the edited tree attributes to a .csv file.

: (Available under the profile window) Return to the previous record and the profile window will zoom to the tree point cloud jumped



: (Available under the profile window) Return to the previous record and the profile window will zoom to the tree point cloud jumped
to. (Hotkey: ←)

: (Available under the profile window) Go to the next record of current one. And the profile window will zoom to the tree point cloud
jumped to. (Hotkey: →)

: Calculate the straightness of a tree: Users need to select out the point cloud of the tree to be calculated in the profile window.
Then, according to the calculating standard of tree straightness proposed by Macdonald E et al., the height of the selected point
cloud must be higher than 6 meters. If the straightness information has not been updated after calculation, right click on the cell to
refresh.

: Length measurement, to measure tree attributes (e.g. tree height) in the profile window.

: Area measurement, to measure tree attributes (e.g. crown area, crown diameter) in the profile window. The crown diameter can
be derived from the formula S=πr², in which S is the circle area fitted from the measured crown area and r is the corresponding
crown radius.



Profile Radius：Adjust the radius of hexagon in the profile window.

Note: Users must ensure there are seed points in the window before measuring individual tree attributes. If there is no update to edited
tree attributes, users can right click on the corresponding cell to refresh (Hotkey: F5).

DBH Inspector

: Height measurement, to measure tree attributes (e.g. tree height, crown base height) in the profile window.

Brief: This tool is used to check if the overlapped DBHs exsit in the data.



It is shown as follow when this function is activated:

Filter Trees

As shown below, after individual tree segmentation, use the filtering by tree ID method and set the minimum and maximum values as 1 and
10, respectively. The points within this range will be highlighted.

Point Cloud Segmentation Based on Seed

Clear Tree ID

Setting

Brief: This tool is used to check if the overlapped DBHs exsit in the data.

Brief: The individual tree filtering tool is used for manually examining or editing DBH fitting or individual tree segmentation results.
Based on the user-defined filtering range, users can display, hide, delete, extract and highlight individual trees. The filtering
methods are based on confidence level (only for DBH batch fitting results), tree ID, DBH, and tree height (only for individual tree
segmentation results).

Brief: Segment the point cloud data based on the edited seed points. Refer to PCS with Seeds. The tree heights will be
recalculated after tree segmentation.

Brief: If the point cloud data has been segmented already, the TreeID should be removed prior to reperforming individual tree
segmentation. Refer to Clear Tree ID.

Brief: Includes seed point setting and height setting for point cloud display.



Show Point Cloud Height: Set the height for point cloud display in the window. The default height for point cloud display is 1.2-1.4
meters, i.e., the point cloud at the height of a tree’s DBH.

Min Height (meter)(default value is "1.2"): The minimum height of the point cloud displayed in the window. The default is 1.2
meters.
Max Height (meter)(default value is "1.4"): The maximum height of the point cloud displayed in the window. The default is 1.4
meters.

: Increase the display range according to user's input. The range of visualization height will be from Minimum Height minus
user's input to Maximum Height plus user's input.

: Decrease the display range according to user's input. The range of visualization height will be from Minimum Height plus
user's input to Maximum Height minus user's input.

DBH Configuration：
Minimum DBH (meter)(default value is "0.05"): The minimum DBH value based on user's prior knowledge. If the DBH of a tree is
smaller than this value, the fitted DBH will be treated as an error.
Maximum DBH (meter)(default value is "1.00"): The maximum DBH value based on user's prior knowledge. If the DBH of a tree is



larger than this value, the fitted DBH will be treated as an error.
Maximum tree inclination angle (degree)(default value is "30"): The maximum tree inclination angle based on user's prior
knowledge. If the inclination angle of a tree is larger than this value, the corresponding points will not be treated as a tree. Note that
this threshold is only effective to the method of Fit Column.

Seed Setting: Seed point setting includes the color, alpha and size of the seed points, and whether the seed point ID and its label size
are shown.

Color (default color is "Red"): Click , and then the dialog for selecting colors will pop up as shown below. Any color can be
selected as the seed point color from this window.

Alpha (default value is "0.5"): Transparency of the seed point, ranging from 0 to 1, with 0 being completely transparent and 1 being
opaque. The default value is 0.5. Click , and the value will be incremented or decremented by 0.1; or one can directly
enter a specific value.

Display Label: Set if display the label of the Seed ID in the window.
Label Size (default value is "1")：The label size, ranging from [0, 100). Click , and the value will be incremented
or decremented by 1; or you can directly enter a specific value.
Show Seed ID (optional): Use the check box to determine if the seed point ID is displayed in the window.
Size (default value is "0.2"): The seed size, ranging from [0,100). Click , and the value will be incremented or
decremented by 1; or one can directly enter a specific value.

Confidence Level： Estimate the confidence level of batch fitted DBH values, and visualize the fitting results with different confidence
levels using different user-defined colors.

Low Confidence Level： The DBH fitting results is poor, and users need to visually examine and edit the results to improve the
fitting accuracy. Users can set the visualization color.
Medium Confidence Level： The DBH fitting results is medium, and users may need to visually examine and edit the results if
necessary. Users can set the visualization color.
High Confidence Level： The DBH fitting results is very good. Note that if only a single tree was fitted, the default confident level will
be set as high.

Note that if the visualization height range is larger than 0.4 m when fitting the DBH in batch, LiDAR 360 will use a more strict
method to estimate the confidence level. This method usually performed better for trees with a long trunk.

Exit

Note: If the point cloud has been segmented, you need to Clear Tree ID before being segmented again. Otherwise, the message "All
files have been segmented, please clear tree ID first!" will prompt.

    @inproceedings{
        author={ Macdonald E, Mochan S},
        title={Protocol for stem straightness assessment in Sitka spruce},

Brief: To exit TLS Editor, click the exit button and a prompt window will pop up. Click “Yes” to close the TLS Editor toolbar, or click
“No” to return to the editor window.



        booktitle={Journal of Bacteriology,176(17):5578-82},
        year={2000}
    }



Individual Tree Editor

Summary

Individual tree editor can extract the individual tree from the big data point cloud for editing, including functions such as creating trees,
merging trees, and deleting trees.

Usage

Load the point cloud data needs to be edited in the window and make sure to activate that window.

Click TLSForest > Individual Tree Editor to activate the editing bar in current window.

The buttons in the individual tree editor toolbar, from left to right, are: start/end editing, profile, and exit.

Start/End Editing

Click Edit > Start Editing.

Select the data set needs to be edited and click the OK button. The data will be displayed by Tree ID. And all the other functions will become
available.

When the editor is on, the selected data cannot be removed from the window. And after the editing, click stop editing to end the editing.

Profile

Description
Click *Profile* button to open the profile window. Start to draw a hexagon in that window by click the mouse and end drawing by
double-click the mouse. This ROI is the area to be edited. And at this moment, the individual tree editing toolbar will appear at the
top of the profile window. The tools are, from left to right, load/remove editing area, save, create tree, delete tree, undo, and redo.



Note: Please pay attention to the boundary of the hexagon when selecting the ROI in this profile tool. If the tree is not completely
selected, the result may be influenced. Or users can avoid editing the edge of the point cloud data when editing to avoid affecting the
results.

Load/Remove Editing Area

Description

Click Remove Editing Area button, if no operation is done to the point cloud file, it will exit the editing directly; if any operation is done, the
software will prompt users whether to save the edited point cloud data. If users want to save the result, please click yes, and the edited data
will be displayed in the main window. If users do not want to save the result, please click no. And after this step, users can draw a new
hexagon in the main window again.

Save

Description

Click *Load Editing Area* button to set the area in the hexagon as the area to be edited. At this time, users cannot draw another
hexagon in the main window; only the point cloud data in the current ROI can be edited; and the all the editing tools are available
in the profile window.

Click *Save* button, all the operations to edit the individual trees will be saved in the point cloud file. And the edited point cloud will
be displayed in the main window.



Create Tree

Description
Click *Create Tree* button and the following window will popup. Select the class of the points that will be used to create the tree in
the drop-down menu. All the classes are selected by default. And then, select the selection tool in the toolbar. The polygon
selection tool is selected by default. Start to draw the selection area in the profile window by clicking the mouse. And ending the
drawing by double-click the the mouse. The color of the points selected will be changed. At this moment, the new tree is created
successfully.



Merge Tree

Description

Delete Tree

Click *Merge Tree* and then pick the tree in the profile window. If the picked tree's ID is not 0, its ID will be recorded. And then,
pick another tree in the profile window. This newly picked tree will be merge to the tree which is recorded in the first step. The
color of the merged tree will be the same as that tree first picked. Users can right-click to end the picking.



Description

Undo

Description

Redo

Description

Pick point

Description

Hide tree

Description

Exit

Description

Click *Undo* button to undo the last option. The maximum times of undoing is 20. Any operation before the last 20 steps cannot
be undone.

Click *Redo* to redo the undone operations.

CClick *Pick Point* button，then select on the point cloud in profile viewer, and its attribute info will display.

CClick *Hide tree* button，then select on the point cloud in profile viewer, and the corresponding tree will hide.

Click *Exit* button, if no operation is done to the point cloud file, it will exit the editing directly; if any operation is done, the software
will prompt users whether to save the edited point cloud data. If users want to save the result, please click *yes*, and the edited
data will be displayed in the main window. If users do not want to save the result, please click *no*. And after this step, the profile
window will be closed, and the individual tree editor function will be turned off.





DBH Measuring

Summary

The DBH measurement tool can measure the tree DBH on the TLS forestry point cloud data. And support to export the measurement results
as txt, asc, neu, xyz, pts, and csv formats.

Usage

Load the point cloud data to be edited into the window, and set this window as the active window.

Click TLS Forestry > DBH Measuring to open the DBH measuring window.

Steps

1. Activate the DBH measuring button  (Initially activated). Use the left mouse button to click the roots of the trees in the scene to

measure DBH in sequence. This function will select the point cloud of the corresponding range according to the set parameters and use
the method of fitting the circle to fit DBH. The fitting results are displayed in the 3D window and the DBH measurement window at the
same time.

2. Click to select any row in the list, and click the  button to delete this measurement result.

3. Click the Start Edit botton , and double-click the cell in the table to change the selected field.

4. Click the Add Field botton , and the following window will pop up. Currently, it supports the following types of custom fields: integer,
float, text, date, and enum. After clicking the "OK" button, the new field will be displayed in the list window.

5. Click the Remove Field button  to delete the added field selected in the Remove Field dialog (only the fields created by the users can

be removed).

6. The selected results can be exported in multiple formats such as txt, asc, neu, xyz, pts, and csv. Click the  button, the "Select
Method" dialog box pops up (as shown).

7. Click the  button to select the output path and select all the fields need to be export. Then, click "OK" button to finalize the

exporting.

8. If the users do not save the selected result, when exiting this function, the software will pop up the following interface, click "Save" to
save the point, click "No" to exit the function.



Settings

Measuring Height: This function uses a cylindrical area to select the point cloud, and fits the points obtained with a planar circle to get
the DBH. The measuring height corresponds to the height from the fitting circle to the selected tree root.
Buffer Height: The height of the cylindrical area to select the point cloud.
Buffer Radius: The radius of the cylindrical area to select the point cloud.
Label Size: The display size of the label for displaying DBH measurement results in the three-dimensional window.
Total Number: The total tree of measurement result (cannot be manually modified).



Power Line
The Power Line module is used for processing and analysis of power line point cloud, including Settings,Mark Tower,Classify,Dangerous
point detection and Clear Danger Points.

Settings

Mark Tower

Classify

Detect Danger Points

Clear Danger Points



Settings

Summary

This setting will pop up automatically when powerline module is turned on. Powerline module parameter settings include common settings
and detection parameter settings. Common settings include working directory settings, point cloud coordinate systems settings, class and
detection parameters settings, detected line voltage level settings; detection parameter settings include class settings, detection types, and
safety distance settings.

Common Settings

The user can set the working directory, point cloud coordinate system, class and detection parameters, detected line voltage level and add
configuration tables. The software can record the user's last 5 input history records in settings of the working directory, point cloud coordinate
system and classes and detection parameters. User can select the most recently used item in the drop-down list. The working directory is
used to manage the project. The prj.ini file in the working directory records the point cloud coordinate system, classes and detection
parameters, and voltage level of the current project.

Working Directory: Used to save the intermediate and final results.
Classes and Detection Parameters: Set the path of the xml format configuration file.
Detected Line Voltage Level: The voltage level of the detected powerline.

Detection Parameter Settings

Displays key detection classes and safety distance detection parameters. User can add voltage levels and then configure their corresponding
detection parameters, including clearance distance analysis and crossing analysis. Clearance distance analysis includes detections for
different classes of objects, as well as different safety distance and distance detection methods. For crossing analysis, user only needs to set
the classes to be detected, and user does not need to set a safety distance.



Select: Whether to detect this class.
Checked (default): Detect the danger point in this class.
Unchecked (default): Do not detect the danger point in this class.

Class: Select the number (from 1 to 32) of the class in the drop-down menu.
Detection Type: Select the detection type in the drop-down menu.

Clearance Distance: Judge the point whether to be a danger point by the clearance distance. If the distance is less than this value,
it is a danger point.
Vertical Distance: Judge the point whether to be a danger point by the vertical distance. If the distance is less than this value, it is a
danger point.
Horizontal Distance: Judge the point whether to be a danger point by the horizontal distance. If the distance is less than this value,
it is a danger point.
Horizontal Distance / Vertical Distance: Firstly judge the point whether to be a danger point by the horizontal distance. If the
distance is less than set horizontal value, it is a danger point. If the distance is larger than set horizontal value, judge the point
whether to be a danger point by the vertical distance.
Horizontal Distance / Clearance Distance: Firstly judge the point whether to be a danger point by the horizontal distance. If the
distance is less than set horizontal value, it is a danger point. If the distance is larger than set horizontal value, judge the point
whether to be a danger point by the clearance distance.
Horizontal Distance / Vertical Distance / Clearance Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is larger than set horizontal
value, judge the point whether to be a danger point by the vertical distance. If the distance is less than the set vertical distance, it is a
danger point. If the distance is larger than the set vertical distance, judge the point whether to be a danger point by the clearance
distance then.

Add Row: Add a new detection class record.
Delete Row: Delete the selected row of detection class.
Add Column: Add a new column for a severity level threshold. I.E., severe, important, and general.
Delete Column: Delete the selected column.
Change Column Name: Change the name of selected column.
Save: Save the configuration to the current xml file.
Save as: Save the configuration as a new xml file.



Mark Tower

Summary

After clicking in the point cloud data and choosing the tower type, user can save the result into LiTower file. After adding the position
information of the tower, the software will automatically generate the index and name information of the tower. Index is a number starting from
the starting value and incrementing by 1. By default, name is the same as Index. Tower type includes "None", "Tension Tower", and "Straight
Line Tower". Double-click the row for each tower to jump to that tower in the displaying window. By checking or unchecking the checkbox in
front of "display all tower points" to display or hiding the tower points in the window. Point size can be modified.

Display All Tower Points (checked by default)：Display the tower names or indexes in the window. Uncheck this option to hide the all
the tower names or indexes.
By Index: Display the tower index.
By Name: Display the tower name.
Point Size (meter) (default value is "5.0"): Set the red marker sphere and text font size of the tower. 

Select Tower

Add Tower After

Click this button to start to pick the tower points. Click again to exit this function and save the current tower information to the
tower.LiTower file in the working directory.

Add a tower record after currently selected record.



Add Tower Before

Delete Tower

Modify Tower Position

Input Tower File

Export Tower File

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Input the tower file and renew the tower list in LiTower, txt, csv, and kml file.

Export the information in the current tower list to LiTower or kml file.



Classify

Summary

Usage

Add the point cloud data, and click Power Line > Classify.

Settings

GPU Acceleration (Unchecked by default): Use GPU to accelerate when voltage is more than 500KV.

Corridor Width (meters) (default is "60"): Width extending to both sides of the powerline. The software can record the user's current
settings and automatically restore the settings when opened again.

Starting Tower Index: Towers with index numbers smaller than this value are not involved in the calculation. The default value is the
minimum Index in the tower file.
Ending Tower Index: Towers with index numbers larger than this value are not involved in the calculation. The default value is the
maximum Index in the tower file.
Classify Ground Points: Please refer to the Classify Ground Points in the Classify toolbox for the detailed information of parameter

According to the tower file, clip and classify the point cloud data. Classify the point cloud into transmission tower, powerline,
ground points, noise, and other selected classes.This function can process multiple data simultaneously. Click to add the data
to be processed. Click to remove the selected data. Click to clear the data list. This function can perform segmentation,
classification, and noise removal in one step, or user can select the function needed by checking the box in front of the name of
each function.



settings. The software will not classify the ground points if this option is unchecked.
Remove Noise (Checked by default): Classify the noise points. The software will not classify the noise if this option is unchecked.
Number of Thread (default value is "4"): Set the number of thread (1 to 32) to run this function. The software can record the currently
setting and when the user open this function again, the setting will be kept.
Default: Restore the default parameter settings.

Note: The segmented data will be stored in the output path folder. The name of the file will be (Smaller Tower Index_Larger Tower
Index). In order not to impact the following steps, it is highly recommended not to change the file name. After the automatic
classification, user need to check the accuracy of the result and manually modify it in the Profile Tools.



Detect Danger Points

Summary

Usage

Click Power Line > Detect Danger Points

Settings

Starting Tower Index: Towers with index numbers smaller than this value are not involved in the calculation. The default value is the
minimum Index in the tower file.
Ending Tower Index: Towers with index numbers larger than this value are not involved in the calculation. The default value is the
maximum Index in the tower file.
Corridor Width (meters) (default is "60"): Width extending to both sides of the powerline. The software can record the user's current
settings and automatically restore the settings when opened again.

Detection Parameters: Detect the clearance danger points according to the customized

Cluster by Class: Unchecked by default. Used to control whether to cluster the result by class.If this option is checked, the danger
points will be clustered into different groups if they are in different classes; otherwise, the class information will not influence the
clustering process. The software can record the user's current settings and automatically restore the settings when opened again.
Min Distance (meters) (default value is "0.3"): Points with clearance distance less than this distance are not detected as danger
points, as they are considered to be noise. The software can record the user's current settings and automatically restore the settings
when opened again.
Safety Distance (meter) (default value is "4.5"): If the distance between the detected point and the powerline point is greater than

Batch process the point cloud file to generate the danger points images and reports based on the tower file. The interface of
detect danger points function is shown as follow. This This function can process multiple data simultaneously. Click to add the
data to be processed. Click to remove the selected data. Click to clear the data list.



the minimum distance and less than or equal to the safe distance, the point is considered to be a danger point. If the xml file is not
set, user needs to enter the safety distance; otherwise, this parameter is extracted from the xml file. When using the xml to set the
parameter, user can set different safety distances for different classes, and for different severity level.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when the detection results are
clustered. This value should be smaller than the maximum clustering range. Three-dimensional Euclidean clustering is used to
cluster the danger points. The software can record the user's current settings and automatically restore the settings when opened
again.

Maximum Clustering Range (meters) (default value is "20.0"): After the detection results are clustered, if the length along
the power line direction is greater than this value, they are divided into multiple dangerous point clusters. The software can
record the user's current settings and automatically restore the settings when opened again.

Number of Thread (default value is "4"): Set the number of thread (1 to 32) to run this function. The software can record the currently
setting and when the user open this function again, the setting will be kept.
Default: Restore the default parameter settings.



Clear User Data

Summary

Usage

Power Line > Clear

Settings

Number of Thread (default value is "4"): Set the number of thread (1 to 32) to run this function. The software can record the currently
setting and when the user open this function again, the setting will be kept.

Clear all the danger point detection result in the point cloud. After execute this function successfully, all the danger points (in red)
will be changed into non-danger point.



Geological Analysis
Geological Analysis provides automatical as well as manual analysis tools for flow direction, flow accumulation, fill, dip and strike.

Raster Flow Direction

Raster Flow Accumulation

Raster Fill

Query Dip and Strike



Raster Flow Direction

Summary

The tool use D8 algorithm to calculate the raster of flow direction for each pixel.

D8 algorithm is to build flow direction from each pixel to downhill neighbouring pixel of the most steep angle.The output of pixel value is within
1-255 of Integer format.

Note:
1.If the pixel Z value is the lowest among the eight neighbouring pixels, it will be assigned to the minimum value among its
neighbourings. And flow direction is to this pixel. If multiple neighbouring pixels have the same lowest value, it will still be assigned to
the minimum value among its neighbourings.But its flow direction will be definded via one of the following method. This can filter
abnormal low noisy point.

2.If the z-value of a pixel changes the same in multiple directions, and the pixel is part of a sunken point, the flow direction of the pixel
will be considered undefined. At this time, the value of the pixel in the output flow direction raster will be the sum of these directions.
For example, if the z-value changes the same to the right (flow direction = 1) and downward (flow direction = 4), the flow direction of the
cell is 1 + 4 = 5. You can use the sink tool to mark pixels with undefined flow directions as sunken points.

3.If the z-value of a pixel changes the same in multiple directions, and the pixel is not part of a depression, a lookup table that defines
the most probable direction will be used to specify the flow direction. See Greenlee (1987).

4.The output D8 descent rate raster data will be calculated based on the z-value change rate of the path length between the pixel
centers and expressed as a percentage. For adjacent pixels, this is similar to the percentage slope between pixels. When crossing a
flat area, the distance becomes the distance to the nearest pixel with a lower elevation. The result is a graph of the percentage
increase in elevation in the steepest descent path from each pixel.

5.When calculating the D8 descent rate raster data of a flat area, in order to improve performance, the distance to the diagonally
adjacent pixel (1.41421 cell size) is approximately calculated as 1.5 cell size.

Description

The key to obtaining the hydrological characteristics of the surface is to determine the flow direction from each pixel in the grid. This can be
done with the flow direction tool.

The tool takes the surface as input and outputs a raster showing the direction of flow from each pixel. If the output rate of decline raster data
option is selected, an output raster expressed as a percentage will be created, showing the maximum rate of change in elevation from each
pixel along the flow direction to the length of the path between the pixel center. If the Force all edge cells to flow outward is selected, all cells
at the edges of the surface raster will flow outward from the surface raster.

The flow direction is determined by the steepest descent direction or the maximum descent direction from each pixel. The flow direction is
calculated as follows:

maximum_drop = change_in_z-value / distance * 100

Calculate the distance between the centers of the pixels.

1.If the pixel size is 1, the distance between two orthogonal pixels is 1, and the distance between two diagonal pixels is 1.414 (the square root
of 2). If multiple pixels have the same maximum descending direction, the range of adjacent pixels will be expanded until the steepest
descending direction is found. After finding the direction of the steepest descent, the output pixel will be encoded with a value representing
that direction.

2.If all neighboring pixels are higher than the pixel to be processed, the pixel to be processed will be regarded as noise and filled with the
lowest value of its neighboring pixels. The pixel to be processed has a flow direction towards itself. However, if the single pixel sink point is
located near the actual edge of the grid or has at least one NoData pixel as an adjacent pixel, it cannot be filled due to insufficient
neighborhood information. To treat a pixel as a real single-pixel sink, all neighborhood information must exist.

3.If two pixels flow into each other, they are both meeting points and have an undefined flow direction. This method of obtaining flow direction
through a digital elevation model (DEM) was introduced by Jenson and Domingue (1988).

Usage

Click Geological Analysis >Raster Flow Direction.



Parameters

Input File：Select input tiff file.

Output Path：Select output path.

  @inproceedings{
      author={Sch\"{o}Greenlee, D. D.},
      title={Raster and Vector Processing for Scanned Linework},
      booktitle={Photogrammetric Engineering and Remote Sensing },
      year={1987},
  }

  @inproceedings{
      author={Sch\"{o}Qin, C., Zhu, A. X., Pei, T., Li, B., Zhou, C., & Yang, L},
      title={An adaptive approach to selecting a flow partition exponent for a multiple flow direction algorithm},
      booktitle={International Journal of Geographical Information Science},
      year={2007},
  }



Raster Flow Accumulation
This tool is used to calculate raster of flow accumulation by pixel.

Notes:

1.The result will be a flow accumulation raster, each pixel value is calculated by all the uphill pixels by cumulative weight.

2.D8 flow direction modeling algorithm is used in this tool.

3.If the Raster Flow Direction is not used for the input raster, the flow accumulation might be annular and go into endless loop.

4.Pixels of undefined flow direction will only take in uphill pixels, they will not form any downhill flow. For D8 algorithm, if the pixel is not
of value 1、2、4、8、16、32、64 or 128, we consider the pixel flow-undefined.

5.Flow accumulation is based on the amount of uphill pixels, the pixel itself will not be considered in.

6.The large value pixels can indicate rivers.

7.The low value pixels can indicate ridges.

Summary

This tool is used to calculate raster of flow accumulation by pixel. The pixel value is the cumulative weight of all the uphill pixels.

Usage

Click Geological Analysis >Raster Flow Accumulation

Parameters

Input File：Select input tiff file.

Output Path：Select output path.

    @inproceedings{
        author={Sch\"{o}enson, S. K., J. O. Domingue},
        title={Extracting Topographic Structure from Digital Elevation Data for Geographic Information System Analysis},
        booktitle={Photogrammetric Engineering and Remote Sensing},
        year={1988},
    }

    @inproceedings{
        author={Sch\"{o}Tarboton, D. G., R. L. Bras, I. Rodriguez–Iturbe},
        title={On the Extraction of Channel Networks from Digital Elevation Data},
        booktitle={Hydrological Processes},
        year={1991},
    }



Raster Fill
Raster Fill is used to improve the raster by filling in the depression of the raster.

Depression pixel refers to the pixel lower than other surrounding pixels, which is unable to define the flow direction.The pour point is the
boundary pixel with the lowest elevation relative to the confluence area of the depression pixel. If the depression is filled with water, the water
will pour out from that point.

1. Z defines the maximum elevation difference between depression pixel and pour point, which decides the minimum depth of the
depression area need to be filled.

For example, suppose the elevation of the pour point in a depression area is 210 feet, and the deepest point of the depression is 204 feet
(depth:6 feet). If the z limit is set to 8, this depression will be filled. However, if the z limit is set to 4, the area will not be filled because the
depth exceeds the limit value, and it is regarded as a valid depression pixel.

2.All qualified depression pixels will be modified to the elevation of pour point.

3.The more the depression points, the longer the processing time.

Summary

The Raster Fill tool uses functions equivalent to the focus flow, flow direction, depression, watershed, and area fill tools to locate and fill
depressions. The execution of the tool will iterate until all depressions within the specified z limit are filled. While filling the depressions, other
depressions may be created at the boundaries of the filled area, and these depressions will be removed in the next iteration.

Usage

Click Geological Analysis> Raster Fill。

Parameters

Input File：Select input tiff file.

Output Path：Select output path.

Note: If the raster data is of integer type, the output filled raster data is also of integer type. If the input raster data is of floating point
type, the output raster data is also of floating point type.

    @inproceedings{
        author={Sch\"{o}Planchon, O.,Darboux, F},
        title={A fast, simple and versatile algorithm to fill the depressions of digital elevation models},
        booktitle={Catena},
        year={2002},
    }

    @inproceedings{
        author={Sch\"{o}Tarboton, D. G., R. L. Bras,I. Rodriguez–Iturbe},
        title={On the Extraction of Channel Networks from Digital Elevation Data},
        booktitle={Hydrological Processes},
        year={1991},
    }



Query Dip and Strike

Summary

This tool is used to calculate dip and strike automatically or based on the point cloud selected manually. Related analysis tool and result
report are also available.

Usage

Load the point cloud in the viewer. Click Geological Analysis > Query Dip and Strike, and the toolbar will show in the viewer.

In the Query Dip and Strike window, there are several buttons: Export Data, Query Dip and Strike, Automatically Query Dip and Strike, Clear
data, Statistic Report,Adjust radius and Settings.

 Export Data：Save data in the table as CSV file.
 Query Dip and Strike： By clicking this button, a round selection box will show in the point cloud viewer.You can also adjust the radius of

the circle. After selecting the point cloud by the round box, the Dip and Strike info will show as 3D model in the viewer. Meanwhile, a query
record will add in the table below.

 Auto Query Dip and Strike：This tool can automatically calculate Dip and Strike, and add the record in the table below.

Point Cloud File：Select point cloud file in the drop-down list.
From Class：Select the class of point cloud to be calculated, default setting is ground point.
Octree Level：Create an octree for the point cloud. The higher the level, the fewer the number of point clouds contained in each octree



node. The specific results of the segmentation are as follows: the larger the value is set, the finer the queried facet, otherwise the larger
the facet.
Facets：Parameters of Facets.

Facets Type：Different type of Facets.
Max Root mean square error：The maximum root mean square of the distance between the point cloud of the cluster and the
fitted plane in the segmentation.
Max distance@68%：The maximum distance of the top 68% of the distance between the point cloud of the cluster in the
segmentation and the fitted plane.
Max distance@95%：The maximum distance of the top 95% of the distance between the point cloud of the cluster in the
segmentation and the fitted plane.
Max distance@99%（by default）：The maximum distance of the top 99% of the distance between the point cloud of the cluster
in the segmentation and the fitted plane.
Max distance： The maximum distance between the point cloud of the cluster in the segmentation and the fitted plane.

Distance Threshold： The larger the threshold, the more points will be segmented into a facet, which means there will be more large
facets.
Min Points Per Facet：The minimum points of a facet. The larger the value, the more the points of a facet.

 Clear Data：Clear data in the viewer and the table.
 Statistic Report：Click the button to do statistics and filter on the dip and strike. Set the interval for dip and strike statistics. The rose

diagrams and corresponding statistical reports can also be generated. When filtering, you can choose different filtering types and rendering
types, and filter by setting the minimum and maximum angle threshold.

 Settings：Checking or unchecking the box to decide whether to show label, axis and horizontal plane.



Mine
Provides tools related to mines, including extract tunnel points, compute normal vectors, trangulation modeling, poisson modeling and other
functions.

Extract Tunnel Points

Triangulation Modeling

Compute Normal Vectors

Triangulation Modeling (Poisson)



Extract Tunnel Points

Summary

Generate the center axis by importing from files or manually drawing, and then remove the noise inside the tunnel along the center axis, and
generate a new file. The algorithm first extracts the roadway point cloud in a certain range around the center axis, and slices the roadway
point cloud vertically along the center axis at the certain step. Then calculate the outer ring (roadway boundary) of each slice, remove the
internal noise, and finally merge the results. This function is suitable for caves, shield tunnels, underground tunnels and other data.

Usage

Click Mine > Extract Tunnel Points 。

Settings

Input Data:The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software.
Center Axis: Currently, two methods of "import from files" and "manual drawing" are supported to obtain the center axis. The algorithm
will extract the tunnel point cloud around these center axes and denoise, and finally generate a new file.

Import Center Axis from Files: Supports center axis files in SHAPE format and ASCII format. The center axis file must contain at
least two columns, namely: X and Y. After the center axis file is imported, it will be displayed in the scene. The center axis needs to
be fitted with the point cloud, otherwise the function will not work properly.
Manual Drawing: The user can use the interactive polyline as a medium to automatically calculate the center axis. Click this button 

 to start drawing a polyline in the view with the left mouse button, double-click to end the drawing of the current polyline, and

add it to the list of polylines. Select a polyline in the list and click the button  to delete the corresponding polyline.
Step (m) (Default Value is "0.25"): The tunnel is longitudinally sectioned along the center axis with this step length, and each segment
of the point cloud after sectioning is individually denoised. The step size affects the efficiency and precision of the algorithm. The smaller
the step size, the lower the efficiency and the finer the denoising effect. When the tunnel surface consistency is good and the direction
change is gentle, the value can be increased appropriately. Good results can be obtained by keeping this value between 0.2 and 3.0.

Tunnel Thickness (Default Value is "0.2"): The thickness of the tunnel refers to the average distance from the inner wall of the tunnel
to the surface of the tunnel. Points in the tunnel greater than this distance will be counted as noise points.
Tunnel Width (m) (Default Value is "8"): The tunnel width refers to the maximum width of the contour section in the tunnel, which
determines the extration range of the point cloud on both sides of the center axis. This value needs to be greater than the maximum



values of the net width of the entire tunnel to avoid the inability to obtain the tunnel point cloud during the calculation process.



Triangulation Modeling

Summary

Use point clouds for 3D modeling and generate 3D model files in .obj format.

Usage

Click Mine > Triangulation Modeling。

Settings

Input Data：The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software. File
format: *.LiData.
Radius Ratio Bound (Default Value is "5": In the process of triangulation reconstruction, the ratio of the radius of the candidate triangle
to the radius of the boundary triangle. The algorithm will detect candidate triangles along the surface of the point cloud. When the point
cloud is missing, the radius of the candidate triangle will become larger and it will easily become sharp. This value is used to control
whether these triangles are used as candidates. The larger the value, the fewer holes in the model generated and the more shape
triangles.
Angle Threshold Beta (Radians) (Default Value is "0.52"): The threshold of the minimum included angle between the triangle at the
boundary and the candidate triangle in the triangulation reconstruction process. The larger the value, the smoother the reconstructed
triangulation model, but the algorithm is eaiser to terminate at the point where the point cloud shape changes drastically. This value is
recommended to be set between 0.1 and 1.5.



Compute Normal Vectors

Summary

Calculate the normal vector of the tunnel. The algorithm will search for adjacent points within a certain radius for each point, and then
calculate the local plane and normal direction based on these points. Finally, use the minimum spanning tree to optimize the direction of the
normal (optional). The generated normal will be stored as an additonal attribute, and the addtional attribute field is "Normals".

Usage

Click Mine > Compute Normal Vectors。

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software. File
format: *.LiData.
Search Radius (m) (Default Values is "0.5"): Neighborhood search radius. The algorithm obtains neighboring points through
neighborhood search for each point, and then calculates the normal direction based on these points. If this value is too large or too small,
it will cause the normal calculation error, and when it is too large, it will also cause the algorithm efficiency to decrease. This value can be
set to 5 times the average dot spacing to get the best results.
Orientation (Default is checked): When this option is checked, the minimum spanning tree will be used to optimize the consistency of
the normal direction.



Triangulation Modeling (Poission)

Summary

Use point cloud for Poission modeling and generate 3D model file in .obj format. Before running this function, the point cloud must be
processed with Compute Normal Vectors.

Usage

Click Mine > Triangulation Modeling (Poission)。

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in the LiDAR360 software. File
format: *.LiData.
Every Node Sample (Default Value is "1.5"): The minimum number of points retained in each node after the octree reconstruction is
mainly used to weaken the influence of noise on the reconstruction result. The larger the value, the stronger the anti-noise ability, but
more details will be ignored. For point clouds with a small amount of noise, it can be set between 1.0 and 5.0. For point clouds with a lot
of noise, it can be set between 15 and 20.
Point Weight（Default Value is "2.0": The weight of the interpolated point in the Poisson implicit equation. The larger the weight value,
the closer the reconstructed implicit triangulation surface is to the original point cloud.
Resolution (Default Value is "0.4": The resolution of the reconstructed implicit triangulation surface. The higher the resolution, the
denser the reconstructed triangulation, and more details will be preserved. On the contrary, the sparser the triangulation.



Tutorials
Getting Started Tutorial

Point Cloud Data Basic Operations Tutorial

Data Management

Statistics

Classify

Strip Alignment Tutorial

Terrain Tutorial

Forestry Tutorial

ALS Regression Analysis

Power Line Dangerous point detection

Videos
1. LiDAR360 Installation and License Activation
2. LiDAR360 Overview and Loading Data
3. LiDAR360 Window Management
4. LiDAR360 Measurement Tools
5. LiDAR360 Selection Tools
6. LiDAR360 Profile Tools
7. LiDAR360 Camera Roam in 90 Seconds
8. Point Cloud Generation
9. LiDAR360 Strip Adjustment Module

10. LiDAR360 Classify Ground
11. LiDAR360 Classify Ground by Selected
12. LiDAR360 Terrain Module
13. LiDAR360 Tree Segmentation
14. LiDAR360 ALS Forestry Module
15. LiDAR360 TLS Forestry Module

https://youtu.be/dgL7XTsZ-Tc
https://youtu.be/_At7rVVslDU
https://youtu.be/7pdqo7tY0A4
https://youtu.be/z7KEild2uLQ
https://youtu.be/JZ1PC9VSDZI
https://youtu.be/uxtArbCCwl4
https://youtu.be/1e2cBpmT038
https://youtu.be/5XmpQmgXM2M
https://youtu.be/HZz1tlN-60M
https://youtu.be/-XLi3URV2I4
https://youtu.be/Gz4x2B4bBXo
https://youtu.be/y9l_hSRj5mc
https://youtu.be/23Q0BHdbR8Q
https://youtu.be/wIBE3suS43I
https://youtu.be/0OE8SAZN9rA


Strip Alignment
This tutorial introduces the standard workflow of strip alignment for airborne LiDAR point clouds through boresight calibration by LiDAR360.

Steps

1. Data Quality Inspection Data Quality Inspection is required to make sure the data meets the requirements of strip alignment module. It
improves the alignment quality after processing.

1.1. Click Strip Alignment > Trajectory Quality Analysis to check the trajectory quality from the height analysis, speed analysis
and flight attitude analysis.
1.2. Click Strip Alignment > Strip Overlap Analysis to analyze the overlap between point clouds.
1.3. Click Strip Alignment > Density Quality Analysis to analyze the density of point cloud.

2. Click Strip Alignment > Boresight to align strips through boresight calibration.

3. (Optional) Click Strip Alignment > Elevation Difference Inspection to analyze the elevation difference between point clouds.

4. (Optional) Click  Cut Overlap in the Strip Alignment module. For point cloud from LiDAR, the smaller the scanning angle, the
higher the quality of the corresponding point cloud. Therefore, to ensure the quality of the point cloud data in the area, the low quality
redundant points in the overlapped regions can be removed.

Tutorial Videos

1. Point Cloud Generation

2. LiDAR360 Strip Adjustment Module

https://youtu.be/5XmpQmgXM2M
https://youtu.be/HZz1tlN-60M


Terrain
This tutorial introduces the standard workflow for terrain processing by LiDAR360.

Steps

1. Due to multipath effect, there are gross noise points in the point cloud data. Click Data Management > Point Cloud Tools > Remove
Outliers to remove outlier points of point cloud data.

2. Click Classify >Classify Ground Points to classify ground points for unclassified point cloud.
3. For the result of ground points classification at first time, if the classification results of a large number of points are inaccurate due to

unreasonable parameter settings, you can click Classify > Classify by Attribute to restore the point cloud category to unclassified and
set parameters again for reclassification.

4. After ground points classification, for the inaccuracy of local area point cloud classification, you can use the Classify Ground by
Selected or Classify by Interactive Edit to perform the ground point classification of the local area.

5. Make sure the classification of ground point cloud is accurate, then click Terrain > DEM or Terrain > DSM to generate DEM or DSM.
Currently the software provides three ways to generate DEM or DSM from the point cloud: TIN, Kriging, IDW.

6. Click Terrain > Hillshade to create a hillshade map. This tool determines the illumination-enhanced surface visualization by setting each
cell in the raster. At the same time, you can click Data Management> Conversion>Convert TIFF to LiModel to convert single-band Tiff
images to LiModel. The LiModel data can be viewed in 3D view more intuitively. In addition, the LiModel data can be edited by clicking
Terrain > LiModel Editor for generating a better quality of DEM model. Similarly, DSM data can also be operated as above.

7. There are two ways to generate contour lines: Raster to Contour and Point Cloud to Contour. By these two ways, you can generate
contours from the DEM raster data generated in the previous step or use the ground points after the fourth step classification. In addition,
the TIN can be generated from the ground point cloud, and the result of ground points classification can be viewed more intuitively. The
TIN model can be modified by clicking Terrain > LiTIN Editor, and then click Terrain > TIN to Contour to generate contour lines.

Tutorial Videos

1. LiDAR360 Classify Ground Points
2. LiDAR360 Classify Ground by Selected
3. LiDAR360 Terrain Module

https://youtu.be/-XLi3URV2I4
https://youtu.be/Gz4x2B4bBXo
https://youtu.be/y9l_hSRj5mc


ALS Point Cloud Regression Analysis

Summary

Lidar technology has a strong ability to obtain the three-dimensional structure of the forest, and the obtained canopy structure parameters
have a strong correlation with the forest volume and above-ground biomass. It is a large-area forest photosynthesis capacity assessment,
biomass and carbon storage. Estimation provides a good means. LiDAR360 provides four methods: linear regression, support vector
machine, fast artificial neural network, and random forest. The regression model is constructed from the sample plot survey data and the
variables obtained from the lidar point cloud to estimate the forest volume and the amount of the sample square or larger area. Parameters
such as biomass.

Regression analysis using LiDAR360 roughly goes through the following steps: denoising, filtering, generating Digital Elevation Model (DEM),
point cloud normalization, generating forest parameters, and regression analysis.

Linear Regression Model

SVR Regression



Fast Artificial Neural Network Regression Model

Data Preparation

The input data for regression analysis is normalized point cloud data. The steps to generate a normalized point cloud are as follows:

-Click Data Management> Point Cloud Tools> Outlier Removal to denoise the point cloud data and remove the influence of noise.

-Click Classification> Classify Ground Points to classify the ground points from the point cloud to generate DEM.

-Click Terrain> DEM to generate a digital elevation model based on the site surface.

-Click Data Management> Point Cloud Tools> Normalization to generate normalized point cloud data.

-Click ALS Forest> Forest Parameters> Calculate Forest Metrics By Grid, Calculate Forest Metrics By Polygon or Calculate Forest
Metrics by Forest Stands to generate the independent variable data set required for regression.

Steps

The linear regression steps are as follows:

-Click ALS Forest>Regression Analysis>Linear Regression to load the generated forest parameter independent variables into the function
dialog box for linear regression analysis.

The support vector regression steps are as follows:

-Click ALS Forest> Regression Analysis> Support Vector Machine, load the generated forest parameter argument into the function dialog
box, and perform support vector regression analysis.

The steps of fast artificial neural network regression are as follows:

-Click ALS Forest> Regression Analysis> Fast Artificial Neural Network to load the generated forest parameter independent variables
into the function dialog box for quick Artificial neural network regression analysis.

The regression steps of the random forest network are as follows:

-Click ALS Forest> Regression Analysis> Random Forest to load the generated forest parameter independent variables into the function
dialog box for fast artificial nerve Network regression analysis.

Accuracy Assessment

After the regression analysis is completed, an html file with the same name as the result file will be generated to view the accuracy of the
regression analysis and the variables involved in the regression analysis.

The figure below is the support vector machine regression accuracy report. Degree, Gamma and K-Fold are input parameters, which are set
by the user in the parameter interface. The accuracy evaluation of the regression model is determined by R, R Square and RMSE. R Square
is the ratio of the sum of squares of the difference between the predicted data and the mean of the original data to the sum of the squares of
the difference between the original data and the mean. The value range is [0 1]. The closer the value is to 1, the independent variable's ability



to explain the dependent variable. The stronger. RMSE (Root Mean Square Error), this value is the mean value of the square root of the error
between the predicted value and the measured value. Dependent and Independent Variable are the dependent and independent variables
participating in the regression analysis. Only one dependent variable is used for each regression analysis.



Power Line Dangerous point detection
This tutorial introduces the standard workflow of power line data processing by LiDAR360.

Steps

The main process for using the power line module to process point cloud data, detect dangerous points, and generate dangerous point
detection reports is as follows:

1. Click File > Data > Add Data to open data.
2. Click Power Line > Start Mark Tower，Start the power line module.
3. Click Power Line > Mark Tower to mark position of towers and edit properties of towers.
4. Click Classify > Clipping and Classifying to clip and classify point cloud data into tower, power line, ground points, noise and

unclassified data automatically. It is necessary to manually check the classification results after automatic classification.
5. Click Power Line > Danger Points to perform dangerous points detection, tree segmentation, image rendering and report generation.



Appendix
This chapter introduces some key terms, file formats and ways of high-performance graphics mode adjustment.

Key Terms

File Formats

LiData

LiAtt

LAS

LiModel

LiTin

Clipping Point Cloud File Format

Clip by Circle File Format

Clip by Rectangle File Format

Extract by Time File Format

Homologous Points File Format

POS File

OUT File

Control Point File Format

Notes Elevation Points File

Sample Data File

Seed Points File

Individual Tree Segmentation Result File

Seven Parameters Inputs

Section Product File Format

ID List of Json Callable Functions for Batch Processing

Shortcut Keys

Menu Shortcut Keys

Viewer Shortcut Keys

Shortcut Keys for Profile Editing

High-Performance Graphics Mode Adjustment

LiTower File



Key Terms
Workflow – A sequence of steps to produce the final products.
Clipping – Extracting a subset of points from point cloud using an extent.
Extracting – Extracting a subset of points from point cloud using a specific point attribute.
Return Number – The Return Number is the pulse return number for a given output pulse. A given output laser pulse can have many
returns, and they must be marked in sequence of return. The first return will have a Return Number of one, the second a Return Number
of two, and so on up to five returns.
Intensity – The intensity value is the integer representation of the pulse return magnitude. This value is optional and system specific.
However, it should always be included if available.
Outlier – A point or group of points isolated from other points of interest that are considered noise or extraneous objects.



File Formats
This section introduces the data formats supported by LiDAR360 and the specific file formats involved in various functional modules, such as
POS file, control point file, seed point file and so on.

LiData

LiAtt

LAS

LiModel

LiTin

Clipping Point Cloud File Format

Clip by Circle File Format

Clip by Rectangle File Format

Extract by Time File Format

Homologous Points File Format

POS File

OUT File

Control Point File Format

Notes Elevation Points File

Sample Data File

Seed Points File

Individual Tree Segmentation Result File

Seven Parameters Inputs

Section Product File Format

LiTower

MatrixFormat



LiData
LiData is a point cloud data file format defined by LiDAR360. It consists of a public header block, variable length records, and point data
records.

This format can be exchanged with other common point cloud data format files, including LAS, LAZ, E57, PLY, ASCII, etc.

When loading common point cloud data formats (including: LAS, LAZ, E57, PLY, ASCII, etc.) into LiDAR360, a LiData file named after the
same name will be generated, and the subsequent operations are based on that LiData file.

LiData file has a version number to indicate its version. Currently, the most updated version of LiData is V2.0.

Starting from LiDAR360 V4.0, the all the LiData versions before V2.0 are supported. For LiDAR360 V3.x, the highest supported version is
LiData V1.9. The differences between LiData V1.9 and V2.0 are listed as follows:

Features LiData V1.9 LiData V2.0

Classfication 0-31 （32 classes in total) 0-255 (256 classes in total)

Classfication
Flag Not supported Supported

Scanner
Channel Not supported Supported

Near Infrared Not supported Supported

Scan Angle
Rank

In degree, in the range of
[-90°~+90°]

In in range of [-30000, +30000] (unitless) which corresponds to the degree of
[-180°, +180°]

Additional
Attribute Not supported Supported

Additional Attributes are stored in the LiAtt files



LiAtt File Format
LiAtt is the additional attribute file format of LiData. It consists of a file header and additional attribute data records.

The additional attribute is supported since LiData V2.0.

The additional attributes are matched with the corresponding LiData file by the file name.

When the non-matching LiData and LiAtt files are manually modified to have the same file name, the software may still be able to recognize
all the additional attributes in the LiAtt file, but the corresponding additional attribute values may be incorrect. Modifying the LiAtt may destroy
the LiAtt file structure and cause the additional attribute file to no longer be recognized when opening the LiData file next time.

Deleting LiAtt files does not affect the normal use of LiData files. But after LiDAR360 loads LiData, deleting the corresponding LiAtt files may
cause some operations to fail and cause unknown errors.



LAS
LAS file format Support the LAS file in the following formats:

LAS 1.1

LAS 1.2

LAS 1.3*

LAS 1.4*

Limitation for LAS 1.3 and LAS 1.4:

Not support waveform data currently.

https://www.asprs.org/committee-general/laser-las-file-format-exchange-activities.html
http://www.asprs.org/wp-content/uploads/2010/12/asprs_las_format_v11.pdf
http://www.asprs.org/wp-content/uploads/2010/12/asprs_las_format_v12.pdf
http://www.asprs.org/wp-content/uploads/2010/12/LAS_1_3_r11.pdf
http://www.asprs.org/wp-content/uploads/2010/12/LAS_1_4_r13.pdf


LiModel
LiModel file stores triangulated regular network models generated by DEM or DSM. It saves regular grid nodes and block-organized
triangulated regular network models according to quadtree. DOM texture information can be superimposed on the model. LiModel could be
transformated from massive data of DEM or DSM. It supports editing operations including flatten height, smooth height, noise points removal
and so on. After editing, it can be exported to Tiff file for generating contours.



LiTin
The LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud. It can improve quality of contour lines by editing
operations including flatten height, smooth height, vertex addition and removal, etc. It organizes data in full memory mode, which takes up
large memory and causes low rendering efficiency. So it is suggested to generate LiTin file into tiles.



Clipping Point Cloud File Format

Summary

The file is a text file that contains a list of scopes used to load multiple circles or rectangles.

Clip by Circle File Format

Each circle consists of three values separated by commas: the X coordinate, the Y coordinate and the radius of the center.

The following table is an example of a circular extent file:

322610.51, 4102305.22, 50

322685.86, 4102400.5, 50

322820.45, 4102510.21, 100

322850.35, 4102655.33, 100

323000.00, 4103000.00, 60

The above values can be stored in a text file (such as "extents.txt") and loaded into the LiDAR360 software.

Clip by Rectangle File Format

Each rectangle consists of four values separated by commas: X minimum, X maximum, Y minimum and Y maximum.

The following table is an example of a rectangular extent file:

322601.255, 322801.255, 4102309.655, 4102409.655

322548.966, 322600.110, 4102310.180, 4102360.180

322539.155, 322600.255, 4102309.655, 4102359.655

322745.950, 322780.110, 4102204.660, 4102250.180

322875.224, 322975.224, 4102028.660, 4102128.660

The above values can be stored in a text file (such as "extents.txt ") and loaded into the LiDAR360 software.



Extract by Time File Format
Each extraction range consists of two values separated by commas: starting GPS time and ending GPS time.

The following table is an example of extracting range files by GPS time:

526494.500,527494.500

527494.500, 528494.500

527494.500, 528494.500

528494.500, 529494.500

529494.500, 530494.500

The above values can be stored in a text file (such as "extents.txt ") and loaded into the LiDAR360 software.



Homologous Points File Format
Homologous points file is a comma separated text file. The first row is a file header. Each row consists of 9 columns: ID, reference coordinate
(X,Y,Z), reference source file, alignment coordinate(X,Y,Z) and alignment source file.

 ID     ref_X        ref_Y        ref_Z           file                align_X       align_Y    align_Z  file
P01, 322500.1100, 4102499.9600, 2613.1400, E:/data/LiForest.LiData, 322500.0089, 4102499.9856, 0.0000, null
P02, 322999.8400, 4102499.7900, 2614.3400, E:/data/LiForest.LiData, 322999.9283, 4102499.9585, 0.0000, null
P03, 322999.8300, 4102000.3200, 2554.4100, E:/data/LiForest.LiData, 322999.8738, 4102000.1457, 0.0000, null
P04, 322500.3700, 4102000.1600, 2490.7400, E:/data/LiForest.LiData, 322500.1140, 4102000.0595, 0.0000, null



POS File
The POS File contains information such as GPS time, longitude, latitude, height, roll, pitch, heading, GridX and GridY. GPS time, longitude,
latitude, height, roll, pitch and heading must be necessary, while longitude and latitude or GridX and GridY include at least one. If POS file
doesn't include GridX and GridY, we need to set projection coordinate system when we input trajectory files. GridX and GridY can be
calculated according to projection coordinate system, longitude and latitude in strip alignment module.

The trajectory information stored in its file is structured as follows:

Data Units Type

GPS time seconds double

longitude degree double

latitude degree double

height meters double

roll degree double

pitch degree double

heading degree double

GridX(Optional) meters double

GridY(Optional) meters double

The examples the POS file is shown below. Example 1(not including GridX，GridY):

 380954.000,112.5311950876, 26.8969520123,378.543,  7.1701230000,  3.0890110000,-39.4065340000
 380954.008,112.5311938923, 26.8969533249,378.537,  7.2001860000,  3.0914780000,-39.4034150000
 380954.016,112.5311926975, 26.8969546376,378.531,  7.2368710000,  3.0936380000,-39.4011190000
 380954.024,112.5311915034, 26.8969559507,378.525,  7.2683090000,  3.1015050000,-39.3975470000
 380954.032,112.5311903098, 26.8969572641,378.518,  7.3007560000,  3.1115160000,-39.3929590000
 380954.040,112.5311891169, 26.8969585779,378.512,  7.3269790000,  3.1179720000,-39.3878260000
 380954.048,112.5311879247, 26.8969598920,378.506,  7.3525870000,  3.1180460000,-39.3804020000
 380954.056,112.5311867331, 26.8969612065,378.500,  7.3745730000,  3.1151630000,-39.3713830000

Example 2(including GridX，GridY):

383207.336,112.5421590662,26.9034172036,313.865,3.538615,2.660518,-67.848653,653147.099716932,2976670.62354689
383207.344,112.5421572108,26.9034177865,313.861,3.533299,2.659177,-67.840828,653146.914649722,2976670.68587654
383207.352,112.5421553554,26.9034183697,313.857,3.522385,2.658042,-67.828619,653146.729582108,2976670.74823943
383207.36,112.5421535001,26.9034189529,313.854,3.512757,2.659231,-67.816251,653146.544524429,2976670.81060244
383207.368,112.5421516447,26.9034195363,313.85,3.502656,2.662677,-67.807435,653146.35945655,2976670.87298749
383207.376,112.5421497892,26.9034201198,313.846,3.502243,2.664987,-67.803265,653146.174378605,2976670.9353835
383207.384,112.5421479336,26.9034207035,313.843,3.500293,2.668456,-67.80232,653145.989290462,2976670.99780155
383207.392,112.5421460783,26.9034212874,313.839,3.501546,2.671267,-67.797563,653145.804231844,2976671.06024212
383207.4,112.5421442231,26.9034218713,313.835,3.496569,2.674773,-67.789195,653145.619183163,2976671.12268281
383207.408,112.542142368,26.9034224554,313.832,3.483849,2.676885,-67.774991,653145.434144147,2976671.18514579
383207.416,112.5421405129,26.9034230395,313.828,3.471533,2.676137,-67.765536,653145.24910513,2976671.24760876
383207.424,112.5421386577,26.9034236237,313.824,3.47028,2.675779,-67.760612,653145.064056049,2976671.3100827
383207.432,112.5421368024,26.9034242079,313.82,3.475101,2.677064,-67.761833,653144.878997039,2976671.37255652
383207.44,112.5421349471,26.9034247923,313.817,3.476053,2.681571,-67.761664,653144.69393776,2976671.43505249



OUT File
Out file is a binary file that stores trajectory information. The following table shows the format of the POSPac SBET file provided by Applanix.
For details, refer to the PosPac quick start guide.

The trajectory information stored in its file is structured as follows:

Data Units Type

time seconds double

latitude radians double

longitude radians double

altitude meters double

x velocity meters/second double

y velocity meters/second double

z velocity meters/second double

roll radians double

pitch radians double

platform heading radians double

wander angle radians double

x body acceleration meters/second² double

y body acceleration meters/second² double

z body acceleration meters/second² double

x body angular rate radians/second double

y body angular rate radians/second double

z body angular rate radians/second double

https://www.applanix.com


Control Point File Format
The control point file contains a list of control points in TXT format. The first row is the file header, while other rows store comma separated X,
Y, Z coordinates of control points. The following table is an example of a control point file:

X, Y, Z
473575.563, 291005.332, 127.244
473576.899, 291004.245, 126.328
473576.899, 291004.243, 126.317
473576.899, 291004.245, 126.328
473576.899, 291004.243, 126.317



Notes Elevation Points File
The notes elevation points file is a comma-delimited CSV file. The first row is the file header, while other rows store X, Y, Z and Label
(separated by comma).

The following figure shows an example of notes elevation points file:

X, Y, Z, Label
322539.46, 4102000.01, 2489.21, 2489.21
322551.33, 4102009.72, 2489.55, 2489.55
322562.85, 4102000.03, 2489.74, 2489.74
322563.16, 4102019.38, 2489.98, 2489.98 
322511.58, 4102056.04, 2492.86, 2492.86



Sample Data File
The sample data file is a text file (*.txt) delimited by commas that contains a file header in the first row. The first two columns of each row are
the X and Y coordinates, followed by a number of dependent variables. Multiple dependent variables can be stored, but only one is used for
each regression analysis.

The dependent variable is tree height in the following example of a sample data file:

X,Y,Height
322859.25,4102463.86,33
322862.25,4102459.35,31.5
322864.56,4102462.49,32
322874.58,4102463.50,35
322655.52,4102192.25,21.1



ALS Seed Points File
Seed points file is a comma-separated CSV file. The first row is the file header, while other rows contain a number of seed points. Each row
contains four columns: tree ID, tree location X coordinate, tree location Y coordinate and tree location Z coordinate.

The following table shows an example of a seed points file:

TreeID,TreeLocationX,TreeLocationY,TreeLocationZ    
1,322971.5,4102497.5,47.387
2,322549.5,4102496.5,49.42    
3,322678.5,4102495.5,48.456    
4,322716.5,4102494.5,34.366    
5,322516.5,4102489.5,23.726

TLS Seed Points File
Seed points file is a comma-separated CSV file. The first row is the file header, while other rows contain a number of seed points. Each row
contains five columns: tree ID, tree location X coordinate, tree location Y coordinate, DBH location Z coordinate and DBH value.

The following table shows an example of a seed points file:

TreeID,TreeLocationX,TreeLocationY,TreeLocationZ,DBH    
1,-5.135,-21.219,1.303,0.244
2,-1.693,-30.778,1.3,0.365
3,3.249,-26.096,1.3,0.389
4,-3.852,-28.103,1.304,0.309
5,4.89,-30.851,1.301,0.299



CHM Segmentation Result
The CHM segmentation result contains a comma-separated .csv table file and a polygon-type .shp vector file.

The .csv table contains the attributes of tree ID, x, y coordinate position, tree height, crown diameter and crown area.

The following table shows an example of the segmentation result of CHM:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, CrownDiameter, CrownArea
1, 322716.24, 4102494.69, 36.165, 8.982, 63.36
2, 322751.21, 4102499.9, 41.282, 4.491, 15.84
3, 322519.35, 4102499.3, 32.008, 4.708, 16.64
4, 322742.15, 4102497.7, 26.956, 8.347, 54.72
5, 322892.26, 4102499.5, 45.493, 7.792, 47.68

The .shp file contains the geometric extents of each tree segmented. The attribute table contains the ID, x, y coordinate position, tree height,
crown diameter and crown area attributes of each tree.

ALS Forest Results of Point Cloud Segmentation & PCS with Seeds
The ALS Forest results of point cloud segmentation and PCS with seeds are comma-separated .csv table files containing the attributes of
TreeID, x, y coordinate position, tree height, crown diameter, crown area and crown volume.

The following table shows an example of the results of the ALS individual tree segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, CrownDiameter, CrownArea, CrownVolume
1, 322511.52, 4102089.78, 60.606, 10.85, 92.04, 3240.171



2, 322511.81, 4102015.14, 53.785, 13.15, 135.09,4358.651 
3, 322537.43, 4102062.51, 46.667, 12.45, 126.76, 3272.472
4, 322529.42, 4102073.12, 45.197, 4.071, 13.019, 342.992 
5, 322525.07, 4102101.07, 43.861, 3.105, 7.57, 107.672

TLS Forest Results of Point Cloud Segmentation & PCS with Seeds
The TLS Forest results of point cloud segmentation and PCS with seeds are comma-separated .csv table files containing the attributes of
TreeID, x, y coordinate position, tree height, DBH, crown diameter, crown area and crown volume.

The following table shows an example of the results of the TLS individual tree segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, DBH
1, 136547.147, 289995.532, 6.498, 0.081
2, 136562.037, 289985.496, 5.652, 0.112
3, 136543.853, 290001.586, 6.115, 0.078
4, 136547.766, 289997.909, 5.868, 0.081
5, 136547.127, 289980.102, 5.217, 0.097

Format of Tree Attribute Information from TLS Point Cloud
Segmentation
Individual tree attribute information from TLS point cloud segmentation is recorded in comma-separated .csv table files containing the
attributes of tree ID, x, y coordinate position, tree height, DBH, crown diameter, crown area, crown volume, crown base height and
straightness.

The following table shows an example of the individual tree attribute information from TLS point cloud segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, DBH, CrownDiameter, CrownArea, CrownVolume, CBH, Straightness
1, 136547.147, 289995.532, 6.498, 4.394, 12.964, 132.006, 120.961, 1.221, 7
2, 136562.037, 289985.496, 5.652, 3.008, 6.234, 30.524, 32.742, 1.351, 3
3, 136543.853, 290001.586, 6.115, 4.123, 8.627, 58.447, 78.947, 1.234, 4
4, 136547.766, 289997.909, 5.868, 4.464, 9.574, 71.984, 43.512, 1.471, 6
5, 136547.127, 289980.102, 5.217, 6.070, 11.155, 97.727, 307.870, 1.186, 1



Seven Parameters Calculation File Format
Control points should have at least three pairs and should be saved correspondingly in source and targeted coordinate files. Supported
coordinate formats are spatial Cartesian coordinate system (X, Y, Z) and geographic coordinate system (B, L, H) (in the format of degree or
degree:minute:second). Each point should be written in one row, and the geographic coordinates should be written in format of latitude,
longitude, and height, separated by comma.

Example (degree:minute:second):

    24:20:52.04982,116:40:30.53733,75.01
    24:20:16.93056,116:40:25.28056,78.57
    24:19:41.28740,116:40:18.60240,83.92



Section Result File Format

Two-Dimensional Section Result File Format

The 2D section file format can be ASCII file (.txt), vector file (.shp), dxf file (.dxf), and hdm format.

ASCII(.txt) file is an ASCII file separated by comma. Names can help to distinguish they are cross section or longitudinal section
(CrossSection is the name for points in cross section and LongiSection is the name for points in longitudinal section by default). The
section result file contains three columns, including name, distance to origin (in longitudinal section, the origin is the starting point. In
longitudinal section, the origin is the intersection of cross section and longitudinal section. To left is negative, to right is positive), and
elevation. Name suggests in which cross section this point is. E.g., CrossSection1(0) indicates this point is in the cross section named
CrossSection1, and this cross section and the longitudinal section 0 are orthogonal. Elevation records the true hight of this point in the
three-dimensional coordinate system. Following is the part of exported two-dimensional section result file:

    Name,Distance,Height
    CrossSection1(0),39.510,0.025
    CrossSection1(0),39.413,0.085
    ...
    CrossSection2(0),33.884,0.000
    CrossSection2(0),32.447,0.033
    ...
    CrossSection7(1),43.774,0.000
    CrossSection7(1),42.662,0.025

hdm (south). This format file is a comma-separated text file that records the mileage of each section and the distance perpendicular to
the central axis. The format can be described as follows:

-One hdm file can contain multiple cross sections. -Each section line starts with BEGIN field, followed by section mileage, section serial
number (can be omitted), and ends before the next BEGIN field. For example, BEGIN, 0.000:1, it means that the mileage of this section is
100.000, and the serial number is 1.

-The section data is then recorded and separated by commas. There are 2 fields in each row. The first field is the offset and the second field
is the elevation. The offset is divided into positive and negative points. Mileage direction), the left deviation is negative, the right deviation is
positive.

-For the cross section without a middle stake point, the offset takes the first point on the left as the base point, and both are positive.

-The example is as follows, including 3 hdm data with mid-stake point section:

        BEGIN,0.000:1
        -13.265,90.242
        -12.617,90.284
        0.000,90.173
        13.819,89.890
        18.002,89.631
        19.329,88.435
        20.581,88.404
        20.721,89.645
        23.318,89.641
        BEGIN,7.229:2
        -13.918,90.280
        -7.584,90.219
        0.000,90.106
        1.415,89.919
        16.547,89.944
        BEGIN,27.542:3
        -24.713,90.563
        -22.875,90.290
        -7.484,90.045
        0.000,89.819
        7.535,89.624
        21.322,89.731

    Note: The middle pile is not necessarily the center point of the cross section, and the left and right widths of some cross sections are differ
ent 

hdm (latitude ground). This file is a comma-separated text file that records the pile number, the height of the middle pile and the distance
to the middle axis of each section. One hdm file can contain multiple cross sections. Each section line occupies three lines, the first line is
the mileage and the height of the middle pile, the second line is the offset and elevation in the left direction of the line, and the third line is
the offset and the elevation in the right direction of the line. Then record a section line.



  Mileage pile number Middle pile height
  Left Offset Elevation Left Offset Elevation Left Offset Elevation Left Offset Elevation Left Offset Elevation
  Right offset Elevation Right offset Elevation Right offset Elevation Right offset Elevation Right offset Elevation 
  0    288.08
      5.93    0.18    21.79    3.45    32.07    4.49    36.32    8.21
      4.22    -0.09    10.03    0.08    12.31    -5.28    26.9    -5.28
  0    456
      4.22    -0.09    10.03    0.08    12.31    -5.28    26.9    -5.28
      5.93    0.18    21.79    3.45    32.07    4.49    36.32    8.21
  ...

When the export format is a vector file, distance and height will be connected as X and Y values respectively to form a series of
polygons. Each polygon corresponds to a section. The section name is saved in the file as an attribute value.

When the export format is dxf (2004), each section will be automatically arranged into a table with N rows and three columns according to
their respective coordinate values, and the vertical sections will form a single row. Below each section is a text label (optional), the label
content includes left and right width, middle pile height difference, fill and excavation area, etc. When exporting, you can choose
horizontal and vertical scales, whether to add elevation symbols on the survey section, and the prefix of the fill and cut mark text. The
scale information will be marked in the lower right corner of the graph. The label text and the cross-section coordinates are in different
layers.

Three-Dimensional Section Result File Format

The 3D Section result file format can be ASCII file (.csv), vector file (.shp) and dxf file (.dxf).

ASCII file. A comma-separated text file. There are 4 columns in the file, namely: name, X coordinate, Y coordinate, and Z coordinate.
Points with the same name belong to the same section.

Name,X,Y，Z CrossSection1(0),323128.788,4104260.073,0.025 CrossSection1(0),323130.481,4104261.752,39.413 ...
CrossSection2(0),323245.294,4104234.559,0.073 CrossSection2(0),323245.659,4104234.934,0.103 ...
CrossSection7(1),323429.209,4104472.832,0.000 CrossSection7(1),323430.965,4104472.877,0.011

Vector file. X, Y, and Z will be sequentially connected as coordinate values to form a series of polygons. Each polygon corresponds to a
section. The section name will be saved in the file as the attribute value.

dxf format file. X, Y, and Z will be sequentially connected as coordinate values to form a series of polygons. Each polygon corresponds to
a section.

Note: When exporting multiple files, all vertical sections and cross sections will be output as separate files; when exporting a single file, all
sections belonging to the same vertical section will be integrated into one file, and all vertical sections will remain Will be output as a separate
file.



Matrix Format
The matrix file has four rows and four columns, each row of data is separated by a comma.

a00,a01,a02,a03

a10,a11,a12,a13

a20,a21,a22,a23

a30,a31,a32,a33    

See example below:

0.99, 0.085, 0.86, -100

0.99, 0.085, 0.86, 100

0.99, 0.085, 0.86, 100

0, 0, 0, 1



ID List of Json Callable Functions for Batch Processing
The following table shows the Plugin ID and Action ID of each Json callable function available in LiDAR360.

Function Name Plugin ID Action ID

Remove_Outliers 0 0

Normalize_by_DEM 0 1

Normalize_by_Ground_Points 0 15

Tile_by_Range 0 2

Tile_by_PointNumber 0 16

Merge 0 3

Extract_Point_Cloud_Boundary 0 4

Subsampling 0 5

PCV_Rendering 0 6

Define_Projection 0 7

Reproject 0 8

Extract_Color_from_Image 0 9

Subdivision 0 10

Transformation 0 11

Clip_by_Circle 0 30

Clip_by_Rectangle 0 31

Clip_by_Polygon 0 32

Convert_to_LiData 0 40

Convert_to_Las 0 41

Convert_to_ASCII 0 42

Convert_to_TIFF 0 43

Convert_to_Shape 0 44

Convert_to_DXF 0 48

Extract_by_Class 0 60

Extract_by_Elevation 0 61

Extract_by_Intensity 0 62

Extract_by_Return 0 63

Classify_Ground_Points 1 0

Extract_Median_Ground_Points 1 5

Classify_by_Attribute 1 10

Classify_Low_Points 1 11

Classify_Below_Surface_Points 1 12

Classify_Isolated_Points 1 13

Classify_Air_Points 1 14

Classify_byHeightAboveGround 1 15

Classify_byMinElevationDifference 1 16

Classify_Buildings 1 20

Classify_Powerlines 1 21



Classify_Model_Key_Points 1 17

Classify_by_Machine_Learning 1 25

Classify_by_Trained_ML_Model 1 26

DEM 2 0

DSM 2 1

Point_Cloud_to_Contour 2 20

Generate_TIN 2 23

Elevation_Metrics 4 0

Intensity_Metrics 4 1

Canopy_Cover 4 2

Leaf_Area_Index 4 3

Gap_Fraction 4 4

Linear_Regression 4 5

Support_Vector_Machine 4 6

Fast_Artificial_Neural_Network 4 7

Point_Cloud_Segmentation 4 10

Generate_Seeds_from_Layer_Stacking 4 14

Clear_Tree_ID 4 11



Shortcut Keys
This section introduces the shortcut keys associated with menus, viewers and point editing in profile windows.

Menu Shortcut Keys

Viewer Shortcut Keys

Point Editing Shortcut Keys in Profile Window



Menu Shortcut Keys

Shortcut Key Meaning

Ctrl+N New LiDAR360 project(*.LiPrj file)

Ctrl+O Open LiDAR360 project(*.LiPrj file)

Ctrl+Shift+O Open files supported by LiDAR360

Ctrl+S Save LiDAR360 project(*LiPrj file)

Alt+F4 Exit LiDAR360

Ctrl+F3 Add New window

Ctrl+F4 Close Current Window

F11 Full Screen

F3 Orthogonal/ Perspective Projection

F1 Help



Viewer Shortcut Keys

Shortcut Key Meaning

A Anticlockwise Rotation

G Clockwise Rotation

C Front Rotation

E Back Rotation

T Tips

W Show Model/Triangle/Points

P Adjust lighting (improve the display effect of LiModel, LiTin, OSGB and other model files)

↑ Up

↓ Down

← Left

→ Right

+ Zoom in

- Zoom out

Left Button Rotation

Right Button Pan

Middle Wheel Zoom

Space Default

Delete Delete Label/Delete Seed Points



Shortcut Keys for Profile Editing

Shortcut Key Meaning

0-9 Modify the currently selected points to the new classification indicated by the number key pressed

L Activate the "Line Above Selection" tool

Shift+L Activate the "Line Below Selection" tool

Shift+R Activate the "Rectangle Selection" too

Shift+P Activate the "Polygon Selection" tool

Shift+C Activate the "Circle Selection" tool

Shift+F Activate the "Circular Brush Selection" tool

Ctrl+Shift+L Activate the "Lasso Selection" tool

Ctrl+Shift+D Activate the "Detect Plane" tool

Shift+Q Switch between different selection tools in order

Shift+E Switch between different classification tools in order

ALt+← Change the selected tile to the left one

ALt+→ Change the selected tile to the right one

ALt+↑ Change the selected tile to the upper one

ALt+↓ Change the selected tile to the lower one

X Activate/deactivate profile tool rotation tool

Ctrl+Shift+S Save

↑ Move the cross-section/profiling area forward

↓ Move the cross-section/profiling area backward

→ Rotate the cross-section/profiling area clockwise

← Rotate the cross-section/profiling area counter-clockwise

R Activate/deactivate profile scene rotation tool



High-Performance Graphics Mode Adjustment
Follow the procedure below to optimize graphics for LiDAR360 (for NVIDIA graphic cards).

1. Right click on desktop and select NVIDIA Control Panel.

2. Select Manage 3D settings > Program Settings > Add to add LiDAR360.exe to high-performance graphics mode list.





FAQ
This chapter introduces the frequently asked questions and solutions in the use of LiDAR360. It contains Installation and License Activation
FAQ, Platform FAQ, Strip Alignment FAQ, Terrain FAQ, Forestry FAQ and Power Line FAQ.

Installation and License Activation FAQ

Platform FAQ

Strip Alignment FAQ

Terrain FAQ

Forestry FAQ



Hardware requirements and supported operating systems
RAM: at least 8G or more.
CPU: Intel® Core™ i5/i7; Dual-core processor.
Display Adapter: NVIDIA graphics card recommended, video memory no less than 2GB.
Operating Systems: Windows 7 (64 bit), Windows 8 (64 bit), Windows 10 (64 bit) or Windows Server 2012 or later.

After successful installation on my computer, why does the software
crash when I try to open or load data?

Please check whether the software installation environment satisfies the recommended hardware configuration. If yes, please check the
following two things. (1) Whether the graphic card is working properly. Right click on My Computer, select the device manager, find the
corresponding graphic card in the Display Adapter, and view the graphic card properties status. If it shows "this device is working
normally", it means that the graphic card device is running properly. (2) Update the graphic card driver to the latest version, and then use
the high-performance graphic mode to run the software. For the operating procedure, see adjust the graphics mode to high
performance.
Please contact us by email info@greenvalleyintl.com to check the reason remotely if you still get an error.

Why does LiDAR360 pop up the message indicating the trial license
expired after installation?

The LiDAR360 trial license fail might be caused by the following reasons:

System Time Changes: During the trial period, some reasons that may cause system time change, resulting in expired trials.
Trial Expiration: LiDAR360 has 30-day trial period for each version. If the same version has been installed for 30 days, the trial has
expired.
Other Reasons: Please contact us by email info@greenvalleyintl.com.

How to activate LiDAR360?
Send Activation Information: Run the software as administrator, click Help > Activate License in the menubar, or double-click the
License Manager.exe in the installation directory.

mailto:info@greenvalleyintl.com
mailto:info@greenvalleyintl.com


Fill in Name (Mandatory);
Fill in Company (Mandatory);
Select the appropriate module(s);
Click Copy;
Send an email with the copied content to info@greenvalleyintl.com.

Activate License：
Copy the license code to your local drive. Pleaser refer to the License Manager for license activation.

Does LiDAR360 support Windows Server System?
Windows Server is supported.

Please install and activate LiDAR360 using the administrator account. The software must be installed in the folder to which all users
have access.

Can I continue to use LiDAR360 after the trial period ends?
When the trial period ends, you can still use the LiDAR360 software as a point cloud visualization tool. The major software functions,
such as the viewer, measurement tool and selection tool in the toolbar will still be available. If you still need a full license or a license for a
specific module, please contact us info@greenvalleyintl.com for more information on purchasing the software.

Why the help document in the License Manager window cannot be
opened by clicking the help button?

Please check if you have set the default program for opening PDFs. If not, please choose one.

mailto:info@greenvalleyintl.com
mailto:info@greenvalleyintl.com


How can I use the authorization code on another computer if it cannot
be revoked due to the broken of current computer?

Please sent an email to us through info@greenvalleyintl.com with the corresponding authroization code. We will revoke the code in the
activation server for you so that it can be used in another computer.



How to check the version information of LiDAR360 software?
You can check the version information of LiDAR360 in Help > About, 2.0 is the software version and 1019 is the build date.

How to change the menu language?
Click Display > Language in the menubar. Currently the supported languages are English, Chinese and French.

Why does the software exit abnormally?
Based on our experience, the major two reasons of abnormal exits are the insufficient disk space or memory space in your computer and
the existence of opened instance of screen word capturing software. If you meet any other scenarios that lead to abnormal exits, please
contact us info@greenvalleyintl.com.

What are the supported data formats in LiDAR360?
LiDAR360 can import the following data formats:

Point Cloud: Proprietary LiData File(*.LiData), LAS File(*.las,*.laz), ASCII File(*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv), PLY File(*.ply).
Raster: Image File(*.tif,*.jpg).
Vector: Vector File(*.shp).
Table: Table File(*.csv)
Model: Proprietary Model File(*.LiModel), Proprietary TIN File*.LiTin), OSG Model File(*.osgb, *.ive, *.desc, *.obj).

LiDAR360 can export the following data formats:

Point Cloud: Proprietary LiData File(*.LiData), LAS File(*.las,*.laz), ASCII File(*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv), PLY File(*.ply).
Raster: Image File(*.tif,*.jpg).
Vector: Vector File(*.shp, *.dxf)
Table: Table File(*.csv)
Model: Proprietary Model File(*.LiModel), Proprietary TIN File(*.LiTin).

If the color scheme of the data displayed in the viewer window is not
correct, how can I correct this?

First, right click on the desktop. Select NVIDIA Control Panel.
Second, select manage 3D settings > program settings > add to add LiDAR360 software to the list of high-performance graphics
mode. Refer to adjust high-performance graphics mode.

How to fix drag and drop in windows 8 and windows 10?

mailto:info@greenvalleyintl.com


Go to RUN, or search "regedit.exe" then run as administrator. On Registry Editor go to:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System, double click "EnableLUA", and change the
value from 1 to 0. Restart windows, and the problem will be solved. Reference.

Why is the EDL visual effect not obvious if multiple data are added in
the same window?

It's recommended to show distant multiple data in separate windows with EDL effect. Or remove unwanted data in the current window.

What is the unit of point cloud data in LiDAR360?
The unit is meter. If users have point clouds with foot or other units, they can be converted by Data Management > Conversion >
Convert to LiData / Convert to Las.

Is LiDAR360 capable to handle the point cloud generated by
photogrammetry software?

Yes, it is.

How does LiDAR360 perform seven parameter transformations?
Click Data Management > Projections and Transformations > Reproject.
Check Use Seven Parameters.
Input seven parameters: translations X, Y, Z; rotations Rx, Ry, Rz; and scale λ.
Select target coordinate reference system. (You have to define projection for the point cloud if it doesn't have source coordinate
reference system)

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


How to subsample the point cloud uniformly?
LiDAR360 provides subsampling methods by Minimum Points Spacing, Sampling Rate, or Octree. The subsampling by Octree is an
uniform method.

Click Data Management > Point Cloud Tools > Subsampling, then select the sampling type Octree.

How to Pick Rotation Center while using the Pick Multi-Point tool?



Hold the Ctrl key and pick rotation center by left-click.

Why are point cloud transformation results incorrect in LiDAR360?
This is because different units are used in each program. In LiDAR360 degree units are used. In order to carry out a correct
transformation, the units must be degrees.

Can lidar data or software be built into a GIS Platform?
Yes. Our software can generate shapefiles (.shp) and .tiff files which can be integrated into a GIS system. In our software you can also
create new polygons, lines as well as generate contour lines, DEM and other digital models.

What memory(RAM) requirement is there to process large datasets in
LiDAR360?

We recommend at least 16GB of RAM for processing large datasets.

Why there are very large error after rectifying? How to solve it?
You can view the residuals for all the homologous points pairs and remove the homologous points pairs with large residuals. After that,
redo the rectifying process.



What are the supported POS formats by LiDAR360?
ASCII format (*.pos) and binary format (*.out) are currently supported.

*.pos file contains GPS time, longitude and latitude, flight height, roll, pitch and heading. An example is shown as follows:

*.out file is a proprietary format of the company Applanix. Please refer to OUT File.

Is the strip alignment manual or automatic in LiDAR360?
There are both manual and automatic methods in LiDAR360. And the results will be displayed in real-time.

What is the time reference in POS file supported by LiDAR360? Is the
GPS time necessary?

The only requirement is that the time stamps in POS file and point cloud data files have the same reference (e.g., GPS Time or UTC
Time). If they are not the same, you have to convert one to the other. Generally, time in point cloud counts in SOW(seconds of a week) or
SOD(seconds of a day).

Sometimes, the point clouds after strip alignment are partially aligned,
but partially not, and in some area they are even distorted. Why?

This may occur if the POS file is of low accuracy. The principle of the Strip Alignment module is to correct boresight errors between
laser scanner system and GPS/INS system. The precondition is that the POS accuracy for the acquired data meets the standard
specifications. Otherwise the resulting point clouds are partially distorted. Boresight correction alone doesn't guarantee the aligned
results with high accuracy.

Why there is no output when I try to clip the point cloud data with the
POS file?



Please check the GPS starting and ending time of both the POS file and the point cloud data. And see if there are any overlap between
the GPS time of two files.



What ground points filtering algorithm is used in LiDAR360 software?
LiDAR360 uses an Improved Progressive TIN Densification (IPTD (Zhao et al.,2016) ) filtering algorithm to classify ground points.
Specific parameter settings see Classify Ground Points.

The actually scanned LiDAR point density is much larger than the DEM
point density requirement of the production. Can data be subsampled?

If the actually scanned LiDAR point density is much greater than the production demand, you can use the Subsampling tool to
subsample the point clouds. This function provides three types of subsampling methods: "Minimum Points Spacing", "Sampling Rate"
and "Octree".

Some of the contour lines generated by the function "Point Cloud to
Contour" are broken. Why?

The broken contour lines may be caused by the lack of ground points. The contours can be contiguous by increasing the parameter
"Triangle's Maximum Length" on the interface. For example, set 30 meters up to 50 meters or an even larger value.

During DEM processing, the result of this process has .tiff format. Can I
convert this into 3D data?

You can convert your .tiff DEM into our custom 3D model format (LiModel). Go to Data Management > Conversion > Convert TIFF to
LiModel(../ToolReference/DataManagement/Conversion/ConvertImagetoLiModel.md).

How to check and improve the quality of DEM generated by LiDAR360?
You can first create a hillshade map from the hillshade tool in the terrain module. This tool determines the illumination-enhanced surface
visualization by setting each cell in the raster. At the same time, you can use Data Management > Conversion > Convert TIFF to
LiModel to convert single-band Tiff images to LiModel. The LiModel can be viewed in 3D and is more intuitive. In addition, the model can
be edited by using Terrain > LiModel Editor, such as "Flatten Height", "Smooth Height", and "Repair Height" to improve the quality of
DEM. Similarly, DSM or CHM data can also be operated as above.



How do you generate a smoother contour for a DEM?
Perform a smoothing operation using smooth height tool. Save the data. Then Convert the LiModel back to .tiff format, Data
Management > Conversion > Convert LiModel to
TIFF(../ToolReference/DataManagement/Conversion/ConvertLiModeltoImage.md). From here perform a contour operation Terrain >
Raster to Contour(../ToolReference/Terrain/RastertoContour.md).

How to choose the interpolation method for generating DSM?
It is recommended to choose IDW interpolation for forestry area, and TIN interpolation (Spike Free TIN) for urban area.

    @inproceedings{
        author={Zhao X Q, Guo Q H, Su Y J and Xue B L},
        title={Improved progressive TIN densification filtering algorithm for airborne LiDAR data in forested areas},
        booktitle={ISPRS Journal of Photogrammetry and Remote Sensing,117:79-91},
        year={2016}
    }



Is it possible to save each sample as a separate file when cutting the
point cloud data by center and radius?

The results of Clip by Circle and Clip by Rectangle can be saved as multiple files or merged into a single file. The user can choose
either one as an option.

Can LiDAR360 generate CHM in batches?
LiDAR360 can generate CHM in batches (ALS Forest > Batch Process > Canopy Height Model(CHM) Segmentation).



How to evaluate the accuracy of individual tree segmentation results?
For evaluation of individual tree segmentation accuracy, please refer to Li et al's article on (Li et al., 2012). By comparing with field
measurement, the number of correctly segmented trees, the number of falsely segmented trees, and the number of missed trees are
calculated according to the following formulae: recall (r), precision (p), and F-score (F). Recall indicates the tree detection rate, precision
indicates the correctness of the detected trees, and F-score is the overall accuracy taking both commission and omission errors into
consideration. The values of r, p and F vary from 0 to 1.

（a）Correctly detected tree (True Positive, TP)（b）undetected tree (False Negative, FN) （c）falsely detected tree(False Positive, FP)

What parameters affect the CHM segmentation accuracy and how
should these parameters be set?



The accuracy of CHM segmentation are affected by CHM resolution and Gaussian smoothing factor.
CHM is the difference between DSM and DEM. The CHM resolution is determined by the resolution of DSM and DEM. Generally
speaking, this value should not exceed one-third of the crown width, and the range can be set to 0.3-1m. Usually, the resolution of
0.5-0.6m can get a higher segmentation accuracy.
Sigma is the Gaussian smoothing factor (default value is "1"). The greater the value is, the smoother the results are. The degree of
smoothness can affect the number of trees being segmented. In the case of under-segmentation, it is recommended to reduce this
value (e.g. 0.5); and in the case of over-segmentation, it is recommended to increase the value (e.g. 1.5).

Moreover, beside the algorithm parameters, the CHM segmentation result can also be largely influenced by tree density and tree
species. If the algorithm does not work well in s certain study area, users can try to use other segmentation algorithms to get the best
segmentation result.

How to remove some results with small crown area after running CHM
segmentation?

After running CHM segmentation, a shp file containing the tree boundary is obtained. The attribute table includes the ID, location, height,
crown diameter and crown area of each tree. The data can be imported into a third-party software (e.g. ArcGIS), and you can remove the
segmentation results with a small crown area according to the crown area attribute.

How to make point cloud data below 2m be participated in
segmentation?

The parameter "Height Above Ground" on the Point Cloud Segmentation and Point Cloud Segmentation from Seed Points
interfaces indicate that points below the value are not considered as part of the tree and will be ignored during the segmentation process.
The default value is 2m. If you need to make the point cloud below 2m participate in the segmentation, the value can be reduced
appropriately.

Which kind of segmentation method for coniferous and broad-leaved
mixed forest data can be used to obtain higher accuracy?

For coniferous and broad-leaved mixed forest data, CHM Segmentation is recommended.



The growth of trees in the area is not the same, how to achieve higher
segmentation accuracy?

It is recommended to clip the point cloud according to the growth as different data by Select Tools or Clip Tools and handle them
separately.

If the tree canopy is covered in weeds, can tree identification still be
performed in LiDAR360?

Yes, it can.

How to export individual tree segmentation results to third-party
software for analysis?

Click ALS Forest > Extract by Tree ID, the segmented point cloud can be exported to CSV file for subsequent analysis using other
software. LiDAR360 supports exporting each tree as a separate CSV file or exporting all points as one file. The exported CSV file is
shown in the figure below, which contains X, Y, Z coordinates and tree ID information.

How many sample data files are required for regression analysis?
The number of sample data used for regression analysis is not clearly defined. In general, under the premise of ensuring the accuracy of
plot location and measurement, the greater the number of sample data is, the higher the accuracy of regression analysis can achieve.
Sample sites should be randomly selected and representative to cover different forest types within the study area. A sample size less
than 30 is referred as a small sample, and a sample size of 30 or greater is referred as a large sample. To ensure regression analysis
accuracy, the recommended sample size should be greater than or equal to 30 (you should also consider the size and complexity of the
study area).



How to choose the independent variables involved in the regression
analysis?

The elevation percentiles obtained from LiDAR data are generally the independent variables for regression analysis. However, specific
elevation percentiles are not all the same for different study areas.

Can trained regression models be used for other data?
Yes. Click ALS Forest > Regression Analysis > Run Existing Regression Model. Available regression models (Linear Regression,
Support Vector Machine, Fast Artificial Neural Network and Random Forest Regression) can be used to estimate forest metrics.

Can I export the independent variables (e.g. elevation percentiles)
generated by LiDAR360 into third-party software (e.g. SPSS, R) for
regression analysis?

Yes. Independent variables provided by LiDAR360 including Elevation Percentile, Elevation Density, Intensity Percentile, Leaf Area
Index, Canopy Cover and Gap Fraction. Among them, Elevation Percentile, Elevation Density and Intensity Percentile are in CSV
formats, and they can be imported into third-party software such as SPSS directly. Leaf Area Index, Canopy Cover, and Gap Fraction are
in TIF formats that can be converted to text format by ArcGIS and imported into third-party software.

    @inproceedings{
        author={ Li W K, Guo Q H, Jakubowski M K and Kelly M},
        title={A new method for segmentation individual trees from the LiDAR point cloud},
        booktitle={ Photogrammetric Engineering and Remote Sensing,78(1):75-84},
        year={2012}
    }

What if the TLS Stem Extraction runs in a flash or there is no change in
the classification result?
-The function of TLS Stem Extraction is based on deep learning and needs to use GPU. Make sure the latest driver has been installed on
your computer.

-For Windows7 System, the driver need to be installed includes：

451.67-desktop-win8-win7-64-international-whql.exe

GeForce_Experience_v3.20.3.63.exe

Please select the appropriate driver according to your own operating system for your Nvidia GPU and installation.

If you still cannot run this function after installing the latest driver, please check whether the required system patches are installed. For
example, Windows 7 needs to install the following patches:

https://www.nvidia.cn/Download/index.aspx?lang=cn


Windows6.1-KB3068708-x64.msu

Windows6.1-KB3080148-x64.msu

Please make sure all the required patches are correctly installed on your computer.



LiDAR360 Version Release Notes

v5.2 - 19/11/2021
New Features：

Breakline
Point cloud profile editor supports breakline drawing
Improve LiTIN editor breakline drawing
Support adding breaklines to DEM
Support adding breaklines to contour lines

Add extract water area tool
Support point clouds in PCD format

Enhancement：
Section Analysis

Support create section by adding model data
Support adding section at any position
Optimize create section by point cloud and fix the missing section caused by the missing point cloud
Optimize export of section to meet production requirements

Optimize projection and coordinate conversion, add support for storage of user-defined conversion models, parameters can be
created and applied directly
The measurement tool supports unit setting
Optimize the efficiency of the control point report function with an average increase of 40%
Generate CHM function to support big data processing
Strip alignment supports SBET format trajectory data
Contour function supports class selection
Roaming tool supports pause during roaming
Add trial application on start page
Point cloud data GPS time conversion supports selecting date for conversion
Mutual conversion between shp and kml supports geographic coordinate system
Subdivision tool supports buffer setting
Support report custom settings
Optimize the bit rate of the screen recording tool to provide a defaul value based on the system resolution

v5.1 - 29/7/2021
New Features：

Add mine module
Extract tunnel points
Compute normal vectors
Triangulation modeling
Triangulation modeling (poission)

Vector editor
Support 3D vector drawing
Add tools for shaping elements
Add split polygon tool
Add semi-automatic extraction of building outlines
Add semi-automatic extraction of road shoulders
Add intersection drawing line
Add section auxiliary drawing
Add associated window to assist drawing
Add selection file editing
Add temporary draft editing
Support 3D capture
Support 3D selection
Support shortcut key setting
Support rollback and redo

Add the hover mode, support the use of hover mode under measurement point selection



Add cutting by straight line
Add dividing by polygon

Enhancement：
Profile editing classification

Select tool support category settings, to be individually set and recorded
Select cutting to support cutting of the triangulation model
Tree segmentation point cloud editing supports directory tree control display and hidden
Cut by polygon, support inner and outer cutting options
Manual translation and rotation support X\Y\Z component progress control
Directory tree

Support right-click to open the folder
Vector data supports dxf format

v5.0 - 29/1/2021
Here is the release note:

New Features:

Add geology module
Add flow direction function
Add fill function
Add slope/aspect query function
Add data IO API for software development
Support creating LiData point cloud file
Support reading LiData point cloud file
Support modifying LiData point cloud file
Add powerline module
Add deep learning classification of powerline function
Add danger point detection function
Add customization of the danger point detection
Support danger point visualization
Add point cloud smoothing function
Add trunk extraction function
Add elevation annotation points generation based on contour lines function
Add new format transform tools
shp to kml
kml to shp
Support background grid display in viewers
Support extracting point cloud by TreeID
Support clear individual tree record and segmentation by TreeID
Add calculating forest metrics

Enhancement:

UI
Brand new Ribbon user interface style
Support free dragging of child windows
Support customization of UI pages
Supports automatic hiding of docked window
Support one-click industry application processing
Strip alignment
Add strip adjustment function
Support clipping trajectory by the quality and selecting with a brush on a trajectory
Directory tree
More comprehensive point cloud information display
Support selecting the version of the LAS file when right-clicking to export
Support right-clicking to add additional attributes of point cloud
Support right-clicking to rename files
Support setting the point size of table data
Expand the projection library to support more projections and geoid
Optimize PCV efficiency and support more point cloud calculations for PCV
Optimize ALS automatic individual tree segmentation



Improve point cloud attribute extension of an individual tree, slope and altitude information is added.
Optimize individual tree seed point editing
Improve method of profile selecting
Improve method of adding and deleting seed points
Add viewpoint position and direction for easy positioning of trees
Real-time update of attribute table corresponding to seed point modification
Support undo and redo
Support setting profile viewpoint distance
Optimize individual tree point cloud editing
Improve method of profile selecting
Support creating an individual tree by specifying a chosen tree
Support setting profile viewpoint distance
Automatically save the configuration
Optimized profile point cloud editing
Improve the efficiency of block editing by more than 50%
Support mouse position tracking in the profile window
Support data exporting
Add section comparing analysis function in section analysis
Upgrade LiModel format to solve the problem of coordinate accuracy loss
Reduce the GPU usage rate of point cloud display by 20%
Support multiple calls to the same function in batch processing
Fix the bug when using cross selection and clipping tool simultaneously
Improve the efficiency of point cloud conversion to DXF file

v4.1 - 8/6/2020
New Features:

Add three-point angle measurement
Add registration of UAV and backpack forestry point cloud data
Added individual tree attribute information expansion
Add detection of forest structure changes
Add DBH measurement
Help menu

Add software usage problems and demand feedback channel
Add FAQ, quick start, official website link, etc.

Enhancements:

Optimize the efficiency of loading multiple files
Improve color rendering of point cloud attributes
Additional attribute management

Support deleting
Support component combination rendering

Improve profile editing and classifying
Support grid scale display in profile window
Support directory tree to manage point cloud tiles in memory

Support import boundary of measurement area with SHP file in volume measurement
Improve the efficiency of filtering function and the density of ground points
Support directory tree to manage point cloud tiles in memory in individual tree point cloud editing function
Support combined calculation in forestry metrics
Support extract point cloud by tree ID, support export the extracted point cloud to LAS and LiData format
Support attribute filtering in ALS seed point editing
Improve LiTIN editing, support 3D view editing, and support the setting of starting height of broken line
Add tunnel cross-section in cross-section analysis
Window layout supports multiple layout modes
Newly designed UI icons

v4.0 - 30/12/2019
New Features:



Add denormalization tool
Add classify close points tool
Add manual rotation and translation tool
Add convert ASCII to BLH tool
Add individual tree editor tool. Support to create, merge, and delete tree
Add statistics individual tree attributes tool
Add TLS leaf area index tool
Add ALS forestry metrics calculation in give area tools
Add deviation analysis tool for two data of the same area collected in different times.
Add change detection tool
Add transform GPS time tool. Support to transform GPS time between GPS coordinate time and GPS week second

Enhancements:

Support online update checking and installing
Upgrade the version of LiData to 2.0. Support all the features of LAS 1.4 (except the waveform information) and support the
additional attribute of the point cloud file
Support the color rendering for all the attributes of point cloud data
Support the rotation of 2D view
Support fast mode and precise mode in volume calculation and providing the information of the measuring area
Support zooming to the layer by double-clicking the file in the directory tree
Support recovering the data association in the same path for the project file path
Support EDL effect in render to file and save to video tools
Support generating automatic alignment report and clearing the data alignment information
Improve the profile editor. Support customizing hot keys. Solve the problem of profile buffer settings
Improve the EDL effects in orthogonal projection
Improve the cross selection tool. Support data clipping when being used with selection tool, or 2D drawing when being used with
vector editor.
Improve data interaction experience：

Improve browsing fluency
Support automatically picking the rotation center
Improve point picking experience
Support measuring components in the measurement tools
Support measuring points number in the density measurement tool

Support recording the original Z value in normalization tool
Improve the data formats supported

Support E57 point cloud format
Support additional attributes for LAS, PLY, and ASCII format point cloud files
Support choosing the version of las file when exporting point cloud in las format (las 1.2, las 1.3, and las 1.4)
Support converting version of LiData (LiData 1.9 and LiData 2.0)
Support converting point cloud in Geographic Coordinate System to projected LiData

Improve the calculation method of individual tree crown volume
Improve the efficiency of the calculation of forestry metrics

v3.2 - 6/6/2019
New Features：

Add brightness settings tool
Add ICP registration function
Support exporting TIN in DXF format
Add raster statistics tool

Enhancements:

Optimize EDL display effect in profile editing mode
Optimize the ground point filter
Optimize the efficiency and effect of "Classify Buildings" tool
Support rectangular/circular interactive area selection tool in clipping function
Change band calculator to raster calculator; support custom formula
Support hot keys and right-clicking menu in ALS individual tree segmentation editing tool
Support position uncertainty optimization mode in regression analysis
Support corresponding multiple point cloud files to one trajectory in "cut point cloud based on trajectory" tool
Profile editing and classifying：



Add the lasso selection tool
Add the plane detection tool
Support clearing the triangular network already been built
Support setting the size of brush selection tool
Support setting the step length of the profile translation
Optimize the efficiency of triangular network generating

TLS individual tree segmentation editing：
Support ignoring the Z-values of the input seed file
Support right-clicking menu and hot keys
Support hot keys in single tree attributes measuring
Support display of LiBackpack trajectory file

Manual registration：
Support inputting/outputting coordinate transformation matrix
Support the preview of transformation

Raster and table data：
Support color settings
Support highlighting objects when they are selected
Support centralizing the objects when they are double-clicked

Bug Fixed:

Fix the bug that the order of the vector and table data's attribute table is wrong.
Fix the bug that only the displayed data will be used in "batch extraction DBH" tool
Fix the bug that profile selection will disappear in the main window if users edit point cloud in profile window

v3.1 - 31/12/2018
New Features:

Profile edit and classify:

Support block editing and classifying
Support multiple windows selecting and classifying
Add the brush selecting tool
Block editing mode supports to undo/redo
Add the automatic timing/automatic saving function
Add multiple selecting area filter classification/classification setting tools
Support hot key switch function
Block editing mode supports RAM usage warning

Boundary extraction adds convex hull and concave hull mode

Add check for updates function

Enhancements:

Improve the efficiency of LiData generating
Support to recalculate the histogram of point cloud intensity and elevation
Move the rectify to reprojection and transformation module
Multiple point selecting tool supports to customize the extended attributes
Support projected coordinate systems in JGD2011 coordinate system
Support POS files in more formats. Now support POS file with projected coordinates.
Support converting length units for las and LiData files.

v3.0.1 - 10/12/2018
New Features:

TLS data editing tools:
Add circle selection tool
Add profile translation tool
Add DBH inspector tool

Enhancements:

Optimize the color rendering for individual tree segmentation.



Optimize the segmentation of the vector boundary of crown in CHM individual tree segmentation.
Support the .shp file in section tool.

Bugs Fixed:

Fix the bugs already known

v3.0 - 16/10/2018
New Features：

Save users’ parameter setting as default, prompt the information about each parameter when putting mouse on it
Support the spike-free TIN generation algorithm
Add the random forest regression model
Add the regression predict analyze
Add the Projections and Transformations toolset:

Seven parameters solution
Four parameters solution
Vertical datum transformation

Add noise classification function
Support to convert raster data to LiData

Enhancements：

Improve the ground point filtering algorithm
Improve the accuracy and efficiency of the TLS individual tree segmentation tool
Upgrade the LiTIN format to support saving the corresponding LiDAR point classes in LiTIN data and display LiTIN data by classes
Improve the editing and flattening TIN data in LiTIN format
Tile by range supports buffer setting and vector exporting
Support subdivisions of Graticules
Support to generate multiple files when performing polygon clipping
Support to select RGB range when convert data to las format

v2.2 - 20/06/2018
New Features：

Multi-threaded batch processing support
Measurement of individual tree attributes (total height, crown base height, stem straightness, diameter at breast height (DBH), etc.)
from TLS data

Enhancements:

Improved regression analysis which allows for the importation of independent variables from external sources
Output elevation and intensity variables as .tif formatted files
Individual tree segmentation from a selected point cloud class
Improved TLS data editing tools that allow users to (1) batch process data to extract DBH measurements and (2) fit DBHs to point
clouds selected in the profile view window
Add crown diameters, crown areas, and crown volumes to the outputs of the TLS individual tree segmentation tool
Functionality added to the Section Analysis Tool in the Terrain Module allowing users to now: (1) analyze .dxf formatted files, (2)
import more than one file at a time and draw multiple section lines. (3) define a step value to simplify sections. (4) export multiple
section files
Output contour feature as 2D polylines (.shp)
Edit for vector dataset attributes

Bugs Fixed:

Tree heights now updated for tree filtering after tree segmentation tool has been run
Projection information of las data can now be read

v2.1.2 - 24/04/2018
Enhancements:

Improved batch extraction function for DBH (Diameter at Breast Height)
LiData upgrade



30-day trial for power line module
Bug Fixed:

Strip alignment function

v2.1.1 - 08/04/2018
Enhancements:

Supports LAZ/LAS 1.4 file formats
Recognize intensity information with ply data

v2.1 - 05/02/2018
New Features:

Automatic calculation of flight strips matching parameters
Median ground point clouds classification
Supervised classification based on machine learning
Support to revise ground point filtering results of a defined region
Support cross section analysis
Support vector editing
Support selected region extends from both end in profile viewer
Support point cloud partitioning based on the number of points
Support to generate TIF images with projection information

Enhancements:

Improved DEM/DSM interpolation algorithm
Improved the efficiency of generating contour lines
Improved the efficiency of individual tree segmentation algorithm(individual tree segmentation from point cloud and individual tree
segmentation based on seed point)
Supports richer terrain product formats, including a new ASC format for raster data and a new DXF format for the contour line

Bugs Fixed:

De-redundant function
Multipoint selection
Classification by attribute

v2.0 - 30/10/2017
New Features:

New License Key: The software could be activated by month or by module
Forest Module (divided to ALS module and TLS module):

ALS Module:
Seeds generation algorithm: generate segmentation seed layer based on CHM, Point Cloud Segmentation and Layer
Stacking
Seeds edition: add/delete seeds,select seeds and segment individual tree based on seeds
Batch-processed segmentation based on input seed layer

TLS Module:
Ground Classification using TLS data
Batch-processed segmentation based on input seed layer
Calculate DBH of tree
Generate and edit segmentation seed layer

Classification Module:
Improve performance of ground points filter algorithm
Classification for key feature points. By identifying the key surface points, this allows the down-sampling of relatively flat areas
thus improving processing efficiency without sacrificing quality
More user input parameters and options

Power Line Module:
Create vector output for power line and tower classifications
Real-time measurement of the distances from any given point to the closest power line and tower



Set point cloud display point size for individual layers
Automatically identify point cloud center point and set it as rotation center
Improved the visual effects of TIN
Display shapefile layer attribute table
Identify and locate the corresponding individual tree in the viewer by double-clicking a row in the segmentation result list table
Cross selection tool supports more accurate adjustment of the boundingbox
Display parameter in LOG viewer. The LOG file still stays at system's TEMP folder
Support information collection when the software crashes. You can send crash information in the pop up interface to the mailbox.
The cut results for multiple data sources can be saved separately or be merged into a file

v1.5 - 14/07/2017
New Features:

Added power line module. The main functions include marking tower position, cutting the point cloud data based on the tower
position, automatic classification of power line and tower, dangerous points detection and report generation
Added selection toolbar. It includes polygon selection, rectangle selection, sphere selection, in cut, out cut, save cut and cancel
selection
Added editing point cloud classification with real-time TIN
Support to merge multiple files into one
Support undo to profile editing and selection function by Ctrl+Z

Enhancements:

CHM segmentation algorithm improvement. Users can adjust more parameters and generate the shape file of tree boundary
Add the residual report to the registration function. Users can choose the points for coordinate transformation
Cross selection result can be export
The parameters setting for batch processing for multiple files and multiple functions can be imported and exported
Improved profile editing efficiency
Users can choose whether to generate minor, basic and major contour when using "point cloud to contour" and "TIN to contour"
functions
Add seven parameters transformation for reprojection function
The results of Clip by Circle and Clip by Rectangle can be exported as one file, or save as individual files according to the extent of
circle or rectangle
The real-time coordinates in the status bar are more accurate
Improved user experience of navigating

v1.4 - 31/05/2017
New Features:

Added "generate TIN", "TIN edit", "TIN to Contour", "TIN to DEM" functions
Added Grid Volume Statistics function
Added "Camera Roam" and "Save to Video functions"
Fix the bug for memory leak when loading .ply data

v1.3 - 17/04/2017
New Features:

PLY data import and export added to I/O module
Elevation difference, overlap and density quality reports added to strip adjustment module
Add "Subsampling based on octree" and "point cloud convert to DXF" to data management module
Power line classification
Support for mix and glass coloring modes in rendering
Batch process for multi-files and multi-functions
Geometric correction (support point cloud registration based on points or sphere targets)

Enhancements:

Speed improvements for contour generation based on point cloud
Users can set the properties of minor, basic and major contours for "point cloud to contour". The elevation attributes can be read
Show the boundary of concave polygon for area measurements



The resolution of surface model is not limited to 0.5m
Bugs Fixed:

Fix the bug of file opening error when there is an invalid file in multiple .csv files
Fix the bug of window flash caused by EDL effect in windows 10
Bug fixed for stepwise regression
Bug fixed for software crash caused by opening old version of LiData
Bug fixed for software crash when opening the point cloud with unstandardized projection

Lite - 04/02/2017
Free version of LiDAR360, main functions including data visualization and grid statistics

v1.1 - 22/12/2016
New Features:

Software platform update: 2D&3D integration, multiple window linkage, rolling screen, display order changed by drag, cross
selection,etc
Strip quality check function
Generate contour lines based on point cloud
Chinese software version
Bug fixed for raster image subdivision and LiModel with texture

v1.0 - 11/10/2016
First version release of LiDAR360
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